Subject: RE: why i should like pibs

From: "Sahita, Ravi" <[email-masked]>
Date: Thu, 21 Mar 2002 09:04:34 -0800

Juergen,

I've added some items in addition to what you've enumerated. 
Some of these are direct effects of the PIB data 
model, and some of them because of usage of the
data model with COPS-PR.

a. I think the PIB data model is better since:

a.1. Other additions which formalize Pointers, typed and
untyped, Tag-Groups and single-inheritance (via EXTENDS)
allow code generation by an algorithm to generate 
entire funtional PIB layers over COPS-PR, and make 
processing of PIB transactions and error handling easier.

a.2. PIB PRCs do not require some SMIv2 column attributes 
which are needed there due to multi-managers support, and 
hence do not have that complexity.

b. Reuse of 'all'(a special client-type) and other 
assigned client-type PIBs via Client-type infrastructure
that allows the work by a wg of subject-matter experts,
to be reused by another group that needs those entire
modules or specific PRCs defined within them.

c. Some of the advantages of the framework-pib (which
is specified as an 'all' client-type) and hence the
advantages are distributed to other PIBs also are:

c.1. Facility to report subject-matter specific 
capabilities and PRC and/or attribute level 
implementation limitations which allows the PDP to 
validate configuration for a device to be configured 
effectively and unambigously amongst heterogeneous 
devices to which that configuration applies. 

c.2. Facility to install multiple contexts of
device configuration (with one active configuration 
context) and the ability to switch between them with 
very small decisions. This helps in bulk configuration.

d. Ability to outsource requests or provision decisions 
using the same data model, which gives you more than
just yes/no answers for resource allocation.

e. Allows resource management interaction at a PDP which
may be managing multiple resources (or client-types)-which
gives one the facility to build a closed-feedback system
where one client-type interaction may cause a change in another
client-type. This bullet point talks to the state maintenance
point that many people mentioned.

These I think are in addition to what you and Dave have
mentioned.

Ravi

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]]
Sent: Thursday, March 21, 2002 2:30 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: why i should like pibs

I tried to incorporate Dave's feedback and here is my updated list of
the major technical contributions of COPS-PR over SNMP:

a) TCP transport for large transactions when the network is up and
   running.

b) Reduced OID overhead and less degrees of freedom to achieve the same
   thing.

c) Improved data definition language. (There is disagreement how much
   improvement there really is.)

d) State sharing and one manager assumption for a given set of instance 
   data.

e) Some failover support built into the protocol.

Dave, do you agree with this revised list?

/js

-- 
Juergen Schoenwaelder    <http://www.informatik.uni-osnabrueck.de/schoenw/>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 22 Mar 2002 11:22:53 +0100

>>>>> Sahita, Ravi writes:

Ravi> I've added some items in addition to what you've enumerated.
Ravi> Some of these are direct effects of the PIB data model, and some
Ravi> of them because of usage of the data model with COPS-PR.

[...]

Ravi> These I think are in addition to what you and Dave have
Ravi> mentioned.

I think this is all covered under item (c). I personally have no
interest to into the details at this point in time. Dave and I already
agree that we disagree about how much improvement the SPPI brings us.

/js