Subject: [Rfced-future] The voices of stakeholders

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 29 Jan 2021 13:11:49 -0000

Hi,

I've been chewing on this thought for a while and trying to keep up with the
list (but please excuse me if this has come up and I missed it).

The thrust of Ekr's proposal (1/25) seems reasonable, but I have a concern
about how we handle the people who might be considerably impacted by any
changes the WG might come up with, but who are not present in the WG.

Now, I can usually get behind, "If you want to influence the work,
participate in the work." That is certainly how we have operated in the
IETF, and generally it gives good results for producing quality technical
specifications. But I think that this WG might be in a slightly different
space.

In practice, we are asking people who are consumers of RFCs to participate
in the discussions about the publication format etc. when they might not
even be aware that the forum exists, and might anyway be unaccustomed to
this way of working. In some cases, the stakeholders might even be one step
removed from the RFCs (for example, regulators who want to point at RFCs,
but who do not actually implement or read them).

My concern is that one or two people turning up from these large but
under-represented classes of stakeholder may be swamped by our normal "rough
consensus" process. I am not saying that their voices will not be heard, nor
that the correct mechanisms will not be used to consider their input. But I
am worried that they will lack the experience and expertise to make their
points stick in this WG, and that, if push comes to shove, their voice will
be seen as a minority and they will be placed "in the rough".

Of course, the chairs of the WG will have a considerable responsibility to
make sure that things go well for everyone, but in the end, they also call
rough consensus. They are only advocates for participants in ensuring that
their voice has the opportunity to be heard.

So my questions are: Who is the advocate for the under-represented
stakeholders? Whose job is it to actively search out relevant opinions? Who
has the role of champion for these groups of RFC consumers to make sure that
the decisions the WG make do not negatively impact them?

Thanks,
Adrian

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 31 Jan 2021 14:05:57 +1300

On 30-Jan-21 02:11, Adrian Farrel wrote:
...
> the decisions the WG make do not negatively impact them?
We could, of course, specify this as one of the things the RSA/E should
handle. I'd certainly have felt it as a very natural job for the
RSE in the previous regime.

I do agree that it's important. Newspapers that ignore their readers
soon don't have many readers.

   Brian C

---

From: Christian Huitema <[email-masked]>
Date: Sat, 30 Jan 2021 23:51:38 -0800

> soon don't have many readers.

Yes, it definitely is important. But I hardly believe that this is 
mostly related to the technicalities of managing publication. When we 
publish specifications for Internet protocols, we want to make sure that 
these protocols get implemented and deployed. Yes, the documents 
describing these protocols should be easy to read. But they should also 
address real problems and solve them through good engineering practice. 
That's not something to delegate to just a few publication experts. 
That's a task for the entire community, and especially for the IETF 
leadership.

-- Christian Huitema

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 31 Jan 2021 11:09:19 -0000

Christian,

You make my point for me, thank you.

I ask again, in our new proposed format: Who is the advocate for the under-represented stakeholders? Whose job is it to actively search out relevant opinions? Who has the role of champion for these groups of RFC consumers to make sure that
the decisions the WG make do not negatively impact them?

Regards,
Adrian

-----Original Message-----
From: Christian Huitema <[email-masked]> 
Sent: 31 January 2021 07:52
To: Brian E Carpenter <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Rfced-future] The voices of stakeholders

-- Christian Huitema

---

From: S Moonesamy <[email-masked]>
Date: Sun, 31 Jan 2021 12:43:13 -0800

Hi Adrian,
At 03:09 AM 31-01-2021, Adrian Farrel wrote:
>I ask again, in our new proposed format: Who is the advocate for the 
>under-represented stakeholders? Whose job is it to actively search 
>out relevant opinions? Who has the role of champion for these groups 
>of RFC consumers to make sure that

The person who is better suited for that job is the RFC Series 
Editor.  It is unlikely that under-represented stakeholders would be 
regular participants of the group in which the decision is taken.

Regards,
S. Moonesamy

---

From: Jay Daley <[email-masked]>
Date: Mon, 1 Feb 2021 10:22:25 +1300

> On 1/02/2021, at 9:43 AM, S Moonesamy <[email-masked]> wrote:
> 
> Hi Adrian,
> The person who is better suited for that job is the RFC Series Editor.  It is unlikely that under-represented stakeholders would be regular participants of the group in which the decision is taken.

The more I read people discuss "what are the needs of the readers of RFCs" the more it becomes clear that answering that question requires a major project of extensive data gathering across a wide range of communities and AFAICT nobody has done that because nobody has referred to it. Therefore it seems extremely unlikely that we can find the kind of expert needed for an RSE/A, who is already in a position to advocate for the under-represented stakeholders with any degree of confidence.  It would certainly be possible to find an RSE/A who is also capable of running such a project, but that would require considerable time and effort if it is to be done properly.  If this project were decoupled from the RSE/A then that would simplify the role specification by removing a long-standing messy area.  A broader project could also result in multiple "advocates for under-represented stakeholders" with a common evidential understanding, not just a single RSE/A,

Jay

> 
> Regards,
> S. Moonesamy 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 31 Jan 2021 21:27:23 +0000

Hiya,

On 31/01/2021 21:22, Jay Daley wrote:
> If this project were decoupled from the RSE/A then that would
> simplify the role specification by removing a long-standing messy
> area.
Personally, I think that'd be a mistake. I think we'd be
better off to find a RSE/A, and task them with tackling this
issue, but in the knowledge that it's a long-term and not
a short-term project. IOW, 50 years of RFCs I think means
we don't need an answer very urgently and we're ok to evolve
relatively slowly. (I figure I'd actually prefer evolution
in the series to be a bit quicker than we've seen in the
past, but not that much quicker.)

Cheers,
S.

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 1 Feb 2021 10:41:52 +1300

> past, but not that much quicker.)

Sure. But Jay is correct that it isn't necessarily part of
the skill set we could reasonably require of the RSA/E.
However, they could certainly be tasked with commissioning
such an effort (very possibly via the LLC).

   Brian C

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 31 Jan 2021 21:46:37 +0000

Hiya,

> such an effort (very possibly via the LLC).

Could be, sure. I'd say parts of that task could well
be handled fine via an RFP issued by the LLC. (Not by
LLC staff themselves I'd hope, lest the LLC headcount
expand too much.)

But (again personally) I think owning that task is a
core part of being an RSE/A. Absent that ISTM we'd be
hiring a fancily-titled managing copy editor.

Cheers,
S.

---

From: Christian Huitema <[email-masked]>
Date: Sun, 31 Jan 2021 13:53:18 -0800

> regular participants of the group in which the decision is taken. 

I don't think so. We have more or less agreed that this is a matter of 
knowing who the RFC "consumers" are and understand what their unmet 
needs might be. In a commercial business, that's a task for marketing 
departments and business managers. If I look at past RSE hiring 
processes, market research and business management were not high on the 
list of hiring criteria. If I look at RFC 8728, I don't find any mention 
of market studies, user panels and the like. Indeed, doing such studies 
would be very hard when the budgeted workload is only "approximately 20 
hrs per week". So, no, the RFC Series Editor is not the better suited 
person for that job.

-- Christian Huitema

---

From: Jay Daley <[email-masked]>
Date: Mon, 1 Feb 2021 11:12:19 +1300

> On 1/02/2021, at 10:46 AM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 
> core part of being an RSE/A.

I don’t believe that someone can only advocate for a position if they have personally collected the data to support that position.  It should be entirely possible for the RSE/A to advocate based on a detailed report produced by a third party.

Jay

> Absent that ISTM we'd be
> <OpenPGP_0x5AB2FAF17B172BEA.asc>

--
Jay Daley
IETF Executive Director
[email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 31 Jan 2021 22:14:44 +0000

Hiya,

On 31/01/2021 22:12, Jay Daley wrote:
> I don’t believe that someone can only advocate for a position if they
> have personally collected the data to support that position.  It
> should be entirely possible for the RSE/A to advocate based on a
> detailed report produced by a third party.
Of course. It's more a matter of who initiates and decides
what information is required. I think that's something that
needs to be an RSE/A task. It's fine if the LLC arrange for
the work to be done well, but deciding what's needed isn't
IMO something for the LCC to do itself.

S.

---

From: Jay Daley <[email-masked]>
Date: Mon, 1 Feb 2021 11:23:34 +1300

> On 1/02/2021, at 11:14 AM, Stephen Farrell <[email-masked]> wrote:
> 
> Signed PGP part
> 
> Hiya,
> 

I wasn’t thinking of the LLC controlling or doing this.

Having the RSE/A control it seems to decouple it both from the community members who raise the issue regularly, and from the streams who produce the content in the first place.

Jay

--
Jay Daley
IETF Executive Director
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 1 Feb 2021 17:15:13 +1300

On 01-Feb-21 11:23, Jay Daley wrote:
> 
> 
>> On 1/02/2021, at 11:14 AM, Stephen Farrell <[email-masked] <mailto:[email-masked]>> wrote:
>>
>> Signed PGP part
>>
>> Hiya,
>>

If it's done properly, the messaging and survey will be reviewed by the WG in advance, so all the streams can have their say. I think what Stephen is looking for is a person who is responsible for making it happen. Otherwise it will be one of those tasks that everybody thinks somebody else should do.

   Brian C