Subject: [Rfced-future] Proposed "Oversight Body" structure

From: Eric Rescorla <[email-masked]>
Date: Mon, 25 Jan 2021 07:10:00 -0800

I was asked to come up with a proposal for what to do about a
proposed oversight body.

The current overall proposals are for a two-level structure, which
has:

An open WG that is responsible for producing proposed changes to the
RFC series An Approval Body [name TBD] which is responsible for
approving the output of the WG

At the last interim, it seemed like there were at least three
rationales that people thought that the AB might potentially use to
disapprove a proposed change:

1. It didn’t work for one of the Streams
2. The process wasn’t followed
3. They didn’t agree with the contents

I heard a fair amount of agreement on the first two of these, but also
a number of people objecting to (3) on the grounds that the AB
shouldn’t be overriding the judgement of the WG. Conflicts between the
IESG and WGs on the contents of documents have been a persistent
feature of the current system, leading to, for instance, the DISCUSS
criteria. Given the amount of distrust of leadership making decisions
here, I think we should consider not replicating that structure.

It also seems to me that the function of determining whether something
works for the individual Streams is a question for the Stream
Managers, but they’re not particularly well positioned to determine
whether the process has been followed. Given that this WG is likely to
exist under the auspices of the IAB and they are likely to select the
chairs, it seems like they are the natural body to determine whether
the process was followed.

With that in mind, what I propose is the following:

An RFC Stream Manager Committee (RSMC) would be formed, consisting
solely of the four Stream Managers. They would need to approve each
process change, but objections need to be limited to the question of
whether a specific change would cause harm to their own Stream.  The
specific voting rules are TBD, but the obvious choices are unanimity
or 3/4 supermajority. If we require unanimity, that creates the
concern of allowing one manager to stonewall, which seems suboptimal.

The IAB would be responsible for ensuring that the process was
followed. I think the easiest way to do this is not for them to
formally approve documents coming out of the WG but rather for them to
be an appeals body. However, the appeal grounds should be limited to
process issues, not substantive objections. I hear that there are
concerns that the WG won’t listen to expert advice. In my opinion, the
right balance here is that the expert gets an opportunity to speak and
the process requires they be heard and the WG explicitly decide not to
take their opinion, but the WG is the final decision maker. Then “WG
did not fully consider and decide on whether to take expert advice”
can become an appeal ground, but it’s not an opportunity for the IAB
to substitute their own judgement for the WG’s.

In short, the WG would be responsible for the strategic work, but would
be subject to two forms of narrowly scoped review: the stream
managers for "this will break my stream" and the IAB for "the
process wasn't followed".

-Ekr

---

From: Eliot Lear <[email-masked]>
Date: Mon, 25 Jan 2021 16:32:06 +0100

Thank you, Eric.  We now have a concrete proposal the supervisory body and on how appeals are managed.  I also know that John is working hard (perhaps too hard!) on his action item, as we will soon see.

May I ask colleagues to please review and comment on the text below?  I have created a copy of the specific text below at https://github.com/intarchboard/rfced-future/blob/master/wg-approval-body.txt <https://github.com/intarchboard/rfced-future/blob/master/wg-approval-body.txt>.  For those people who would like to create PRs, that is fine.  Please keep discussion here, and of course, people should feel free to propose changes on list.

Eliot

> On 25 Jan 2021, at 16:10, Eric Rescorla <[email-masked]> wrote:
> 
> rationales that people thought that the AB might potentially use to disapprove a proposed change:
> 
> --
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 25 Jan 2021 15:32:58 +0000

I really liked seeing the rationale behind the proposal.

I agree with all of it.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 25 Jan 2021 10:48:40 -0500

If we take the premise that the quasi-WG is always technically correct, 
then most of what Eric proposes follows.
However, I do not accept that premise.

Even in cases where WGs are actually technically expert on their area, I 
have seen them make significant mistakes that are called by other 
review.  This proposal removes all such external review.

Also, this proposal removes all respect for and meaningful inclusion of 
the hired expert, reducing them to a participant in the WG.  While such 
reduction is appropriate for IETF technical WGs, it does not seem 
appropriate for this body.  Particularly when we are trying to recover 
from a debacle of insufficient respect for hired experts.

Given that the disagreement is about the basic premise, I do not see any 
point in trying to craft an alternative proposal.

Yours,
Joel

On 1/25/2021 10:32 AM, Eliot Lear wrote:
> Thank you, Eric.  We now have a concrete proposal the supervisory body 
> and on how appeals are managed.  I also know that John is working hard 
> (perhaps too hard!) on his action item, as we will soon see.
> 
> May I ask colleagues to please review and comment on the text below?  I 
> have created a copy of the specific text below at 
> https://github.com/intarchboard/rfced-future/blob/master/wg-approval-body.txt 
> <https://github.com/intarchboard/rfced-future/blob/master/wg-approval-body.txt>. 
>   For those people who would like to create PRs, that is fine.  Please 
> keep discussion here, and of course, people should feel free to propose 
> changes on list.
> 
> Eliot
> 
>> On 25 Jan 2021, at 16:10, Eric Rescorla <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> [email-masked] <mailto:[email-masked]>

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 25 Jan 2021 08:10:05 -0800

> However, I do not accept that premise.

FWIW, this is not *precisely* my premise. Rather, my premise is that despite
there being differences of opinion about the right thing to do, the way to
resolve
those differences is through our ordinary mechanisms. Of course, sometimes
that procedure will yield decisions which turn out to be bad -- just as our
current
procedure of WG design followed by IETF LC and IESG review sometimes
makes mistakes -- but that's true of any decision procedure.

> the hired expert, reducing them to a participant in the WG.

Well, that's not my intent. Rather, I think that they should have a clear
advisory role and in the case where they disagree with the WG the chairs
ensure
they are heard, but that the WG should be the ultimate decision maker.

Perhaps that's the right place to start: consider the situation where the WG
has strong consensus for some course of action and the expert disagrees,
and the WG continues to have consensus even after hearing the expert out.
What do people believe the right outcome is?

-Ekr

---

From: Russ Housley <[email-masked]>
Date: Mon, 25 Jan 2021 11:56:16 -0500

> On Jan 25, 2021, at 10:10 AM, Eric Rescorla <[email-masked]> wrote:
> 

I was thinking that the ballot process should be similar to the IESG WG chartering process.

You need at least one YES ballot position and no BLOCK ballot positions.  With the assumption that most BLOCK positions will be associated with detail, not the whole idea, the BLOCK will lead to a problem solving discussion.

After discussion, if the BLOCK is not sorted out, then the a vote is a reasonable next step.  This would be similar to the IESG override process.  I would think that 2/3rds voting YES would be a good approach to overriding a BLOCK by a stream manager.

Russ

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 25 Jan 2021 13:19:34 -0500

I will try to give my take on the question you asked.  To keep it clear 
what I am answering, that part is below.
Thank you,
Joel

On 1/25/2021 11:10 AM, Eric Rescorla wrote:
...
> What do people believe the right outcome is?

I suspect that there is no right answer to this question, since it 
probably depends upon the myriad details.

Having said that, I also recognize that the resolution procedure needs 
to exist independent of the details.
Personally, it seems like having the RSE on the approval body, with an 
equal vote with the stream heads, and the body allowed to apply 
technical judgment, seems as reasonable as anything I can think of.  I 
am assuming that it takes a majority of the approval body to approve a 
document for this discussion.  If the RSE can't persuade two of the 4 
stream heads that there is a real problem, then the RSE will have to 
figure out how to work with the result being approved.

Yours,
Joel

---

From: Christian Huitema <[email-masked]>
Date: Mon, 25 Jan 2021 11:47:22 -0800

> process wasn't followed".

I largely agree with this proposal, except for the lack of some kind of 
community wide consultation. The proposal addresses two failure modes, 
hampering the management of streams and not following due process. I 
understand why we might not want to invest a small body with the power 
of overriding WG consensus. But I am concerned about a different failure 
mode, group-think in the WG blindsiding the community at large. This is 
addressed in the IETF process by the IETF last call. I believe we need 
something similar here, some kind of "community last call", and that the 
Approval Body should be entrusted to verify that issues raised during 
this community last call are properly addressed.

-- Christian Huitema

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 25 Jan 2021 12:30:58 -0800

> this community last call are properly addressed.

Thanks for making this suggestion. I agree that it would be an improvement.

-Ekr

---

From: Martin J. Dürst <[email-masked]>
Date: Tue, 26 Jan 2021 08:00:33 +0900

> makes mistakes -- but that's true of any decision procedure.

The advantage of having IETF LC and IESG review after WG consensus is 
that the same stuff is looked at at least three times. This has a higher 
chance of avoiding group think and finding issues relevant in a wider 
perspective. As Christian also pointed out, the current proposal is 
rather under-developed in this respect.

Regards,   Martin.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 26 Jan 2021 14:21:41 +1300

Several comments in line:

>> concern of allowing one manager to stonewall, which seems suboptimal.

This is not sufficient. There needs to be somebody there who can speak
for the RFC Editor function and say, if necessary, "This will break
the RFC editing service itself." In the emerging proposal, that person
can really only be the RSA/E themself, assuming we don't want to put
a representative of the RFC Editor contractor in the process.

Also, I think we'd need a rep from the contracting agency (i.e. the LLC)
who can say, if necessary, "This will break the contract or budget".

>> managers for "this will break my stream" 

As noted, there are other things that might break.

>> and the IAB for "the

I am far from convinced that the IAB is a valid representative of the
community served by RFCs. (It *is* a valid representative of the
community creating RFCs, but that's different.)

Unfortunately I don't have a better suggestion at the moment.
 
> this community last call are properly addressed.

Agreed, but there is another aspect of the same problem, as we have often
discussed: how to send a Last Call to the RFC user community, not just to
the RFC writing community? As noted some time ago, the rfc-interest list
doesn't even scratch the surface.

Regards
     Brian

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 26 Jan 2021 01:30:31 +0000

Hiya,

I keep saying it but I must be wrong as nobody ever seems
to notice:-)

On 26/01/2021 01:21, Brian E Carpenter wrote:
> Agreed, but there is another aspect of the same problem, as we have
> often discussed: how to send a Last Call to the RFC user community,
> not just to the RFC writing community?

For such arcane topics, which these are bound to be - to make
a genuine effort to reach the biggest subset of the people
who read RFCs: we should write an RFC. (Hey, that'd also
match the expansion of the acronym too:-)

While the above is not perfect, ISTM any other option has
to be less good, when the target is the set of people who
read RFCs. Someone could send mail and tweet about it too
of course but the text in an RFC is what'd be best, almost
by definition.

Cheers,
S.

---

From: Eliot Lear <[email-masked]>
Date: Tue, 26 Jan 2021 08:15:05 +0100

Hi Stephen

> On 26 Jan 2021, at 02:30, Stephen Farrell <[email-masked]> wrote:
> 

With the caveat that I am extrapolating from a sample size of 1, what Brian pointed out was that specific requirements get written into various other standards, and those standards get clicked through to get to specific RFCs.  If one really wanted to play with fire to address this, one could intercept the URL for those specific RFCs and throw up an informational notice, like “before you download, we are looking for your feedback…”. That in itself would probably produce some script breakage, but the topic might be a good one for the new working group to tackle.

Eliot

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 27 Jan 2021 17:34:26 +1100

> who can say, if necessary, "This will break the contract or budget".

I think that the latter suffices for the former.  Let's say that it is the LLC.  They can be responsible for determining whether their contractor is able to handle the change.

That seems like a pretty reasonable amendment in addition to Christian's request for a formal public review process (which I support).

---

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 27 Jan 2021 14:51:23 +0100

Hi Brian, hi Ekr, hi Christian, hi all,

Thanks for putting this proposal together! Look like a good way forward to me. Please see further below.

> On 26. Jan 2021, at 02:21, Brian E Carpenter <[email-masked]> wrote:
> 

So I think it’s two different questions about a) what and from whom we need to hear during the process and b) who should be on the approval body.

Input can be provided either to the working group directly or to the approval body (in form of liaisons or “non-voting” member - basically other people who participate in meetings). E.g. if the RSx or Jay, or anybody else brings a concern to the approval body and can convince someone there that it is a real problem, I think that problem will be handled adequately.

So for the approval body we need people who can listen and have a good overview about want’s going on in their respective part of the community. And I’d say the stream manager might be well positioned for that. See on a follow up point below.

> community creating RFCs, but that's different.)

Not sure if the IAB need to be a valid representative of the community in that role. If the question is if the process was followed, the main requirement is that we have an appeal body that was not part of the process so far.

> doesn't even scratch the surface.

There is the other point about stream manager that I wanted to make. I think stream managers actually represent their part of the community. As such I don’t see it as the stream managers role to decide (except for small points that are straight forward) but to check for consensus in their community. Each stream has an own process for that and I think we should make use of those established processes.

Yes, that doesn’t reach all the readers/consumers but that also true for all documents that we publish in each stream.

Mirja

---

From: Russ Housley <[email-masked]>
Date: Wed, 27 Jan 2021 12:13:43 -0500

> who can say, if necessary, "This will break the contract or budget".

I think the RFC Production Center and the IETF Admin LLC need to have advisor roles.  They can answer questions about the publication process, budget, and contractor capabilities.  There may be some tough calls where the community wants something that will cause big changes.  We have lived this.  The transition to the XML v3 schema has process and budget impacts.  Yet, we are doing it.

I think the addition os a Last Call into the process is a good idea, but we need to figure out a way to announce it very broadly.  I assume the announcement will point to a place for the discussion to take place, but it should not be [email-masked].

Russ

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 28 Jan 2021 07:47:53 +1300

Martin,
On 27-Jan-21 19:34, Martin Thomson wrote:
> I think that the latter suffices for the former.  

Not really. I don't mean that the RSA/E would be concerned about
operational breakage. I was thinking about comments like:

"This proposal will damage the RFC Series as an archival series, because..."
or
"This proposal will damage the reputation of the series because..."
or
"This proposal won't work as the WG expects because..."
or, of course, things that I can't imagine since I'm not an expert
in technical publishing. Most of us aren't, which is why we need
an RSA/E in the first place.

    Brian

> Let's say that it is the LLC.  They can be responsible for determining whether their contractor is able to handle the change.
>

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 28 Jan 2021 10:35:33 +1100

> an RSA/E in the first place.

I think that was addressed in Ekr's proposal (or at least it was to my satisfaction).  

That is, the advisor would be expected to provide this input to the working group analogue as part of consideration of any change.  If that input was considered, but not accepted, then that is within process and the expert could be "in the rough" as occasionally happens to domain experts in other fields.  (Noting of course the hazard of that is well understood and that understanding should be particularly well-noted in any documentation we create.)  In other words, the working group analogue is able to do damage to these things if it reaches broad consensus.  Generally though, I would expect harms along those lines to be balanced by advantages in other ways, which makes the overall assessment situational, difficult, and nuanced.  That is why I think that the open forum is the most appropriate way to ensure that those concerns are surfaced, heard, and addressed.

The only grounds for blocking a proposal that has consensus of the WGA is for the approval body to reject it or if the process was not properly followed.  The approval body is given fairly narrow grounds upon which they can reject something.

That all said, you might consider the above reasons to be included as reasons for a stream manager to block something, depending on the details of the situation.  For example, any stream might reasonably regard input that suggests catastrophic loss of series credibility as a threat to the viability of that stream.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 27 Jan 2021 18:46:15 -0500

The big difference is that in normal IETF working groups, the people 
making decision are themselves experts in the field.  That's why people 
trust us to make these decisions.

In this case, the "wg" members are not experts in the field of technical 
publishing.

I do not think "sorry, the RSE?A was in the rough" is really enough.

And given teh history of even skilled working groups making occaisonal 
significant technical mistakes, I do not think it suffices for the 
review body to be barred from saying "you blew it".

Yours,
Joel

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 28 Jan 2021 11:04:28 +1100

> trust us to make these decisions.

This oversimplifies things.  As a regular participant in discussions, I often find that the level of expertise in various subject areas varies greatly.  When everything is working (which is most of the time) I am able to offer my particular expertise and rely on others for theirs.  We each defer to others in areas where we recognize our own shortcomings.

You seem to be suggesting that participants in this process won't do the same.  I can't accept that argument.  I appreciate that we might need systems in place to cover the difficulty in communicating across disciplinary lines, but that does not - for me - extend to reification of the advisory role.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 27 Jan 2021 19:09:06 -0500

The question is not how it works when everything works right.  An 
amazing range of structures will work when everything goes right.

My concern is what guardrails we have to help us when things go wrong.

This is rather similar to the point several lawyers have made to me over 
the years about contracts.  The contract isn't for when the business is 
working smoothly.  It is for when things go wrong.

Yours,
Joel

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 28 Jan 2021 15:18:48 +1300

> You seem to be suggesting that participants in this process won't do the same.  I can't accept that argument.  I appreciate that we might need systems in place to cover the difficulty in communicat…
The suggestion is not to give the RSA/E a pocket veto by putting them in
the approval group. It's to make sure the approval group will hear directly
from the expert, in the case (hopefully rare) where the common sense and/or
groupthink of the WG has led to a proposal that the publishing expert
thinks is seriously wrong. We give the security ADs a "DISCUSS" button;
why wouldn't we give the technical publishing expert one too?

    Brian

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 28 Jan 2021 05:51:21 -0800

On Wed, Jan 27, 2021 at 6:19 PM Brian E Carpenter <
[email-masked]> wrote:

> > This oversimplifies things.  As a regular participant in discussions, I
> often find that the level of expertise in various subject areas varies
> greatly.  When everything is working (which is most of the time) I am able
> to offer my particular expertise and rely on others for theirs.  We each
> defer to others in areas where we recognize our own shortcomings.
> >
> > You seem to be suggesting that participants in this process won't do the
> same.  I can't accept that argument.  I appreciate that we might need
> systems in place to cover the difficulty in communicating across
> disciplinary lines, but that does not - for me - extend to reification of
> the advisory role.
> thinks is seriously wrong.

Well, the structures I proposed were intended to ensure this. Presumably if
the RSA/E believes something is seriously wrong, then that will be raised
to the attention of the committee or the IAB. Perhaps it would make sense
to have them to prepare a review which is provided to the committee and the
IAB.

> We give the security ADs a "DISCUSS" button;

The security ADs are selected via our quasi-democratic nomcom process
[0].This role is not.

-Ekr

[0] Yes, I am aware that not all the stream managers are selected via this
process, but they are the representatives of their streams equities in this
case.

---

From: Eliot Lear <[email-masked]>
Date: Thu, 28 Jan 2021 21:50:23 +0100

Hi Mirja

> There is the other point about stream manager that I wanted to make. I think stream managers actually represent their part of the community. As such I don’t see it as the stream managers role to de…

What would you envision the IETF stream representative decision process being?

Eliot

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 29 Jan 2021 13:01:10 +1300

On 29-Jan-21 02:51, Eric Rescorla wrote:
> 
> 
> On Wed, Jan 27, 2021 at 6:19 PM Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Well, the structures I proposed were intended to ensure this. Presumably if the RSA/E believes something is seriously wrong, then that will be raised to the attention of the committee or the IAB. Perhaps it would make sense to have them to prepare a review which is provided to the committee and the IAB.
>  
> 
> The security ADs are selected via our quasi-democratic nomcom process [0].This role is not.

I don't see that as relevant. If we select this person on the grounds that they know more about technical publishing than the rest of us do, that seems like exactly what we need as a finger on the DISCUSS button.

   Brian

> 
> -Ekr
> 
> [0] Yes, I am aware that not all the stream managers are selected via this process, but they are the representatives of their streams equities in this case.

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 29 Jan 2021 00:08:46 +0000

Hiya,

On 29/01/2021 00:01, Brian E Carpenter wrote:
> If we select this person on the grounds that they know more about
> technical publishing than the rest of us do, that seems like exactly
> what we need as a finger on the DISCUSS button.
FWIW, I'm very sympathetic to that.

Though at the same time I don't think we need to too closely
follow the IETF WG setup quite so much here when it comes to
final approval of changes to the status quo.

I've a related question. Apologies if I missed that being
already resolved, but does the RSE(A) also get to initiate
new activities off their own bat, or only with approval of
someone(s) else?

Ta,
S.

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 28 Jan 2021 16:17:57 -0800

On Thu, Jan 28, 2021 at 4:01 PM Brian E Carpenter <
[email-masked]> wrote:

> [email-masked] <mailto:[email-masked]>> wrote:
> >
> >     > This oversimplifies things.  As a regular participant in
> discussions, I often find that the level of expertise in various subject
> areas varies greatly.  When everything is working (which is most of the
> time) I am able to offer my particular expertise and rely on others for
> theirs.  We each defer to others in areas where we recognize our own
> shortcomings.
> >     >
> >     > You seem to be suggesting that participants in this process won't
> do the same.  I can't accept that argument.  I appreciate that we might
> need systems in place to cover the difficulty in communicating across
> > Well, the structures I proposed were intended to ensure this. Presumably
> if the RSA/E believes something is seriously wrong, then that will be
> raised to the attention of the committee or the IAB. Perhaps it would make
> sense to have them to prepare a review which is provided to the committee
> and the IAB.
> >
> >
> I don't see that as relevant.

I guess we'll have to disagree on that point. I see it as a matter of
democratic legitimacy.

If we select this person on the grounds that they know more about technical
> publishing than the rest of us do, that seems like exactly what we need as
> a finger on the DISCUSS button.
>

We engage a lawyer who is also an expert on topics that we are not, and
which are rather more consequential if we screw them up, and yet we don't
give them a veto.

-Ekr

   Brian
>
> >
> > -Ekr
> >
> > [0] Yes, I am aware that not all the stream managers are selected via
> this process, but they are the representatives of their streams equities in
> this case.
>
>

---

From: Martin J. Dürst <[email-masked]>
Date: Fri, 29 Jan 2021 11:43:54 +0900

On 29/01/2021 09:17, Eric Rescorla wrote:
> On Thu, Jan 28, 2021 at 4:01 PM Brian E Carpenter

> which are rather more consequential if we screw them up, and yet we don't

The expertise of lawyers is more widely acknowledged by most 
participants because most participants are more accustomed to deal with 
lawyers, and know that some stuff has to be left to the lawyers. Also, 
lawyers are more used to attempts to screw them up, and know what to 
ignore, how to defend themselves, and so on. It's difficult to imagine 
that a lawyer would quit because they were treated as "just a 
contractor", because being treated as "just a contractor" wouldn't 
happen to the lawyer in the first place, or only to the extent that they 
would be used to be as part of their usual business.

This seems to be quite different for an expert in technical publishing. 
They are not licensed, they don't have any arms to twist, and so on.

Also, I think "give them a veto" may exaggerate a bit. A DISCUSS 
formally is a veto, but many DISCUSSes have been retracted without the 
raiser having gotten exactly what they originally proposed.

Regards,   Martin.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 29 Jan 2021 16:11:06 +1300

A point below which may appear picky but is actually fundemental to this disagreement:

> raiser having gotten exactly what they originally proposed.

No, a DISCUSS is *not* formally a veto. It is quite narrowly defined
and there is a procedure for overriding a DISCUSS. See
https://www.ietf.org/about/groups/iesg/statements/iesg-discuss-criteria/
Indeed, a similar definition and procedure would be appropriate in
this case too. 

   Brian

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 28 Jan 2021 19:34:08 -0800

On Thu, Jan 28, 2021 at 6:44 PM Martin J. Dürst <[email-masked]>
wrote:

> technical
> lawyers are more used to attempts to screw them up,

Just to clarify my less than awesome writing "screw them up" in this refers
to the topics, not the lawyers.

-Ekr

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 28 Jan 2021 19:35:30 -0800

> Indeed, a similar definition and procedure would be appropriate in

Fair enough. To the best of my knowledge we don't give our lawyer
a vote on, for instance, the LLC Board.

-Ekr

---

From: Michael StJohns <[email-masked]>
Date: Thu, 28 Jan 2021 22:56:14 -0500

On 1/28/2021 10:35 PM, Eric Rescorla wrote:
>
>
> On Thu, Jan 28, 2021 at 7:11 PM Brian E Carpenter 
> <[email-masked] <mailto:[email-masked]>> wrote:

> a vote on, for instance, the LLC Board.
Yet, by design, the LLC board includes people that have other skills 
than writing protocols or chairing WGs and one of the current members is 
a lawyer and does get a vote.

Later, Mike

---

From: Adam Roach <[email-masked]>
Date: Thu, 28 Jan 2021 23:28:39 -0600

> On Jan 28, 2021, at 21:11, Brian E Carpenter <[email-masked]> wrote:
> 

The most important aspect of a DISCUSS ballot is that, if an AD holding it is alone in their conviction, the position can be overridden — on substance, not process — by the remaining ADs. I have grave concerns about allowing someone to be alone in their disagreement (expert or not) without recourse.

/a

---

From: Eliot Lear <[email-masked]>
Date: Fri, 29 Jan 2021 08:38:35 +0100

Adam, I hope you don’t mind that I’m taking your note as an opportunity to explore some hypotheticals.  Really I made a left turn with it, but the DISCUSS discussion is as good of jump off point as any ;-)

> On 29 Jan 2021, at 06:28, Adam Roach <[email-masked]> wrote:
> 

To my knowledge a single DISCUSS has never been overridden.  One can draw one of two conclusions from that: either we pick really good ADs who would not be overridden, or the process of overriding an AD is too onerous.  Whether you want a veto override or a supermajority will depend on the purpose of approval.

I think EKR is arguing for a process veto based on something breaking one of the streams (please correct me if I’m wrong).  Let’s say in a fictitious example, the WG decided to eliminate the distinction between normative and informative references.  This would arguably break the IETF stream. At that point, the IETF stream manager would object.  How that person would object is its own interesting question, but putting that aside for now, the objection is lodged.

What would happen next?

Doc could be returned to the WG
The veto is somehow overridden by the approval body
The veto is appealed

Looking at the latter two options, what is the basis for overriding and what is the basis for appeal?  If the basis for appeal is whether process was followed to override, then that is mechanical: either it was or it wasn’t.  This is what I think EKR is suggesting (again, correct me if I am wrong).  Otherwise if the appeals body might be asked to consider the substance: is the stream going to break?

What is the basis for veto override?  I think this is where the question of, “Is the stream really going to break” comes to play under EKR’s proposal (yet again, correct me if I am wrong).

Now let’s replace the above example with some other theoretical (hopefully otherwise unimaginable) example like “this won’t generate documents that blind people can read”.  The WG has decided that they don’t care.*  Does this “break a stream”?  Is the mechanical check on appeal all that mechanical in terms of interpreting what “breaking a stream” means? Should there be another check?  Should the doc go through?

These are just some thought exercises for people to consider as they evaluate proposals.  It’s not that these sorts of cases would be expected to come up often, and it is up to this group to decide whether to optimize for them or whether that would go too far.

Eliot

* The not-so-crazy version of this would be discussion of color in diagrams.

---

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 29 Jan 2021 11:33:16 +0100

> On 28. Jan 2021, at 21:50, Eliot Lear <lear=[email-masked]> wrote:
> 
> Hi Mirja
> 
> On this point:
> 
>> 

Each stream manage reviews the documents and then decides if the change in the document should be brought to the respective community for further feedback. In case of the IETF stream manager we would use the IETF last call process, IAB would put the document for discussion (and maybe vote) on an IAB agenda, the IRTF chair might request a review from thee IRSG, and the ISE could check with its review committee.

I don’t think it has to be a requirement that we run this process for all documents and I think it's okay to trust the stream managers judgement which ones should go that route. However, we could also do that for all documents as I don’t expect a too high load. Or we could also make different decision here for the different streams, e.g. start an IETF last call for all documents because why not…

Mirja

---

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 29 Jan 2021 11:37:26 +0100

I think those on the board who have a vote/ballot should be selected by the some community process and have a fixed term to ensure we have some refreshment over time. I wouldn’t want to see one of these position to be bound to one specific person. However, for the RSx I would actually like to have a person for a long time to provide continuity and enable that person to build up RFC specific expertise. That’s the conflict for me.

> On 29. Jan 2021, at 04:56, Michael StJohns <[email-masked]> wrote:
> 
>> On Thu, Jan 28, 2021 at 7:11 PM Brian E Carpenter <[email-masked]> wrote:
> 
> Yet, by design, the LLC board includes people that have other skills than writing protocols or chairing WGs and one of the current members is a lawyer and does get a vote.
> 
> Later, Mike
> 
> --

---

From: Adam Roach <[email-masked]>
Date: Fri, 29 Jan 2021 06:53:23 -0600

On 1/29/2021 1:38 AM, Eliot Lear wrote:
> Adam, I hope you don’t mind that I’m taking your note as an 
> opportunity to explore some hypotheticals.  Really I made a left turn 
> with it, but the DISCUSS discussion is as good of jump off point as 
> any ;-)
>
>> On 29 Jan 2021, at 06:28, Adam Roach <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> The most important aspect of a DISCUSS ballot is that, if an AD 
>> holding it is alone in their conviction, the position can be 
>> overridden — on substance, not process — by the remaining ADs. I have 
>> grave concerns about allowing someone to be alone in their 
>> disagreement (expert or not) without recourse.
>
> To my knowledge a single DISCUSS has never been overridden.  One can 
> draw one of two conclusions from that: either we pick really good ADs 
> who would not be overridden, or the process of overriding an AD is too 
> onerous.

No US president has ever been impeached and convicted, and yet I don't 
think anyone would think it prudent to remove the process. The presence 
of the mechanism is generally sufficient to compel behavior that avoids 
its technical invocation -- and in that second sentence, I'm talking 
about the DISCUSS ballot override procedure as much as impeachment. In 
my three years on the IESG, single-DISCUSS-override process invocations 
were *nearly* brought to bear in at least two cases; and without getting 
into the details, I can say that I believe the presence of the process 
served its intended purpose without actually being invoked.

>  Whether you want a veto override or a supermajority will depend on 
> the purpose of approval.
>
> I think EKR is arguing for a process veto based on something breaking 
> one of the streams (please correct me if I’m wrong).

If only process vetos are allowed, and if all process-related issues can 
be appealed and overridden, then all vetos can be appealed and 
overridden. If that's what we want to write down, then I'm happy.

The remainder of your discussion prompts are good, and I definitely 
think they need to be explored. However, my limited time to participate 
in this effort doesn't afford me the luxury of addressing everything. I 
do have a strong top-level concern about the ability of a hired expert 
(or any other person who cannot be removed by a community-initiated 
process) to unilaterally veto an overwhelming community position without 
recourse to appeal the *substance* of the decision, and that's the point 
I dropped in to make. I hope this topic gets driven to ground before we 
churn too much on the decision structure of the stream managers.

/a

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 29 Jan 2021 08:04:47 -0500

I hope that I am misreading Adam and EKR.  As far as I can tell, they 
are arguing against a proposal no one made.

What I suggested was that the RSE/A be a full member of the approval 
body with an equal vote with the stream manager.  I explicitly noted 
that this would mean that under most voting regimes this would require 
the RSE/A to be able to persuade at least one stream manager to agree 
with them about the importance of whatever problem they are raising.  It 
might even require them to be able to get two stream heads to agree with 
them.  Other folks phrased this in terms of the discuss procedure, with 
the same kind of discuss over-ride that the IESG uses (which in this 
case would mean that the 4 stream heads could over-ride a discuss by the 
RSE/A).

It may be that one proposal called for the RSE/A to have a full veto, 
but that is not what I have seen folks asking for, and not what I asked for.

Yours,
Joel

---

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 29 Jan 2021 15:07:28 +0100

Hi Joel,

I think what we discussed to far and what people might have on their mind is a ballot-like model as used by the IESG where every single DISCUSS position blocks publication (and not a majority voting which you seem to have on mind, right?).

Mirja

> On 29. Jan 2021, at 14:04, Joel M. Halpern <[email-masked]> wrote:
> 
> I hope that I am misreading Adam and EKR.  As far as I can tell, they are arguing against a proposal no one made.
> 
> What I suggested was that the RSE/A be a full member of the approval body with an equal vote with the stream manager.  I explicitly noted that this would mean that under most voting regimes this would require the RSE/A to be able to persuade at least one stream manager to agree with them about the importance of whatever problem they are raising.  It might even require them to be able to get two stream heads to agree with them.  Other folks phrased this in terms of the discuss procedure, with the same kind of discuss over-ride that the IESG uses (which in this case would mean that the 4 stream heads could over-ride a discuss by the RSE/A).
> 
> It may be that one proposal called for the RSE/A to have a full veto, but that is not what I have seen folks asking for, and not what I asked for.
> 
> Yours,
> Joel
>

---

From: Eliot Lear <[email-masked]>
Date: Fri, 29 Jan 2021 15:16:09 +0100

I think Joel meant “voting system” in a generic way, IESG-like DISCUSS being just one such approach.

> On 29 Jan 2021, at 15:07, Mirja Kuehlewind <[email-masked]> wrote:
> 
> Hi Joel,
>

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 29 Jan 2021 14:16:55 +0000

Still wondering if we're not covering all the
kinds of decisions needed, sorry;-)

On 29/01/2021 14:07, Mirja Kuehlewind wrote:
> I think what we discussed to far and what people might have on their
> mind is a ballot-like model as used by the IESG where every single
> DISCUSS position blocks publication (and not a majority voting which
> you seem to have on mind, right?).

The above assumes that most/all decisions are
based around document approval. Heather put in
place an archival agreement for RFCs with a
couple of archiving institutions. Regardless of
whether one thinks that was fantastic or not
needed, ISTM the set of activities required
wouldn't map well to a WG/IESG-like document
approval process.

I'm a bit worried we're ignoring such things,
perhaps because we're more used to haggling
over how many DISCUSS ballots fit on the head
of a pin:-)

Cheers,
S.

---

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 29 Jan 2021 15:21:49 +0100

Please see below.

> On 29. Jan 2021, at 15:16, Stephen Farrell <[email-masked]> wrote:
> 
> 

Not sure. The process I would see in future for these kind of things is that something like this would be proposed to the working group in form of a short document (that also explains why this is useful or needed). That document would be approved and published and then the LLC will help to execute such agreements. It might look like overhead to have a document here but I think it would actually be useful now to have some documentation of why Heather thought these agreements are important.

Mirja

> <OpenPGP_0x5AB2FAF17B172BEA.asc>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 29 Jan 2021 15:23:15 +0100

Yes, I just wanted to say that I believe Joel and Adam/EKR have to different systems in mind and therefore might be taking past each other a bit… just trying to help…

> On 29. Jan 2021, at 15:16, Eliot Lear <[email-masked]> wrote:
>

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 29 Jan 2021 06:33:16 -0800

On Fri, Jan 29, 2021 at 5:05 AM Joel M. Halpern <[email-masked]> wrote:

> body with an equal vote with the stream manager.

Understood. I am not in favor of this. I believe the actual decision making
should be done by people who were selected by a community-driven
process, rather than hired experts.

-Ekr

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 29 Jan 2021 15:05:55 +0000

Hiya,

On 29/01/2021 14:21, Mirja Kuehlewind wrote:
> Not sure. The process I would see in future for these kind of things
> is that something like this would be proposed to the working group in
> form of a short document (that also explains why this is useful or
> needed). That document would be approved and published and then the
> LLC will help to execute such agreements. It might look like overhead
> to have a document here but I think it would actually be useful now
> to have some documentation of why Heather thought these agreements
> are important.
I fear that misses the point. Assuming for a second
that that archiving arrangement was a good plan, a
document-based approach could quite likely have lead
to asking the LLC to go issue an RFP or some such,
and I reckon that'd be a worse outcome. In that case,
and perhaps in many other cases, I believe there were
a number of informal investigation steps before anything
was agreed, so while yes, it'd have been good if the
arrangement had been documented after it was arrived
at, (and maybe that happened, I don't know), I'd worry
that driving everything via document publication and
approval is just a bad plan.

S.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 29 Jan 2021 10:06:08 -0500

I would like an approach along the lines of the IESG discuss where one 
objector forces serious discussion, but unless that objector can get 
support, they eventually have to yield.  I can live with a majority vote 
proposaal (which would require the RSE/A to be able to get two 
supporters to block something.)
What I was commenting on specifically was those who were objecting to 
giving the RSE/A a veto, when that was not what was asked.

I understand from EKRs response to my message that even with those 
approaches, he does support this, and wants only community appointed 
people having any say in the approval.

I do not see how to get past so fundamental a degree of disagreement. 
But I hope we can.

Yours,
Joel

PS: I suspect Stephen has a good point that focusing on the documents 
may cause us to miss important aspects of what we are discussing, even 
if we (reasonably) assume that all decisions need to end up documented.

---

From: Eliot Lear <[email-masked]>
Date: Fri, 29 Jan 2021 19:42:30 +0100

Is there a middle ground here in which the RSE/A acts as an ex-officio non-voting member of the approval body, who can raise issues that would “break the series” but have to garner some amount of support from voting members to halt a proposal?  This would move the ballgame to what does it mean, “break the series”.

Eliot

> On 29 Jan 2021, at 16:06, Joel M. Halpern <[email-masked]> wrote:
> 
> I would like an approach along the lines of the IESG discuss where one objector forces serious discussion, but unless that objector can get support, they eventually have to yield.  I can live with a majority vote proposaal (which would require the RSE/A to be able to get two supporters to block something.)
> What I was commenting on specifically was those who were objecting to giving the RSE/A a veto, when that was not what was asked.
> 
> I understand from EKRs response to my message that even with those approaches, he does support this, and wants only community appointed people having any say in the approval.
> 
> I do not see how to get past so fundamental a degree of disagreement. But I hope we can.
> 
> Yours,
> Joel
> 
> PS: I suspect Stephen has a good point that focusing on the documents may cause us to miss important aspects of what we are discussing, even if we (reasonably) assume that all decisions need to end up documented.
>

---

From: Lucy Lynch <[email-masked]>
Date: Fri, 29 Jan 2021 14:24:14 -0800

> On Jan 29, 2021, at 10:42 AM, Eliot Lear <lear=[email-masked]> wrote:
> 
> Is there a middle ground here in which the RSE/A acts as an ex-officio non-voting member of the approval body, who can raise issues that would “break the series” but have to garner some amount of support from voting members to halt a proposal?

Not for me - I strongly believe that the RSE/A needs active inclusion and a voting role here. The long term health and usability of the series for all the use cases outside of steam authors must have weight in these discussions. A body composed of just the stream editors will be to short sighted and if the RSE/A is included it should be as a full member.

>  This would move the ballgame to what does it mean, “break the series”.
> 
> Eliot
>

---

From: Nevil Brownlee <[email-masked]>
Date: Sat, 30 Jan 2021 15:58:46 +1300

Hi all:
I reckon there's a lot of pointless argument on this list!

The RSE/A does not have veto powers over the rest of the oversight
committee, a workable consensus is needed for every proposed change.

Also, I agree completely with Lucy - the RSE/A eeds active inclusion
and a voting role here.  Also, the RSE/A does not have veto powers
over the rest of the oversight committee, a workable consensus is
needed for every proposed change

Cheers, Nevil

> >  This would move the ballgame to what does it mean, “break the series”.

-----------------------------------
Nevil Brownlee, Taupo, NZ

---

From: S Moonesamy <[email-masked]>
Date: Fri, 29 Jan 2021 19:24:05 -0800

Dear Program Chairs,

Is there a Last Call on a proposal?

Regards,
S. Moonesamy

---

From: Eliot Lear <[email-masked]>
Date: Sat, 30 Jan 2021 09:53:51 +0100

Hi SM

> On 30 Jan 2021, at 04:24, S Moonesamy <[email-masked]> wrote:
> 
> Dear Program Chairs,
> 

Not for any particular draft.  However we have completed a number of consensus calls.  I will send separate messages on that.

Eliot

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 31 Jan 2021 13:03:57 -0800

On Fri, Jan 29, 2021 at 10:42 AM Eliot Lear <lear=[email-masked]>
wrote:

> Is there a middle ground here in which the RSE/A acts as an ex-officio
> non-voting member of the approval body, who can raise issues that would
> “break the series” but have to garner some amount of support from voting
> members to halt a proposal?  This would move the ballgame to what does it
> mean, “break the series”.
>

I can live with this.

-Ekr

> proposaal (which would require the RSE/A to be able to get two supporters
> to block something.)
> approaches, he does support this, and wants only community appointed people
> having any say in the approval.
> >
> may cause us to miss important aspects of what we are discussing, even if
> we (reasonably) assume that all decisions need to end up documented.
> >
> mind is a ballot-like model as used by the IESG where every single DISCUSS
> position blocks publication (and not a majority voting which you seem to
> have on mind, right?).
> >> Mirja
> body with an equal vote with the stream manager.  I explicitly noted that
> this would mean that under most voting regimes this would require the RSE/A
> to be able to persuade at least one stream manager to agree with them about
> the importance of whatever problem they are raising.  It might even require
> them to be able to get two stream heads to agree with them.  Other folks
> phrased this in terms of the discuss procedure, with the same kind of
> discuss over-ride that the IESG uses (which in this case would mean that
> the 4 stream heads could over-ride a discuss by the RSE/A).
> >>>
> holding it is alone in their conviction, the position can be overridden —
> on substance, not process — by the remaining ADs. I have grave concerns
> about allowing someone to be alone in their disagreement (expert or not)
> without recourse.
> >>>> /a
> >>>
> >>> --

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 1 Feb 2021 10:35:41 +1300

That's how I think the DISCUSS in the IESG was really intended to work anyway.

Regards
   Brian C

On 01-Feb-21 10:03, Eric Rescorla wrote:
> 
> 
> On Fri, Jan 29, 2021 at 10:42 AM Eliot Lear <lear=[email-masked] <mailto:[email-masked]>> wrote:
> 
>     > On 29 Jan 2021, at 16:06, Joel M. Halpern <[email-masked] <mailto:[email-masked]>> wrote:
>     >
>     >>> On 29. Jan 2021, at 14:04, Joel M. Halpern <[email-masked] <mailto:[email-masked]>> wrote:
>     >>>
>     >>>>> On Jan 28, 2021, at 21:11, Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
>     >>>>>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 31 Jan 2021 17:25:10 -0500

Why "ex-officio".   All of the procedures I have seen proposed require 
that the RSE/A has to get some support from the stream heads.  (The 
details vary as to whether one or two other stream heads need to agree.)
I think it is far more sensible and effective for the RSE/A to be an 
official voting member of the body.
After all, anyone can raise an issue with the approval body.

Net: I am happy to require that for the RSE/A objection to stick there 
has to be some support from the other members of the body.
I am not happy with the RSE/A being a non-voting member of the body.  (I 
am not sure what meaning is intended by "ex-officio".  If the maning is 
"by virtue of that person's position", then yes, they are an ex-officio 
member (I hope voting).  If it means "different class of member then I 
also object to the term.)

Yours,
Joel

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 31 Jan 2021 16:15:58 -0800

> also object to the term.)

I don't think the term ex officio decides the question one way or the other.

For example, the IAB chair is an ex officio member of the IESG [0] but does
not get to ballot.
By contrast, the IESG chair was an ex officio member of the IAOC [1] and
voted.

-Ekr

[0] https://tools.ietf.org/html/rfc3710#section-2
[1] https://iaoc.ietf.org/members.html

> >> On Fri, Jan 29, 2021 at 10:42 AM Eliot Lear <lear=
> [email-masked] <mailto:[email-masked]>> wrote:
> >>
> >>      Is there a middle ground here in which the RSE/A acts as an
> ex-officio non-voting member of the approval body, who can raise issues
> that would “break the series” but have to garner some amount of support
> from voting members to halt a proposal?  This would move the ballgame to
> what does it mean, “break the series”.
> >>
> >>
> >> I can live with this.
> >>
> >> -Ekr
> >>
> >>
> >>      Eliot
> >>
> >>      > I would like an approach along the lines of the IESG discuss
> where one objector forces serious discussion, but unless that objector can
> get support, they eventually have to yield.  I can live with a majority
> vote proposaal (which would require the RSE/A to be able to get two
> >>      > What I was commenting on specifically was those who were
> objecting to giving the RSE/A a veto, when that was not what was asked.
> >>      >
> >>      > I understand from EKRs response to my message that even with
> those approaches, he does support this, and wants only community appointed
> >>      > PS: I suspect Stephen has a good point that focusing on the
> documents may cause us to miss important aspects of what we are discussing,
> even if we (reasonably) assume that all decisions need to end up documented.
> >>      >
> >>      >> I think what we discussed to far and what people might have on
> their mind is a ballot-like model as used by the IESG where every single
> DISCUSS position blocks publication (and not a majority voting which you
> seem to have on mind, right?).
> >>      >> Mirja
> >>      >>> On 29. Jan 2021, at 14:04, Joel M. Halpern <
> [email-masked] <mailto:[email-masked]>> wrote:
> >>      >>>
> >>      >>> I hope that I am misreading Adam and EKR.  As far as I can
> tell, they are arguing against a proposal no one made.
> >>      >>>
> >>      >>> What I suggested was that the RSE/A be a full member of the
> approval body with an equal vote with the stream manager.  I explicitly
> noted that this would mean that under most voting regimes this would
> require the RSE/A to be able to persuade at least one stream manager to
> agree with them about the importance of whatever problem they are raising.
> It might even require them to be able to get two stream heads to agree with
> them.  Other folks phrased this in terms of the discuss procedure, with the
> same kind of discuss over-ride that the IESG uses (which in this case would
> mean that the 4 stream heads could over-ride a discuss by the RSE/A).
> >>      >>>
> >>      >>> It may be that one proposal called for the RSE/A to have a
> full veto, but that is not what I have seen folks asking for, and not what
> I asked for.
> >>      >>>
> >>      >>> Yours,
> >>      >>> Joel
> >>      >>>
> >>      >>>>> On Jan 28, 2021, at 21:11, Brian E Carpenter <
> >>      >>>> The most important aspect of a DISCUSS ballot is that, if an
> AD holding it is alone in their conviction, the position can be overridden
> — on substance, not process — by the remaining ADs. I have grave concerns

---

From: Joel Halpern Direct <[email-masked]>
Date: Sun, 31 Jan 2021 19:21:06 -0500

Then  (if the term "ex-officio" is largely irrelevant) it seems we 
should focus on the question that matters, whether the RSE/A has a vote. 
  And worry about the exact description of their membership once we know 
what we want from the role.

And there we seem to differ.

Yours,
Joel

On 1/31/2021 7:15 PM, Eric Rescorla wrote:
> 
> 
> On Sun, Jan 31, 2021 at 2:25 PM Joel M. Halpern <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> For example, the IAB chair is an ex officio member of the IESG [0] but 
> does not get to ballot.
> <https://tools.ietf.org/html/rfc3710#section-2>
> [1] https://iaoc.ietf.org/members.html <https://iaoc.ietf.org/members.html>
> 
> 
>     Yours,
>     Joel
> 
>      >> On Fri, Jan 29, 2021 at 10:42 AM Eliot Lear
>     <lear=[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >>
>     ex-officio non-voting member of the approval body, who can raise
>     issues that would “break the series” but have to garner some amount
>     of support from voting members to halt a proposal?  This would move
>     the ballgame to what does it mean, “break the series”.
>      >>
>      >>
>      >> I can live with this.
>      >>
>      >> -Ekr
>      >>
>      >>
>      >>      Eliot
>      >>
>      >>      > On 29 Jan 2021, at 16:06, Joel M. Halpern
>     <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>      >>      >
>      >>      > I would like an approach along the lines of the IESG
>     discuss where one objector forces serious discussion, but unless
>     that objector can get support, they eventually have to yield.  I can
>     live with a majority vote proposaal (which would require the RSE/A
>     to be able to get two supporters to block something.)
>      >>      > What I was commenting on specifically was those who were
>      >>      >
>      >>      > I understand from EKRs response to my message that even
>     with those approaches, he does support this, and wants only
>     community appointed people having any say in the approval.
>      >>      >
>      >>      > I do not see how to get past so fundamental a degree of
>     disagreement. But I hope we can.
>      >>      >
>      >>      > Yours,
>      >>      > Joel
>      >>      >
>      >>      > PS: I suspect Stephen has a good point that focusing on
>     the documents may cause us to miss important aspects of what we are
>     discussing, even if we (reasonably) assume that all decisions need
>     to end up documented.
>      >>      >
>      >>      > On 1/29/2021 9:07 AM, Mirja Kuehlewind wrote:
>      >>      >> Hi Joel,
>      >>      >> I think what we discussed to far and what people might
>     have on their mind is a ballot-like model as used by the IESG where
>     every single DISCUSS position blocks publication (and not a majority
>     voting which you seem to have on mind, right?).
>      >>      >> Mirja
>      >>      >>> On 29. Jan 2021, at 14:04, Joel M. Halpern
>     <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>      >>      >>>
>      >>      >>> I hope that I am misreading Adam and EKR.  As far as I
>     can tell, they are arguing against a proposal no one made.
>      >>      >>>
>      >>      >>> What I suggested was that the RSE/A be a full member of
>     the approval body with an equal vote with the stream manager.  I
>     explicitly noted that this would mean that under most voting regimes
>     this would require the RSE/A to be able to persuade at least one
>     stream manager to agree with them about the importance of whatever
>     problem they are raising.  It might even require them to be able to
>     get two stream heads to agree with them.  Other folks phrased this
>     in terms of the discuss procedure, with the same kind of discuss
>     over-ride that the IESG uses (which in this case would mean that the
>     4 stream heads could over-ride a discuss by the RSE/A).
>      >>      >>>
>      >>      >>> It may be that one proposal called for the RSE/A to
>     have a full veto, but that is not what I have seen folks asking for,
>     and not what I asked for.
>      >>      >>>
>      >>      >>> Yours,
>      >>      >>> Joel
>      >>      >>>
>      >>      >>> On 1/29/2021 12:28 AM, Adam Roach wrote:
>      >>      >>>>> On Jan 28, 2021, at 21:11, Brian E Carpenter
>     <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >>      >>>>>
>      >>      >>>>> A point below which may appear picky but is actually
>     fundemental to this disagreement:
>      >>      >>>>>
>      >>      >>>>>> On 29-Jan-21 15:43, Martin J. Dürst wrote:
>      >>      >>>>>>> On 29/01/2021 09:17, Eric Rescorla wrote:
>      >>      >>>>>>> On Thu, Jan 28, 2021 at 4:01 PM Brian E Carpenter
>      >>      >>>>>>
>      >>      >>>>>>>> If we select this person on the grounds that they
>     know more about technical
>      >>      >>>>>>>> publishing than the rest of us do, that seems like
>     exactly what we need as
>      >>      >>>>>>>> a finger on the DISCUSS button.
>      >>      >>>>>>>>
>      >>      >>>>>>>
>      >>      >>>>>>> We engage a lawyer who is also an expert on topics
>     that we are not, and
>      >>      >>>>>>> which are rather more consequential if we screw
>     them up, and yet we don't
>      >>      >>>>>>> give them a veto.
>      >>      >>>>>>
>      >>      >>>>>> The expertise of lawyers is more widely acknowledged
>     by most
>      >>      >>>>>> participants because most participants are more
>     accustomed to deal with
>      >>      >>>>>> lawyers, and know that some stuff has to be left to
>     the lawyers. Also,
>      >>      >>>>>> lawyers are more used to attempts to screw them up,
>     and know what to
>      >>      >>>>>> ignore, how to defend themselves, and so on. It's
>     difficult to imagine
>      >>      >>>>>> that a lawyer would quit because they were treated
>     as "just a
>      >>      >>>>>> contractor", because being treated as "just a
>     contractor" wouldn't
>      >>      >>>>>> happen to the lawyer in the first place, or only to
>     the extent that they
>      >>      >>>>>> would be used to be as part of their usual business.
>      >>      >>>>>>
>      >>      >>>>>> This seems to be quite different for an expert in
>     technical publishing.
>      >>      >>>>>> They are not licensed, they don't have any arms to
>     twist, and so on.
>      >>      >>>>>>
>      >>      >>>>>> Also, I think "give them a veto" may exaggerate a
>     bit. A DISCUSS
>      >>      >>>>>> formally is a veto, but many DISCUSSes have been
>     retracted without the
>      >>      >>>>>> raiser having gotten exactly what they originally
>     proposed.
>      >>      >>>>>
>      >>      >>>>> No, a DISCUSS is *not* formally a veto. It is quite
>     narrowly defined
>      >>      >>>>> and there is a procedure for overriding a DISCUSS. See
>      >>      >>>>>
>     <https://www.ietf.org/about/groups/iesg/statements/iesg-discuss-criteria/>
>      >>      >>>>> Indeed, a similar definition and procedure would be
>     appropriate in
>      >>      >>>>> this case too.
>      >>      >>>> The most important aspect of a DISCUSS ballot is that,
>     if an AD holding it is alone in their conviction, the position can
>     be overridden — on substance, not process — by the remaining ADs. I
>     have grave concerns about allowing someone to be alone in their
>      >>      >>>> /a
>      >>      >>>
>      >>      >>> --
>      >>      >>> Rfced-future mailing list
>      >>      >>> [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>      >>      >>> https://www.iab.org/mailman/listinfo/rfced-future
>     <https://www.iab.org/mailman/listinfo/rfced-future>
>      >>      >
>      >>      > --
>      >>      > Rfced-future mailing list
>      >>      > [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>      >>      > https://www.iab.org/mailman/listinfo/rfced-future
>     <https://www.iab.org/mailman/listinfo/rfced-future>
>      >>
>      >>      --
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     <https://www.iab.org/mailman/listinfo/rfced-future>
>      >>
>      >>
>      >
>

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 31 Jan 2021 16:33:25 -0800

> what we want from the role.

Sure. As far as I can tell, all of the people on this proposed committee
are ex officio, in that they are there by benefit of their position.

Yes. Perhaps a topic for the interim

-Ekr

> >      >>      > On 29 Jan 2021, at 16:06, Joel M. Halpern
> >      >>      > I would like an approach along the lines of the IESG
> >      >>      > I understand from EKRs response to my message that even
> >      >>      > PS: I suspect Stephen has a good point that focusing on
> >      >>      >> I think what we discussed to far and what people might
> >      >>      >>> On 29. Jan 2021, at 14:04, Joel M. Halpern
> >      >>      >>> I hope that I am misreading Adam and EKR.  As far as I
> >      >>      >>> What I suggested was that the RSE/A be a full member of
> >      >>      >>> It may be that one proposal called for the RSE/A to
> >      >>      >>>>> On Jan 28, 2021, at 21:11, Brian E Carpenter
> >     <
> https://www.ietf.org/about/groups/iesg/statements/iesg-discuss-criteria/>
> >      >>      >>>> The most important aspect of a DISCUSS ballot is that,

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 1 Feb 2021 16:06:35 +1300

On 01-Feb-21 13:33, Eric Rescorla wrote:
> 
> 
> On Sun, Jan 31, 2021 at 4:21 PM Joel Halpern Direct <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Sure. As far as I can tell, all of the people on this proposed committee are ex officio, in that they are there by benefit of their position.
> 
> 

What we want, really, is consensus (*not* rough consensus) in the approval body. In a small group, ideally, consensus occurs without voting. If we take that as a starting point, the question is not who is a "voting member" but how the body reaches consensus.

    Brian C

>     > On Sun, Jan 31, 2021 at 2:25 PM Joel M. Halpern <[email-masked] <mailto:[email-masked]>
>     >      > That's how I think the DISCUSS in the IESG was really intended to
>     >     work anyway.
>     >      >
>     >      > Regards
>     >      >     Brian C
>     >      >
>     >      > On 01-Feb-21 10:03, Eric Rescorla wrote:
>     >      >>
>     >      >>
>     >      >> On Fri, Jan 29, 2021 at 10:42 AM Eliot Lear
>     >     <lear=[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>     >     <mailto:[email-masked] <mailto:[email-masked]>
>     >     <mailto:[email-masked] <mailto:[email-masked]>>>> wrote:
>     >      >>
>     >      >>      Is there a middle ground here in which the RSE/A acts as an
>     >      >>
>     >      >>
>     >      >> I can live with this.
>     >      >>
>     >      >> -Ekr
>     >      >>
>     >      >>
>     >      >>      Eliot
>     >      >>
>     >      >>      > On 29 Jan 2021, at 16:06, Joel M. Halpern
>     >     <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>     >     <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>> wrote:
>     >      >>      >
>     >      >>      > I would like an approach along the lines of the IESG
>     >      >>      > What I was commenting on specifically was those who were
>     >      >>      >
>     >      >>      > I understand from EKRs response to my message that even
>     >      >>      >
>     >      >>      > I do not see how to get past so fundamental a degree of
>     >      >>      >
>     >      >>      > Yours,
>     >      >>      > Joel
>     >      >>      >
>     >      >>      > PS: I suspect Stephen has a good point that focusing on
>     >      >>      >
>     >      >>      > On 1/29/2021 9:07 AM, Mirja Kuehlewind wrote:
>     >      >>      >> Hi Joel,
>     >      >>      >> I think what we discussed to far and what people might
>     >      >>      >> Mirja
>     >      >>      >>> On 29. Jan 2021, at 14:04, Joel M. Halpern
>     >     <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>     >     <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>> wrote:
>     >      >>      >>>
>     >      >>      >>> I hope that I am misreading Adam and EKR.  As far as I
>     >      >>      >>>
>     >      >>      >>> What I suggested was that the RSE/A be a full member of
>     >      >>      >>>
>     >      >>      >>> It may be that one proposal called for the RSE/A to
>     >      >>      >>>
>     >      >>      >>> Yours,
>     >      >>      >>> Joel
>     >      >>      >>>
>     >      >>      >>> On 1/29/2021 12:28 AM, Adam Roach wrote:
>     >      >>      >>>>> On Jan 28, 2021, at 21:11, Brian E Carpenter
>     >     <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>     >     <mailto:[email-masked] <mailto:[email-masked]>
>     >     <mailto:[email-masked] <mailto:[email-masked]>>>> wrote:
>     >      >>      >>>>>
>     >      >>      >>>>> A point below which may appear picky but is actually
>     >      >>      >>>>>
>     >      >>      >>>>>> On 29-Jan-21 15:43, Martin J. Dürst wrote:
>     >      >>      >>>>>>> On 29/01/2021 09:17, Eric Rescorla wrote:
>     >      >>      >>>>>>> On Thu, Jan 28, 2021 at 4:01 PM Brian E Carpenter
>     >      >>      >>>>>>
>     >      >>      >>>>>>>> If we select this person on the grounds that they
>     >      >>      >>>>>>>> publishing than the rest of us do, that seems like
>     >     exactly what we need as
>     >      >>      >>>>>>>> a finger on the DISCUSS button.
>     >      >>      >>>>>>>>
>     >      >>      >>>>>>>
>     >      >>      >>>>>>> We engage a lawyer who is also an expert on topics
>     >     that we are not, and
>     >      >>      >>>>>>> which are rather more consequential if we screw
>     >      >>      >>>>>>> give them a veto.
>     >      >>      >>>>>>
>     >      >>      >>>>>> The expertise of lawyers is more widely acknowledged
>     >     by most
>     >      >>      >>>>>> participants because most participants are more
>     >     accustomed to deal with
>     >      >>      >>>>>> lawyers, and know that some stuff has to be left to
>     >     the lawyers. Also,
>     >      >>      >>>>>> lawyers are more used to attempts to screw them up,
>     >     and know what to
>     >      >>      >>>>>> ignore, how to defend themselves, and so on. It's
>     >     difficult to imagine
>     >      >>      >>>>>> that a lawyer would quit because they were treated
>     >     as "just a
>     >      >>      >>>>>> contractor", because being treated as "just a
>     >     contractor" wouldn't
>     >      >>      >>>>>> happen to the lawyer in the first place, or only to
>     >     the extent that they
>     >      >>      >>>>>> would be used to be as part of their usual business.
>     >      >>      >>>>>>
>     >      >>      >>>>>> This seems to be quite different for an expert in
>     >     technical publishing.
>     >      >>      >>>>>> They are not licensed, they don't have any arms to
>     >     twist, and so on.
>     >      >>      >>>>>>
>     >      >>      >>>>>> Also, I think "give them a veto" may exaggerate a
>     >     bit. A DISCUSS
>     >      >>      >>>>>> formally is a veto, but many DISCUSSes have been
>     >     retracted without the
>     >      >>      >>>>>> raiser having gotten exactly what they originally
>     >     proposed.
>     >      >>      >>>>>
>     >      >>      >>>>> No, a DISCUSS is *not* formally a veto. It is quite
>     >     narrowly defined
>     >      >>      >>>>> and there is a procedure for overriding a DISCUSS. See
>     >      >>      >>>>>
>     >      >>      >>>>> Indeed, a similar definition and procedure would be
>     >     appropriate in
>     >      >>      >>>>> this case too.
>     >      >>      >>>> The most important aspect of a DISCUSS ballot is that,
>     >      >>      >>>> /a
>     >      >>      >>>
>     >      >>      >>> --
>     >      >>      >>> Rfced-future mailing list
>     >      >>      >>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>     >     <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>     >      >>      >>> https://www.iab.org/mailman/listinfo/rfced-future
>     >      >>      >
>     >      >>      > --
>     >      >>      > Rfced-future mailing list
>     >      >>      > [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>     >     <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>     >      >>      > https://www.iab.org/mailman/listinfo/rfced-future
>     >      >>
>     >      >>      --
>     >      >>      Rfced-future mailing list
>     >      >> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>     >     <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>     >      >> https://www.iab.org/mailman/listinfo/rfced-future
>     >      >>
>     >      >>

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 01 Feb 2021 15:10:48 +1100

On Mon, Feb 1, 2021, at 14:06, Brian E Carpenter wrote:
> What we want, really, is consensus (*not* rough consensus) in the 
> approval body. In a small group, ideally, consensus occurs without 
> voting. If we take that as a starting point, the question is not who is 
> a "voting member" but how the body reaches consensus.

I think that given the dynamics involved, agreement should be the common case here.  If this were just stream managers, those people would all agree (ideally based on consultation with other stakeholders for their stream) that the proposed change is good.

What we are looking for is for a stream to be able to say "no, this is unworkable to the extent that it would damage my stream".  And for that, I liked Russ' proposal: any stream manager can block a proposal on those grounds, provided that they follow some process (my suggestion would be that they produce clear documentation explaining why).  That might be enough.  Or, if you decide that the occurrence of recalcitrance on the part of a single stream is unacceptable, you might say that, given the blocking position from one stream, the other streams can - with unanimity and after considering the arguments presented - override that position.

That's all very crisp and it depends on clearly established lines of responsibility that trace to stakeholders.  I think we're struggling here with the manner in which other stakeholders have their say: whether it be during the open process of working group deliberations or whether it is at this "approval" stage.  Ekr proposed that this be approval only.  I think that others have imagined a larger forum where other stakes are represented, through their position (RSA/E) or through something like the Nomcom.  I like the simpler approval structure with a narrow remit and direct responsibility, because it is very clear on the extent of the powers and responsibilities of the body.

The risk that Joel and others have raised of groupthink might be addressed by ensuring that the working group present dissenting arguments when (rough) consensus is reached on a proposed change.  You don't necessarily have to privilege the expert position here in process, though you might encode in their contract an expectation that they contribute such documents if - in their professional opinion - the consensus position had any flaws.  You might even say that they provide an an analysis of any proposal from the group.  Then, all it takes is for those arguments to convince one person (or to be fair, the community they represent) for the consensus to be overturned.