Subject: [Rfced-future] draft-saintandre-rfced-model - msj2

From: Michael StJohns <[email-masked]>
Date: Mon, 26 Apr 2021 22:05:02 -0400

The first paragraph of section 5.1.2, specifically the sentence 
beginning "The sole function..." does not appear to represent a 
consensus, and from my point of view is likely to contribute to a 
failure of the process.

Basically, there needs to be a way for the RSAB to move documents along 
that they believe are necessary to provide for the operation of their 
streams and the overall RFC series, even if they are unable to gain 
consensus within the RSWG.   And that assumes (and this is not 
necessarily valid) that the RSWG is both populated and functional.

Loud noises (or total silence) in the RSWG should not prevent the RSAB 
from authoring a document, providing it for community comment and 
publishing it to address a need the RSWG has no interest in addressing.

Section 5.2.2 must change to admit for RSAB originated documents.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 26 Apr 2021 22:22:46 -0400

Given that this is to be strategic direction, not tactical choices or 
day-to-day operations, it is not clear to me that the RSAB does need (or 
even should have) the authority to move a document forward without the 
support of the RSWG.  If it is that important, they ought to be able to 
get more people to participate so that the RSWG engages.  If they can't 
get necessary work done, then it seems to me we have a problem with the 
whole process.

Yours,
Joel

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 27 Apr 2021 12:22:49 +1000

On Tue, Apr 27, 2021, at 12:05, Michael StJohns wrote:
> consensus within the RSWG.   

I can't agree with this.

Streams that *need* to publish can publish on their own streams.  That might be subject to rules established for that stream, but if something is important enough for a stream, that's an option.

When it comes to things that affect all streams, having this closed group act without engaging with the RSWG is just outside the spirit of the agreed structure.  We're still talking about strategy, are we not?

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 27 Apr 2021 14:34:35 +1200

> When it comes to things that affect all streams, having this closed group act without engaging with the RSWG is just outside the spirit of the agreed structure.  We're still talking about strategy,…

Yes. IMHO it should be a bit like the difference between a law (which has been through the whole legislative process) and a regulation (which is signed off by an official). For example, imagine an RFC that says "There shall be a style guide. Its text is approved by the RSAE." You might not agree with that, but it would make the boundaries of authority clear. I think Mike's model would create some fuzziness.

    Brian

---

From: Michael StJohns <[email-masked]>
Date: Mon, 26 Apr 2021 22:43:15 -0400

On 4/26/2021 10:22 PM, Joel M. Halpern wrote:
> day-to-day operations, it is not clear to me that the RSAB does need 
> (or even should have) the authority to move a document forward without 
> the support of the RSWG.  If it is that important, they ought to be 
> able to get more people to participate so that the RSWG engages.  If 
> they can't get necessary work done, then it seems to me we have a 
> problem with the whole process.

This WG which really isn't a WG needs to be able to operate 
indefinitely, without a WG like charter (e.g. with a defined work plan) 
with very intermittent document production.   It may go years between 
producing a document.  Which might mean having to actively recruit new 
people with each possible document.  Not what I would consider a formula 
for success.

I expect that many (most?) documents will be rather non-controversial, 
will involve specific nuances of publication technology or process that 
most IETF participants couldn't care to expend a single read on, and 
could mostly be farmed out to the paid-for expert.   Providing those for 
community comment, revision by the expert and approval by the RSAB would 
seem to me to be at least the fall back process.

I expect pretty much any document in this series to be "strategic" for 
some value of strategic.   I expect the RSAB and the RSWG to keep its 
fingers out of the tactical and day to day stuff (e.g. most of what John 
L is doing for us).

By default, the minimum RSWG consists of the RSAB plus the two chairs.   
I expect that to be the typical set of participants as well except for 
dealing with some of the hobby horses certain folk are hoping to ride 
once this gets done.  C.f. Mark Nottingham's document.  Once those are 
disposed of, I hope for blessed silence.

I maintain this needs to be opened as an issue.

(I think the above covers Martin's note as well).

Mike

>> Basically, there needs to be a way for the RSAB to move documents 
>> along that they believe are necessary to provide for the operation of 
>> their streams and the overall RFC series, even if they are unable to 
>> gain consensus within the RSWG.   And that assumes (and this is not 
>> Loud noises (or total silence) in the RSWG should not prevent the 
>> RSAB from authoring a document, providing it for community comment 
>> and publishing it to address a need the RSWG has no interest in 
>> addressing.
>>

---

From: Joel Halpern Direct <[email-masked]>
Date: Mon, 26 Apr 2021 22:54:53 -0400

In case I was unclear, I was not objecting to opening the issue.  I was 
starting the discussion of the issue.  I presume Eliot or Brian will 
open an issue as they indicated.

Yours,
Joel

On 4/26/2021 10:43 PM, Michael StJohns wrote:
> By default, the minimum RSWG consists of the RSAB plus the two chairs. I 
> expect that to be the typical set of participants as well except for

---

From: Eliot Lear <[email-masked]>
Date: Tue, 27 Apr 2021 09:47:14 +0200

> On 27 Apr 2021, at 04:54, Joel Halpern Direct <[email-masked]> wrote:
> 
> In case I was unclear, I was not objecting to opening the issue.  I was starting the discussion of the issue.  I presume Eliot or Brian will open an issue as they indicated.

Already done.  You can track all open issues at https://github.com/intarchboard/program-rfced-future/issues.

Eliot

>>> Given that this is to be strategic direction, not tactical choices or day-to-day operations, it is not clear to me that the RSAB does need (or even should have) the authority to move a document forward without the support of the RSWG.  If it is that important, they ought to be able to get more people to participate so that the RSWG engages.  If they can't get necessary work done, then it seems to me we have a problem with the whole process.
>> This WG which really isn't a WG needs to be able to operate indefinitely, without a WG like charter (e.g. with a defined work plan) with very intermittent document production.   It may go years between producing a document.  Which might mean having to actively recruit new people with each possible document.  Not what I would consider a formula for success.
>> I expect that many (most?) documents will be rather non-controversial, will involve specific nuances of publication technology or process that most IETF participants couldn't care to expend a single read on, and could mostly be farmed out to the paid-for expert.   Providing those for community comment, revision by the expert and approval by the RSAB would seem to me to be at least the fall back process.
>> I expect pretty much any document in this series to be "strategic" for some value of strategic.   I expect the RSAB and the RSWG to keep its fingers out of the tactical and day to day stuff (e.g. most of what John L is doing for us).
>> By default, the minimum RSWG consists of the RSAB plus the two chairs. I expect that to be the typical set of participants as well except for dealing with some of the hobby horses certain folk are hoping to ride once this gets done.  C.f. Mark Nottingham's document.  Once those are disposed of, I hope for blessed silence.
>>>> The first paragraph of section 5.1.2, specifically the sentence beginning "The sole function..." does not appear to represent a consensus, and from my point of view is likely to contribute to a failure of the process.
>>>> 
>>>> Basically, there needs to be a way for the RSAB to move documents along that they believe are necessary to provide for the operation of their streams and the overall RFC series, even if they are unable to gain consensus within the RSWG.   And that assumes (and this is not necessarily valid) that the RSWG is both populated and functional.
>>>> 
>>>> Loud noises (or total silence) in the RSWG should not prevent the RSAB from authoring a document, providing it for community comment and publishing it to address a need the RSWG has no interest in addressing.
>>>> 
> --
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: Eliot Lear <[email-masked]>
Date: Tue, 27 Apr 2021 09:48:34 +0200

I’ll open an issue on the below.  It would be good to know if others agree with Mike on this point.

Eliot

> On 27 Apr 2021, at 04:05, Michael StJohns <[email-masked]> wrote:
>

---

From: Eliot Lear <[email-masked]>
Date: Tue, 27 Apr 2021 09:49:06 +0200

Issue 50.