Subject: [Rfced-future] Proposal: Community calls for comment (transparency)

From: Mark Nottingham <[email-masked]>
Date: Tue, 8 Jun 2021 16:11:00 +1000

At the interim, I took a action item to propose text about community review and transparency. Looking at the current draft, I see that there is already an open issue to 'specify what counts as a "community call for [comment]".' 

My proposal is to insert the following into a new section for reference from 5.2.2 (Specifics); exact placement I leave to the editor.

~~~
X.X Community Call for Comment

When a community call for comment is made, the RSAB sends a notice to at least the rfc-interest mailing list with a Subject line beginning with "Call for Comment:". When either the RSAB or the RSWG considers the proposal warrant it, the notice is also be sent to the ietf-announce and irtf-announce mailing lists. Notices are also to be made available and archived on the rfc-editor.org web site.

A notice contains:

* A clear, concise summary of the proposal
* A URL for the proposal document 
* Any commentary or questions for the community that the RSAB deems necessary (using their usual decision-making procedures)
* Clear instructions on how to provide public comments
* A deadline for comments

A comment period will not be less than two weeks, unless both the RSAB and RSWG have consensus that adopting the proposal is urgent and uncontroversial, in which case the minimum comment period is one week. If a proposal requires more than one comment period, those after the first can be shortened to one week at the discretion of the RSAB.

Comments will be publicly archived on the rfc-editor.org web site.
~~~

Thoughts?

Since we're talking about transparency, I'm also inclined to think we need to have announcement and records about the decisions taken (in addition to the comment periods). E.g., any CONCERN positions and the actual voting of the RSAB needs to be made public, and archived. Does that make sense?

Also, I haven't addressed transparency in the RSWG, under the presumption that since it operates like a normal WG, it should follow that it operates in the open. If folks think that needs to be clarified or strengthened, we should do so.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 8 Jun 2021 02:37:09 -0400

Mark, I think I am missing two aspects in your proposed text.

First, it seems to me that any action that has reached final enough form 
for community comment should go to ietf-announce (or the ietf last-call 
list maybe?)  Saying that only special decisions need to go to the full 
IETF seems odd.

Separately, there was also extensive discussion on this list of the need 
to include the larger community in the feedback loop.  Your proposed 
text does nto seem to do so.

Yours,
Joel

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 8 Jun 2021 16:47:22 +1000

Hi Joel,

Thanks for the prompt feedback. Responses below.

> On 8 Jun 2021, at 4:37 pm, Joel M. Halpern <[email-masked]> wrote:
> 
> First, it seems to me that any action that has reached final enough form for community comment should go to ietf-announce (or the ietf last-call list maybe?)  Saying that only special decisions need to go to the full IETF seems odd.

I'm not against it, but am a bit wary of flooding ietf-announce with small changes. I suppose it might come down to the anticipated rate and granularity of the decisions flowing through this new group -- do we have a shared sense of that yet?

> Separately, there was also extensive discussion on this list of the need to include the larger community in the feedback loop.  Your proposed text does nto seem to do so.

rfc-interest would capture anyone who's interested enough in RFCs to be subscribed, regardless of IETF affiliation (as ephemeral a concept as that is).

Putting it on the RFC Editor Web site makes it discoverable to a broader audience as well. In previous drafts I specified that there should be an Atom/RSS feed of the notices; happy to add that again.

What else can we do? I suppose we could have a dedicated list just for the notices. We could more forcefully try to get it in front of people who a decision might affect -- but I suspect that's going to be an uphill battle, competing with much more enticing things for their interest. We could require circulating in relevant communities -- e.g., XML, publishing standards, etc. -- but that's largely a judgement call, and sometimes it's going to be difficult to identify the right place to engage a particular community; at best I think we could add some advisory text guiding the RSAB to consider broader audiences that are appropriate. Is that enough?

Suggestions very welcome here.

Cheers,

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 08 Jun 2021 17:21:57 +1000

On Tue, Jun 8, 2021, at 16:47, Mark Nottingham wrote:
> What else can we do? 

I think that rfc-interest@ and rfc-editor.org are probably adequate as a baseline.

Rather than attempting to enumerate the options, why not allow the RSAB to maintain a list of places that it might send notices to and allow them to exercise judgment in whether they do that.  I'd say that they can keep a list of "groups that might be interested" in a wiki or similar and just check to see if they want to share specially with those groups if something relevant to them comes up.

That's pretty much what you have, except that you are attempting to specify the list now.  I agree with Joel that maybe sometimes ietf-announce@ might be appropriate.  But I wouldn't mandate it.

What I think is needed is a system that would catch accidents where it would have been good for notice to be provided, but the RSAB just forgot.

---

From: Lars Eggert <[email-masked]>
Date: Tue, 8 Jun 2021 11:13:00 +0300

Hi,

> I'm not against it, but am a bit wary of flooding ietf-announce with small changes. I suppose it might come down to the anticipated rate and granularity of the decisions flowing through this new gr…

+1 on not flooding ietf-announce. We've already been getting feedback that it's too noisy (mostly due to some automatic datatracker-generated emails of maybe limited general interest.)

> rfc-interest would capture anyone who's interested enough in RFCs to be subscribed, regardless of IETF affiliation (as ephemeral a concept as that is).

Since ietf-announce is of course an IETF-specific list, again +1 for rfc-interest.

Thanks,
Lars

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 9 Jun 2021 16:36:19 +1200

Could you add some words to make it clear that this defines *minimum* targets for distribution, and that wider distribution is welcome and encouraged? 

Regards
   Brian

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 9 Jun 2021 15:40:14 +1000

> On 9 Jun 2021, at 2:36 pm, Brian E Carpenter <[email-masked]> wrote:
> 

Modified proposal:

~~~

When a community call for comment is made, the RSAB sends a notice containing:

* A Subject: line beginning with 'Call for Comment:'

Notices will always be sent to the rfc-interest mailing list. When either the RSAB or the RSWG considers it necessary, a notice will also be sent to the ietf-announce and irtf-announce mailing lists. The RSAB is encouraged to send notices to other parties and communities that may be interested or impacted by a proposal as they see fit. Notices are also to be made available and archived on the rfc-editor.org web site.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 9 Jun 2021 01:58:32 -0400

Can you provide an example of something that is simultaneously urgent, 
uncontroversial, and strategic (since if it is not strategic it is not 
in the remit of the RSWG / RSAB)?  I don't object in principle to the 
permission for a short call, but I am trying to understand why we might 
want to allow it?  (I tend to think of this as being similar to an IETF 
last call, and while the IETF has provisions for things needing longer 
calls, it has no provisions for things getting shorter calls.)

Yours,
Joel

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 9 Jun 2021 16:01:39 +1000

Good Q. I put that in mostly because I didn't want the group backed into a corner if there was something actually urgent; I have no idea what that might be. Perhaps that part can be dropped, if we all agree that it's implied that the rules can be broken by broad consent in such circumstances.

Cheers,

> On 9 Jun 2021, at 3:58 pm, Joel M. Halpern <[email-masked]> wrote:
> 
> Can you provide an example of something that is simultaneously urgent, uncontroversial, and strategic (since if it is not strategic it is not in the remit of the RSWG / RSAB)?  I don't object in principle to the permission for a short call, but I am trying to understand why we might want to allow it?  (I tend to think of this as being similar to an IETF last call, and while the IETF has provisions for things needing longer calls, it has no provisions for things getting shorter calls.)
> 
> Yours,
> Joel
>

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 09 Jun 2021 16:25:18 +1000

I was going to comment that we had previously agreed that 2 weeks was fine (and up to 4 weeks was OK if people thought that longer was needed).  No reason not to apply that here.

After all, this is about document approvals, which presumably had discussion in the WG that ended in consensus.  And we are looking for people outside of that group to notice, read, think, and respond.  In that context, 1 week is short, precipitous even.

More urgent answers might be needed for less strategic occurrences, but that would fall into the previously discussed procedures.  In that case, let the RSAB make a singular ruling for the circumstances and then refer the matter to the WG.

On Wed, Jun 9, 2021, at 16:01, Mark Nottingham wrote:
> Good Q. I put that in mostly because I didn't want the group backed 
> into a corner if there was something actually urgent; I have no idea 
> what that might be. Perhaps that part can be dropped, if we all agree 
> that it's implied that the rules can be broken by broad consent in such 
> circumstances.
> 
> Cheers,
> 
> 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future
>

---

From: Eliot Lear <[email-masked]>
Date: Wed, 9 Jun 2021 11:49:24 +0200

Hi mark,

Thanks for this.

Just one comment:

On 09.06.21 07:40, Mark Nottingham wrote:

>   When either the RSAB or the RSWG considers it necessary, a notice will also be sent to the ietf-announce and irtf-announce mailing lists.

We did discuss this at some point.  My read of the group was that the 
RSAB and RSWG should maintain living lists based on running code.  So... 
no need to specifically mention either of those lists. However, one 
thing we didn't discuss is  permission to post to different fora.  We 
don't want to appear to be spammers.

Also, do we want to leave open the possibility that the groups might 
want to publicize announcements through other vehicles 
(MyFaceTweetTockTwitch)?

Eliot

---

From: Lars Eggert <[email-masked]>
Date: Wed, 9 Jun 2021 13:44:20 +0300

Hi,

On 2021-6-9, at 8:40, Mark Nottingham <[email-masked]> wrote:
> Notices will always be sent to the rfc-interest mailing list. When either the RSAB or the RSWG considers it necessary, a notice will also be sent to the ietf-announce and irtf-announce mailing lists.

there are very few roles that come with posting privileges to the ietf-announce and irtf-announce mailing lists, and I wouldn't want to set a precedent for a WG to be able to decide to post something to these lists.

I'd prefer if this said "When either the RSAB or the RSWG considers it necessary, they will suggest to the IETF and IRTF Chairs that a notice be sent to the ietf-announce and irtf-announce mailing lists."

Thanks,
Lars

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 11 Jun 2021 13:38:03 +1000

Let's call this v3.

~~~

Notices will always be sent to the rfc-interest mailing list. The RSAB and RSWG can also send notices to other communities that may be interested in or impacted by a proposal as they see fit, following policies for those fora as appropriate. Notices are also to be made available and archived on the rfc-editor.org web site, and other communication channels can be established for notices (e.g., using an RSS feed, social media).

A comment period will not last less than two weeks. Comments will be publicly archived on the rfc-editor.org web site.
~~~

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 11 Jun 2021 17:13:37 +1200

I could live with this, but I'd prefer s/can also send notices to other communities/should also send notices to other communities/.

Regards
   Brian Carpenter

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 11 Jun 2021 16:04:59 +1000

I'm fine with that modification, thanks. I assume you don't intend SHOULD.

Cheers,

> On 11 Jun 2021, at 3:13 pm, Brian E Carpenter <[email-masked]> wrote:
>

---

From: Brian Carpenter <[email-masked]>
Date: Fri, 11 Jun 2021 19:47:33 +1200

Correct. RFC2119 really wasn't designed for this sort of document.

Regards,
    Brian Carpenter
    (via tiny screen & keyboard)

On Fri, 11 Jun 2021, 18:05 Mark Nottingham, <[email-masked]> wrote:

> > I could live with this, but I'd prefer s/can also send notices to other
> communities/should also send notices to other communities/.
> >
> > Regards
> >   Brian Carpenter
> >
> >> * Any commentary or questions for the community that the RSAB deems
> necessary (using their usual decision-making procedures)
> >> Notices will always be sent to the rfc-interest mailing list. The RSAB
> and RSWG can also send notices to other communities that may be interested
> in or impacted by a proposal as they see fit, following policies for those
> fora as appropriate. Notices are also to be made available and archived on
> the rfc-editor.org web site, and other communication channels can be
> established for notices (e.g., using an RSS feed, social media).
> >>
> >> A comment period will not last less than two weeks. Comments will be
> publicly archived on the rfc-editor.org web site.
> >> ~~~
> >>
> >> --