Subject: [Rfced-future] Issue 69: Who can adopt WG items?

From: Eliot Lear <[email-masked]>
Date: Tue, 29 Jun 2021 08:11:00 +0200

EKR raised the following question in Issue 69:

>  2. If there is sufficient interest in the proposal, RSWG may adopt
>     the proposal as a draft proposal of the RSWG, much the same way a
>     working group of the IETF or IRTF would.
>
> As has been pointed out previously, 2418 is a bit vague on how 
> adoption happens. Do we want to be vague here?
>
2418 is *intentionally* vague about this because of the wide variety of 
circumstances that can arise, and the need for chairs to have some 
flexibility.  Also, that document was written 22 years ago, and we had 
considerably less experience than we do now.  Still, that flexibility 
might prove necessary – or not.

In any event, for those who think we *should* be more specific, we need 
proposed text.  Otherwise perhaps this is one can be deferred until 
there is some operational experience?  This also ties to the matter of 
possibly appealing lack of action on the part of the chairs.  The RSAB 
could certainly say to chairs that they were unreasonable either in 
adopting or not adopting something.

Comments?

Eliot

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 30 Jun 2021 11:21:41 +1200

On 29-Jun-21 18:11, Eliot Lear wrote:
>> As has been pointed out previously, 2418 is a bit vague on how adoption happens. Do we want to be vague here?
>>
circumstances that can arise, and the need for chairs to have some flexibility.  Also, that document was written 22 years ago, and we had considerably less experience than we do now.  Still, that flexibility might prove necessary – or not.
> In any event, for those who think we *should* be more specific, we need 
proposed text.  Otherwise perhaps this is one can be deferred until there is some operational experience?  This also ties to the matter of possibly appealing lack of action on the part of the chairs.  The 
RSAB could certainly say to chairs that they were unreasonable either in adopting or not adopting something.
> Comments?

The problem is that even RFC7221 is contentious and https://datatracker.ietf.org/doc/html/draft-carpenter-gendispatch-rfc7221bis-01 proved to be even more so.

If the IETF can't sort this out, can we?

Regards
   Brian C