Subject: Re: [Roll] Polling the Roll WG for Adoption of the Terminology Draft

From: "Mischa Dohler" <[email-masked]>
Date: Wed, 1 Oct 2008 12:03:14 +0200

I am in favor. Mischa.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
David E. Culler
Sent: Wednesday, October 01, 2008 1:03 AM
To: [email-masked]
Subject: [Roll] Polling the Roll WG for Adoption of the Terminology Draft

I would like to poll the membership on adoption of the Terminology ID.  Link
to the draft is below.

http://www.ietf.org/internet-drafts/draft-vasseur-roll-terminology-02.txt

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Tim Winter <[email-masked]>
Date: Wed, 01 Oct 2008 11:13:02 -0400

In favor.

-Tim

David E. Culler wrote:
> I would like to poll the membership on adoption of the Terminology
> ID.  Link to the draft is below.
>

---

From: [email-masked]
Date: Wed, 1 Oct 2008 10:45:11 -0500

I'm in favor. 

However, as one of the requirement's authors I am not sure how best to 
utilize this document in other documents.  Should we simply have the 
'terminology' document as a normative reference? or should we insert the 
definitions from this document directly into other documents.  It might be 
good to add a bit of narrative into the Terminology ID noting how to 
utilize the document.

"David E. Culler" <[email-masked]> 
Sent by: [email-masked]
09/30/2008 06:05 PM

To
[email-masked]
cc

Subject
[Roll] Polling the Roll WG for Adoption of the Terminology Draft

I would like to poll the membership on adoption of the Terminology ID. 
Link to the draft is below.

---

From: David Meyer <[email-masked]>
Date: Wed, 1 Oct 2008 09:30:12 -0700

Hey Jerald,

> definitions from this document directly into other documents.  

	What I've done for my authors in the past (when I had a
	terminology document, or at least when several documents
	shared common terminology) was to provide the xml source
	so that folks could include definitions where needed (and
	so they would be consistent). So what I've done in the
	past is make definitions avilable so they could be
	"included", e.g., 

	  <?rfc include='terminology-section.xml'?> 

	(or break it up to be more fine grained). So you might
	include that and then cite the terminology document. 

	In this way you can make your document standalone if you
	like (and terminology stays consistent). Of course, this
	approach requires some version management, so well,
	subversion or cvs or the like. 

> It might be good to add a bit of narrative into the Terminology
> ID noting how to utilize the document.

	Not a bad idea.

	Dave

---

From: Zachary Smith <[email-masked]>
Date: Wed, 1 Oct 2008 10:05:27 -0700

Hey all,

Generally works well and I would move to adopt it.

I do have a minor quibble with the definition of commissioning tool.  
There is a broad class of use cases for such tools in which they are  
not "added to the network" but where the tool starts a network for the  
sole purpose of commissioning and then, after configuring the device  
or devices in question, releases it (them) to their operational mode  
and network.

Thanks,

   z

> http://www.ietf.org/internet-drafts/draft-vasseur-roll-terminology-02.txt

Zachary Smith - CTO
http://www.daintree.net/

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 1 Oct 2008 19:26:02 +0200

All for it. What I'd love next is converge some terminology with 6LoWPAN
or at least propose a ROLL <-> 6LoWPAN dictionary ;)

Pascal

David E. Culler
>Sent: mercredi 1 octobre 2008 01:03
>To: [email-masked]

---

From: JP Vasseur <[email-masked]>
Date: Wed, 01 Oct 2008 20:16:39 +0200

Hi Jerry,

On 10/1/08 5:45 PM, "[email-masked]" <[email-masked]>
wrote:

> 
> I'm in favor.  
> 
> However, as one of the requirement's authors I am not sure how best to utilize
> this document in other documents.  Should we simply have the 'terminology'
> document as a normative reference? or should we insert the definitions from
> this document directly into other documents.
> 
> JP> Pretty simple. Just reference the terminology document in your document as
> a informative document, that¹s it, no need to repeat text.
> 
> It might be good to add a bit of narrative into the Terminology ID noting how
> to utilize the document.
> 
> JP> Sure.
> 
> Cheers,
> 
> JP.
> 
> Sent by: [email-masked] 09/30/2008 06:05 PM
> To 
> [email-masked] 
> cc
> Subject

---

From: JP Vasseur <[email-masked]>
Date: Wed, 01 Oct 2008 20:17:42 +0200

> or at least propose a ROLL <-> 6LoWPAN dictionary ;)

As long as you remove specific reference to 15.4 that should be feasible
(we're media "agnostic" in ROLL) ;-)

Cheers,

JP.

---

From: Kris Pister <[email-masked]>
Date: Thu, 02 Oct 2008 08:14:27 -0700

I'm in favor.

ksjp

---

From: JP Vasseur <[email-masked]>
Date: Sun, 12 Oct 2008 13:42:12 +0200

Hi Zach,

> or devices in question, releases it (them) to their operational mode

Here is the current definition:

" Any physical or logical device temporarily added to the network for the
expressed purpose of setting up the network and device operational
parameters. The commissioning tool can also be temporarily added to the LLN
for scheduled or unscheduled maintenance."

What you would like to remove is "temporarily" ?

Thanks.

JP.

---

From: JP Vasseur <[email-masked]>
Date: Sun, 12 Oct 2008 13:42:22 +0200

Hi,

Look for JP2>

On 10/1/08 8:16 PM, "JP Vasseur" <[email-masked]> wrote:

>> JP> Pretty simple. Just reference the terminology document in your document
>> as a informative document, that¹s it, no need to repeat text.
>> 
>> JP2> New Text: ³It is expected that all routing requirements documents
>> defining requirements or specifying routing solutions for LLN will use the
>> common terminology specified in this document. This document should be listed
>> as an informative reference.²
>> 
>> Thanks.
>> 
>> JP.
>> 
>> Cheers,
>> 
>> JP.
>>

---

From: Zachary Smith <[email-masked]>
Date: Tue, 14 Oct 2008 13:09:34 -0700

Hi JP (and David),

Thanks for asking.

Well... it's a little more complicated than that. I know it's a minor  
point, but there is a set of important use cases where the  
commissioning tool isn't "added" to the network at all, instead it  
forms the basis for a "commissioning network" - different from the  
operational network since the requirements for commissioning may be  
radically different than those for normal operation - commissions the  
devices and then "lets them go" be a part of the operational network  
(an event that may not happen for months in the case, say, of  
commercial buildings). Perhaps the best solution is to do away  
completely with references to "the network" and say something like this,

> " Any physical or logical device employed, in band, for the
> parameters. The commissioning tool can also be employed for
> scheduled or unscheduled maintenance."

Thoughts?

   z

Zachary Smith - CTO
http://www.daintree.net/