Subject: [Roll] "Control cost" in Protocol survey draft

From: Mukul Goyal <[email-masked]>
Date: Sun, 21 Dec 2008 09:26:56 -0600 (CST)

Hi all,

I have not gone through all the emails that have been sent recently (and earlier) regarding the protocol survey draft. So, it is possible that this issue has been raised before.

I don't think the "control cost" criterion as described in section 4.4 of the draft is complete. The criterion, as described currently in this section, totally ignores the control packet overhead of the routing protocol during the "route discovery" process. So, a protocol like AODV that depends on network-wide broadcast of Route Request messages passes the "control cost" test! In LLNs, frequent route discoveries may be necessary given the dynamic nature of link/node quality.

I think the text in section 4.4 should be modified to also include the cost of route discovery/maintenance. That would also make it necessary to re-evaluate the protocols from the perspective of "control cost" criterion.

Thanks
Mukul
_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: "Stephen Dawson-Haggerty" <[email-masked]>
Date: Sun, 21 Dec 2008 10:46:56 -0800

Text which was added to the current version of the draft after discussions
on the list:
   The control cost metric is a necessary but not sufficient condition
   for a protocol to be a viable routing protocol for LLNs.  Protocols
   not meeting this bound are unacceptable for use in this environment;
   however, there may be protocols which receive a "pass" for this
   metric and yet are also unsuitable.

The fact is, there are several reasons a protocol may pass the "control
cost" metric and yet be unacceptable for use in LLNs; there has been
significant discussion on this point recently (see emails between us and
Christopher Dearlove).  However, as defined, control cost is
easy-to-explain, and if protocols *fail* it, they are clearly unacceptable.
That's the property we're looking for.

Thanks,
Steve

On Sun, Dec 21, 2008 at 7:26 AM, Mukul Goyal <[email-masked]> wrote:

> Hi all,
>
> I have not gone through all the emails that have been sent recently (and
> earlier) regarding the protocol survey draft. So, it is possible that this
> issue has been raised before.
>
> I don't think the "control cost" criterion as described in section 4.4 of
> the draft is complete. The criterion, as described currently in this
> section, totally ignores the control packet overhead of the routing protocol
> during the "route discovery" process. So, a protocol like AODV that depends
> on network-wide broadcast of Route Request messages passes the "control
> cost" test! In LLNs, frequent route discoveries may be necessary given the
> dynamic nature of link/node quality.
>
> I think the text in section 4.4 should be modified to also include the cost
> of route discovery/maintenance. That would also make it necessary to
> re-evaluate the protocols from the perspective of "control cost" criterion.
>
> Thanks
> Mukul

---

From: Philip Levis <[email-masked]>
Date: Sun, 21 Dec 2008 11:45:26 -0800

On Dec 21, 2008, at 10:46 AM, Stephen Dawson-Haggerty wrote:

> Text which was added to the current version of the draft after  
> discussions on the list:
> The fact is, there are several reasons a protocol may pass the  
> "control cost" metric and yet be unacceptable for use in LLNs;  
> there has been significant discussion on this point recently (see  
> emails between us and Christopher Dearlove).  However, as defined,  
> control cost is easy-to-explain, and if protocols fail it, they are  
> clearly unacceptable.  That's the property we're looking for.
>
> Thanks,
> Steve

Exactly; the control cost criterion, as defined, is necessary but not  
sufficient.

Phil