Subject: [Roll] how to find if a parent no longer belongs to a DAG?

From: Mukul Goyal <[email-masked]>
Date: Thu, 24 Sep 2009 12:56:56 -0500 (CDT)

Pascal/Tim

Section 5.3.1 in rpl-2

"9.   If a node receives a RA-DIO from one of its DAG parents, and if
        the parent contains a different DAGID, indicating that the
        parent has left the DAG,"

Obviously, the fact that an RA does not contain DIO for a particular DAG does not mean that the node no longer belongs to that DAG. As I understand it, there is no requirement that a node include DIOs for all DAGs it belongs to in its RA. As per the draft, the node maintains a separate timer for each DAG it belongs to and generates an RA (presumably containing DIO for that DAG) when the timer fires. So, the text above needs to change.

Regards
Mukul

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 28 Sep 2009 13:59:23 +0200

Hi Mukul;

You're correct. This is one of the reasons why we cannot claim we properly support multiDAG at this point.
And we wonder were we'll have to draw the line. The reasoning at the time of this writing was that if multiDAG there is, then  we'd enforce mutual destination exclusion / one DAG per destination or we'd be doing MTR. Either way would could restrict one DAG per something and thus, if the parent advertises that something for a new DIO then he moved.

But that is actually very restrictive. And that might not be the right restriction. So to support multiple DAGs, we might end up having to list all the DAGs a parent belongs to or something. Then again, how far are we willing to go?

Pascal

>-----Original Message-----
>From: Mukul Goyal [mailto:[email-masked]]
>Sent: jeudi 24 septembre 2009 19:57
>To: Pascal Thubert (pthubert)
>Cc: Tim Winter; roll
>Subject: how to find if a parent no longer belongs to a DAG?
>
>Pascal/Tim
>
>Section 5.3.1 in rpl-2
>
>Obviously, the fact that an RA does not contain DIO for a particular DAG does not mean that the node no longer
>belongs to that DAG. As I understand it, there is no requirement that a node include DIOs for all DAGs it
>belongs to in its RA. As per the draft, the node maintains a separate timer for each DAG it belongs to and
>generates an RA (presumably containing DIO for that DAG) when the timer fires. So, the text above needs to
>change.
>
>Regards
>Mukul