Subject: Re: [Roll] Simplifying RPL: (1) multiple DAGs

From: Mukul Goyal <[email-masked]>
Date: Mon, 28 Sep 2009 10:35:36 -0500 (CDT)

Thomas

>Mukul, you state that RPL "allows for a DAG (for a particular OCP) to have unconnected fragments spread throughout the LLN".

I think you misunderstood. I was considering the possibility that DAGs with same OCP could conceptually be considered as part of a global, possibly fragmented, DAG. I abandoned this idea as it involves overloading whole lot of information in OCP. As such, in its current avatar, RPL does not allow fragmented DAGs. A node has to become root of its own floating DAG as soon as it has no parent left in the DAG.

Thanks
Mukul
   
> I agree with you as I don't think RPL enforces to have connected DAGs. In fact, does RPL-02 states anything on what should happen 
> when a packet needs to bridge multiple fragments? If we come to an agreement that it does not, we should definitely specify 
> something (either through Need_Route packets, or by asking all nodes to be administratively part of all DAGs). 

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 28 Sep 2009 09:01:21 -0700

That makes sense.
Thanks,
Thomas