Subject: Re: [Roll] Next items ...

From: Mukul Goyal <[email-masked]>
Date: Wed, 2 Sep 2009 04:50:57 -0500 (CDT)

Hi Pascal,

Please see inline.

>>Just need a clarification.
>>
>>Quoating from your response:
>>"I would assume that a listener would use MLD over its link to its router."
>>
>>The implication seems to be that in an LLN running a "roll over" routing protocol, some nodes may not be
>>routers. That is against my understanding that a "roll over" protocol considers all LLN nodes to be routers.
>>Isn't it so?

>In the IP world, the traditional model is hosts attached to routers, and routing happening between routers. I do not see why ROLL >would be any different. RPL defines a routing protocol between routers. Why would that imply that no host can be attached to the >routers?

I am just trying to understand how things will work in future IPv6-enabled LLNs. So, what you are saying is that only some nodes in an LLN will act as routers while other nodes would act as hosts. The hosts will not participate in routing and simply forward their packets to a router node in their radio range. Is this right? In that case, a question arises regarding how the hosts would come to know of their neighbor routers (via neighbor discovery?) and obviously it also means that router nodes will need to keep track of what hosts are attached to it. Please clarify.

>>If "mesh under" routing were available, I would think that some LLN nodes may not be "roll over" routers. But
>>it seems that there is not going to be any "mesh under" routing available any time soon. Hence, my
>>understanding is that all LLN nodes would be "roll over" routers.

>There are very few mesh under solutions in the IP world today. Mostly FR and ATM. And we learnt a few things from that including >that it is very hard to make good routing decisions at L3 when L2 has hidden costs in a switched topology. 

>So I agree that ROLL is not about mesh under though RPL could probably be adapted at layer 2. 

>>Please clarify.

>Whether you can connect hosts to a router and whether a L2 network relies on mesh under are orthogonal concepts. Are you opposing >them in any fashion?

No. I am just trying to understand what routing architecture the DT has in mind. Not sure if some ROLL document already talks about the routing architecture. If not, then it should be described some where.

Thanks
Mukul

---

From: Mukul Goyal <[email-masked]>
Date: Sun, 6 Sep 2009 08:26:02 -0500 (CDT)

JP,

>> It would be great if the next version of RPL draft could also  
>> contain a section on routing architecture.

>There will be an architecture ID. But if you have specific items in  
>mind, could you list them ?

No. I simply wanted layouts for common deployment scenarios. Architecture ID is a great idea.

>> Layouts for a few common deployment scenarios - (a) single DAG  
>> versus multiple DAGs, (b) all LLN nodes working as RPL routers  
>> versus only a "backbone" of nodes running RPL etc.

>Absolutely, but this will o in the applicability IDs.

OK. I guess we need to start working on applicability IDs now.

>> - would greatly help in understanding the protocol performance in  
>> different scenarios and design LLNs around RPL.
>>

>Not sure what you mean by performance but we usually and rightly do  
>not put performance numbers in RFCs.

This is not what I meant. I was referring to the need for knowing more details regarding routing architecture (and applicability) so that people could start designing their LLNs around RPL.

Thanks
Mukul

> Thanks
> Mukul
>
> ----- Original Message -----
> From: "JP Vasseur" <[email-masked]>
> To: "ROLL WG" <[email-masked]>
> Sent: Friday, September 4, 2009 2:01:55 AM GMT -06:00 US/Canada  
> Central
> Subject: [Roll] Fwd:  Next items ...
>
>
> Dear all,
>
>
> Hope that you all had good vacations. Just a quick follow up to tell  
> you the plan for RPL:
> 1) By end of next week, rev -01 should be posted that will hopefully  
> answer the questions raised on the list and thanks to all of you for  
> the feed-backs. Mostly clarifications, more algorithmic approach for  
> section 5, few improvements (multicast of NA DAO, ...)
> 2) Then there will be a rev-02 ready before the Interim WG meeting  
> in Geneva.
>
>
> Thanks.
>
>
> JP.
>
>
>
> Begin forwarded message:
>
>
>
>
> From: JP Vasseur < [email-masked] >
> Date: August 3, 2009 9:26:34 AM CEDT
> To: ROLL WG < [email-masked] >
> Subject: [Roll] Next items ...
>
>
> Dear all,
>
> As a reminder, RPL being a WG ID, it now "belongs" to the WG.
>
> Several working items have been listed but before starting to  
> address all open items in some unstructured way, I would like to  
> propose the following.
>
> It clearly appeared that there were some misunderstandings on how  
> RPL works. The DT did an outstanding job but I also understand that  
> several areas must be clarified. So before changing RPL, adding new  
> mechanisms (e.g. to optimize P2P, support source routing, loop  
> detection, ... ), I would first want you to list your questions on  
> the mailing list on each area for which you would like to get  
> clarification. This will help make sure that everybody is indeed on  
> the same page.
>
> From there, we will continue to quickly move forward, I will track  
> the list of open items via the issue tracker.
>
> Many Thanks.
>
> JP.
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll