Subject: [Roll] Fwd: Next items ...

From: JP Vasseur <[email-masked]>
Date: Fri, 4 Sep 2009 09:01:55 +0200

Dear all,

Hope that you all had good vacations. Just a quick follow up to tell  
you the plan for RPL:
1) By end of next week, rev -01 should be posted that will hopefully  
answer the questions raised on the list and thanks to all of you for  
the feed-backs. Mostly clarifications, more algorithmic approach for  
section 5, few improvements (multicast of NA DAO, ...)
2) Then there will be a rev-02 ready before the Interim WG meeting in  
Geneva.

Thanks.

JP.

Begin forwarded message:

> From: JP Vasseur <[email-masked]>
> Date: August 3, 2009 9:26:34 AM CEDT
> To: ROLL WG <[email-masked]>
> Subject: [Roll] Next items ...
>
> Dear all,
>
> As a reminder, RPL being a WG ID, it now "belongs" to the WG.
>
> Several working items have been listed but before starting to  
> address all open items in some unstructured way, I would like to  
> propose the following.
>
> It clearly appeared that there were some misunderstandings on how  
> RPL works. The DT did an outstanding job but I also understand that  
> several areas must be clarified. So before changing RPL, adding new  
> mechanisms (e.g. to optimize P2P, support source routing, loop  
> detection, ... ), I would first want you to list your questions on  
> the mailing list on each area for which you would like to get  
> clarification. This will help make sure that everybody is indeed on  
> the same page.
>
> From there, we will continue to quickly move forward, I will track  
> the list of open items via the issue tracker.
>
> Many Thanks.
>
> JP.
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Mukul Goyal <[email-masked]>
Date: Sat, 5 Sep 2009 16:18:16 -0500 (CDT)

It would be great if the next version of RPL draft could also contain a section on routing architecture. Layouts for a few common deployment scenarios - (a) single DAG versus multiple DAGs, (b) all LLN nodes working as RPL routers versus only a "backbone" of nodes running RPL etc. - would greatly help in understanding the protocol performance in different scenarios and design LLNs around RPL.

Thanks
Mukul
  
----- Original Message -----
From: "JP Vasseur" <[email-masked]>
To: "ROLL WG" <[email-masked]>
Sent: Friday, September 4, 2009 2:01:55 AM GMT -06:00 US/Canada Central
Subject: [Roll] Fwd:  Next items ...

Dear all, 

Hope that you all had good vacations. Just a quick follow up to tell you the plan for RPL: 
1) By end of next week, rev -01 should be posted that will hopefully answer the questions raised on the list and thanks to all of you for the feed-backs. Mostly clarifications, more algorithmic approach for section 5, few improvements (multicast of NA DAO, ...) 
2) Then there will be a rev-02 ready before the Interim WG meeting in Geneva. 

Thanks. 

JP. 

Begin forwarded message: 

From: JP Vasseur < [email-masked] > 
Date: August 3, 2009 9:26:34 AM CEDT 
To: ROLL WG < [email-masked] > 
Subject: [Roll] Next items ... 

Dear all, 

Several working items have been listed but before starting to address all open items in some unstructured way, I would like to propose the following. 

It clearly appeared that there were some misunderstandings on how RPL works. The DT did an outstanding job but I also understand that several areas must be clarified. So before changing RPL, adding new mechanisms (e.g. to optimize P2P, support source routing, loop detection, ... ), I would first want you to list your questions on the mailing list on each area for which you would like to get clarification. This will help make sure that everybody is indeed on the same page. 

>From there, we will continue to quickly move forward, I will track the list of open items via the issue tracker. 

Many Thanks. 

JP.

---

From: JP Vasseur <[email-masked]>
Date: Sun, 6 Sep 2009 08:09:54 +0200

Hi Mukul,

On Sep 5, 2009, at 11:18 PM, Mukul Goyal wrote:

> It would be great if the next version of RPL draft could also  
> contain a section on routing architecture.

There will be an architecture ID. But if you have specific items in  
mind, could you list them ?

> Layouts for a few common deployment scenarios - (a) single DAG  
> versus multiple DAGs, (b) all LLN nodes working as RPL routers  
> versus only a "backbone" of nodes running RPL etc.

Absolutely, but this will o in the applicability IDs.

> - would greatly help in understanding the protocol performance in  
> different scenarios and design LLNs around RPL.
>

Not sure what you mean by performance but we usually and rightly do  
not put performance numbers in RFCs.

Thanks.

JP.