Subject: Re: [Roll] 8-bit DAG rank

From: Mukul Goyal <[email-masked]>
Date: Mon, 21 Sep 2009 13:24:44 -0500 (CDT)

Pascal

I guess the first two reasons you mentioned: 
1)need to limit DAG depth; 2)desire to have more siblings 
make sense.

However, I am not comfortable with the third reason.:
DAG ranks calculated for different OCPs should be comparable.

Comparing DAG ranks calculated for different OCPs is simply not apple-to-apple comparison.

Thanks
Mukul

----- Original Message -----
From: "Pascal Thubert (pthubert)" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>, "roll" <[email-masked]>
Sent: Monday, September 21, 2009 5:21:44 AM GMT -06:00 US/Canada Central
Subject: RE: [Roll] 8-bit DAG rank

Hi Mukul:

That is voluntary but maybe the reasons why it's done that way can be
served some other fashion.

Reason 1 is to limit the size of infinity. At the moment, it appears
that we do not have a case where the protocol actually counts to
infinity so this mostly places a barrier on how large we expect the
network to be at most. Considering that a normal hop costs 4, that's 64
hops deep.

Reason 2 is that a coarse metric gives more chance to have siblings. In
a triangle A (root) B, C, having B and C siblings optimizes the
redundancy for all. Note that allowing the OF to be greedy enough to
augment the rank in order to add siblings - but not parents! - seems an
acceptable behavior.

I'm not sure we can avoid severe restrictions on what the rank is as we
abstract the rank into something that should be comparable between DAGs
with completely different metrics and Objective Functions though. As it
is defined now it appears to serve the purpose.

Pascal

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf Of
Mukul Goyal
>Sent: vendredi 18 septembre 2009 18:40
>To: roll
>Subject: [Roll] 8-bit DAG rank
>
>Hi all,
>
>I was just wondering if 8-bit is too small a width for the DAG rank. I
guess the small width puts severe
>restrictions on what rank calculation functions could be used and how
big a DAG can exist for a particular
>rank calculation function. The constraints may be severe for LLNs
consisting of thousands of nodes.
>
>Thanks
>Mukul
>
>"DAGRank:  8-bit unsigned integer.  The DAG rank of the DAG root is 0.
>         The DAG Rank of a node attached to the DAG should be greater
>         than rank of its deepest DAG parent, as computed by an
>         implementation specific routine.  All nodes in the DAG
>         advertise their DAG rank in the DAG Information Options that
>         they append to the RA messages over their LLN interfaces as
>         part of the propagation process." (from rpl-01)
>_______________________________________________
>Roll mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/roll

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 22 Sep 2009 15:01:08 +0200

Hi Mukul;

They don't relate a lot but for the fact that a 'normal' hop costs 4. You need something, however arbitrary, to sort out your routing when a node belongs to 2 DAGs that expose a same destination, default or other. 

For what it's worth making sure that the rank 'cost' to destination decreases at each hop gets you there without a loop, that's the DV way for you.

Alternatively, you could tag the packets for a given topology, over always follow the least topoId ... but all those multi topology routing techniques lead to complexity that we may not favor for the general case.

Pascal

>From: Mukul Goyal [mailto:[email-masked]]
>Sent: lundi 21 septembre 2009 20:25
>To: Pascal Thubert (pthubert)
>Cc: roll
>Subject: Re: [Roll] 8-bit DAG rank
>
>Pascal
>