Subject: [Roll] RPL Patents

From: Ietf Roll <[email-masked]>
Date: Tue, 19 Jan 2010 14:04:47 -0800 (PST)

ROLLers,
  Did anyone see the Cisco announcement about IPR in RPL.  If you didn't it was probably because it was only sent to the IETF IPR list.  I don't know why it wasn't sent to the ROLL list.  If you didn't see it here is a link:

http://www.ietf.org/mail-archive/web/ipr-announce/current/msg00167.html

I'm a bit confused and concerned that this IPR annoucement was sent so late in the process (December 3) - given that Cisco folks were working on the design team from the beginning.  We are now so late in the design and development that it would be nearly impossible for us to figure out how avoid this patent.

There is a free license to use the patent in RPL so long as you and your company doesn't sue Cisco over ANY other patent for ANYTHING.

Can we avoid the use of the patented technology in RPL?  Should we?  Do we want to?

Did this IPR announcement come too late?

    Rav

---

From: "Don Sturek" <[email-masked]>
Date: Tue, 19 Jan 2010 14:15:31 -0800

Hi Rav,

I have been involved in mesh networking for some time.  It was actually a
good thing to see the IPR statement from Cisco.  Having some certainty
around IPR seems like a good thing for large deployments like Smart Energy.

Best Regards,

Don Sturek

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ietf
Roll
Sent: Tuesday, January 19, 2010 2:05 PM
To: [email-masked]
Subject: [Roll] RPL Patents

ROLLers,
  Did anyone see the Cisco announcement about IPR in RPL.  If you didn't it
was probably because it was only sent to the IETF IPR list.  I don't know
why it wasn't sent to the ROLL list.  If you didn't see it here is a link:

I'm a bit confused and concerned that this IPR annoucement was sent so late
in the process (December 3) - given that Cisco folks were working on the
design team from the beginning.  We are now so late in the design and
development that it would be nearly impossible for us to figure out how
avoid this patent.

There is a free license to use the patent in RPL so long as you and your
company doesn't sue Cisco over ANY other patent for ANYTHING.

Can we avoid the use of the patented technology in RPL?  Should we?  Do we
want to?

    Rav

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Omprakash Gnawali <[email-masked]>
Date: Tue, 19 Jan 2010 14:47:00 -0800

Here is a list of patents mentioned in the IPR announcement:

7,190,678:
Arrangement for router attachments between roaming mobile routers in a
clustered network
Thubert; Pascal (La Colle sur Loup, FR), Wetterwald; Patrick (Cagnes
sur Mer, FR), Molteni; Marco (Antibes, FR), Forster; David Charlton
(Reading, GB)
http://www.google.com/patents?vid=USPAT7190678

7,203,175:
Arrangement for router attachments between roaming mobile routers in a
mobile network
Thubert; Pascal (La Colle sur Loup, FR), Wetterwald; Patrick (Cagnes
sur Mer, FR), Molteni; Marco (Antibes, FR), Forster; David Charlton
(Reading, GB)
http://www.google.com/patents?vid=USPAT7203175

7,209,978:
Arrangement in a router of a mobile network for optimizing use of
messages carrying reverse routing headers
Thubert; Pascal (La Colle sur Loup, FR), Molteni; Marco (Antibes, FR),
Wetterwald; Patrick (Cagnes sur Mer, FR), Auerbach; David (Biot, FR)
http://www.google.com/patents?vid=USPAT7209978

7,366,111:
Arrangement for providing optimized connections between peer routers
in a tree-based ad hoc mobile network
Thubert; Pascal (La Colle sur Loup, FR), Wetterwald; Patrick (Mouans
Sartoux, FR), Ribiere; Vincent Jean (Biot, FR), Levy-Abegnoli; Eric M.
(Valbonne, FR)
http://www.google.com/patents?vid=USPAT7366111

7,428,221:
Arrangement for providing network prefix information from attached
mobile routers to a clusterhead in a tree-based ad hoc mobile network
Thubert; Pascal (La Colle sur Loup, FR), Wetterwald; Patrick (Mouans
Sartoux, FR), Molteni; Marco (Antibes, FR), Moon; Billy G. (Cary, NC)
http://www.google.com/patents?vid=USPAT7428221

- om_p

---

From: Omprakash Gnawali <[email-masked]>
Date: Tue, 19 Jan 2010 14:47:00 -0800

7,190,678:

7,203,175:

7,209,978:

7,366,111:

7,428,221:

- om_p

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 20 Jan 2010 07:58:21 +0100

Hi:

Just to make things straight, Cisco published to IETF and announced that
IPR on April 16th to the ROLL ML:
http://www.ietf.org/mail-archive/web/roll/current/msg01181.html 

There has been some administrative delay porting the message to the RPL
draft, but the content is basically the same.

Cheers;

Pascal

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ietf Roll
Sent: mardi 19 janvier 2010 23:05
To: [email-masked]
Subject: [Roll] RPL Patents

ROLLers,
  Did anyone see the Cisco announcement about IPR in RPL.  If you didn't
it was probably because it was only sent to the IETF IPR list.  I don't
know why it wasn't sent to the ROLL list.  If you didn't see it here is
a link:

I'm a bit confused and concerned that this IPR annoucement was sent so
late in the process (December 3) - given that Cisco folks were working
on the design team from the beginning.  We are now so late in the design
and development that it would be nearly impossible for us to figure out
how avoid this patent.

Can we avoid the use of the patented technology in RPL?  Should we?  Do
we want to?

    Rav

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 20 Jan 2010 16:36:27 +0100

Le 20/01/2010 07:58, Pascal Thubert (pthubert) a écrit :
> Hi:
>
> Just to make things straight, Cisco published to IETF and announced
> that IPR on April 16th to the ROLL ML:

YEs, I thought the same, but after digging I realize the above statement
pertains to :

           draft-thubert-roll-fundamentals-01

whereas the statement forwarded by 'Rav' pertains to another draft:

                   draft-dt-roll-rpl

So we end up with two Cisco IPR statements, which is good IMHO.  My
interest, in this RoLL landscape, is whether there's somebody else than 
Cisco claiming IPR on RoLL technologies and whether the different claims 
converge to the benefit of everybody else.

Alex

>
> There has been some administrative delay porting the message to the
> RPL draft, but the content is basically the same.
>
> Cheers;
>
> Pascal
>
> -----Original Message----- From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Ietf Roll Sent: mardi 19
> janvier 2010 23:05 To: [email-masked] Subject: [Roll] RPL Patents
>
> ROLLers, Did anyone see the Cisco announcement about IPR in RPL.  If
> you didn't it was probably because it was only sent to the IETF IPR
> list.  I don't know why it wasn't sent to the ROLL list.  If you
> didn't see it here is a link:
>
>  I'm a bit confused and concerned that this IPR annoucement was sent
> so late in the process (December 3) - given that Cisco folks were
> working on the design team from the beginning.  We are now so late in
> the design and development that it would be nearly impossible for us
> to figure out how avoid this patent.
>
> There is a free license to use the patent in RPL so long as you and
> your company doesn't sue Cisco over ANY other patent for ANYTHING.
>
> _______________________________________________ Roll mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/roll
> _______________________________________________ Roll mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/roll
>

---

From: Ietf Roll <[email-masked]>
Date: Fri, 22 Jan 2010 14:38:51 -0800 (PST)

Do we know how any of these apply to RPL?  What applies to what parts of RPL?  What can we change in RPL to avoid these patents?

- RAV

--- On Tue, 1/19/10, Omprakash Gnawali <[email-masked]> wrote:

> From: Omprakash Gnawali <[email-masked]>
> Subject: Re: [Roll] RPL Patents
> To: [email-masked]
> Date: Tuesday, January 19, 2010, 10:47 PM
> >  Did anyone see the Cisco announcement about IPR in
> RPL.  If you didn't it was probably because it was only
> sent to the IETF IPR list.  I don't know why it wasn't sent
> to the ROLL list.  If you didn't see it here is a link:
> >
> > I'm a bit confused and concerned that this IPR
> annoucement was sent so late in the process (December 3) -
> given that Cisco folks were working on the design team from
> the beginning.  We are now so late in the design and
> development that it would be nearly impossible for us to
> figure out how avoid this patent.
> >
> > There is a free license to use the patent in RPL so
> long as you and your company doesn't sue Cisco over ANY
> other patent for ANYTHING.
> >

---

From: Ietf Roll <[email-masked]>
Date: Fri, 22 Jan 2010 14:46:20 -0800 (PST)

I don't think that is at all true.  The original IPR statement published was applicable only to draft-thubert-roll-fundamentals.  There was no indication for many months that the IPR statment made about draft-thubert-roll-fundamentals was at all applicable to the work coming from the RPL DT.

I think it is very unfortunate that this information was not made available to the working long long ago so that before investing these many months of effort we could have understood that the design was encumbered with Cisco intellectual property.

You were on the DT, so I don't understand why the IPR statement about the output of the DT was not made months ago and also why when the IPR was published, why didn't anyone send it to the ROLL list???

- Rav

--- On Wed, 1/20/10, Pascal Thubert (pthubert) <[email-masked]> wrote:

> From: Pascal Thubert (pthubert) <[email-masked]>
> Subject: RE: [Roll] RPL Patents
> To: "Ietf Roll" <[email-masked]>, [email-masked]
> Date: Wednesday, January 20, 2010, 6:58 AM
> Hi:
> 
> From: [email-masked]
> [mailto:[email-masked]]
> On Behalf Of
> Ietf Roll
> RPL.  If you didn't

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 25 Jan 2010 08:31:58 +0100

Hum...

The IPR listed has not changed. The broad operations that are covered by the IPR are the same in both drafts.
People who actually contribute to this work can see that, and go beyond names. Names change all the time anyway.
Sorry you don't. What's your interest then?

Pascal

-----Original Message-----
From: Ietf Roll [mailto:[email-masked]] 
Sent: vendredi 22 janvier 2010 23:46
To: [email-masked]; Pascal Thubert (pthubert)
Subject: RE: [Roll] RPL Patents

- Rav

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 25 Jan 2010 08:38:56 +0100

Talking about unfortunate, 

I do not think that your email address is appropriate in this list. 
It is actually confusing the autocompletion in my mail client, and could end up confuse readers.
I suggest you peek another one, maybe with something that would more openly indicate your name and interests...

Pascal

-----Original Message-----
From: Ietf Roll [mailto:[email-masked]] 
Sent: vendredi 22 janvier 2010 23:46
To: [email-masked]; Pascal Thubert (pthubert)
Subject: RE: [Roll] RPL Patents

- Rav