Subject: Re: [Roll] Fwd: New Version Notification for draft-tripathi-roll-rpl-simulation-01

From: Joydeep Tripathi <[email-masked]>
Date: Wed, 23 Dec 2009 19:31:53 -0500

Hi,

For those who cannot find the pdf version, you can click this link

http://tools.ietf.org/pdf/draft-tripathi-roll-rpl-simulation-01.pdf

Thanks,
Joydeep

On Wed, Dec 23, 2009 at 7:26 PM, Hajime Tazaki <[email-masked]> wrote:
>
> Dear authors,
>
> I also really wanna see the pdf with figures.
>
> regards,
> hajime
>
> At Tue, 22 Dec 2009 23:09:59 -0800,
> Omprakash Gnawali wrote:
>>
>>It is great to start understanding how RPL would work.
>>
>>On this file:
>>http://tools.ietf.org/html/draft-tripathi-roll-rpl-simulation-00
>>
>>I don't see the figures...
>>
>>- om_p
>>
>>On Mon, Dec 21, 2009 at 8:12 PM, Jaudelice de Oliveira
>><[email-masked]> wrote:
>>> Dear WG,
>>> We have just posted draft-tripathi-roll-rpl-simulation-01with a detailed
>>> performance evaluation of RPL for several metrics of interest (please see
>>> PDF file with plots). We are currently working on results with local repair
>>> and shall post them shortly. We would love feedback/suggestions from the WG.
>>> Are there other metrics you would like to see?
>>> Cheers,
>>> Jau.
>>>
>>>
>>>
>>>
>>> Jaudelice C. de Oliveira
>>> Associate Professor
>>> ECE Dept., Drexel University
>>> http://www.ece.drexel.edu/faculty/deoliveira/
>>>
>>>
>>>
>>>
>>>
>>> Begin forwarded message:
>>>
>>> From: IETF I-D Submission Tool <[email-masked]>
>>> Date: December 21, 2009 10:58:21 PM EST
>>> To: [email-masked]
>>> Cc: [email-masked],[email-masked]
>>> Subject: New Version Notification for
>>> draft-tripathi-roll-rpl-simulation-01
>>>
>>> A new version of I-D, draft-tripathi-roll-rpl-simulation-01.txt has been
>>> successfuly submitted by Jaudelice Oliveira and posted to the IETF
>>> repository.
>>> Filename: draft-tripathi-roll-rpl-simulation
>>> Revision: 01
>>> Title: Performance Evaluation of Routing Protocol for Low Power and Lossy
>>> Networks (RPL)
>>> Creation_date: 2009-12-21
>>> WG ID: Independent Submission
>>> Number_of_pages: 12
>>> Abstract:
>>> This document presents a performance evaluation of the Routing
>>> Protocol for Low power and Lossy Networks (RPL).  Detailed
>>> simulations are carried out to produce several routing performance
>>> metrics using a set of real-life scenarios.
>>> Status of this Memo
>>> This Internet-Draft is submitted to IETF in full conformance with the
>>> provisions of BCP 78 and BCP 79.
>>> Internet-Drafts are working documents of the Internet Engineering
>>> Task Force (IETF), its areas, and its working groups.  Note that
>>> other groups may also distribute working documents as Internet-
>>> Drafts.
>>> Internet-Drafts are draft documents valid for a maximum of six months
>>> and may be updated, replaced, or obsoleted by other documents at any
>>> time.  It is inappropriate to use Internet-Drafts as reference
>>> material or to cite them other than as "work in progress."
>>> The list of current Internet-Drafts can be accessed at
>>> http://www.ietf.org/ietf/1id-abstracts.txt.
>>> The list of Internet-Draft Shadow Directories can be accessed at
>>> http://www.ietf.org/shadow.html.
>>> This Internet-Draft will expire on June 24, 2010.
>>> Copyright Notice
>>> Copyright (c) 2009 IETF Trust and the persons identified as the
>>> document authors.  All rights reserved.
>>> This document is subject to BCP 78 and the IETF Trust's Legal
>>> Provisions Relating to IETF Documents
>>> (http://trustee.ietf.org/license-info) in effect on the date of
>>> publication of this document.  Please review these documents
>>> carefully, as they describe your rights and restrictions with respect
>>> to this document.  Code Components extracted from this document must
>>> include Simplified BSD License text as described in Section 4.e of
>>> the Trust Legal Provisions and are provided without warranty as
>>> described in the BSD License.
>>>
>>>
>>> The IETF Secretariat.
>>>
>>>
>>>
>>> _______________________________________________
>>> Roll mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/roll
>>>
>>>
>>_______________________________________________
>>Roll mailing list
>>[email-masked]
>>https://www.ietf.org/mailman/listinfo/roll
>

---

From: Joydeep Tripathi <[email-masked]>
Date: Wed, 23 Dec 2009 19:33:33 -0500

On Wed, Dec 23, 2009 at 2:52 AM, Omprakash Gnawali
<[email-masked]>wrote:

> I managed to find the pdf with the graphs. Here are some comments.
>
> It will help greatly if more information about the link model were
> included. -01 mentions:
>
> "* Link failure model: Time varying real network traces containing
> packet delivery probability for each
> link and over all channels for both indoor network deployment and
> outdoor network deployment were used.
> Thus, di erent types of link characteristics are used in the study.
> * Topology: The topologies are gathered from real-life deployment
> (traces mentioned above) as opposed
> to random topology simulations. are repeated here:"
>

Actually,we collected real-life traces with hundreds of links varying with
time for the network,  and simulated the same variation in PDR for each link
as in the real deployment.

> Is the simulation topology a topology from real-world deployment or
> the one mentioned in figure 1?
>

It is indeed from a real life deployment of an indoor network, where the
topology looks like the one shown in figure 1. We have shown a link between
two nodes in the topology if they are heard by each other.

>
> Some graphs showing link characteristics (including temporal
> characteristics) will also be helpful. Right now, we just know that
> the link is modeled on real world deployments. What radio was used?
> Indoor/outdoor? And any other relevant information.
>

That is a wonderful idea. We will include temporal link characteristics in
further revision which we plan to submit very soon.

>
> These additional information will help us understand how and why of
> RPL's performance.
>
> A lot of people are interested in path stretch for p2p routing. Some
> of this information is available on the plots but not directly. It
> will be great if we can have a plot that shows the distribution of
> path stretch for p2p routing.
>

We also plan to show this metric, keeping in mind the typical scenarios of
P2P routing in building and home routing (or any other interesting scenario,
on request). Once again, thanks for your feedback.

Thanks,
Joydeep