Subject: [Roll] Patents on RPL

From: Ietf Roll <[email-masked]>
Date: Mon, 18 Jan 2010 09:51:45 -0800 (PST)

ROLLers,
  Did anyone see the Cisco announcement about IPR in RPL.  If you didn't it was probably because it was only sent to the IETF IPR list.  I don't know why it wasn't sent to the ROLL list.  If you didn't see it here is a link:

http://www.ietf.org/mail-archive/web/ipr-announce/current/msg00167.html

I'm a bit confused and concerned that this IPR annoucement was sent so late in the process (December 3).  Given that Cisco folks were working on the design team from the beginning why did it take so long for cisco to identify the IPR.  We are now so late in the design and development that it would be nearly impossible for us to figure out how avoid this patent.

There is a free license to use the patent in RPL so long as you and your company doesn't sue Cisco over ANY other patent for ANYTHING.

Can we avoid the use of the patented technology in RPL?  Should we?  Do we want to?

Did this IPR announcement come too late?

    Rav

---

From: Philip Levis <[email-masked]>
Date: Wed, 20 Jan 2010 09:26:30 -0800

> Can we avoid the use of the patented technology in RPL?  Should we?  Do we want to?

I think we can, want to, and should.

Phil

---

From: Emmanuel Baccelli <[email-masked]>
Date: Wed, 20 Jan 2010 18:31:29 +0100

I agree we should try to avoid such patent related issues. In the long run,
it is probably worth spending extra time and energy to do so.
Emmanuel

On Wed, Jan 20, 2010 at 6:26 PM, Philip Levis <[email-masked]> wrote:

>   Did anyone see the Cisco announcement about IPR in RPL.  If you didn't it
> was probably because it was only sent to the IETF IPR list.  I don't know
> why it wasn't sent to the ROLL list.  If you didn't see it here is a link:
>
> I'm a bit confused and concerned that this IPR annoucement was sent so late
> in the process (December 3).  Given that Cisco folks were working on the
> design team from the beginning why did it take so long for cisco to identify
> the IPR.  We are now so late in the design and development that it would be
> nearly impossible for us to figure out how avoid this patent.
>
> There is a free license to use the patent in RPL so long as you and your
> company doesn't sue Cisco over ANY other patent for ANYTHING.
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 20 Jan 2010 18:42:04 +0100

Le 20/01/2010 18:26, Philip Levis a écrit :
>> ROLLers, Did anyone see the Cisco announcement about IPR in RPL.
>> If you didn't it was probably because it was only sent to the IETF
>> IPR list. I don't know why it wasn't sent to the ROLL list. If you
>> didn't see it here is a link:
>>
>>  I'm a bit confused and concerned that this IPR annoucement was
>> sent so late in the process (December 3). Given that Cisco folks
>> were working on the design team from the beginning why did it take
>> so long for cisco to identify the IPR. We are now so late in the
>> design and development that it would be nearly impossible for us
>> to figure out how avoid this patent.
>>
>> There is a free license to use the patent in RPL so long as you
>> and your company doesn't sue Cisco over ANY other patent for
>> ANYTHING.
>>

I don't think we can - it's too late.  We can't now discard the DT
output and documents.

Also, I don't think we want to avoid the use of patented technology in
RPL.  The IPR statements were on this list as early as April 2009.
Since then work was ongoing showing high interest from many parties.
That says we didn't want to.

Or maybe we have changed mind recently?

Or maybe we want to dissect the RPL document, identify the IPRed parts 
and remove them?

Alex

>
> Phil
>
>
>
> _______________________________________________ Roll mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/roll

---

From: Omprakash Gnawali <[email-masked]>
Date: Wed, 20 Jan 2010 09:50:20 -0800

On Wed, Jan 20, 2010 at 9:42 AM, Alexandru Petrescu
<[email-masked]> wrote:
> Or maybe we want to dissect the RPL document, identify the IPRed parts and
> remove them?

I don't think it is too late to consider this issue.

It will be great if the patented parts of RPL were clearly identified.
Maybe Pascal et al. can help in doing that.

- om_p

---

From: "JeongGil Ko (John)" <[email-masked]>
Date: Thu, 21 Jan 2010 13:13:36 -0800

I agree that we should try find a way to avoid these patent issues. However, at this point, with the given information, its hard to locate the patented parts though :(

-John

> Maybe Pascal et al. can help in doing that.

------
JeongGil Ko (John)
Ph.D. Student
Department of Computer Science
Johns Hopkins University
http://www.cs.jhu.edu/~jgko

---

From: Ietf Roll <[email-masked]>
Date: Fri, 22 Jan 2010 14:49:25 -0800 (PST)

Mr Levis,
  I agree, but how do we do so?  What parts of these patents are using in RPL and how do we start the process to extricate RPL from the patents.

- RAV

--- On Wed, 1/20/10, Philip Levis <[email-masked]> wrote:

> From: Philip Levis <[email-masked]>
> Subject: Re: [Roll] Patents on RPL
> To: "Ietf Roll" <[email-masked]>
> Cc: [email-masked]
> Date: Wednesday, January 20, 2010, 5:26 PM
> 
>   Did anyone see the Cisco announcement about IPR in
> RPL.  If you didn't it was probably because it was
> only sent to the IETF IPR list.  I don't know why
> it wasn't sent to the ROLL list.  If you didn't
> see it here is a link:
> 
> I'm a bit confused and concerned that this IPR
> annoucement was sent so late in the process (December
> 3).  Given that Cisco folks were working on the design
> team from the beginning why did it take so long for cisco to
> identify the IPR.  We are now so late in the design and
> development that it would be nearly impossible for us to
> figure out how avoid this patent.
> 
> There is a free license to use the patent in RPL so long as
> you and your company doesn't sue Cisco over ANY other
> patent for ANYTHING.
> 
> Can we
>  avoid the use of the patented technology in RPL? 
> Should we?  Do we want to?
>

---

From: Ietf Roll <[email-masked]>
Date: Fri, 22 Jan 2010 14:52:07 -0800 (PST)

Can Mr. Thubert identify the issues in RPL?

--- On Wed, 1/20/10, Omprakash Gnawali <[email-masked]> wrote:

> From: Omprakash Gnawali <[email-masked]>
> To: "Alexandru Petrescu" <[email-masked]>
> Cc: [email-masked]
> Date: Wednesday, January 20, 2010, 5:50 PM
> >>> Can we avoid the use of the patented
> technology in RPL? Should we?
> >>> Do we want to?
> >>>
> >>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 25 Jan 2010 08:57:31 +0100

Hi:

I think this is asking the wrong question. There are tons of IPR related to sensor work, most of it not declared to this list. Some of it might be claimed to apply to work we are doing or could be doing in this WG, but the people involved simply wait for our work to complete before they launch the attack. I'm not joking, this is known to have happened to other SDOs and has been discussed in this ML already. 

Do we have a strategy to avoid it?

In fact, we have some. We have academic papers such as CTP that make dates and can be used to prove prior art in court, when things go that far. But as you figure, issued IPR announced to match the RFC is a lot stronger deterrent; in that regard, we could and probably should consider the cisco IPR as a counter-fire. People and organizations that comply with the terms are not only safe from Cisco, but also a lot safer from the rest of the existing but undeclared IPR than they would be without the cisco IPR.

The 'standard' Cisco terms are quite generous, and usually well accepted for IETF activities. I have personally worked in other groups that have accepted those terms, and from which actual code and products derive, including open source implementations. I do not think that working around our own defense and open the door to attacks from unknown parties is the right strategy for this WG.

Let us focus on delivering, time is short.

Pascal

---

From: "Don Sturek" <[email-masked]>
Date: Mon, 25 Jan 2010 07:09:16 -0800

Although I don't know the details on selection of technology for the RPL DT,
I agree with Pascal's note below.  We will NOT be avoiding patents.  We will
only potentially be selecting someone else's IPR that we will find out about
when we deploy.

Pascal's note is correct.  Other SDO's involved in mesh networking are
finding issues during deployment with companies claiming to have essential
patents on mesh networking.

For ROLL, I think it is actually better to know there is IPR  and have clear
access to it than to design out all known IPR and find out later.....

Don

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Pascal Thubert (pthubert)
Sent: Sunday, January 24, 2010 11:58 PM
To: Alexandru Petrescu; Omprakash Gnawali
Cc: [email-masked]
Subject: Re: [Roll] Patents on RPL

Hi:

I think this is asking the wrong question. There are tons of IPR related to
sensor work, most of it not declared to this list. Some of it might be
claimed to apply to work we are doing or could be doing in this WG, but the
people involved simply wait for our work to complete before they launch the
attack. I'm not joking, this is known to have happened to other SDOs and has
been discussed in this ML already. 

In fact, we have some. We have academic papers such as CTP that make dates
and can be used to prove prior art in court, when things go that far. But as
you figure, issued IPR announced to match the RFC is a lot stronger
deterrent; in that regard, we could and probably should consider the cisco
IPR as a counter-fire. People and organizations that comply with the terms
are not only safe from Cisco, but also a lot safer from the rest of the
existing but undeclared IPR than they would be without the cisco IPR.

The 'standard' Cisco terms are quite generous, and usually well accepted for
IETF activities. I have personally worked in other groups that have accepted
those terms, and from which actual code and products derive, including open
source implementations. I do not think that working around our own defense
and open the door to attacks from unknown parties is the right strategy for
this WG.

Pascal

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ietf
Roll
Sent: vendredi 22 janvier 2010 23:52
To: Alexandru Petrescu; Omprakash Gnawali
Cc: [email-masked]
Subject: Re: [Roll] Patents on RPL