Subject: Re: [Roll] Roll Digest, Vol 25, Issue 42

From: "Reddy, Joseph" <[email-masked]>
Date: Tue, 23 Feb 2010 18:13:38 -0600

JP, Adrian,

I too like the new IPR statement from Cisco much better and would favor continuing work on the current draft.

-Regards, Joseph

------------------------------

Message: 2
Date: Tue, 23 Feb 2010 13:21:12 -0500
From: "Salazar, Ruben" <[email-masked]>
Subject: Re: [Roll] Posting of IPR Disclosure related to Cisco's
	Statement	of IPR relating to draft-ietf-roll-rpl-06
To: "Pascal Thubert \(pthubert\)" <[email-masked]>,	"Roger
	Alexander" <[email-masked]>, <[email-masked]>,	"Sung
	Lee" <[email-masked]>,	"Emmanuel Baccelli"
	<[email-masked]>
Cc: [email-masked], "Dan Lang \(dlang\)" <[email-masked]>
Message-ID:
	<[email-masked]>
Content-Type: text/plain;	charset="iso-8859-1"

Pascal, et al.
This is definitely a great move in the right direction.
We feel much better with the new IPR statement from Cisco.
Regards

Ruben Salazar, PhD
Director of Research  and Technology
Landys+Gyr EMS
Office: 678 258 3165
Cellular: 678 438 0063
[email-masked]
www.landisgyr.com
manage energy better

Ruben Salazar
Director of Technology
Landis+Gyr
Energy Management Solutions
Office: +1 678 258 3165
Fax: +1 678 258 1550
[email-masked]
www.landisgyr.com
manage energy better
-----Original Message-----
From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Tuesday, February 23, 2010 12:21 PM
To: Roger Alexander; [email-masked]; Salazar, Ruben; Sung Lee; Emmanuel Baccelli
Cc: [email-masked]; Dan Lang (dlang)
Subject: FW: Posting of IPR Disclosure related to Cisco's Statement of IPR relating to draft-ietf-roll-rpl-06

Hi Roger, Ruben, Sung, Emmanuel, Don, and all concerned with the Cisco IPR debate:

It is my understanding that this new declaration implements Roger's suggested compromise regarding Sung and Ruben's concerns, also relayed by Emmanuel.

For reference:
Roger suggested:
http://www.ietf.org/mail-archive/web/roll/current/msg03045.html
Sung said:
http://www.ietf.org/mail-archive/web/roll/current/msg03034.html
Emmanuel said:
http://www.ietf.org/mail-archive/web/roll/current/msg03063.html
Ruben said:
http://www.ietf.org/mail-archive/web/roll/current/msg03026.html 

With this new IPR declaration, Cisco retains its defensive right in the context of RPL implementations *only*. By the new terms Cisco will not "walk freely anywhere" in someone else's "property". And the answer to Sung's question about "infringing patents NOT related to RPL" is now a NO. Simply, Cisco opens its IPR on RPL to anyone that reciprocally does the exact same, which seems quite fair to me. For all I know, this is a major and somewhat exceptional step that should be recognized as such.
And alternate terms based on RAND are still available to anyone who would prefer that way.

Sadly, I'll still refrain from detailing which exact pieces RPL I personally think are covered by this IPR. I think it is pretty clear by now that this would not have a lot of value since 1) I'm not a lawyer, and 2) even less your own lawyer. Also the logic of claims somewhat escapes me, in particular when it comes to coverage. All I know is that the disclosures I was involved with detail ways to build trees and DAGs, propagate metrics and paint unicast and multicast routes along the DAGs, compress and expands routing headers, all things that are somewhat similar to RPL operations.

I sincerely hope that this declaration will allow us to reach a positive consensus on the current poll about Cisco's IPR and move forward with RPL as soon as possible. Please let us know.

Pascal

---

From: "Reddy, Joseph" <[email-masked]>
Date: Tue, 23 Feb 2010 18:23:56 -0600

Hi Tzeta,

Assuming that there is link layer security already available in the network, do you envision any additional benefit that will be provided by the proposed RPL security ?

-Thanks, Joseph

Date: Tue, 23 Feb 2010 13:44:19 -0500
From: Tzeta Tsao <[email-masked]>
Subject: [Roll] An Update from the Security Design Team
To: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

WG,

This is a short summary of the high-level proposals from the security DT for securing RPL:

1. Protect the DIO, DIS, and DAO control messages; 2. Allow options of the security services to be provided to those control messages; 3. Use the sub-option fields of those messages to indicate which services are provided; 4. Specify a instance-wide layer-3 key as the base requirement.

We will put out a draft to describe the details and are interested in any input.

Thanks,
Tzeta

---

From: Tzeta Tsao <[email-masked]>
Date: Wed, 24 Feb 2010 09:40:40 -0500

Hi Joseph,

Indeed, there may or may not be link layer security, while there may be 
benefit to have layers of security. A design that leaves the decision to 
the user seems to be the best compromise.

Regards,
Tzeta

Reddy, Joseph wrote:
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>