Subject: [Roll] Closing on the IPR

From: JP Vasseur <[email-masked]>
Date: Mon, 1 Feb 2010 14:57:13 +0100

Dear all,

Given the discussions about the IPR disclosure at https://datatracker.ietf.org/ipr/1246/ 
  and the IETF's IPR policy at http://www.ietf.org/ipr/policy.html I  
would like to make sure that the working group is happy to proceed  
with draft-ietf-roll-rpl in its current form. Please state your  
opinions on the list. I will make a consensus call on Friday 11  
February.

Thanks.

JP.

---

From: "Don Sturek" <[email-masked]>
Date: Mon, 1 Feb 2010 06:59:42 -0800

Hi JP,

As noted in an earlier thread, I am fine with proceeding using the
draft-ietf-roll-rpl.

Best Regards,

Don Sturek

From: [email-masked] [mailto:[email-masked]] On Behalf Of JP
Vasseur
Sent: Monday, February 01, 2010 5:57 AM
To: ROLL WG
Subject: [Roll] Closing on the IPR

Dear all,

Given the discussions about the IPR disclosure at
https://datatracker.ietf.org/ipr/1246/ and the IETF's IPR policy at
http://www.ietf.org/ipr/policy.html I would like to make sure that the
working group is happy to proceed with draft-ietf-roll-rpl in its current
form. Please state your opinions on the list. I will make a consensus call
on Friday 11 February.

Thanks.

JP.

---

From: "Pete St. Pierre" <[email-masked]>
Date: Mon, 01 Feb 2010 08:46:37 -0800

Hi JP -
I think it would be easier to answer this question if we knew  exactly which portions of the work were encumbered.

If Pascal could summarize the implications of Cisco's IP on the current draft, I'm sure we'd all have a better understanding and could then move this along with confidence.

Regards,
...Pete

On Feb 1, 2010, at 5:57 AM, JP Vasseur wrote:

> Dear all,
> 
> Given the discussions about the IPR disclosure at https://datatracker.ietf.org/ipr/1246/ and the IETF's IPR policy at http://www.ietf.org/ipr/policy.html I would like to make sure that the working group is happy to proceed with draft-ietf-roll-rpl in its current form. Please state your opinions on the list. I will make a consensus call on Friday 11 February.
> 
> Thanks.
> 
> JP.
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Emmanuel Baccelli <[email-masked]>
Date: Mon, 1 Feb 2010 18:35:44 +0100

Hi JP,

as discussed, IPR may indeed be difficult to avoid entirely, even without
looming deadlines... If I recall correctly, we are discussing this because
someone claimed that Cisco forces an IPR deal which, quoting this now famous
anonymous, can be summarized by the following:

"Free license to use the patents in RPL so long as you and your company
don't sue Cisco over any other patent for anything."

We are engineers, not lawyers, so to understand legal matters, most of us
need such one-liner to understand what is the deal. Therefore in my mind,
the right questions that we need to ask ourselves at this point are:

1 - is the above an accurate summary of the IPR deal imposed by Cisco?
2 - if no, what is an accurate summary of the IPR deal imposed by Cisco?
3 - if yes, are we OK with these terms?

Let's clarify this and move on quickly, back to protocol design where we
belong!

Regards,

Emmanuel

On Mon, Feb 1, 2010 at 5:46 PM, Pete St. Pierre <[email-masked]>wrote:

> Hi JP -
> I think it would be easier to answer this question if we knew  exactly
> which portions of the work were encumbered.
>
> If Pascal could summarize the implications of Cisco's IP on the current
> draft, I'm sure we'd all have a better understanding and could then move
> this along with confidence.
>
> Regards,
> ...Pete
>
>
>

---

From: Philip Levis <[email-masked]>
Date: Mon, 1 Feb 2010 10:16:52 -0800

On Feb 1, 2010, at 9:35 AM, Emmanuel Baccelli wrote:

> Hi JP,
> 
> as discussed, IPR may indeed be difficult to avoid entirely, even without looming deadlines... If I recall correctly, we are discussing this because someone claimed that Cisco forces an IPR deal which, quoting this now famous anonymous, can be summarized by the following:
> 
> "Free license to use the patents in RPL so long as you and your company don't sue Cisco over any other patent for anything."  
> 
> We are engineers, not lawyers, so to understand legal matters, most of us need such one-liner to understand what is the deal. Therefore in my mind, the right questions that we need to ask ourselves at this point are:
> 
> Let's clarify this and move on quickly, back to protocol design where we belong!

Agreed -- part of the issue here is that I think it's not really possible for Pascal to describe exactly what the patents cover: he's not a patent lawyer, and I doubt that Cisco would like him to speak for them in this regard. My brief interactions with patent law have taught me that it often works quite differently than engineers might expect. So we should be careful assuming that we can easily understand the full situation. :)

Phil

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 01 Feb 2010 22:17:51 +0100

Just my two cents worth in this new thread,

Le 01/02/2010 19:16, Philip Levis a écrit :
>> as discussed, IPR may indeed be difficult to avoid entirely, even
>> without looming deadlines... If I recall correctly, we are
>> discussing this because someone claimed that Cisco forces an IPR
>> deal which, quoting this now famous anonymous, can be summarized
>> by the following:
>>
>> "Free license to use the patents in RPL so long as you and your
>> company don't sue Cisco over any other patent for anything."
>>
>> We are engineers, not lawyers, so to understand legal matters,
>> most of us need such one-liner to understand what is the deal.
>> Therefore in my mind, the right questions that we need to ask
>> ourselves at this point are:
>>
>> 1 - is the above an accurate summary of the IPR deal imposed by
>> Cisco? 2 - if no, what is an accurate summary of the IPR deal
>> imposed by Cisco? 3 - if yes, are we OK with these terms?
>>
> Agreed -- part of the issue here is that I think it's not really
> possible for Pascal to describe exactly what the patents cover: he's
> not a patent lawyer,

YEs, I mostly agree.  There's a long way between the initial idea laid
down in a company-internal "disclosure", what gets filed by the patent
attorney and what gets patented.

However, as a technical writer of some other IPRs (not in RoLL space) I
can tell that when I write technical IPR and technical IETF text I know
100% which IPR covers which IETF text.

This is why I believe it is relatively easy to offer some guidance about
which text in the current draft _might_ be tainted.

If we really want to know, then it's easy to find out: just ask the
right questions: may section x.y.z be covered?

OTOH, if we don't really care then we can't blame Pascal or anybody else
about absence of declarations.  They already did what IETF asks them to:
they disclosed.

Alex

  and I doubt that Cisco would like him to speak
> for them in this regard. My brief interactions with patent law have
> taught me that it often works quite differently than engineers might
> expect. So we should be careful assuming that we can easily
> understand the full situation. :)
>
> Phil
>
> _______________________________________________ Roll mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/roll
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Feb 2010 08:33:24 +0100

Hi:

Phil: You're so right. It is also my experience that the process of patenting rapidly escapes the author, and the coverage of the resulting words is just beyond people like me. I made the exercise of browsing the claims for the ten+ disclosures listed, and I'm clear that 3 to 6 of these have an application in RPL. How far that goes I can hardly assert. I simply think that if some external party comes at any of us in the future claiming its own IPR against RPL, there's a good probability that the Cisco IPR makes their attack quite a bit more difficult on a number of key elements.

Emmanuel: 1) is my understanding as well. I talked to our legal team to try to understand as deeply as I could and my understanding has not changed. So We're on the exact same line. I just wanted to make it clear that the Cisco IPR is not only a defense for Cisco; it is also an umbrella that provides some degree of protection to any group that would implement RPL. And 3) is my understanding of what JP is asking to the group at this time. Great summary!

So:  3 - if yes, are we OK with these terms?

Cheers,

Pascal
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Philip Levis
Sent: lundi 1 février 2010 19:17
To: Emmanuel Baccelli
Cc: ROLL WG
Subject: Re: [Roll] Closing on the IPR

Phil

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 02 Feb 2010 10:51:18 +0100

Cisco IPR protection umbrella to any group implementing IPR?

                      NO!

If I implement this stuff I will not need Cisco protection - I will
write a different protection, a different licensing scheme.  I don't
need Cisco licensing to protect me.  What I need from Cisco is to
interoperate.

Take my stance as moderate - as I previously said, I am generally ok
with Cisco disclosures at IETF - but I never considered it as a
protection umbrella, rather as something that I had to live with.

This is also why a second disclosure on RPL, from a competitor would be
beneficial.

Alex

Le 02/02/2010 08:33, Pascal Thubert (pthubert) a écrit :
> Hi:
>
> Phil: You're so right. It is also my experience that the process of
> patenting rapidly escapes the author, and the coverage of the
> resulting words is just beyond people like me. I made the exercise
> of browsing the claims for the ten+ disclosures listed, and I'm
> clear that 3 to 6 of these have an application in RPL. How far that
> goes I can hardly assert. I simply think that if some external party
> comes at any of us in the future claiming its own IPR against RPL,
> there's a good probability that the Cisco IPR makes their attack
> quite a bit more difficult on a number of key elements.
>
> Emmanuel: 1) is my understanding as well. I talked to our legal team
> to try to understand as deeply as I could and my understanding has
> not changed. So We're on the exact same line. I just wanted to make
> it clear that the Cisco IPR is not only a defense for Cisco; it is
> also an umbrella that provides some degree of protection to any
> group that would implement RPL. And 3) is my understanding of what JP
> is asking to the group at this time. Great summary!
>
> Pascal -----Original Message----- From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Philip Levis Sent: lundi
> 1 février 2010 19:17 To: Emmanuel Baccelli Cc: ROLL WG Subject: Re:
> [Roll] Closing on the IPR
>
>
> not a patent lawyer, and I doubt that Cisco would like him to speak

---

From: JP Vasseur <[email-masked]>
Date: Tue, 2 Feb 2010 11:15:47 +0100

Hi Alex,

Just to make sure since we're looking for an answer to the following  
question:

"Given the discussions about the IPR disclosure at https://datatracker.ietf.org/ipr/1246/ 
"

Are you OK ? Based on what you said I think that the answer is "yes"  
but I wanted to make sure.

Thanks.

JP.

---

From: JP Vasseur <[email-masked]>
Date: Tue, 2 Feb 2010 11:17:51 +0100

Hi Alex,

Thanks.

JP.

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 02 Feb 2010 11:30:03 +0100

Hi JP,

Le 02/02/2010 11:17, JP Vasseur a écrit :
> "Given the discussions about the IPR disclosure at
> http://www.ietf.org/ipr/policy.html I would like to make sure that
> the working group is happy to proceed with draft-ietf-roll-rpl in
> its current form. Please state your opinions on the list. I will make
> a consensus call on Friday 11 February. "
>

On my side I am ok with the questions above.

The WG as whole - your draw.

Alex

>> Take my stance as moderate - as I previously said, I am generally
>> ok with Cisco disclosures at IETF - but I never considered it as a
>> This is also why a second disclosure on RPL, from a competitor
>> would be beneficial.
>>
>> Alex
>>
>>> Phil: You're so right. It is also my experience that the process
>>> of patenting rapidly escapes the author, and the coverage of the
>>>  resulting words is just beyond people like me. I made the
>>> exercise of browsing the claims for the ten+ disclosures listed,
>>> and I'm clear that 3 to 6 of these have an application in RPL.
>>> How far that goes I can hardly assert. I simply think that if
>>> some external party comes at any of us in the future claiming
>>> its own IPR against RPL, there's a good probability that the
>>> Cisco IPR makes their attack quite a bit more difficult on a
>>> number of key elements.
>>>
>>> Emmanuel: 1) is my understanding as well. I talked to our legal
>>> team to try to understand as deeply as I could and my
>>> understanding has not changed. So We're on the exact same line.
>>> I just wanted to make it clear that the Cisco IPR is not only a
>>> defense for Cisco; it is also an umbrella that provides some
>>> degree of protection to any group that would implement RPL. And
>>> 3) is my understanding of what JP is asking to the group at this
>>> time. Great summary!
>>>
>>> <mailto:[email-masked]> [mailto:[email-masked]] On
>>> Behalf Of Philip Levis Sent: lundi 1 février 2010 19:17 To:
>>> Emmanuel Baccelli Cc: ROLL WG Subject: Re: [Roll] Closing on the
>>> IPR
>>>
>>>
>>>> as discussed, IPR may indeed be difficult to avoid entirely,
>>>> even without looming deadlines... If I recall correctly, we are
>>>> discussing this because someone claimed that Cisco forces an
>>>> IPR deal which, quoting this now famous anonymous, can be
>>>> summarized by the following:
>>>>
>>>  possible for Pascal to describe exactly what the patents cover:
>>> he's not a patent lawyer, and I doubt that Cisco would like him
>>> to speak for them in this regard. My brief interactions with
>>> patent law have taught me that it often works quite differently
>>> than engineers might expect. So we should be careful assuming
>>> that we can easily understand the full situation. :)
>>>
>>> Phil
>>>
>>> [email-masked] <mailto:[email-masked]>
>>> [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>

---

From: Geoff Mulligan <[email-masked]>
Date: Fri, 05 Feb 2010 08:24:45 -0700

I am extremely concerned should we decide to proceed with
draft-ietf-roll-rpl in its current form.  I agree with Pete and I second
the request from JP that Pascal indicate what portions of RPL are
covered by the Cisco IPR.

Until we know what portions of RPL are covered by the IPR and how
difficult it might be to "work around" the patents I dont know how to
proceed.

I do not think that Pascal should say that he doesn't know because
patent lawyers got involved.  Pascal is the best person in the world to
show what is covered and what isn't.  He is an author on the patents and
also part of the DT for RPL.  No one else is.

I feel that it is critically important that we not proceed with the
draft as it currently stands.  I think that the current licensing terms
for the IPR are a show stopper.

	geoff

On Mon, 2010-02-01 at 14:57 +0100, JP Vasseur wrote:
> https://datatracker.ietf.org/ipr/1246/ and the IETF's IPR policy
> at http://www.ietf.org/ipr/policy.html I would like to make sure that
> the working group is happy to proceed with draft-ietf-roll-rpl in its
> current form. Please state your opinions on the list. I will make a
> consensus call on Friday 11 February.
> 
> 
> Thanks.
> 
> 
> JP.
> 
>

---

From: "Don Sturek" <[email-masked]>
Date: Mon, 8 Feb 2010 05:32:28 -0800

Can I ask what part of the Cisco licensing is a "show stopper"?  

If we agree that the Cisco licensing terms are unacceptable, are there going
to be any assurances that what is left in RPL is covered by no other IPR
(meaning someone is going to do a patent search and provide such
assurances).

Don

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Geoff Mulligan
Sent: Friday, February 05, 2010 7:25 AM
To: JP Vasseur; [email-masked]
Cc: ROLL WG
Subject: Re: [Roll] Closing on the IPR

	geoff

---

From: [email-masked]
Date: Mon, 8 Feb 2010 08:48:22 -0500

I noticed about the Cisco statement are probably worth discussing.  First, 
the license to use the patented technology is terminated if a company 
decides to sue Cisco.  That seems OK, until you consider that if Company X 
was sued *by* Cisco and then Company X countersued (which is quite common, 
I'm told), then that clause comes into effect.  That doesn't seem quite 
right.

Further, this happens even if the suit has nothing to do with an 
implementation of roll, which also doesn't seem right. 

Perhaps Cisco lawyers can figure out a way to address those issues while 
still giving Cisco reasonable protection.

Ed

---

From: "Don Sturek" <[email-masked]>
Date: Fri, 12 Feb 2010 09:09:34 -0800

Hi JP (and ROLL team),

After a lot of discussion, I have to say there are legitimate concerns on
proceeding with draft-ietf-roll-rpl given the IPR disclosure from Cisco.

Please modify my respond to indicate that I am not in favor of proceeding
with the current RPL draft with the existing IPR statement.

Best Regards,

Don Sturek

From: Don Sturek [mailto:[email-masked]] 
Sent: Monday, February 01, 2010 7:00 AM
To: 'JP Vasseur'; 'ROLL WG'
Subject: RE: [Roll] Closing on the IPR

Hi JP,

Best Regards,

Don Sturek

Dear all,

Thanks.

JP.

---

From: Philip Levis <[email-masked]>
Date: Fri, 12 Feb 2010 09:21:08 -0800

On Feb 12, 2010, at 9:09 AM, Don Sturek wrote:

> Hi JP (and ROLL team),
>  
> After a lot of discussion, I have to say there are legitimate concerns on proceeding with draft-ietf-roll-rpl given the IPR disclosure from Cisco.
>  
> Please modify my respond to indicate that I am not in favor of proceeding with the current RPL draft with the existing IPR statement.
>  
> Best Regards,
>  
> Don Sturek

Don,

Two questions:

1) It's not yet clear what in the RPL draft overlaps with Cisco's IPR. Is your opinion that the draft should not overlap with the disclosed IPR, or that regardless of their relationship we should adopt a complete different design?

2) Given that there is lots of IPR in this space, most of which is not represented here, is your opinion that we should do an IP survey and strive to come up with a design that is covered by none, or that we should only strive to avoid the IPR that's been disclosed within this WG?

It's easy to say "this isn't the right path forward." I'm trying to figure out what you think the alternative is.

Phil

---

From: [email-masked]
Date: Fri, 12 Feb 2010 13:49:53 -0500

Philip Levis wrote on 02/12/2010 12:21:08:
> 
> It's easy to say "this isn't the right path forward." I'm trying to 
> figure out what you think the alternative is.

Logically, either RPL or Cisco's terms could be changed to meet 
objections.  Has Cisco ruled out the latter?

Ed

---

From: "Salazar, Ruben" <[email-masked]>
Date: Fri, 12 Feb 2010 22:59:11 -0500

JP and ROLL team,

Like most of you, I am trying to form a position regarding this discussion about Cisco's IPR, and I can summarize it in a particular way:

Cisco asks companies that are working in this effort and may potentially make use of this protocol to renounce to enforce any potential  IPR violation from Cisco to their own IPR and in exchange these companies get whatever coverage they can get with Cisco's IPR essential to this protocol.

Well, somebody earlier in the exchange compared Cisco's IPR to a "protection umbrella" to all this effort. We know that despite any number of patents that Cisco may consider relevant and essential to it there could (and there will) be areas that their portfolio would not cover, so  the "umbrella" will have "holes" at best.

So my conclusion is that by agreeing to Cisco's terms we would allow Cisco to "walk" freely anywhere in our "property " in exchange from an umbrella with holes to protect work only on RPL. It does not seem right.

The argument that "it has been done before" is not only weak as justification for it to continue being done, but also is not necessarily true: I believe that for every example that can be produced in that sense there will be tens of examples where standardization has happened without such terms.

I also think that knowing what part of the current RPL may be affected by Cisco's IPR would not alleviate the concern, it will just help us see the "holes in the umbrella".

The work on ROLL/RPL is supposed to bring standardization in the relatively new area of low power low reliability wireless networks, and the best way to help it flourish is by bringing to the table, together, the elements of our thoughts that can be shared openly and freely, and leaving the remaining elements to each company to introduce its own differentiating solutions.

Regards

Ruben Salazar, PhD

Director of Research  and Technology

Landys+Gyr EMS

Office: 678 258 3165

Cellular: 678 438 0063

[email-masked]

www.landisgyr.com

manage energy better

From: [email-masked] [mailto:[email-masked]] On Behalf Of JP Vasseur
Sent: Tuesday, February 02, 2010 5:16 AM
To: Alexandru Petrescu
Cc: ROLL WG
Subject: Re: [Roll] Closing on the IPR

Hi Alex,

Just to make sure since we're looking for an answer to the following question: 

"Given the discussions about the IPR disclosure at https://datatracker.ietf.org/ipr/1246/ and the IETF's IPR policy at http://www.ietf.org/ipr/policy.html I would like to make sure that the working group is happy to proceed with draft-ietf-roll-rpl in its current form. Please state your opinions on the list. I will make a consensus call on Friday 11 February.

"

Are you OK ? Based on what you said I think that the answer is "yes" but I wanted to make sure.

Thanks.

JP.

                    NO!

Alex

Hi:

	Cheers,

	Pascal 

Ruben Salazar
Director of Technology
Landis+Gyr
Energy Management Solutions
Office: +1 678 258 3165
Fax: +1 678 258 1550
[email-masked]
www.landisgyr.com
manage energy better
-----Original Message----- From: [email-masked]

	 

		Hi JP,

		by the following:

		Let's clarify this and move on quickly, back to protocol design

		where we belong!

	Phil

---

From: Kris Pister <[email-masked]>
Date: Sat, 13 Feb 2010 16:00:29 -0800

As I have previously stated, I believe that we should move ahead with 
RPL, but I want to correct a mis-perception about protection.

Claims that the Cisco IPR provides any sort of protection are false. 
Patent law doesn't work that way. To use a silly example, Cisco may 
patent an automobile with a motor and a steering wheel and give you the 
rights to make that for free. But someone else can still come after you 
if they own the rights to anything with a round steering wheel, or 
internal combustion motors, or vehicles with rubber wheels, or the 
method that you use to make the steering wheel.

Any company's IPR, regardless of what terms they use to offer it, 
provides us with no protection from anything except the company itself, 
under the terms that they use.

ksjp

Salazar, Ruben wrote:
>
> JP and ROLL team,
>
> Like most of you, I am trying to form a position regarding this 
> discussion about Cisco’s IPR, and I can summarize it in a particular way:
>
> Cisco asks companies that are working in this effort and may 
> potentially make use of this protocol to renounce to enforce any 
> potential IPR violation from Cisco to their own IPR and in exchange 
> these companies get whatever coverage they can get with Cisco’s IPR 
> essential to this protocol.
>
> Well, somebody earlier in the exchange compared Cisco’s IPR to a 
> “protection umbrella” to all this effort. We know that despite any 
> number of patents that Cisco may consider relevant and essential to it 
> there could (and there will) be areas that their portfolio would not 
> cover, so the “umbrella” will have “holes” at best.
>
> So my conclusion is that by agreeing to Cisco’s terms we would allow 
> Cisco to “walk” freely anywhere in our “property “ in exchange from an 
> umbrella with holes to protect work only on RPL. It does not seem right.
>
> The argument that “it has been done before” is not only weak as 
> justification for it to continue being done, but also is not 
> necessarily true: I believe that for every example that can be 
> produced in that sense there will be tens of examples where 
> standardization has happened without such terms.
>
> I also think that knowing what part of the current RPL may be affected 
> by Cisco’s IPR would not alleviate the concern, it will just help us 
> see the “holes in the umbrella”.
>
> The work on ROLL/RPL is supposed to bring standardization in the 
> relatively new area of low power low reliability wireless networks, 
> and the best way to help it flourish is by bringing to the table, 
> together, the elements of our thoughts that can be shared openly and 
> freely, and leaving the remaining elements to each company to 
> introduce its own differentiating solutions.
>
> Regards
>
> Ruben Salazar, PhD
>
> [email-masked] <mailto:[email-masked]>_
>
> _www.landisgyr.com <http://www.landisgyr.com>_
>
> *manage energy better***
>
>
>
> *Ruben Salazar*
> Director of Technology
> Landis+Gyr
> [email-masked] <mailto:[email-masked]>
> www.landisgyr.com <http://www.landisgyr.com/>
> *manage energy better*
>
> *From:* [email-masked] [mailto:[email-masked]] *On 
> Behalf Of *JP Vasseur
> *Sent:* Tuesday, February 02, 2010 5:16 AM
> *To:* Alexandru Petrescu
> *Cc:* ROLL WG
> *Subject:* Re: [Roll] Closing on the IPR
>
> Hi Alex,
>
> working group is happy to proceed with draft-ietf-roll-rpl in its 
>     <mailto:[email-masked]>
>
> ------------------------------------------------------------------------
>

---

From: "Pete St. Pierre" <[email-masked]>
Date: Fri, 19 Feb 2010 08:51:13 -0800

JP & fellow Roll'ers -
Now that the important legal questions are being discussed on the proper lists, I would like to get back to understanding the technical aspects of what elements of ROLL are impacted by the IPR statements Cisco has made.  More comments below...

> covered by the Cisco IPR.

There seems to be much reluctance for anyone to step forward with more specifics.  However, I don't believe I have made an unreasonable request.  BCP 79 specifically states, in the second 1/2 of section 6.4.1:

"In addition, if the IETF Document includes multiple parts and it is not reasonably apparent which part of such IETF Document is alleged to be Covered by the IPR in question, it is helpful if the discloser identifies the sections of the IETF Document that are alleged to be so Covered."

IMHO, given the number of people that have expressed their concerns to NOT move forward compared to those who have expressed a desire to move on, I think that there are issues here that are "not reasonably apparent" and clarification is in order.
> difficult it might be to "work around" the patents I dont know how to

To be clear -- I am not advocating that we "identify and eradicate".  I would simply like to understand the potential IPR encumbrances and implications prior to agreeing to move forward.  

> also part of the DT for RPL.  No one else is.

I agree with Geoff's assessment.  I do NOT expect Pascal to attempt to interpret for us every claim made in the granted patents, since that is certainly better left in the realm of corporate legal staffs. 

As a named inventor on several patents, I understand that the claims made in a patent filing often greatly exceed that of the original embodiment from which the patent was drawn.  However, I would expect that an inventor would recognize the element or elements of a design that, at a minimum, approximate the original embodiment that lead to patenting of the "invention".  

Given that there was a separate design team carved off of the roll WG to do the initial roll/RPL design, I do not think it is unreasonable to ask the named inventors or other members of the DT to provide some insight into the design elements that may be impacted by the IPR stated in this disclosure.

To be clear -- I agree with Dan Lang's earlier comments.  To paraphrase: If you want to be covered, each individual and their lawyers should do their homework.

I believe what we want is to move forward in a confident, expedient manner, and there is information that can be provided to help that along.  If we want to wait until each individual that has expressed a desire to "not move forward", has done their own evaluation, we will be "stuck in neutral" for a while.

> for the IPR are a show stopper.

I think we've beaten this one to death for the moment and I would ask that any additional discussions on this topic continue on the appropriate IPR/ILT (aka non-roll) mailing lists.

Best regards,
...Pete