Subject: Re: [Roll] IPR ROLL

From: "Reddy, Joseph" <[email-masked]>
Date: Mon, 15 Feb 2010 13:43:09 -0600

Hi JP, Adrian,

I am not in favour of moving with the current RPL draft under the proposed licensing terms. 

-Regards, Joseph

>>----------------------------------------------------------------------
>>
>>Message: 1
>>Date: Fri, 12 Feb 2010 21:41:47 +0100
>>From: JP Vasseur <[email-masked]>
>>Subject: [Roll] IPR ROLL
>>To: ROLL WG <[email-masked]>
>>Message-ID: <[email-masked]>
>>Content-Type: text/plain; charset=US-ASCII; format=flowed; delsp=yes
>>
>>Dear all,
>>
>>When I look back over the last six to nine months I am really 
>>impressed with the progress we have made developing RPL. 
>>There are multiple implementations already in progress to 
>>show that the solution can really work.
>>
>>The IPR issue is very important, of course. So far quite a 
>>few people have made comments, but I do not see a clear 
>>consensus and I would like to hear from more people.
>>
>>At the same time, I don't think it would be appropriate for 
>>me to judge the consensus on this issue because my company 
>>affiliation might be considered to influence my independent 
>>IETF role. Therefore I have asked our Routing Area Director 
>>Adrian Farrel to take the judgement decision.
>>
>>Thanks Adrian for accepting to do this job.
>>
>>JP.
>>
>>

---

From: Philip Levis <[email-masked]>
Date: Mon, 15 Feb 2010 14:50:02 -0800

I am not a patent lawyer by any means.

But one thing which worries me about this discussion is that, no-one has even claimed to have looked at the patents and patent applications for a sanity check of what might apply. Of course we'd all like someone from Cisco to speak up on this, but that doesn't mean we ourselves can't do a little homework. Patent law can be very complex, but it's not irrational. 

Most of the patents in the IPR disclosure deal with mobility and mobile ad-hoc routers, e.g., Pascal's prior work on NEMO. For example, "Multicast support by mobile routers in a mobile ad hoc network."

The only one that raised a possible red flag for me was patent *application* 20070091811:

http://www.freepatentsonline.com/y2007/0091811.html

"Forwarding packets to a directed acyclic graph destination using link selection based on received link metrics"

Of course "raise a red flag for me" means "an academic who isn't a patent lawyer thinks it might possibly apply." All of the others seemed to have nothing to do with RPL, at all. At least, that's how I, as someone with ordinary skill in the art, would interpret the claims besides the one above. I'd have to read closely to understand fully. And I'd implore everyone on this list who has concerns to do so.

I understand that there are business as well as technical concerns in play here, I just want to make sure that our discussion is based on fact, not hypothesis.

Phil