Subject: [Roll] RPL question regarding the flow label's "Down" bit

From: Calin Crisan <[email-masked]>
Date: Tue, 23 Feb 2010 15:09:49 +0100

Hi,

    Supposing a simple scenario where a node wants to send a packet to
another node within its subdag, thus having a greater rank. The source node,
who acts as a host in this case, is supposed to set the flow label's bits to
0, including the "Down" bit. The first router in the path will however have
a greater rank, and so it will detect a first forwarding inconsistency. Is
this OK?

    Thanks,

    Calin Crisan.

---

From: "JeongGil Ko (John)" <[email-masked]>
Date: Tue, 23 Feb 2010 07:54:35 -0800

Hi!

Actually the first router will not detect inconsistency because the SenderRank in the flow label is also set to zero when the message is initiated at the source node (there will be no rank value for the first router to compare with). So I think that the first router can receive the message and then decide to modify the down bit before forwarding to the second router, if any.

Thanks.

-John

On Feb 23, 2010, at 6:09 AM, Calin Crisan wrote:

>     Hi,
> 
>     Supposing a simple scenario where a node wants to send a packet to another node within its subdag, thus having a greater rank. The source node, who acts as a host in this case, is supposed to set the flow label's bits to 0, including the "Down" bit. The first router in the path will however have a greater rank, and so it will detect a first forwarding inconsistency. Is this OK?
> 
>     Thanks,
> 
>     Calin Crisan.
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

------
JeongGil Ko (John)
Ph.D. Student
Department of Computer Science
Johns Hopkins University
http://www.cs.jhu.edu/~jgko

---

From: Calin Crisan <[email-masked]>
Date: Tue, 23 Feb 2010 18:58:02 +0100

Hi,

    Thank you for your quick answer. Yes, indeed a rank equal to 0 should
not be considered as making part of the actual network's DODAG, aspect that
I forgot about in my implementation.

    Cheers,

    Calin.

On Tue, Feb 23, 2010 at 4:54 PM, JeongGil Ko (John) <[email-masked]> wrote:

> Hi!
>
> Actually the first router will not detect inconsistency because the
> SenderRank in the flow label is also set to zero when the message is
> initiated at the source node (there will be no rank value for the first
> router to compare with). So I think that the first router can receive the
> message and then decide to modify the down bit before forwarding to the
> second router, if any.
>
> Thanks.
>
> -John
>