Subject: Re: [Roll] Options in DIS

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sun, 21 Mar 2010 18:40:13 +0100

Hi Dominique:

I'd add that it can be interesting for a node to specify what it is
looking for, like the instance that it belongs to and for which it is
searching for a parent.

Yes, you have my support to make this a ticket.

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> [email-masked]
> Sent: Friday, March 19, 2010 10:45 AM
> To: [email-masked]
> Subject: [Roll] Options in DIS
> 
> Hi all,
> 
> I have already expressed a desire for options in the DIS packet
> http://www.ietf.org/mail-archive/web/roll/current/msg02765.html
> Jerry and Mukul expressed their support to the request.
> http://www.ietf.org/mail-archive/web/roll/current/msg02766.html
> http://www.ietf.org/mail-archive/web/roll/current/msg02770.html
> 
> Then Phil asked for a justification for the request, which I admit I
> haven't provided yet.
> http://www.ietf.org/mail-archive/web/roll/current/msg02774.html
> 
> More recently, Tzeta suggested that DIS have security options
> http://www.ietf.org/mail-archive/web/roll/current/msg03101.html
> 
> Independently, Yaov and Matteo both again expressed the need for DIS
> option.
> http://www.ietf.org/mail-archive/web/roll/current/msg03185.html
> http://www.ietf.org/mail-archive/web/roll/current/msg03290.html
> 
> I do believe we have a serious point here.
> Please find the justification below.
> Can we please have a ticket to work on it ?
> I volunteer to gather others contributors' opinions/requests and and
> propose detailed text to be included in future revisions of the RPL
> draft.
> Best,
> 
> Dominique
> 
> -------------------------------------------
> The following is extracted from a typical water/gas smart metering
> infrastructure.
> The utility company worker adds new metering points into the network
as
> meters are replaced or fitted with sensing/transmission  electronics.
> Before the worker leaves the premises, he/she is requested to check
that
> the meter has actually joined the network.
> This cannot wait for a trickled-down DAO to arrive.
> Therefore, the meter will send a DIS to collect information from the
> network.
> Without DIS options, all neighbor routers will respond, spending
energy
> for their own transmission and triggering energy expenditure in  all
> neighbor nodes that overhear the responses.
> 
> Let's consider a "wheel" model for the network topology, with a sink
at
> the center and spokes connecting outward to ring-1 routers, ring-2
> routers and periphery meters. The meters have routing capability
> themselves, although I'll call them meters in the following text to
> distinguish them from devices solely intended at providing
connectivity,
> which I'll call routers.
> Let's consider a generic "pizza slice" of this wheel. Since there's
> central symmetry in the network, there's no border effect in the slice
> We typically have
> - one mains-powered sink at the center,
> - N severely energy-limited meters at the periphery, deeply burried
into
> basements or manholes
> - N/20 fairly energy-limited ring-1 routers, located on high spots
> - N/10 fairly energy-limited ring-2 routers, located on high spots
> In RPL parlance, ring-1 routers would have a typical rank of 4, and
> ring-2 routers would have a typical rank of 8
> The N/10 and N/20 ratios above are dictated by energy/lifetime
> considerations, not radio coverage.
> A typical connectivity is the following
> - each meter is in range of N/10 and N/20 routers, albeit with *very*
> different link qualities
> - each router is in range of N/10 and N/20 routers, with various link
> qualities
> - each meter is in range of N/20 meters
> The ratios and assumptions above hold for values of N in the [20..200]
> range.
> 
> **** Without DIS options, we have
> NT0 = Number of DIS multicast transmission = 1
> NR0 = Number of DIS active receptions = N/5 (due to N/20 meters and
> (N/10+N/20) routeurs),
> NT1 = N/20 DIO transmissions from meters; each one being overheard by
> N/20 meters and (N/10+N/20) routers
> NT2 = N/10+N/20 DIO transmissions from routers; each one being
overheard
> by N meters and (N/10+N/20) routers
> NR1 ~= NT1 * (3N/20 + N/20) = N^2/100 = 0.01 * N^2 receptions due to
DIO
> coming from meters
> NR2 ~= NT2 * (N + N/20 + N/10) = N^2*69/400 = 0.17 * N^2 receptions
due
> to DIO coming from routers
> 
> We therefore have
> Number of transmissions: NT = NT0 + NT1 + NT2 = 1 + N/20 + (N/10 +
N/20)
> = 24/20 * N = 1 + 0.2 * N
> Number of receptions   : NR = NR0 + NR1 + NR2 = 0.2 * N + 0.18 * N^2
> 
> Total energy cost Etotal = NT * Et + NR * Er
> 
> If the network is asynchronous and uses basic preamble sampling, the
> cost of overhearing Eo is the cost of receiving the expected duration
> (half) of the preamble.
> Since the DIS packet is small, its unit reception cost Er is about the
> same as the overhearing cost Eo.
> With a small (<1KB) DIO packet, the cost of transmission Et is
> essentially the cost of sending the preamble.
> Let's assume transmission cost Et is 6 times Eo (full preamble length
> accounts for x2, power consumption for x3)
> 
> Etotal ~= Eo * ( 1 * 6 + N * (0.2 * 6 + 0.2) + 0.18 * N^2) ~= Eo * ( 6
+
> 1.4 * N + 0.18 * N^2)
> 
> **** With DIS options
> A typical protocol currently in use in widely deployed proprietary
smart
> metering networks is the following.
> Newborn nodes send successive DIS'es with decreasing demands on rank
> and
> link quality
> - iteration 1: only sinks, LQI >= 0,75*maxLQI
> - iteration 2: only sinks, LQI >= 0,5*maxLQI
> - iteration 3: only sinks, LQI >= 0,25*maxLQI
> - iteration 4: ring-1 routers, LQI >= 0,75*maxLQI,
> - iteration 5: ring-1 routers, LQI >= 0,50*maxLQI,
> - iteration 6: ring-1 routers, LQI >= 0,25*maxLQI,
> - iteration 7: ring-2 routers, LQI >= 0,75*maxLQI,
> - iteration 8: ring-2 routers, LQI >= 0,50*maxLQI,
> - iteration 9: ring-2 routers, LQI >= 0,25*maxLQI,
> - etc
> The newborn node will usually send several DIS's instead of just one.
> Its direct neighbors (N/20 meters, N/10+N/20 routers) will also incur
> the cost of receiving these extra DIS'es.
> Let's suppose iteration 7 is successful and prompts 25% of the
neighbor
> ring-2 routers to send their DIOs.
> Number of DIS transmissions = 7
> Number of DIS receptions = 7 * (N/20 + N/10 + N/20) = 7/5 * N
> Number of DIO transmissions = 25% of N/10 = N/40, overheard by 23/20 *
N
> nodes (N meters and N/10+N/20 routers).
> Number of DIOs overheard = 23/800 * N^2 = 0.029 * N^2
> Etotal ~= Eo * ( 7*6 + N * ( 7/5 + 6/40) + 0.029 * N^2) ~= Eo * (42 +
> 1.6 * N + 0.029 * N^2)
> 
> In this case, the global energy cost of inserting a new node in the
> network is reduced by a factor ranging from 2 to 5 depending on N in
> [20..200]. Additional analysis shows that this saving affect both
meters
> and routers (specifically, we are not pushing the burden towards the
> energy-critical meters).
> Similar results are obtained with differents iterations numbers.
> 
> Just to re-inforce this calculation, it has been our experience that
> node insertion into a dense low-power network, if done wrong, is a
> significant energy drain. Please let us enhance RPL to do it right.
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: <[email-masked]>
Date: Mon, 22 Mar 2010 09:10:06 +0100

Hi Dominique, all,

I also support this request.

Regards,

Quentin

-- 

*LAMPIN Quentin RD-TECH-GRE*
* GRE/TECH/MATIS*
Tel : 04 76 76 41 22
Email: [email-masked] 
<mailto:[email-masked]>
R&D Grenoble 28 chemin du Vieux Chêne - BP98 38243 Meylan Cedex - France

---

From: Geoffrey Riggs <[email-masked]>
Date: Mon, 22 Mar 2010 09:22:02 +0100

Hello Everyone,

Dominique, you have my support as well regarding your proposal.

Best regards,

\\ Geoffrey

---

From: "CDS" <[email-masked]>
Date: Wed, 24 Mar 2010 09:00:59 +0100

Hi Dominique,

I fully support this proposal that contributes to power savings in
self-routing algorithms.

Best regards

Christophe

On Sun, Mar 21, 2010 at 6:40 PM, Pascal Thubert (pthubert)
<[email-masked]> wrote:

Hi Dominique:

Pascal

Of
as
that
energy
at
connectivity,
into
overheard
DIO
due
N/20)
+
smart
neighbor
N
meters

Ce message entrant est certifié sans virus connu.
Analyse effectuée par AVG - www.avg.fr
Version: 8.5.437 / Base de données virale: 271.1.1/2762 - Date: 03/21/10
19:33:00