Subject: Re: [Roll] proposal for DAOs in non-caching DODAGs

From: Mukul Goyal <[email-masked]>
Date: Wed, 31 Mar 2010 16:06:37 -0500 (CDT)

>> I'm not sure I understand the concern. Is it that if this isn't stated explicitly, then an implementation might put a neighbor in the parent set for which it cannot compute DAGRank from the OF? How would it ever compute its own DAGRank? Can you explain the failure condition?
> 
> Consider the situation where node A receives a DIO from node B and knows the cost of link B->A (either it already knew this cost or DIO carries this cost or it assumes a value for this cost) but not that of link A->B. Then, node A may be able to compute its DAG rank via node B and thus possibly select node B as a DIO parent. But, even if B becomes a DIO parent, A should not consider B as a candidate for DAO parenthood because A does not know the cost of link A->B.    

[Phil] So a node A MUST NOT select node B as a parent if the OF cannot compute the DAGRank of the resulting route?

Node A may have sufficient information to calculate its DAG rank via B but still may not have the information to calculate B's suitability as a DAO parent (e.g. if OF just considers the upwards costs in calculating the DAG rank and such costs are known to A but requires knowledge of downwards costs for a parent's selection as DAO parent and these downwards costs (from B to A) are not known to A).

Mukul

---

From: Philip Levis <[email-masked]>
Date: Wed, 31 Mar 2010 16:32:16 -0700

> Node A may have sufficient information to calculate its DAG rank via B but still may not have the information to calculate B's suitability as a DAO parent (e.g. if OF just considers the upwards cos…

I'm sorry -- your sentence is kind of long and convoluted, and I can't understand it. Does it say yes my sentence is correct or no it is not correct?

Note that my description did not qualify DAO parent, DIO parent, or direction of the route: I think it's completely independent of this? I personally think it seems so obvious that it doesn't warrant mention, but if others feel otherwise, then probably better to include it than not.

Phil

---

From: Jonathan Hui <[email-masked]>
Date: Wed, 31 Mar 2010 19:15:22 -0700

Mukul,

On Mar 31, 2010, at 2:06 PM, Mukul Goyal wrote:

>> Consider the situation where node A receives a DIO from node B and  
>> knows the cost of link B->A (either it already knew this cost or  
>> DIO carries this cost or it assumes a value for this cost) but not  
>> that of link A->B. Then, node A may be able to compute its DAG rank  
>> via node B and thus possibly select node B as a DIO parent. But,  
>> even if B becomes a DIO parent, A should not consider B as a  
>> candidate for DAO parenthood because A does not know the cost of  
>> link A->B.
>
> [Phil] So a node A MUST NOT select node B as a parent if the OF  
> cannot compute the DAGRank of the resulting route?
>
> Node A may have sufficient information to calculate its DAG rank via  
> B but still may not have the information to calculate B's  
> suitability as a DAO parent (e.g. if OF just considers the upwards  
> costs in calculating the DAG rank and such costs are known to A but  
> requires knowledge of downwards costs for a parent's selection as  
> DAO parent and these downwards costs (from B to A) are not known to  
> A).

It's obvious that if A's link cost estimation information about the  
path from A -> B, then whatever mechanism is used to generate that  
link cost metric needs to be communicated to be resident at A.  It's  
not obvious to me that the routing protocol should be responsible for  
make sure this happens.  I'd actually prefer that the link estimation  
mechanism handle the necessary propagation of information.

--
Jonathan Hui