Subject: [Roll] Ack the DAO?

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 10 Mar 2010 11:39:24 +0100

WG:

RPL 07 provides means for a node to advertise some reachability using a DAO mechanism. The DAO can be triggered by the node to match its own needs. It can also be stimulated by a parent, by incrementing the DTSN, or by the root, by setting the T bit that causes the DTSN increment to span the whole DODAG.

The DTSN was added as a replacement to a single bit because, due to the nature of an LLN, we thought that the bit might be lost whereas a DTSN increment must be seen at some point. But the other way around, the DAO message is not acknowledged so a node might not obtain the service that it expects, and a route propagation might be inappropriately delayed.

So the simple question is, should we make the DAO a bit more reliable by adding an ack? 

Pascal Thubert
Engineer.software Engineering
Product Development
[email-masked] <mailto:[email-masked]> 
Phone: +33 4 9723 2634
Mobile: +33 6 1998 2985

Cisco Systems France
Village d'Entreprises Green Side
400 Avenue de Roumanille 
Batiment T 3 
06410 
BIOT - SOPHIA ANTIPOLIS
France
Cisco.com <http://www.cisco.com/global/FR/> 

 Think before you print.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone, For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html <http://www.cisco.com/web/about/doing_business/legal/cri/index.html>

---

From: "Roger Alexander" <[email-masked]>
Date: Wed, 10 Mar 2010 08:58:01 -0500

Hi Pascal, WG,

I do think DAOs should be acknowledged. From the perspective of a system employing ‘storing’ nodes, there will be additional benefits in terms of optimizations that reduce the overhead of exchanged state information if the DAO messages are reliably transmitted. This may require some additional update to the DAO message structure but will open the possibility for implementations to further reduce RPL overhead.

Roger

From: [email-masked] [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Wednesday, March 10, 2010 5:39 AM
To: [email-masked]
Subject: [Roll] Ack the DAO?

WG:

 

Pascal Thubert
Engineer.software Engineering
Product Development
 <mailto:[email-masked]> [email-masked]
Phone: +33 4 9723 2634
Mobile: +33 6 1998 2985

Cisco Systems France
Village d'Entreprises Green Side
400 Avenue de Roumanille 
Batiment T 3 
06410 
BIOT - SOPHIA ANTIPOLIS
France
 <http://www.cisco.com/global/FR/> Cisco.com

Think before you print.Think before you print.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone, For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Anders Jagd <[email-masked]>
Date: Wed, 10 Mar 2010 12:59:15 -0500

Pascal, WG,

Not sure I agree with a requirement for a RPL level ACK to the DAO.

As you discuss, if a parent (or the root) is requesting the information,
there are mechanisms in place already to trigger retries/refresh (not all
timers necessarily worked out yet, but state machine and DTSN mechanism is
there).

So, this deals with the situation where a child node is volunteering the
information rather responding to a request from the parent. I hope I
understand this right, otherwise please let me know.

Typically, upon learning of a new child node, the above DTSN based DAO
trigger mechanism should start. However, if a node wants to issue an
unsolicited DAO, I don't see anything wrong with doing so, and then, if no
trigger arrives (DTSN based or otherwise) within a reasonable time (again,
timers are not defined by RPL, but could/would be by the Object Function),
it could assume the unsolicited DAO was not received and retry.

However, since child to parent DAO transmission has link scope, wouldn't
this all often become a mood point, since many link layers would provide
such  link layer ack mechanism anyways. Some maybe not, but I think making
an RPL layer ACK a requirement may be too costly in many cases. Some case by
case here, so if we do define an ACK, at least make it optional.

/Anders

On Wed, Mar 10, 2010 at 5:39 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> WG:
>
>
>
> RPL 07 provides means for a node to advertise some reachability using a DAO
> mechanism. The DAO can be triggered by the node to match its own needs. It
> can also be stimulated by a parent, by incrementing the DTSN, or by the
> root, by setting the T bit that causes the DTSN increment to span the whole
> DODAG.
>
>
>
> The DTSN was added as a replacement to a single bit because, due to the
> nature of an LLN, we thought that the bit might be lost whereas a DTSN
> increment must be seen at some point. But the other way around, the DAO
> message is not acknowledged so a node might not obtain the service that it
> expects, and a route propagation might be inappropriately delayed.
>
>
>
> *Pascal Thubert*
> *Engineer.software Engineering*
> *Product Development*
> [email-masked]
> Phone: *+33 4 9723 2634*
> Mobile: *+33 6 1998 2985*
>
> *Cisco Systems France*
> Cisco Systems France, Société à responsabiité limitée, Rue Camille
> Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux,
> Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la
> publication: Jean-Luc Michel Givone, For corporate legal information go to:
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 30 Mar 2010 07:49:00 +0200

Hi Roger:

This looks interesting. Could you please refine your ideas on this subject? 

Pascal

From: Roger Alexander [mailto:[email-masked]] 
Sent: Wednesday, March 10, 2010 2:58 PM
To: Pascal Thubert (pthubert); [email-masked]
Subject: RE: [Roll] Ack the DAO?

Hi Pascal, WG,

Roger

WG:

 

Pascal Thubert

Cisco Systems France

 Think before you print.