Subject: [Roll] Target in DIO [was Clarification request about RPL]

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 30 Mar 2010 16:57:38 +0200

Hi Mathieu

You'll note that all nodes do not have to send DAOs. Only destinations
(nodes|prefixes|mcast) that need to be reachable do. 

During this IETF, there were a number of corridor discussions asking the
same question.

Basically we have this node sitting there in the RPL network and for a
number of reasons, this node is not reachable by some other party in the
network. 

Reasons can be:
- this node is a deep sleeper leaf, does not want to spend everybody's
energy when it does not expect to be reached (your case)
- RPL inconsistency, the route to the node is temporary lost
- another node wants to start a P2P conversation with this node

In all those cases, it appears that the capability to indicate one or
more targets in a DIO is a useful thing. 

Is that what you are asking for?

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Mathieu Pouillot
> Sent: Tuesday, March 30, 2010 11:03 AM
> To: [email-masked]
> Subject: [Roll] Clarification request about RPL
> 
> Hi all,
> 
> Watteco is implementing a RPL (draft-05 for the moment) on PLC nodes
in a
> low power and low data rate context. After some tests, we have some
> interogations:
> 
> - The DAO request generates a lot of traffic on the network, and most
of the
> time it is not necessary to have the downward routes of all devices.
> Is there a mechanism to ask a DAO to  specified devices? If not, what
do you
> think to add a sub-option in the DIO to ask DAO to a specified device
or
> maybe(more complex) a group of devices?
> - A point that is not very clear: Can the same node belong to several
DoDag of
> the same instance? If yes, how the data traffic(UDP,TCP, or
> others) knows which route has to be used? By the way, when you are in
> different instance  how the flow label has to be filled?
> - Is there a way to broadcast or multicast some data traffic in all
our DoDag?
> - Is there a mechanism to annonce a broken route during data traffic?
> 
> Thanks for the clarifications,
> 
> best regards,
> 
> Mathieu
> 
> --
> Mathieu Pouillot
> R&D Engineer
> [email-masked]
> 
> Tel : +33(0)4 98 01 60 05 (Poste 43)
> Fax : +33(0)4 94 14 10 80
> 1766 Chemin de la Planquette
> 83130 LA GARDE - France
> www.watteco.com<http://www.watteco.com/>
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Mathieu Pouillot <[email-masked]>
Date: Thu, 01 Apr 2010 08:55:39 +0200

Hi Pascal,

Exactly, my mind is near your 3 reasons and I think too an application 
with a lot of sensor nodes which send automatically sample data to the 
sink. And for one of them I want to change the number of sample to send, 
and so I want just to communicate with him at this moment and not to be 
polluted by all other nodes which have the DAO capability.

regards,

Mathieu

Le 30/03/2010 16:57, Pascal Thubert (pthubert) a écrit :
>> From:[email-masked]  [mailto:[email-masked]] On Behalf
>>      
> Of
>    
>> Mathieu Pouillot
>> To:[email-masked]

-- 
Mathieu Pouillot
R&D Engineer
[email-masked]