Subject: [Roll] Ticket # 25 - Tracking the MUST requirement

From: JP Vasseur <[email-masked]>
Date: Mon, 29 Mar 2010 21:31:07 +0200

Dear WG,

I put together a spreadsheet to track the "MUST requirements" spelled  
out in our four requirements documents.

To that end, I listed all MUST and used the following color code:

GREEN: Satisfied requirement

YELLOW: the requirement is partially satisfied and the WG thinks that  
the requirement is not sufficiently satisfied.

For example:
Support of Point-to-Point: "The routing protocol MUST provide routes  
between arbitrary hosts within the appropriate
administrative domain". Strictly speaking RPL supports P2P but the WG  
thinks that more work is required, thus the
Yellow color

RED: the requirement is not satisfied (e.g. additional mechanisms  
required) or not yet done (e.g. security)

PINK: the requirement is partially satisfied or non satisfied but the  
WG decided that this was acceptable. It may
be wise to document it.

GREY: Evaluation is differed (not a show stopper for LC). For example,  
it may take time to deploy a network with
few dozens of thousands of nodes. Note that in this case, simulations  
may help.

Let's continue to work on our opened tickets and update that  
spreadsheet accordingly.

Note that in both the YELLOW and RED cases, RPL could not be last  
called until they turn GREEN.

Comments very welcome of course.

Thanks.

JP.

---

From: "Monnerie, Emmanuel" <[email-masked]>
Date: Mon, 29 Mar 2010 18:21:54 -0400

Jean-Pierre,

Thanks for compiling this summary. This is very helpful.

In the case of a satisfied requirement (Green), would it be possible to
add a reference (chapter number) to the text in the draft standard that
describe the corresponding RPL feature? This would help a lot.

In the case of a deferred requirement (Grey), could you please provide
additional information explaining how this choice was made? Is it a
recommendation or a decision?

Best Regards

From: [email-masked] [mailto:[email-masked]] On Behalf Of
JP Vasseur
Sent: Monday, March 29, 2010 3:31 PM
To: ROLL WG
Subject: [Roll] Ticket # 25 - Tracking the MUST requirement

Dear WG,

For example:

Yellow color

PINK: the requirement is partially satisfied or non satisfied but the WG
decided that this was acceptable. It may 

be wise to document it.

Let's continue to work on our opened tickets and update that spreadsheet
accordingly.

Note that in both the YELLOW and RED cases, RPL could not be last called
until they turn GREEN.

Thanks.

JP. 

Emmanuel Monnerie
Senior Research Engineer
Landis+Gyr
Energy Management Solutions
Office: +1 678 258 1695
Fax: +1 678 258 1316
[email-masked]
www.landisgyr.com
manage energy better

---

From: JP Vasseur <[email-masked]>
Date: Tue, 30 Mar 2010 00:21:28 +0200

Here you are:

On Mar 30, 2010, at 12:14 AM, Thomas Heide Clausen wrote:

> Any chance of getting that in a format that we can read without  
> spending several KUSD on special-purpose software?
>
> Thanks,
>
> Thomas
> On Mar 29, 2010, at 21:31 PM, JP Vasseur wrote:
>
>> Dear WG,
>>
>> I put together a spreadsheet to track the "MUST requirements"  
>> spelled out in our four requirements documents.
>>
>> YELLOW: the requirement is partially satisfied and the WG thinks  
>> that the requirement is not sufficiently satisfied.
>>
>> For example:
>> Support of Point-to-Point: "The routing protocol MUST provide  
>> routes between arbitrary hosts within the appropriate
>> administrative domain". Strictly speaking RPL supports P2P but the  
>> WG thinks that more work is required, thus the
>> Yellow color
>>
>> PINK: the requirement is partially satisfied or non satisfied but  
>> the WG decided that this was acceptable. It may
>> be wise to document it.
>>
>> GREY: Evaluation is differed (not a show stopper for LC). For  
>> example, it may take time to deploy a network with
>> few dozens of thousands of nodes. Note that in this case,  
>> simulations may help.
>>
>> <RPL-MUST.xlsx>
>> _______________________________________________
>> Roll mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/roll
>

---

From: JP Vasseur <[email-masked]>
Date: Tue, 30 Mar 2010 00:24:34 +0200

Hi Emmanuel,

On Mar 30, 2010, at 12:21 AM, Monnerie, Emmanuel wrote:

> In the case of a satisfied requirement (Green), would it be possible  
> to add a reference (chapter number) to the text in the draft  
> standard that describe the corresponding RPL feature? This would  
> help a lot.

I can try but most likely, this will be a collection of places.

>
> In the case of a deferred requirement (Grey), could you please  
> provide additional information explaining how this choice was made?  
> Is it a recommendation or a decision?

Just a first take, to be discussed of course, the WG ends up deciding  
of course!

Cheers.

JP.

> From: [email-masked] [mailto:[email-masked]] On Behalf  
> Of JP Vasseur

---

From: Thomas Heide Clausen <[email-masked]>
Date: Tue, 30 Mar 2010 00:14:51 +0200

Thanks,

Thomas

---

From: Thomas Heide Clausen <[email-masked]>
Date: Tue, 30 Mar 2010 00:26:14 +0200

Thanks a bunch, JP!

Thomas

On Mar 30, 2010, at 00:21 AM, JP Vasseur wrote:

> <RPL-MUST.pdf>