Subject: Re: [Roll] how does a node get an IP address

From: "Reddy, Joseph" <[email-masked]>
Date: Mon, 26 Apr 2010 18:32:24 -0500

Hi Michael,

I believe you need to have "working ND" to operate in an IPv6 network. Whether that is 6lowpan-ND or classic-ND or some other version. I don't believe RPL should try to solve the problem of configuing an IP address and performing router discovery. 

-Joseph

--------------------------------------------------------------------------------

>>>>> "Daniel" == Daniel Gavelle <[email-masked]> writes:
    Daniel> Isn't IP and subnet assignment replacing functionality that
    Daniel> should be in ND? 

    Daniel> The majority of ROLL implementations I know of at the moment
    Daniel> are targeting 6LowPAN and there is a 6LowPAN ND draft in
    Daniel> progress that covers subnet 
    Daniel> assignment and router discovery.

>>>[Michael Richardson]

>>>I am not targetting 6lowpan, nor does RPL make that assumption.

>>>If you have working ND, then great.  Last I read, one mode of 6lowpan won't have working ND until RPL finishes, and as far as I can see, configuring an IP address is an important part of joining a DODAG.

---

From: Michael Richardson <[email-masked]>
Date: Mon, 26 Apr 2010 21:08:21 -0400

>>>>> "Joseph" == Joseph Reddy <Reddy> writes:
    Joseph> I believe you need to have "working ND" to operate in an
    Joseph> IPv6 network. Whether that is 6lowpan-ND or classic-ND or
    Joseph> some other version. I don't believe RPL should try to solve
    Joseph> the problem of configuing an IP address and performing
    Joseph> router discovery.

Then, what you are saying is either that:
      a) RPL must provide for multicast so that ND/DAD will work.
      b) RPL must always run on top of 6lowpan.

I don't object to a statement that 6lowpan is required.
In fact, life would be simpler if we just required parts of it
(at least the whiteboard parts).

I believe that RPL originally intended to work inside ND, and therefore
it made sense that you had "working ND" --- it no longer lives inside
ND, so the quesiton as to how ND works arises.

- -- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 27 Apr 2010 14:16:16 +0200

Hi Joseph:

I concur with Michael here;

6LowPAN ND has a very bad story (ot no story at all) to disseminate the
PIO. The idea is that Ra information gets propagated from a router to
the next.
But really, that does not tie a subnet together. RPL does.

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Reddy, Joseph
> Sent: Tuesday, April 27, 2010 1:32 AM
> To: [email-masked]
> Subject: Re: [Roll] how does a node get an IP address
> 
> 
> 
> Hi Michael,
> 
> I believe you need to have "working ND" to operate in an IPv6 network.
> Whether that is 6lowpan-ND or classic-ND or some other version. I
don't
> believe RPL should try to solve the problem of configuing an IP
address and
> performing router discovery.
> 
> -Joseph
> 
>
------------------------------------------------------------------------
--------
> >>>If you have working ND, then great.  Last I read, one mode of
6lowpan
> won't have working ND until RPL finishes, and as far as I can see,
configuring
> an IP address is an important part of joining a DODAG.
> 
> 
> 
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll