Subject: [Roll] Feedback from ZigBee interop event

From: "Reddy, Joseph" <[email-masked]>
Date: Mon, 12 Apr 2010 16:20:23 -0500

Hi,

I would like to share some feedback from the recent interop event held by the ZigBee Alliance that was attended by several 802.15.4 platform vendors. At this event, the main focus was on testing TCP, RPL and 6lowpan protocols.

For the RPL protocol, the DAG formation and data transmission "up" towards the root were tested successfully among the various platforms. In addition to the feedback on the exiting spec ( see below ), the main request is to ensure the spec is quickly updated with the routing/forwarding for "downwards" paths so we can move forward with our testing.

-Regards, Joseph

1. Need clarification on the Rank and DagRank. The root rank has value of 1 but not clear if that is just the integer part or not.

2. In OF0, the values for minRankIncrease and maxRankIncrease take value of 256 which cannot be represented in the DoDAG config suboption ( which allows only 1 byte ). This needs to be fixed in the spec. Also, re-consider if we really need fractional part in the rank, it doesn't seem to be very useful.

3. Clarify the IP source address for DIS/DAO packets - should this be the link local or global address ( or either ) ?

4. Need clarification on flowlabel. Currently it is not possible to implement as defined ( without layer violations ) since a node will need to know if the next hop is the final destination and if the previous hop was the originator of the packet.....current implementations have removed flow label validation

5. Need clarification on the use of the destination prefix. How many of them can be included in a DIO ? Is this intended to be the prefix of the 6lowpan or is this a prefix that can be reached by the root node ( on the wired side ) ?

6. Does RPL intend to define messages to allow neighboring nodes to exchange bidirectional link quality estimates between themselves ?

---

From: "Roger Alexander" <[email-masked]>
Date: Fri, 16 Apr 2010 17:43:11 -0400

Hi Joseph,

Thanks for the feedback on the Alliance's interop event which highlights a
number of issues that do need clarification and some of which are still open
in the on-going RPL discussions.

A few of my takes below based on previously indicated positions.

Thanks.

Roger

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Reddy, Joseph
Sent: Monday, April 12, 2010 5:20 PM
To: [email-masked]
Subject: [Roll] Feedback from ZigBee interop event

Hi,

I would like to share some feedback from the recent interop event held by
the ZigBee Alliance that was attended by several 802.15.4 platform vendors.
At this event, the main focus was on testing TCP, RPL and 6lowpan protocols.

For the RPL protocol, the DAG formation and data transmission "up" towards
the root were tested successfully among the various platforms. In addition
to the feedback on the exiting spec ( see below ), the main request is to
ensure the spec is quickly updated with the routing/forwarding for
"downwards" paths so we can move forward with our testing. 

-Regards, Joseph

1. Need clarification on the Rank and DagRank. The root rank has value of 1
but not clear if that is just the integer part or not. 

2. In OF0, the values for minRankIncrease and maxRankIncrease take value of
256 which cannot be represented in the DoDAG config suboption ( which allows
only 1 byte ). This needs to be fixed in the spec. Also, re-consider if we
really need fractional part in the rank, it doesn't seem to be very useful.

3. Clarify the IP source address for DIS/DAO packets - should this be the
link local or global address ( or either ) ?

[Roger] In the more general context of RPL usage beyond HAN, this has to be
global.

4. Need clarification on flowlabel. Currently it is not possible to
implement as defined ( without layer violations ) since a node will need to
know if the next hop is the final destination and if the previous hop was
the originator of the packet...current implementations have removed flow
label validation 

5. Need clarification on the use of the destination prefix. How many of them
can be included in a DIO ? Is this intended to be the prefix of the 6lowpan
or is this a prefix that can be reached by the root node ( on the wired side
) ?

[Roger] As specified in the Section 3.5.1, the destination prefix is generic
in its definition and can be a prefix as well as complete IPv6 destination
address. With regard to the inclusion of multiple addresses, as stated
previously I am also interested in seeing the specification include optional
support for multiple addresses within the DAO message. 

6. Does RPL intend to define messages to allow neighboring nodes to exchange
bidirectional link quality estimates between themselves ?

[Roger] This should be an L2 (subnet) function and does not need to be
directly supported with RPL messages.