Subject: Re: [Roll] [roll] #32: Asymetric Link

From: Mukul Goyal <[email-masked]>
Date: Thu, 1 Apr 2010 06:54:39 -0500 (CDT)

Hi Thomas

I guess we have to distinguish between L3 and L2 metrics. It sees to me that RPL is concerned with L3 metrics and how they relate to L2 metrics should not bother RPL.

[Thomas] This, of course, leads to the question of below which  
"metric" (quality, ...) a link should be considered "uni-directional"  
rather than just "asymmetric"? To take an abstract example, assuming a  
L2 employing ack's for each unicast transmission: if the probability  
of getting a transmission from A to B is 100% and from B to A is 10%,  
is the link A->B "asymmetric" or "uni-directional"? Can the metric for  
A->B be considered without also considering the metric in the opposite  
direction B->A?

[Mukul] In this case, I guess L3 metric A->B would automatically be quite poor because of its dependence of L2 metrics A->B and B->A. But, still L3 metric A->B is independent of the L3 metric B->A.

Thanks,
Mukul

On Apr 1, 2010, at 13:02 PM, Yoav Ben-Yehezkel wrote:

> Hi,
>
> Maybe occasional unicast DIS to a parent(s) from the parent set can  
> be used
> to solve this?
> This coincides with the issue of DIS options.
>
> Thanks,
> Yoav
>
>
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf  
> Of roll
> issue tracker
> Sent: Thursday, April 01, 2010 10:54 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: [Roll] [roll] #32: Asymetric Link
>
> #32: Asymetric Link
> -------------------------------- 
> +-------------------------------------------
> Reporter:  jpv@…               |       Owner:  richard.kelsey@…
>     Type:  defect              |      Status:  new
> Priority:  major               |   Milestone:
> Component:  rpl                 |     Version:
> Severity:  Active WG Document  |    Keywords:
> -------------------------------- 
> +-------------------------------------------
> In a network with asymmetric links, DODAGs can be formed to
> optimize upward, downward, or bidirectional routes.  There
> needs to be some way to indicate how asymmetric link metrics
> are to be used when forming a particular DODAG.  A DODAG
> meant for routing upwards would want to use the upward
> metric values, for example.  A DODAG meant for use in both
> directions might want the average of the upward and downward
> values, or the max or min, depending on the metric.
>
> -- 
> Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/32>
> roll <http://tools.ietf.org/wg/roll/>
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Philip Levis <[email-masked]>
Date: Thu, 1 Apr 2010 08:59:27 -0700

> [Mukul] In this case, I guess L3 metric A->B would automatically be quite poor because of its dependence of L2 metrics A->B and B->A. But, still L3 metric A->B is independent of the L3 metric B->A.

I think the discussion is a bit clearer once you consider the "metric" may not be delivery. I.e., it is possible to have a link that has 100% delivery in both directions yet highly asymmetric metrics. One simple case is latency.

I think that unidirectional links or links with very poor delivery in one direction are a diversion when it comes to routing. As Thomas points out, it is absolutely critical that a routing protocol be able to identify and ignore/avoid them: this isn't too hard. Trying to use them effectively, however, requires a lot of complexity with very little gain, so let's not go down that path.

Phil