Subject: [Roll] Loose source routing Re: Fwd: New Version Notification for draft-hui-6man-rpl-routing-header-00

From: Mukul Goyal <[email-masked]>
Date: Mon, 31 May 2010 03:08:21 -0500 (CDT)

Hi Jonathan

It seems that loose source routing is not possible with proposed type 4 routing header alone.

There is no provision to list the ultimate destination of the packet within the proposed header.

Would it require a separate header? 

Could you allow the specification of the ultimate destination as the final entry in the list of addresses or as a separate field? So that it becomes possible to carry a "completely specified piece" of the route in the proposed header.  

Although RPL base spec does not support loose source routes, we would like to support it in P2P extensions.

Thanks
Mukul

----- Original Message -----
From: "Jonathan Hui" <[email-masked]>
To: "ROLL WG" <[email-masked]>
Sent: Thursday, May 27, 2010 11:20:31 AM GMT -06:00 US/Canada Central
Subject: [Roll] Fwd: New Version Notification for draft-hui-6man-rpl-routing-header-00

To address RPL ticket #35, we submitted a draft to 6man that proposes  
a new IPv6 routing header to support source routing in non-storing mode.

Some high-level details:
- Format is derived from RH0
- Format is extended to support simple compression of IPv6 address  
entries within the routing header
- Use of the RPL routing header is constrained to a RPL domain.

http://tools.ietf.org/html/draft-hui-6man-rpl-routing-header-00

Comments appreciated as always.

--
Jonathan Hui

Begin forwarded message:

> From: IETF I-D Submission Tool <[email-masked]>
> Date: May 26, 2010 11:41:21 AM PDT
> To: [email-masked]
> Cc: [email-masked],[email-masked]
> Subject: New Version Notification for  draft-hui-6man-rpl-routing- 
> header-00
>
>
> A new version of I-D, draft-hui-6man-rpl-routing-header-00.txt has  
> been successfully submitted by Jonathan Hui and posted to the IETF  
> repository.
>
> Filename:	 draft-hui-6man-rpl-routing-header
> Revision:	 00
> Title:		 A Source Routing Header for RPL
> Creation_date:	 2010-05-26
> WG ID:		 Independent Submission
> Number_of_pages: 13
>
> Abstract:
> In Low power and Lossy Networks (LLNs), memory constraints on routers
> may limit them to maintaining at most a few routes.  In some
> configurations, it is necessary to use these memory constrained
> routers to deliver datagrams to nodes within the LLN.  The Routing
> for Low Power and Lossy Networks (RPL) protocol can be used in some
> deployments to store most, if not all, routes on one (e.g. the
> Directed Acyclic Graph (DAG) root) or few routers and forward the
> IPv6 datagram using a source routing technique to avoid large routing
> tables on memory constrained routers.  This document specifies a new
> IPv6 Routing header type for delivering datagrams within a RPL
> domain.
>
>
>
> The IETF Secretariat.
>
>

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: JP Vasseur <[email-masked]>
Date: Mon, 31 May 2010 12:09:46 +0200

Hi Mukul,

On May 31, 2010, at 10:08 AM, Mukul Goyal wrote:

> Could you allow the specification of the ultimate destination as the  
> final entry in the list of addresses or as a separate field? So that  
> it becomes possible to carry a "completely specified piece" of the  
> route in the proposed header.
>
> Although RPL base spec does not support loose source routes, we  
> would like to support it in P2P extensions.
>

It is workable but let's bear in mind that loose routing add a  
significant level of complexity (since this is something that  
Jonathan, David and discussed). Is this really a requirement for your  
P2P solution ?

Thanks.

JP.