Subject: [Roll] [roll] #37: Feed-back fron IPSO interop

From: "roll issue tracker" <[email-masked]>
Date: Fri, 14 May 2010 10:55:34 -0000

#37: Feed-back fron IPSO interop
--------------------------------+-------------------------------------------
 Reporter:  jpv@…               |       Owner:  pthubert@…                        
     Type:  defect              |      Status:  new                               
 Priority:  major               |   Milestone:                                    
Component:  rpl                 |     Version:                                    
 Severity:  Active WG Document  |    Keywords:                                    
--------------------------------+-------------------------------------------
 > Feedback-I:
 > DAO rank: It seems there very couple of different interpretations for
 > setting this value.
 > A. Several implementations were setting the DAO rank to be equal to
 > the
 > node rank (value sent in DIO rank). Each node relays this info in the
 > DAO towards the root. However this does not convey any differentiating
 > info to the receiving nodes when the DAOs are received thru multiple
 > paths in order to install the best route.
 > B. The other implementation was to set the value to 0 (or 1) by the
 > node
 > and have the intermediate nodes increment it as the DAO rides up to
 > the
 > root. The DAO rank in this case is more of a hop count and the
 > receiving
 > nodes can make a decision based on the lowest value received when
 > installing the DAO route.
 > Pros: Decision is optimized based on hopcount. Relatively simple.
 > Cons: Hopcount does not take link cost into account.
 > C. A third proposal was to set the DAO rank equal to the node rank
 > and a
 > link cost in the metric container as each nodes propagates the DAO.
 > The
 > receiving nodes would make a decision based on the link cost.
 > Pros: Decision is optimized based on link cost
 > Cons: The DAOs would need to carry additional info in the packet
 > (bigger
 > DAOs) and more processing needed in the nodes to parse and process.
 >
 > I think we need some more details the spec for describing the value to
 > be set in DAO rank.
 >
 >
 > Feedback-II:
 > DIO Sequence number: The issue was what should be the initial value of
 > this field. The spec is not clear on what should be the initial value
 > set by the root. This has implications at the LBR in reload/reboot
 > conditions. For example, if the initial value is set to 1 and is
 > incremented to say 10. When the LBR reloads/reboots, it would start
 > the
 > sequence number with 1 but its DIOs will be rejected by the nodes as
 > having stale sequence number. The LBR can store the sequence in
 > persistent memory. An easier option could be use 255 as the starting
 > sequence number. Using this value will make sure that the sequence
 > number is always valid.
 >
 > Comments?

 Navneeet Agarwal

-- 
Ticket URL: <https://svn.tools.ietf.org/wg/roll/trac/ticket/37>
roll <http://tools.ietf.org/wg/roll/>

---

From: "roll issue tracker" <[email-masked]>
Date: Fri, 14 May 2010 11:01:39 -0000

Priority:  minor               |   Milestone:                                    
Changes (by jpv@…):

  * priority:  major => minor

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/37#comment:1>
roll <http://tools.ietf.org/wg/roll/>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 17 May 2010 08:13:22 +0200

Hi:

The current proposal as discussed on this list is to drop the DAO rank. Instead, we have a proposal that utilizes the preference in stateless, and combines with a fanout control bitmap in stateful.
Comments would be welcome, in particular WRT the fan-out control mechanism.

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of roll
> issue tracker
> Sent: Friday, May 14, 2010 1:02 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [Roll] [roll] #37: Feed-back fron IPSO interop
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll