Subject: Re: [Roll] Feedback from ZigBee interop event

From: JP Vasseur <[email-masked]>
Date: Fri, 14 May 2010 11:24:59 +0200

Hi Joseph,

First of all, many thanks for the feed-back. I do not think that you  
got yet a reply from the WG. So let me open a ticket to make sure that  
your issues are addressed in the coming revision of the RPL ID.

Thanks again, this type of feed-back is quite useful.

JP.

On Apr 12, 2010, at 11:20 PM, Reddy, Joseph wrote:

>
> Hi,
>
> I would like to share some feedback from the recent interop event  
> held by the ZigBee Alliance that was attended by several 802.15.4  
> platform vendors. At this event, the main focus was on testing TCP,  
> RPL and 6lowpan protocols.
>
> For the RPL protocol, the DAG formation and data transmission "up"  
> towards the root were tested successfully among the various  
> platforms. In addition to the feedback on the exiting spec ( see  
> below ), the main request is to ensure the spec is quickly updated  
> with the routing/forwarding for "downwards" paths so we can move  
> forward with our testing.
>
> -Regards, Joseph
>
>
> 1. Need clarification on the Rank and DagRank. The root rank has  
> value of 1 but not clear if that is just the integer part or not.
>
> 2. In OF0, the values for minRankIncrease and maxRankIncrease take  
> value of 256 which cannot be represented in the DoDAG config  
> suboption ( which allows only 1 byte ). This needs to be fixed in  
> the spec. Also, re-consider if we really need fractional part in the  
> rank, it doesn’t seem to be very useful.
>
> 3. Clarify the IP source address for DIS/DAO packets - should this  
> be the link local or global address ( or either ) ?
>
> 4. Need clarification on flowlabel. Currently it is not possible to  
> implement as defined ( without layer violations ) since a node will  
> need to know if the next hop is the final destination and if the  
> previous hop was the originator of the packet…..current  
> implementations have removed flow label validation
>
> 5. Need clarification on the use of the destination prefix. How many  
> of them can be included in a DIO ? Is this intended to be the prefix  
> of the 6lowpan or is this a prefix that can be reached by the root  
> node ( on the wired side ) ?
>
> 6. Does RPL intend to define messages to allow neighboring nodes to  
> exchange bidirectional link quality estimates between themselves ?
>
>
>
>
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: JP Vasseur <[email-masked]>
Date: Wed, 26 May 2010 11:53:14 +0200

Resending just to make sure that you concerns have been addressed.

On May 14, 2010, at 11:24 AM, JP Vasseur wrote:

> got yet a reply from the WG. So let me open a ticket to make sure  
> that your issues are addressed in the coming revision of the RPL ID.
>
>> the spec. Also, re-consider if we really need fractional part in  
>> the rank, it doesn’t seem to be very useful.
>>
>> 5. Need clarification on the use of the destination prefix. How  
>> many of them can be included in a DIO ? Is this intended to be the  
>> prefix of the 6lowpan or is this a prefix that can be reached by  
>> the root node ( on the wired side ) ?
>>

---

From: "Reddy, Joseph" <[email-masked]>
Date: Thu, 27 May 2010 01:33:03 -0500

Thanks JP

________________________________
From: JP Vasseur [mailto:[email-masked]]
Sent: Wednesday, May 26, 2010 2:53 AM
To: Reddy, Joseph
Cc: [email-masked] WG
Subject: Re: [Roll] Feedback from ZigBee interop event

Hi Joseph,

First of all, many thanks for the feed-back. I do not think that you got yet a reply from the WG. So let me open a ticket to make sure that your issues are addressed in the coming revision of the RPL ID.

JP.

Hi,

I would like to share some feedback from the recent interop event held by the ZigBee Alliance that was attended by several 802.15.4 platform vendors. At this event, the main focus was on testing TCP, RPL and 6lowpan protocols.

For the RPL protocol, the DAG formation and data transmission "up" towards the root were tested successfully among the various platforms. In addition to the feedback on the exiting spec ( see below ), the main request is to ensure the spec is quickly updated with the routing/forwarding for "downwards" paths so we can move forward with our testing.

-Regards, Joseph

1. Need clarification on the Rank and DagRank. The root rank has value of 1 but not clear if that is just the integer part or not.

2. In OF0, the values for minRankIncrease and maxRankIncrease take value of 256 which cannot be represented in the DoDAG config suboption ( which allows only 1 byte ). This needs to be fixed in the spec. Also, re-consider if we really need fractional part in the rank, it doesn't seem to be very useful.

3. Clarify the IP source address for DIS/DAO packets - should this be the link local or global address ( or either ) ?

4. Need clarification on flowlabel. Currently it is not possible to implement as defined ( without layer violations ) since a node will need to know if the next hop is the final destination and if the previous hop was the originator of the packet.....current implementations have removed flow label validation

5. Need clarification on the use of the destination prefix. How many of them can be included in a DIO ? Is this intended to be the prefix of the 6lowpan or is this a prefix that can be reached by the root node ( on the wired side ) ?

6. Does RPL intend to define messages to allow neighboring nodes to exchange bidirectional link quality estimates between themselves ?

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: JP Vasseur <[email-masked]>
Date: Thu, 27 May 2010 08:43:11 +0200

Pascal,

Since you own the ticket, could you reply to the points below ?

Thanks.

JP.

On May 27, 2010, at 8:33 AM, Reddy, Joseph wrote:

>> First of all, many thanks for the feed-back. I do not think that  
>> you got yet a reply from the WG. So let me open a ticket to make  
>> sure that your issues are addressed in the coming revision of the  
>> RPL ID.
>>
>>> platform vendors. At this event, the main focus was on testing  
>>> TCP, RPL and 6lowpan protocols.
>>>
>>> 4. Need clarification on flowlabel. Currently it is not possible  
>>> to implement as defined ( without layer violations ) since a node  
>>> will need to know if the next hop is the final destination and if  
>>> the previous hop was the originator of the packet…..current  
>>> 6. Does RPL intend to define messages to allow neighboring nodes  
>>> to exchange bidirectional link quality estimates between  
>>> themselves ?
>>>
>>>
>>>
>>>
>>>