Subject: Re: [Roll] IPSO Interop event - Feed-back welcome

From: JP Vasseur <[email-masked]>
Date: Fri, 14 May 2010 11:30:15 +0200

Thanks for the feed-back Navneet. You got a few replies to your  
queries, still I think that
they have not all been addressed (feedback II): do you confirm ? If  
so, I'll open a ticket.

Thanks.

JP.

On Apr 11, 2010, at 7:21 AM, Navneet Agarwal (navagar) wrote:

> Hi:
> I have two feedbacks from the router testing perspective.
>
> Feedback-I:
> DAO rank: It seems there very couple of different interpretations for
> setting this value.
> A. Several implementations were setting the DAO rank to be equal to  
> the
> node rank (value sent in DIO rank). Each node relays this info in the
> DAO towards the root. However this does not convey any differentiating
> info to the receiving nodes when the DAOs are received thru multiple
> paths in order to install the best route.
> B. The other implementation was to set the value to 0 (or 1) by the  
> node
> and have the intermediate nodes increment it as the DAO rides up to  
> the
> root. The DAO rank in this case is more of a hop count and the  
> receiving
> nodes can make a decision based on the lowest value received when
> installing the DAO route.
> Pros: Decision is optimized based on hopcount. Relatively simple.
> Cons: Hopcount does not take link cost into account.
> C. A third proposal was to set the DAO rank equal to the node rank  
> and a
> link cost in the metric container as each nodes propagates the DAO.  
> The
> receiving nodes would make a decision based on the link cost.
> Pros: Decision is optimized based on link cost
> Cons: The DAOs would need to carry additional info in the packet  
> (bigger
> DAOs) and more processing needed in the nodes to parse and process.
>
> I think we need some more details the spec for describing the value to
> be set in DAO rank.
>
>
> Feedback-II:
> DIO Sequence number: The issue was what should be the initial value of
> this field. The spec is not clear on what should be the initial value
> set by the root. This has implications at the LBR in reload/reboot
> conditions. For example, if the initial value is set to 1 and is
> incremented to say 10. When the LBR reloads/reboots, it would start  
> the
> sequence number with 1 but its DIOs will be rejected by the nodes as
> having stale sequence number. The LBR can store the sequence in
> persistent memory. An easier option could be use 255 as the starting
> sequence number. Using this value will make sure that the sequence
> number is always valid.
>
> Comments?
>
> Thanks
>
> Regards,
> Navneet
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of Mathilde Durvy (mdurvy)
>> Sent: Thursday, April 08, 2010 1:46 PM
>> To: JP Vasseur
>> Cc: ROLL WG
>> Subject: Re: [Roll] IPSO Interop event - Feed-back welcome
>>
>> Dear All,
>>
>> Following the discussion on the mailing list I just wanted to
>> clarify a few things so that we can find the best way to
>> interact in the future.
>>
>> - We were proposed a slot to announce this first interop
>> event during the ROLL WG meeting, future events may be
>> advertised only on an IPSO web-site if this is preferred by the WG.
>> - IPSO is not defining standards. It is organizing interop
>> events to ensure that different implementations of the same
>> standard do work together. The current status is that you
>> have to pay a membership fee to participate in these events
>> (and indeed these events take work, prior preparation, and
>> money to organize).
>> - We understand (at least) some people are still interested
>> in interop event feedback. This will be given on individual,
>> voluntary, basis by the participants of the interop event.
>>
>> Best,
>> Mathilde
>>
>>
>> -----Original Message-----
>> From: JP Vasseur [mailto:[email-masked]]
>> Sent: vendredi, 26. mars 2010 03:55
>> To: Mathilde Durvy (mdurvy)
>> Cc: ROLL WG
>> Subject: IPSO Interop event - Feed-back welcome
>>
>> Hi,
>>
>> Just re-enforcing my comments during the ROLL WG meeting ...
>> any feed- back from the IPSO interop about any issues that
>> you may have found would be extremely useful to continue to
>> improve our spec. Feel free to also share good news.
>>
>> Thanks.
>>
>> JP.
>>

---

From: "Navneet Agarwal (navagar)" <[email-masked]>
Date: Fri, 14 May 2010 15:59:12 +0530

Hi JP:
Sure,,..pls open a ticket and will followup..appreciate it.

Thanks

Regards,
Navneet

(sent from mobile)

 -----Original Message-----
From: 	JP Vasseur [mailto:[email-masked]]
Sent:	Friday, May 14, 2010 05:30 PM China Standard Time
To:	Navneet Agarwal (navagar)
Cc:	ROLL WG; Mathilde Durvy (mdurvy)
Subject:	Re: [Roll] IPSO Interop event - Feed-back welcome

Thanks.

JP.