Subject: [Roll] Source Routing Header Format

From: "JeongGil Ko (John)" <[email-masked]>
Date: Fri, 7 May 2010 02:24:05 -0400

Hi all,

Have we decided on what the routing header format will be for point-to-point routing?
The last discussion that I remember concluded with "Let's do something like RH0 and do tag/labels for addressing".
Do we have anything else after that?

-John

------
JeongGil Ko (John)
Ph.D. Student
Department of Computer Science
Johns Hopkins University
http://www.cs.jhu.edu/~jgko

---

From: "Anders Brandt" <[email-masked]>
Date: Fri, 7 May 2010 11:33:51 +0200

Hi John

You are completely right that we should get into that discussion now.
It relates very much to the next phase of our work on P2P support and
reactive discovery for non-storing nodes.

draft-dt-roll-p2p-rpl-00 provides the basis for this discussion.
If you have specific proposals for source routing support in RPL,
please come forward ;-)

- Anders

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of JeongGil Ko (John)
> Sent: Friday, May 07, 2010 08:24
> To: ROLL WG
> Subject: [Roll] Source Routing Header Format
> 
> Hi all,
> 
> The last discussion that I remember concluded with "Let's do 
> something like RH0 and do tag/labels for addressing".
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: JP Vasseur <[email-masked]>
Date: Fri, 14 May 2010 19:20:23 +0200

Hi Anders and John,

A ticket has been opened: ticket #35 and Jonathan kindly agreed to  
drive it with the help of the WG of course.
It should be part of the rev-08.

Thanks.

JP.

---

From: JP Vasseur <[email-masked]>
Date: Mon, 17 May 2010 14:44:19 +0200

Hi,

> something like RH0 and do tag/labels for addressing".

Right, Jonathan agreed to take the ownership of the ticket: indeed the  
conclusion was RH0-like, staying within
RPL domain to avoid security issues. Labels may come next (separate ID).

Thanks.

JP.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 18 May 2010 08:36:12 +0200

Hi JP:

For the P2P, it appears that we'll need the record route piece as well.
But the record route does not preexist in IPv6 standards.

It is present in my early work on tree discovery, so in a somewhat
similar context of mobile routers forming networks: 
http://tools.ietf.org/html/draft-thubert-nemo-reverse-routing-header

One option to move forward could be to start from that draft and make it
a separate spec.

We'd cleanup the mobility/tunnel pieces  and make it fully agnostic to
routing protocols.

What does the group think?

Pascal

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of JP
> Vasseur
> Sent: Monday, May 17, 2010 2:44 PM
> To: JeongGil Ko (John)
> Cc: ROLL WG
> Subject: Re: [Roll] Source Routing Header Format
> 
> Hi,
> 
something
> > like RH0 and do tag/labels for addressing".
> 
> conclusion was RH0-like, staying within RPL domain to avoid security
issues.
> Labels may come next (separate ID).
> 
> Thanks.
> 
> JP.
>

---

From: "Popa, Daniel" <[email-masked]>
Date: Mon, 17 May 2010 23:59:06 -0700

Pascal, 

+1. It seems a good starting point. 

Daniel

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Pascal Thubert (pthubert)
> Sent: Tuesday, May 18, 2010 8:36 AM
> To: JP Vasseur; JeongGil Ko (John)
> Cc: ROLL WG
> > > Have we decided on what the routing header format will be for
> point-
> > > to-point routing?

---

From: Daniel Gavelle <[email-masked]>
Date: Tue, 18 May 2010 13:54:26 +0100

All,

Whichever source routing header we use, it will be good if we don't need 
to carry the full IPv6 address of each hop.

This is especially important when using 6LowPAN.  If we don't compress 
the addresses, it won't take many hops before the routing header 
overflows the first 6LowPAN fragment.

Daniel.

-- 
__________________________________________________
Daniel Gavelle, Software Engineer
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK
Comp Reg No: 3191371  Registered In England
http://www.jennic.com
__________________________________________________

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 18 May 2010 18:21:56 +0200

Hi Daniel:

I think the aim is to have a basic header that looks like RH0 with a
record route. Then 6LoWPAN can work on compressing it using 6LowpAN
techniques. 
And we'll certainly commission more work to have our own labeling
system. But none of this should hold our base spec whatsoever!

cheers,
 
Pascal

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Daniel Gavelle
> Sent: Tuesday, May 18, 2010 2:54 PM
> To: ROLL WG
> Whichever source routing header we use, it will be good if we don't
need to
> carry the full IPv6 address of each hop.
> 
the
> addresses, it won't take many hops before the routing header overflows
the
> first 6LowPAN fragment.
Behalf
> >> Of Pascal Thubert (pthubert)
> >>
> >> One option to move forward could be to start from that draft and
make
> >> it a separate spec.
> >>
> >> We'd cleanup the mobility/tunnel pieces  and make it fully agnostic
> >> to routing protocols.
> >>
Behalf
> Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK Comp Reg No:
3191371
> Registered In England http://www.jennic.com

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 18 May 2010 18:33:24 +0200

On May 18, 2010, at 18:21, Pascal Thubert (pthubert) wrote:

> Then 6LoWPAN can work on compressing it using 6LowpAN
> techniques. 

Do we (6LoWPAN) want to?
So far we have focused on compressing things that are very stable.
Tracking a moving target with a compression spec is tedious.

Gruesse, Carsten

---

From: Robert Cragie <[email-masked]>
Date: Fri, 21 May 2010 14:55:50 +0100

That's a good point. As far as I know, we got to the point of specifying 
some hop-by-hop header containing a specific RPL option (which I believe 
Jonathan is working on in 6man) using labels. I would hope the same 
underlying principle can be used for both route record and source 
routing. Otherwise, we are back to using addresses in headers. If this 
is the case, we really need some way of compressing them for 6lowpan.

Robert

Robert Cragie (Pacific Gas & Electric)

Gridmerge Ltd.
89 Greenfield Crescent,
Wakefield, WF4 4WA, UK
+44 1924 910888
+1 415 513 0064
http://www.gridmerge.com <http://www.gridmerge.com/>

---

From: JP Vasseur <[email-masked]>
Date: Fri, 21 May 2010 22:07:15 +0200

Hi Robert,

On May 21, 2010, at 3:55 PM, Robert Cragie wrote:

> That's a good point. As far as I know, we got to the point of  
> specifying some hop-by-hop header containing a specific RPL option  
> (which I believe Jonathan is working on in 6man) using labels. I  
> would hope the same underlying principle can be used for both route  
> record and source routing. Otherwise, we are back to using addresses  
> in headers.

Yes the plan is to have a solution (RH0 like) VERY soon with full  
address, followed by a label-based solution (to be discussed on the  
list of course) to optimize.

> If this is the case, we really need some way of compressing them for  
> 6lowpan.
>
> Robert
> http://www.gridmerge.com