Subject: [Roll] RPL option length

From: Matteo Paris <[email-masked]>
Date: Tue, 25 May 2010 11:01:42 -0400

The RPL option length field is 2 bytes long.  I propose we change it 
to 1 byte.  For comparison, the IPv6 and ND option length fields are 
1 byte long.  Since RPL is being designed for constrained devices, 
there won't be a need for options bigger than IPv6 and ND options.

If you agree, please send a quick +1 to the list in reply so we can 
move this small matter forward to a ticket.

Thanks,
Matteo

---

From: Robert Cragie <[email-masked]>
Date: Tue, 25 May 2010 20:02:35 +0100

+1

A couple of points:

   1. You may need to change PadN as well to work for 2 or more octets
      of padding as in RFC2460 (or maybe simply refer to RFC2460)
   2. 1 octet length option in IPv6 and ND options are in 8 octet units
      - are you proposing the same? I would suggest not in this case.

Robert

Robert Cragie (Pacific Gas & Electric)

Gridmerge Ltd.
89 Greenfield Crescent,
Wakefield, WF4 4WA, UK
+44 1924 910888
+1 415 513 0064
http://www.gridmerge.com <http://www.gridmerge.com/>

On 25/05/2010 4:01 PM, Matteo Paris wrote:
> to 1 byte.  For comparison, the IPv6 and ND option length fields are 1 
> byte long.  Since RPL is being designed for constrained devices, there 
> won't be a need for options bigger than IPv6 and ND options.
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: "Samita Chakrabarti" <[email-masked]>
Date: Tue, 25 May 2010 13:05:28 -0700

+1

-Samita

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Matteo Paris
> Sent: Tuesday, May 25, 2010 8:02 AM
> To: [email-masked]
> Subject: [Roll] RPL option length
> 
> 
> The RPL option length field is 2 bytes long.  I propose we change it to 1
> byte.  For comparison, the IPv6 and ND option length fields are
> 1 byte long.  Since RPL is being designed for constrained devices, there
> If you agree, please send a quick +1 to the list in reply so we can move
> this small matter forward to a ticket.
> 
> Thanks,
> Matteo

---

From: Joakim Eriksson <[email-masked]>
Date: Tue, 25 May 2010 22:28:46 +0200

+1

-- Joakim

Matteo Paris skrev 2010-05-25 17:01:
> byte. For comparison, the IPv6 and ND option length fields are 1 byte
> long. Since RPL is being designed for constrained devices, there won't
> be a need for options bigger than IPv6 and ND options.
>

---

From: Dario Tedeschi <[email-masked]>
Date: Tue, 25 May 2010 15:59:02 -0700

+1

---

From: "Salazar, Ruben" <[email-masked]>
Date: Tue, 25 May 2010 21:47:46 -0400

+1

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Matteo Paris
Sent: Tuesday, May 25, 2010 11:02 AM
To: [email-masked]
Subject: [Roll] RPL option length

Thanks,
Matteo

Ruben Salazar
Director of Technology
Landis+Gyr
Energy Management Solutions
Office: +1 678 258 3165
Fax: +1 678 258 1550
[email-masked]
www.landisgyr.com
manage energy better

---

From: Mathieu Pouillot <[email-masked]>
Date: Wed, 26 May 2010 08:38:02 +0200

+1

Mathieu

-- 
Mathieu Pouillot
R&D Engineer
[email-masked]

Tel : +33(0)4 98 01 60 05 (Poste 43)
Fax : +33(0)4 94 14 10 80
1766 Chemin de la Planquette
83130 LA GARDE - France
www.watteco.com<http://www.watteco.com/>

---

From: "Anders Brandt" <[email-masked]>
Date: Wed, 26 May 2010 08:45:04 +0200

+1

- Anders 

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Matteo Paris
> Sent: Tuesday, May 25, 2010 17:02
> To: [email-masked]
> The RPL option length field is 2 bytes long.  I propose we 
> change it to 1 byte.  For comparison, the IPv6 and ND option 
> length fields are
> 1 byte long.  Since RPL is being designed for constrained 
> devices, there won't be a need for options bigger than IPv6 
> and ND options.
> 
> If you agree, please send a quick +1 to the list in reply so 
> we can move this small matter forward to a ticket.
> 
> Thanks,
> Matteo

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 26 May 2010 14:21:20 +0200

> this small matter forward to a ticket.

I disagree - should I send a -1?

(I can't seem to remember having seen -1 sent to IETF lists, thus I
  wonder whether the '+' is really necessary).

Alex

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 26 May 2010 15:15:01 +0200

Hi Matteo and all,

It seems that we moved to 2 octets sometime in the past for the metrics,
but I see a consensus to try and go back to one octet, even if that
means splitting that specific option.
Related: with 08, we envision to include some RA options in the DIO.
That would be at least the RIO and the PIO. 
- Then comes the question of the SLLA and the MTU options. Do you think
we should carry them as well? 
- And the name space: it makes sense that the RPL options extend the ND
namespace if we are to reuse ND options.  Would you agree?

Cheers,

Pascal

> Sent: Tuesday, May 25, 2010 5:02 PM
> To: [email-masked]
to 1 byte.
> For comparison, the IPv6 and ND option length fields are
there won't
> If you agree, please send a quick +1 to the list in reply so we can
move this
> small matter forward to a ticket.
> 
> Thanks,
> Matteo

---

From: Joakim Eriksson <[email-masked]>
Date: Wed, 26 May 2010 16:12:06 +0200

> That would be at least the RIO and the PIO.

Great!

I have recently been trying out mis-using the destination-prefix in DIOs
as if they were PIOs with Autoconfig flag set. Works fine (but is a
hack) and is a great shortcut for the quite complex "reasoning" that
needs to take place for figuring out what prefix the node should use
for autoconfig if RPL does not send PIOs in the DIOs.

> we should carry them as well?

If we assume that we will not redefine how RA/RS and possibly wants to
avoid too much ND messaging the SLLA is another good "shortcut".

> namespace if we are to reuse ND options.  Would you agree?

Yes!

Best regards,
-- Joakim Eriksson, SICS

-- 
-- Joakim