Subject: Re: [Roll] DAO fan out

From: Dario Tedeschi <[email-masked]>
Date: Mon, 03 May 2010 11:50:17 -0700

Hi Roger

First, let me just say that I think this is an elegant solution to the 
fan-out problem.  I just have one question: What does a bit-map for the 
Path Control field offer over just a straight forward decremented 
counter field? I realise bits can be merged at a common parent, but 
since a parent would need to wait a nominal time to receive multiple 
DAO's, anyway, I can't see why a simpler counter filed could not be used 
instead.

Regards
Dario

Roger Alexander wrote:
> Hi Pascal,
>
> Please find attached an expanded note on the DAO fan out control and path
> prioritization mechanism.
>
> Roger
>
>

---

From: Roger Alexander <[email-masked]>
Date: Tue, 4 May 2010 15:08:04 -0700 (PDT)

Hi Dario,
 
In the case of storing nodes, the destination address
received in a DAO message at a common (storing) ancestor will have a route
entry validity period associated with it (currently communicated through Prefix
Lifetime). In that case when a new DAO message is received the updated Path
Control field can be immediately communicated in the relayed message. The
updated Path Control information will reflect the combined validity of any DAOs
received to that point. 
 
The benefit of the bit map is that it will allow
identification of preference in addition to controlling the fan out count. The
preferred path can be used for purposes of prioritization when multiple
downward paths exist at the root node (or other intermediate common ancestor).
The root or other storing common ancestor will be able to distinguish downward
paths based on the particular Path Control bits that were set in the received
DAO messages.   
 
In the case of non-storing nodes, under Richard's current
proposal, the node owner of a particular DAO message destination address will
be able to indicate the preference ordering of DAO Parents using the Path
Control bits. Each DAO message sent to the root will indicate the selected DAO
Parents and the preference ordering. For non-storing nodes the only common
ancestor that stores DAO messages is the root which will recursive calculate
the downward path(s) to the target node based on the preference of selected DAO
Parents. 
 
Roger

> -----Original Message-----
> From: [email-masked]
[mailto:[email-masked]] On Behalf 
> Of Dario Tedeschi
> Sent: Monday, May 03, 2010 2:50 PM
> To: 'ROLL WG'
> Subject: Re: [Roll] DAO fan out
> 
> Hi Roger
> 
> fan-out problem.  I just have one question: What does a bit-map for 
> the Path Control field offer over just a straight
forward decremented 
> DAO's, anyway, I can't see why a simpler counter
filed could not be 
> used instead.
> 
> Regards
> Dario
> 
> Roger Alexander wrote:
> > Hi Pascal,
> >
> > Please find attached an expanded note on the
DAO fan out control and
> path
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll