Subject: [Roll] [roll] #39: RPL option lenght

From: "roll issue tracker" <[email-masked]>
Date: Thu, 27 May 2010 09:21:16 -0000

#39: RPL option lenght
--------------------------------+-------------------------------------------
 Reporter:  jpv@…               |       Owner:  pthubert@…        
     Type:  defect              |      Status:  new               
 Priority:  major               |   Milestone:                    
Component:  rpl                 |     Version:                    
 Severity:  Active WG Document  |    Keywords:                    
--------------------------------+-------------------------------------------
 From: [email-masked] [mailto:[email-masked]] On Behalf
  > Of
  >> Matteo Paris
  >> Sent: Tuesday, May 25, 2010 5:02 PM
  >> To: [email-masked]
  >> Subject: [Roll] RPL option length
  >>
  >>
  >> The RPL option length field is 2 bytes long.  I propose we change it
  > to 1 byte.
  >> For comparison, the IPv6 and ND option length fields are
  >> 1 byte long.  Since RPL is being designed for constrained devices,
  > there won't
  >> be a need for options bigger than IPv6 and ND options.
  >>
  >> If you agree, please send a quick +1 to the list in reply so we can
  > move this
  >> small matter forward to a ticket.
  >>
  >> Thanks,
  >> Matteo

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/39>
roll <http://tools.ietf.org/wg/roll/>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 31 May 2010 08:54:18 +0200

Hi JP

I think we can close this one. The 08 spec has:
- restored the size to 1 octet expressed in bytes
- included ND's RIO and DIO but with a different type and length to match the rest of RPL.

The last question in my mind is whether we should also include the SLLA and MTU options. Make sense to me and got positive answers on the ML.

Pascal

> -----Original Message-----
> From: roll issue tracker [mailto:[email-masked]]
> Sent: Thursday, May 27, 2010 11:21 AM
> To: Pascal Thubert (pthubert); [email-masked]
> Cc: [email-masked]
> Subject: [roll] #39: RPL option lenght
> 
> #39: RPL option lenght

---

From: "roll issue tracker" <[email-masked]>
Date: Mon, 31 May 2010 07:00:21 -0000

#39: RPL option lenght
--------------------------------+-------------------------------------------
 Reporter:  jpv@…               |        Owner:  pthubert@…        
     Type:  defect              |       Status:  closed            
 Priority:  major               |    Milestone:                    
Component:  rpl                 |      Version:                    
 Severity:  Active WG Document  |   Resolution:  fixed             
 Keywords:                      |  
--------------------------------+-------------------------------------------
Changes (by jpv@…):

  * status:  new => closed
  * resolution:  => fixed

Comment:

 Consensus on the mailing list:

 In revision 08:

 - restored the size to 1 octet expressed in bytes
 - included ND's RIO and DIO but with a different type and length to match
 the rest of RPL.

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/39#comment:1>
roll <http://tools.ietf.org/wg/roll/>

---

From: JP Vasseur <[email-masked]>
Date: Mon, 31 May 2010 09:05:22 +0200

Hi Pa

> - included ND's RIO and DIO but with a different type and length to  

OK, done.

> The last question in my mind is whether we should also include the  
> SLLA and MTU options. Make sense to me and got positive answers on  
> the ML.
>

That would makes sense. All, please let us know if you disagree by end  
of the week since we would like to close on this item for
the revision 09 that we would like to post before the Virtual WG  
meeting.

Thanks.

JP.

>> -------------------------------- 
>> +-------------------------------------------
>> -------------------------------- 
>> +-------------------------------------------