Subject: Re: [Roll] The need for multiplicative metrics and other comments on draft-ietf-roll-routing-metrics-05

From: JP Vasseur <[email-masked]>
Date: Fri, 11 Jun 2010 13:45:26 +0200

Hi,

Text updated in rev-07 (just posted).

Thanks.

JP.

On Apr 28, 2010, at 8:23 PM, JP Vasseur wrote:

> Hi,
>
> Good comments, which we agreed upon some time ago, I forgot to  
> incorporate it.
> OK that will be in the next revision for sure.
>
> Cheers.
>
> JP.
>
> On Apr 28, 2010, at 8:20 PM, Yoav Ben-Yehezkel wrote:
>
>> Hi,
>>
>> Sorry for coming up with this comment after this release... It came  
>> up to
>> me only when reviewing the diffs between new and previous version :)
>>
>> I think there a small issue in the following para.:
>>
>> "
>> 4.3.1.  The Link Quality Level Reliability Metric
>> ...
>>    0               1
>>    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5
>>   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>>   |      Aggregated LQL Value     |
>>   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>>
>>   Figure 13: LQL Type 2 sub-Object format
>>
>>  Aggregated LQL Value: when used an an additive metric (A=0x00), the
>>  aggregated LQL value reports the sum of all the LQL values for all
>>  links along the path.  When used to report a minimum (A=0x02), the
>>  field reports the minimum LQL value of all links along the path.
>>
>> "
>>
>> In case the LQL on any link is unknown 0, and the metric is  
>> multiplicative
>> (A=0x03), using a multiplication by 0 would reset the aggregated LQL
>> value, whereas if the metric is additive, the aggregated LQL value  
>> will
>> remain unchanged. So I suggest to update the above para. to:
>>
>> "
>> ...
>>  Aggregated LQL Value: when used an an additive metric (A=0x00), the
>>  aggregated LQL value reports the sum of all the LQL values for all
>>  links along the path.  When used to report a minimum (A=0x02), the
>>  field reports the minimum LQL value of all links along the path.  
>> When
>>  used to report a multiplication (A=0x03), and the LQL
>>  field of one of the links along the path is undetermined (LQL=0),
>>  the undetermined LQL will be ignored and not aggregated (i.e. no
>>  reset to Aggregated LQL Value field).
>> "
>>
>> Thanks,
>> Yoav
>>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On  
>> Behalf Of JP
>> Vasseur
>> Sent: Wednesday, April 28, 2010 2:06 PM
>> To: Omprakash Gnawali
>> Cc: roll
>> Subject: Re: [Roll] The need for multiplicative metrics and other  
>> comments
>> on draft-ietf-roll-routing-metrics-05
>>
>> Hi,
>>
>> On Apr 13, 2010, at 6:44 PM, Omprakash Gnawali wrote:
>>
>>> On Tue, Apr 13, 2010 at 12:34 AM, JP Vasseur <[email-masked]> wrote:
>>> ...
>>>>> 2. Towards the end of 4.3.2:
>>>>>
>>>>> "The ETX object may be used as a constraint or a path metric.  For
>>>>> example, an Objective Function may indicate that the ETX must not
>>>>> be
>>>>> below some specified value."
>>>>>
>>>>> Should be: ETX must not be more than some specified value.
>>>>>
>>>>
>>>> Good catch, will fix it.
>>>
>>> The ETX Objective Function proposes a threshold. While I was working
>>> on ETXOF, the difficulty was coming up with the "right" threshold  
>>> for
>>> both link ETX and path ETX. This might be a configuration parameter
>>> but it is not clear what the default value should be. It will be  
>>> great
>>> to get feedback from the WG on what the default should be.
>>
>> It is application dependent, and does not need to be standardized.
>> This is not a protocol
>> parameter either, so no need to suggest a default value.
>>
>> Thanks.
>>
>> JP.
>>
>>>
>>> - om_p
>>
>> _______________________________________________
>> Roll mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/roll
>

---

From: JP Vasseur <[email-masked]>
Date: Fri, 11 Jun 2010 13:45:30 +0200

Hi,

On Apr 29, 2010, at 2:03 PM, Yoav Ben-Yehezkel wrote:

> While you're at it, I think I found a few more related small editorial
> comments:
> "
> 2.  Object Formats
> ...
>   o  A Field: The A field is used to indicate whether a routing metric
>      is additive, reports a maximum or a minimum.
> "
> Should be:
> "   o  A Field: The A field is used to indicate whether a routing  
> metric
>      is additive, multiplicative, reports a maximum or a minimum.
> "
>
> Another one in section 2:
> "
>   Example 1: A DAG formed by RPL where all nodes must be main powered
>   and the link metric is the link throughput.  In this case the DAG
>   Metric container carries two routing objects: the link metric is the
>   link throughput (C=0, O=0, A=00, G=1, R=0) and the node constraint  
> is
>   power (C=1, O=0, A=00, G=0, R=0).  Note that in this example, the
>   link throughput is a global additive aggregated link metric.  An RPL
>   implementation may use the metric to report a minimum (A=01).  In
>   this case, when the link throughput metric is processed each node
>   updates it is the link throughput is less than the value reported by
>   the link throughput metric.
> "
>
> The text: "An RPL implementation may use the metric to report a  
> minimum
> (A=01)."
> Should be changed either to:
> "An RPL implementation may use the metric to report a minimum  
> (A=02)." OR
> "An RPL implementation may use the metric to report a maximum (A=01)."
>

Fixed.

> Question regarding the following in 4.3.1:
>
> "  When used to report a minimum (A=0x02), the
>   field reports the minimum LQL value of all links along the path."
>
> This means that an undetermined value (0) beats best value (1) being  
> the
> minimum of the two. Is this really the intent? Suggested replacement  
> text
> if not:
>
> "  When used to report a minimum (A=0x02), the
>   field reports the minimum LQL value of all links along the path,
>   ignoring undetermined LQLs (Aggregated LQL Value = 0)."
>
> Also, why does this para. describe only LQL for additive and minimum?
> Shouldn't it also describe multiplicative (suggested in previous  
> thread
> message) and maximum as well?

Added (the maximum piece was not explicitly indicated)

>
> I think there are some inconsistencies in section 9.2 and maybe also  
> 9.3:
> "
>   Codespace of the A field (NSA Object)
>    Value  Meaning                              Reference
>
>      0    Routing metric is additive           This document
>      2    Routing metric reports a maximum     This document
>      3    Routing metric reports a minimum     This document
>      4    Routing metric is multiplicative     This document
> "
> Should the values be inconsistent with the values in the text?

Fixed. Thanks for catching the typo.

>
> Also:
> "   Codespace of the Flag field (Routing common header)
>     Bit      Description              Reference
>
>      8       Constraint/metric        This document
>      7       Optional Constraint      This document
>      5-6     Additive/Max/Min         This document
>      4       Global/Local             This document
>      3       Recorded/Aggregated      This document
> "
>
> Should it be?
> "5-6     Additive/Max/Min/Mult    This document"
>

Yes.

> What does the term "flag field" mean (for example, "NSA Object flag
> field")? Does it mean flags/fields?
>

It is a very common terminology used in IETF document (a field of  
flags).

> That's it for now :)

Thanks, very useful.

JP.

> From: JP Vasseur [mailto:[email-masked]]
> Sent: Wednesday, April 28, 2010 9:24 PM
> To: Yoav Ben-Yehezkel
> Cc: Omprakash Gnawali; roll
>> From: [email-masked] [mailto:[email-masked]] On Behalf
>> Of JP
>> Vasseur