Subject: [Roll] [roll] #49: Few items to add in RPL 09

From: "roll issue tracker" <[email-masked]>
Date: Mon, 07 Jun 2010 12:00:26 -0000

#49: Few items to add in RPL 09
--------------------------------+-------------------------------------------
 Reporter:  jpv@…               |       Owner:  pthubert@…                        
     Type:  defect              |      Status:  new                               
 Priority:  major               |   Milestone:                                    
Component:  rpl                 |     Version:                                    
 Severity:  Active WG Document  |    Keywords:                                    
--------------------------------+-------------------------------------------
 * Conditions under which unicast are generated
 * Specify DIO with target, whether the nodes below have a route to target
 or not

-- 
Ticket URL: <http://wiki.tools.ietf.org/wg/roll/trac/ticket/49>
roll <http://tools.ietf.org/wg/roll/>

---

From: "roll issue tracker" <[email-masked]>
Date: Mon, 07 Jun 2010 12:00:52 -0000

Comment(by jpv@…):

 * Conditions under which unicast are generated SHOULD READ * Conditions
 under which unicast DIS are generated

-- 
Ticket URL: <http://wiki.tools.ietf.org/wg/roll/trac/ticket/49#comment:1>
roll <http://tools.ietf.org/wg/roll/>

---

From: "roll issue tracker" <[email-masked]>
Date: Mon, 14 Jun 2010 09:52:40 -0000

Comment(by jpv@…):

 The first part of the question has been answered in RPL-09: here is the
 text:

 When a node receives a unicast DIS without a Solicited
 Information option, it MUST unicast a DIO to the sender in response.
 This DIO MUST include a DODAG Configuration option.  When a node
 receives a unicast DIS message with a Solicited Information option,
 if it satisfies the predicates of the Solicited Information option it
 MUST unicast a DIO to the sender in response.  This unicast DIO MUST
 include a DODAG Configuration Option.  Thus a node may transmit a
 unicast DIS message to a potential DAO parent in order to probe for
 DODAG Configuration and other parameters.

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/49#comment:2>
roll <http://tools.ietf.org/wg/roll/>

---

From: JP Vasseur <[email-masked]>
Date: Mon, 14 Jun 2010 11:53:31 +0200

First question of the ticket has been answered in RPL 09 (see ticket).
Second part will be addressed in -10.

JP.

Begin forwarded message:

> From: "roll issue tracker" <[email-masked]>
> Date: June 14, 2010 11:52:40 AM CEDT
> To: [email-masked], [email-masked]
> Cc: [email-masked]
> Subject: Re: [roll] #49: Few items to add in RPL 09
> Reply-To: [email-masked]
>
> -------------------------------- 
> +-------------------------------------------
> -------------------------------- 
> +-------------------------------------------
>
> Comment(by jpv@…):
>
> Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/49#comment:2 
> >

---

From: "roll issue tracker" <[email-masked]>
Date: Thu, 17 Jun 2010 16:11:52 -0000

#49: Few items to add in RPL 09
--------------------------------+-------------------------------------------
 Reporter:  jpv@…               |        Owner:  pthubert@…                        
     Type:  defect              |       Status:  closed                            
 Priority:  major               |    Milestone:                                    
Component:  rpl                 |      Version:                                    
 Severity:  Active WG Document  |   Resolution:  duplicate                         
 Keywords:                      |  
--------------------------------+-------------------------------------------
Changes (by jpv@…):

  * status:  new => closed
  * resolution:  => duplicate

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/49#comment:3>
roll <http://tools.ietf.org/wg/roll/>