Subject: Re: [Roll] Soliciting a DAO

From: Mukul Goyal <[email-masked]>
Date: Thu, 17 Jun 2010 22:06:22 -0500 (CDT)

Hi Tim

>This then is a key question -- pro vs. con

>Given that the P2P draft will elaborate upon the RPL base spec as needed
>to support
>the P2P functionality, is there any need for the RPL base spec to
>support sending a
>DIO + Target from the DODAG root?

I would say no.

>To give a small summary, without DIO + Target, a DODAG root (when a
>downward route is
>not available, other use cases?), may either :

>1) Wait for a local repair / DODAG maintenance to restore the downward route

>2) Trigger a global repair by incrementing the DODAG Version number

>With the DIO + Target, a DODAG root may attempt to solicit a DAO from
>that specific
>target, presumed to be located somewhere in the sub-DODAG..

>Additional details would have to be worked out, e.g. for how long/how
>many DIOs do
>the nodes in the sub-DODAG continue to include/repeat the Target Option
>when they
>emit DIOs for that Version?

Yes, I guess it adds too much complexity to the base spec. 

>WG, is this a feature that we should consider to add to the base
>specification,...?

I would vote no.

Thanks
Mukul

----- Original Message -----
From: "Tim Winter" <[email-masked]>
To: "ROLL WG" <[email-masked]>
Sent: Thursday, June 17, 2010 9:55:10 PM
Subject: Re: [Roll] Soliciting a DAO

Hi Mukul, Phil,

On 06/17/2010 02:24 PM, Mukul Goyal wrote:
> Hi Philip
>
>> Can you be more specific? Currently this is done with the T flag and
> DTSN. But you want to solicit one deep in a sub-DODAG?
>
> Pascal mentioned during the meeting yesterday the possibility of
> soliciting a DAO from a specific destination using the target option
> in the DIO. Please note that I am not requesting such a functionality.
> I am just asking if it is going to be added so that we can refer to it
> in the P2P draft.
>
> I do not have a strong opinion either way regarding such a
> functionality. If present, it makes RPL "reactive" (a pro) but more
> complex (a con). It does not solve the main P2P related problem
> associated with DAG-based routing (the need to go up the DAG and then
> down). So, I tend to think that it will be a rather redundant
> functionality (assuming that the functionality provided by the P2P
> draft would be standardized) unless I am missing some thing.

This then is a key question -- pro vs. con

Given that the P2P draft will elaborate upon the RPL base spec as needed
to support
the P2P functionality, is there any need for the RPL base spec to
support sending a
DIO + Target from the DODAG root?

To give a small summary, without DIO + Target, a DODAG root (when a
downward route is
not available, other use cases?), may either :

1) Wait for a local repair / DODAG maintenance to restore the downward
route

2) Trigger a global repair by incrementing the DODAG Version number

With the DIO + Target, a DODAG root may attempt to solicit a DAO from
that specific
target, presumed to be located somewhere in the sub-DODAG..

Additional details would have to be worked out, e.g. for how long/how
many DIOs do
the nodes in the sub-DODAG continue to include/repeat the Target Option
when they
emit DIOs for that Version?

WG, is this a feature that we should consider to add to the base
specification, or
defer until some future work?

Thanks,

-Tim

>
> Thanks
> Mukul
>
> ----- Original Message -----
> From: "Philip Levis"<[email-masked]>
> To: "Mukul Goyal"<[email-masked]>
> Cc: "Pascal Thubert (pthubert)"<[email-masked]>,
> "roll"<[email-masked]>
> Sent: Thursday, June 17, 2010 12:19:19 PM
> Subject: Re: [Roll] Soliciting a DAO
>
> On Jun 17, 2010, at 9:28 AM, Mukul Goyal wrote:
>
>> Hi Pascal,
>>
>> Will the next version of RPL have a description of how to use
>> DIO+target_option to solicit a DAO? At present, RPL spec does mention
>> the possibility of including a target option in a DIO but has no
>> description of how it will be used.
>>
>> Looks like such a provision will add a "reactive" flavor to RPL.
>
> Can you be more specific? Currently this is done with the T flag and
> DTSN. But you want to solicit one deep in a sub-DODAG?
>
> Phil
> _______________________________________________ Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>
_______________________________________________ Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: JP Vasseur <[email-masked]>
Date: Fri, 18 Jun 2010 08:29:50 +0200

+1