Subject: [Roll] P2P hop-by-hop routes

From: Mukul Goyal <[email-masked]>
Date: Sun, 20 Jun 2010 23:06:25 -0500 (CDT)

The P2P mechanism will allow the establishment of hop-by-hop routes that meet certain constraints regarding the routing metrics.

Now, the other question is how does a packet, that wants to travel along a particular P2P hop-by-hop route, specify its preference for such a route? I guess we need some sort of labeling mechanism here. Any suggestions regarding how will it work?

Thanks
Mukul

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 21 Jun 2010 12:14:17 +0200

What to others think about the P2P term?  Is the term ok to your
understanding?

To my reading, "P2P" stands for peer-to-peer and is in widespread use 
for overlay networks; this terminology is different than the intention 
you seem to use for P2P to mean e.g. straight communication between two 
leaf nodes of same parent.

To my reading, "point-to-point" stands for a specific kind of link,
different than broadcast, or multicast capable links (Ethernet) -
point-to-point links, sometimes abbreviated ptp, are using the PPP
prrotocol ("PPP" stands for point-to-point protocol).  This is again
different than what you seem to use as P2P term - your P2P is not using PPP.

In this sense, I would like to clarify the P2P term used in RoLL.  It is 
good to use common terminology to understand each other.

What to others think about the P2P term?  Is the term ok to your
understanding?

Alex

Le 21/06/2010 06:06, Mukul Goyal a écrit :
> The P2P mechanism will allow the establishment of hop-by-hop routes
> that meet certain constraints regarding the routing metrics.
>
> Now, the other question is how does a packet, that wants to travel
> along a particular P2P hop-by-hop route, specify its preference for
> such a route? I guess we need some sort of labeling mechanism here.
> Any suggestions regarding how will it work?
>
> Thanks Mukul _______________________________________________ Roll
> mailing list [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: "Anders Brandt" <[email-masked]>
Date: Mon, 21 Jun 2010 12:46:37 +0200

Alex,

I think you are right that this term is wrong (!)
The best explanation I can give is that we used it from the start ...
If we are to change it, now is a very good time before it starts working its way into the RPL framework.

So do you have some good acronyms on the table?
PPP is something different; most of all it is a specific protocol, while our term mainly deals with the
special type of traffic that is between two points inside the LLN.

While not sufficiently catchy, "Intra-Network Unicast" (INU) transport is what this is about.
Who can come up with the best acronym which does not resemble something important?

"PTP" doesn't seem to be that overloaded, so can it be done that simple?

Cheers,
  Anders

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Alexandru Petrescu
> Sent: Monday, June 21, 2010 12:14
> To: [email-masked]
> Subject: Re: [Roll] P2P term again (was: P2P hop-by-hop routes)
> 
> What to others think about the P2P term?  Is the term ok to 
> your understanding?
> 
> To my reading, "P2P" stands for peer-to-peer and is in 
> widespread use for overlay networks; this terminology is 
> different than the intention you seem to use for P2P to mean 
> e.g. straight communication between two leaf nodes of same parent.
> 
> To my reading, "point-to-point" stands for a specific kind of 
> link, different than broadcast, or multicast capable links 
> (Ethernet) - point-to-point links, sometimes abbreviated ptp, 
> are using the PPP prrotocol ("PPP" stands for point-to-point 
> protocol).  This is again different than what you seem to use 
> as P2P term - your P2P is not using PPP.
> 
> In this sense, I would like to clarify the P2P term used in 
> RoLL.  It is good to use common terminology to understand each other.
> 
> What to others think about the P2P term?  Is the term ok to 
> your understanding?
> 
> Alex
> 
> _______________________________________________
> Roll mailing list
> [email-masked]

---

From: "Anders Brandt" <[email-masked]>
Date: Mon, 21 Jun 2010 13:17:12 +0200

My take is that an application should not be concerned with particular
hop-by-hop routes
but rather the required metric/OF? 

- Anders

> Behalf Of Mukul Goyal
> Sent: Monday, June 21, 2010 06:06
> To: roll
> Subject: [Roll] P2P hop-by-hop routes
> 
> The P2P mechanism will allow the establishment of hop-by-hop 
> routes that meet certain constraints regarding the routing metrics.
> 
> Now, the other question is how does a packet, that wants to 
> travel along a particular P2P hop-by-hop route, specify its 
> preference for such a route? I guess we need some sort of 
> labeling mechanism here. Any suggestions regarding how will it work?
> 
> Thanks
> Mukul

---

From: [email-masked]
Date: Mon, 21 Jun 2010 09:25:41 -0500

Mukul,

I thought the P2P routes were source
routed?

I can see the potential confusion if
they are hop-by-hop routes.  However, if they're in a different DAG,
wouldn't the DAG ID be the discriminator that the packet needs to follow
a certain path?

Jerry

From:

Mukul Goyal <[email-masked]>

To:

roll <[email-masked]>

Date:

06/20/2010 11:06 PM

Subject:

[Roll] P2P hop-by-hop routes

The P2P mechanism will allow the establishment of
hop-by-hop routes that meet certain constraints regarding the routing metrics.

Now, the other question is how does a packet, that wants to travel along
a particular P2P hop-by-hop route, specify its preference for such a route?
I guess we need some sort of labeling mechanism here. Any suggestions regarding
how will it work?

Thanks

Mukul

Roll mailing list

[email-masked]

---

From: "Monnerie, Emmanuel" <[email-masked]>
Date: Mon, 21 Jun 2010 11:02:00 -0400

Alex,

I agree that the term P2P was not always used the right way. P2P should refer to Peer-to-Peer, not Point-to-Point.

It has been defined in RFC5867 as follow:
"5.2.2 Peer-to-Peer communication
(...)
A network device MUST be able to communicate in an end-to-end manner with any other device on the network."

Best Regards

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Anders Brandt
Sent: Monday, June 21, 2010 6:47 AM
To: Alexandru Petrescu; [email-masked]
Subject: Re: [Roll] P2P term again (was: P2P hop-by-hop routes)

Alex,

Cheers,
  Anders

Emmanuel Monnerie
Senior Research Engineer
Landis+Gyr
Energy Management Solutions
Office: +1 678 258 1695
Fax: +1 678 258 1316
[email-masked]
www.landisgyr.com
manage energy better

---

From: Richard Kelsey <[email-masked]>
Date: Mon, 21 Jun 2010 11:10:26 -0400

> Date: Sun, 20 Jun 2010 23:06:25 -0500 (CDT)
> From: Mukul Goyal <[email-masked]>
> 
> such a route? I guess we need some sort of labeling mechanism
> here. Any suggestions regarding how will it work?

Shouldn't it use the RPLInstanceID from the DODAG that
was used to create the route, same as non-P2P packets?

                               -Richard Kelsey

---

From: Mukul Goyal <[email-masked]>
Date: Mon, 21 Jun 2010 10:25:03 -0500 (CDT)

But, the DAGs created for route discovery are temporary and the RPLInstanceID for them is "local" to the origin router.

That's why I referred to the need for a labeling mechanism to identify the route at each hop.

Thanks
Mukul

----- Original Message -----
From: "Richard Kelsey" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>
Cc: [email-masked]
Sent: Monday, June 21, 2010 10:10:26 AM
Subject: Re: [Roll] P2P hop-by-hop routes

-Richard Kelsey

---

From: Mukul Goyal <[email-masked]>
Date: Mon, 21 Jun 2010 10:29:49 -0500 (CDT)

Jerry

>I thought the P2P routes were source routed?  

No, they can be hop-by-hop as well.

>I can see the potential confusion if they are hop-by-hop routes.
> However, if they're in a different DAG, wouldn't the DAG ID be the
>discriminator that the packet needs to follow a certain path?

Two things:
1) DAG created for route discovery is temporary.
2) DODAGID is nothing but an IPv6 address of the origin router. 

I think there needs to be a (local) label to identify the route. The label gets assigned at the same time as the hop-by-hop state and is conveyed to the next hop along with (or inside) the Discovery Reply message.

Thanks
Mukul

From: Mukul Goyal <[email-masked]>
To: roll <[email-masked]>
Date: 06/20/2010 11:06 PM
Subject: [Roll] P2P hop-by-hop routes

The P2P mechanism will allow the establishment of hop-by-hop routes that
meet certain constraints regarding the routing metrics.

Now, the other question is how does a packet, that wants to travel along
a particular P2P hop-by-hop route, specify its preference for such a
route? I guess we need some sort of labeling mechanism here. Any
suggestions regarding how will it work?

Thanks
Mukul
_______________________________________________ Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 21 Jun 2010 18:00:39 +0200

Le 21/06/2010 17:02, Monnerie, Emmanuel a écrit :
> Alex,
>
> I agree that the term P2P was not always used the right way. P2P
> should refer to Peer-to-Peer, not Point-to-Point.

I agree.

> It has been defined in RFC5867 as follow: "5.2.2 Peer-to-Peer
> communication (...) A network device MUST be able to communicate in
> an end-to-end manner with any other device on the network."

IMHO this P2P definition is probably too much E2E which has a strong TCP 
co-notation itself, thus risking to ambiguate the RPL use of ICMP.

Alex

>
> Best Regards
>
>
>
> -----Original Message----- From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Anders Brandt Sent:
> Monday, June 21, 2010 6:47 AM To: Alexandru Petrescu; [email-masked]
> I think you are right that this term is wrong (!) The best
> explanation I can give is that we used it from the start ... If we
> are to change it, now is a very good time before it starts working
> its way into the RPL framework.
>
> So do you have some good acronyms on the table? PPP is something
> different; most of all it is a specific protocol, while our term
> mainly deals with the special type of traffic that is between two
> points inside the LLN.
>
> While not sufficiently catchy, "Intra-Network Unicast" (INU)
> transport is what this is about. Who can come up with the best
> acronym which does not resemble something important?
>
> Cheers, Anders
>> -----Original Message----- From: [email-masked]
>> [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
>> Sent: Monday, June 21, 2010 12:14 To: [email-masked] Subject: Re:
>> [Roll] P2P term again (was: P2P hop-by-hop routes)
>>
>> To my reading, "P2P" stands for peer-to-peer and is in widespread
>> use for overlay networks; this terminology is different than the
>> intention you seem to use for P2P to mean e.g. straight
>> communication between two leaf nodes of same parent.
>>
>> (Ethernet) - point-to-point links, sometimes abbreviated ptp, are
>> using the PPP prrotocol ("PPP" stands for point-to-point protocol).
>> This is again different than what you seem to use as P2P term -
>> your P2P is not using PPP.
>>
>> In this sense, I would like to clarify the P2P term used in RoLL.
>> It is good to use common terminology to understand each other.
>>
>> [email-masked] https://www.ietf.org/mailman/listinfo/roll
>>
> [email-masked] https://www.ietf.org/mailman/listinfo/roll
>
>
>
> Emmanuel Monnerie Senior Research Engineer Landis+Gyr Energy
> Management Solutions Office: +1 678 258 1695 Fax: +1 678 258 1316
> [email-masked] www.landisgyr.com manage energy
> better
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 21 Jun 2010 18:06:55 +0200

Thanks for the reply.

Le 21/06/2010 12:46, Anders Brandt a écrit :
> transport is what this is about.

Hmm... INU sounds good.  Is it really transport?  (TCP and UDP are
transport).

Intra-Network: right, it is within a network of same routing protocol (RPL).

> "PTP" doesn't seem to be that overloaded, so can it be done that

I may have seen too much "ptp" discussion in the past: in the PMIP and
FMIP protocols they mean "point-to-point links".  Not sure whether the
issued RFCs continue using "ptp", but "point-to-point links" yes.

Do we characterize behaviour?  How does OSPF characterize this
peertopeer-pointopoint behaviour?  Which word?

Alex

>>> Thanks Mukul _______________________________________________
>>> Roll mailing list [email-masked]

---

From: Richard Kelsey <[email-masked]>
Date: Mon, 21 Jun 2010 14:10:04 -0400

> Date: Mon, 21 Jun 2010 10:25:03 -0500 (CDT)
> But, the DAGs created for route discovery are temporary
> and the RPLInstanceID for them is "local" to the origin
> router.

If the discovered routes are only used for packets going to
and from the origin router there is no problem with using a
"local" RPLInstanceID to mark the packets.

Determining when a "local" RPLInstanceID could be reused is
a harder problem, but exactly the same problem would occur
with labels as well.  Both would need a lifetime of some
kind.

I agree that using some kind of label might be better, but I
think that the P2P routing needs to use the same data packet
markers as the core protocol.  I can't see using labels for
P2P routes and RPLInstanceIDs for the core.

                                    -Richard Kelsey

---

From: JP Vasseur <[email-masked]>
Date: Wed, 23 Jun 2010 16:03:18 +0200

P2P refers to Point to Point, no peer to peer. See the terminology ID:

   P2P: Point To Point.  This refers to traffic exchanged between two
    nodes (regardless of the number of hops between the two nodes).

I do not see a reason for changing. Note also that peer-to-peer refers  
to many
other technologies.

Thanks.

JP.

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 23 Jun 2010 17:32:09 +0200

Le 23/06/2010 16:03, JP Vasseur a écrit :
> I do not see a reason for changing. Note also that peer-to-peer
> refers to many other technologies.

JP - I suggest to change and no longer use the term P2P to stand for
traffic exchange between two nodes regardless of the number of hops
between the two nodes (I do agree with the need of _that_ protocol
behaviour, but calling it P2P loses much of its sense to me.)

P2P means so many things, as you say, that it is too easily overloaded
to be understood for our particular RPL meaning.

At IETF there is a Working Group called P2PSIP - they say P2P stands for 
peertopeer.

It is good to use terms that don't collide, at least within the IETF space.

Some people on the list seemed to agree that P2P term should be changed.

Alex

>> communication (...) A network device MUST be able to communicate
>> in an end-to-end manner with any other device on the network."
>>
>> Best Regards
>>
>>
>>
>>> different than the intention you seem to use for P2P to mean e.g.
>>> straight communication between two leaf nodes of same parent.
>>>
>>> protocol). This is again different than what you seem to use as
>>> P2P term - your P2P is not using PPP.
>>>
>> better _______________________________________________ Roll

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 23 Jun 2010 10:39:15 -0500 (CDT)

I guess I am not sure why overloading a popular term like P2P is a problem. P2P can refer to point-to-point in ROLL context and some thing else in some other context. It seems to me that IETF is so broad now that overloading popular terms should be OK.

Thanks
Mukul 

----- Original Message -----
From: "Alexandru Petrescu" <[email-masked]>
To: "JP Vasseur" <[email-masked]>
Cc: "Emmanuel Monnerie" <[email-masked]>, "ROLL WG" <[email-masked]>
Sent: Wednesday, June 23, 2010 10:32:09 AM
Subject: Re: [Roll] P2P term again

It is good to use terms that don't collide, at least within the IETF
space.

Alex

---

From: JP Vasseur <[email-masked]>
Date: Wed, 23 Jun 2010 17:51:27 +0200

> behaviour, but calling it P2P loses much of its sense to me.)

but the counter argument is that Peer to peer refers to something very
different too. P2P as Point to Point is in line with others terms
P2MP and MP2P, this is why I would prefer to keep it unchanged. P2P
in the context of ROLL is defined in the terminology ID (this is why we
have one) so there is no ambiguity.

> At IETF there is a Working Group called P2PSIP - they say P2P stands  
> for peertopeer.
>

---

From: [email-masked]
Date: Wed, 23 Jun 2010 11:03:02 -0500

Furthermore, "P2P" is already baked into the ROLL Requirements
RFCs.  If we start changing the core definition of terms, these completed
documents lose their value.

We've used P2P, P2MP and MP2P for 18
months; let's not change their meaning now.

Jerry

From:

JP Vasseur <[email-masked]>

To:

Alexandru Petrescu <[email-masked]>

Cc:

Emmanuel Monnerie <[email-masked]>,
ROLL WG <[email-masked]>

Date:

06/23/2010 10:51 AM

Subject:

Re: [Roll] P2P term again

>> P2P refers to Point to Point, no peer to peer. See the terminology

>> ID:

> Some people on the list seemed to agree that P2P term should be

> changed.

>>> "PTP" doesn't seem to be that overloaded, so can
it be done that

>>> simple?

>>>> RoLL. It is good to use common terminology to understand
each

>>>> other.

>>>>> The P2P mechanism will allow the establishment of
hop-by-hop

>>>>> routes that meet certain constraints regarding the
routing

>>>>> metrics.

>>>>> labeling mechanism here. Any suggestions regarding
how will it

>>>>> work?

Roll mailing list

[email-masked]

---

From: Yoav Ben-Yehezkel <[email-masked]>
Date: Wed, 23 Jun 2010 19:11:32 +0300

I agree with JP - there's a document specifying exactly what P2P means and
there's a terminology section saying that this reference is used in the
ID.
However, given the objection seen from some members in the WG about the
clarity of this term, may I suggest to add an explicit reference to the
terminology ID the first time P2P is used in documents (at least drafts)?

Thanks,
Yoav

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of JP
Vasseur
Sent: Wednesday, June 23, 2010 6:51 PM
To: Alexandru Petrescu
Cc: Emmanuel Monnerie; ROLL WG
Subject: Re: [Roll] P2P term again

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 23 Jun 2010 18:14:17 +0200

Le 23/06/2010 17:39, Mukul Goyal a écrit :
> I guess I am not sure why overloading a popular term like P2P is a
> problem. P2P can refer to point-to-point in ROLL context and some
> thing else in some other context. It seems to me that IETF is so
> broad now that overloading popular terms should be OK.

Hmmm... sounds right as you present it.

I insist now for two reasons: in the past I have struggled the same with
the RR term.  Were it changed some confusion would have been avoided,
helping in a certain context.

The second is that I see a high profile coming about P2P of RPL and P2P
of cellular networks, which are very different, and risk colliding at
some point, in certain contexts.

Of course this is only speculation, but I will continue to silently keep
supporting good disambiguation of the P2P term between RPL and cellular
systems.

Alex

>
> Thanks Mukul
>
> ----- Original Message ----- From: "Alexandru
> Petrescu"<[email-masked]> To: "JP
> Vasseur"<[email-masked]> Cc: "Emmanuel
> Monnerie"<[email-masked]>, "ROLL WG"<[email-masked]>
>  Sent: Wednesday, June 23, 2010 10:32:09 AM Subject: Re: [Roll] P2P
> term again
>
> P2P means so many things, as you say, that it is too easily
> overloaded to be understood for our particular RPL meaning.
>
>>> Monday, June 21, 2010 6:47 AM To: Alexandru Petrescu;
>>> [email-masked] Subject: Re: [Roll] P2P term again (was: P2P
>>> hop-by-hop routes)
>>>
>>> Alex,
>>>
>>> explanation I can give is that we used it from the start ... If
>>> we are to change it, now is a very good time before it starts
>>> working its way into the RPL framework.
>>>
>>>  mainly deals with the special type of traffic that is between
>>> two points inside the LLN.
>>>
>>>>  Sent: Monday, June 21, 2010 12:14 To: [email-masked] Subject:
>>>> Re: [Roll] P2P term again (was: P2P hop-by-hop routes)
>>>>
>>>> _______________________________________________ Roll mailing
>>>> list [email-masked] https://www.ietf.org/mailman/listinfo/roll
>>>>

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 23 Jun 2010 18:18:58 +0200

Le 23/06/2010 18:03, [email-masked] a écrit :
>
>
> Furthermore, "P2P" is already baked into the ROLL Requirements RFCs. If
> we start changing the core definition of terms, these completed
> We've used P2P, P2MP and MP2P for 18 months; let's not change their
> meaning now.

Hi - sure it's hard to change now - even harder when it's an RFC.

Would one tell how P2P would work on a point-to-point link?

Alex

>
>
> Jerry
>
>
>
>
> From: 	JP Vasseur <[email-masked]>
> To: 	Alexandru Petrescu <[email-masked]>
> Cc: 	Emmanuel Monnerie <[email-masked]>, ROLL WG
> <[email-masked]>
> Date: 	06/23/2010 10:51 AM
> ------------------------------------------------------------------------
>
>
>
>

---

From: JP Vasseur <[email-masked]>
Date: Thu, 24 Jun 2010 09:01:12 +0200

Trying to close on this ... the RPL ID, it is explicitly mentioned  
that the terms
refers to the terminology where P2P is defined, so there is no  
ambiguity.

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 24 Jun 2010 09:27:50 +0200

Le 23/06/2010 18:03, [email-masked] a écrit :
>
>
> Furthermore, "P2P" is already baked into the ROLL Requirements RFCs.
>  If we start changing the core definition of terms, these completed

Hi,

Hmm... being picky I find the definitions to be similar but not quite
the same:

rfc5867 "building reqs":
> Each sensor in the LLN unicasts point to point (P2P)

This latter saying precisely "unicast", the first not saying it - could
the first be multicast point-to-point?  Multicast exists on
point-to-point links: ppp and IPv6 link-local multicast.

and draft-dt-rpl-roll-p2p says:
> RPL also provides mechanisms for point-to-point (P2P) routing between
> any two routers in the DAG. [...]   The P2P routing functionality
> available in RPL[...]

which is different from the previous two definitions.  Different from
the first because the first says "traffic" whereas here we mean
"routing", different from the second because the second says "unicast"
whereas this doesn't say "unicast".

In addition, "P2P" is an established term already, and "point-to-point"
term is already established too.

> We've used P2P, P2MP and MP2P for 18 months; let's not change their

YEs, I agree, these terms have been used extensively in discussion here
and elsewhere for many months.

However they are far from being commonly understood.

TO me it is hard to use these terms (P2P, P2MP, MP2P) meaningfully on a
larger scale outside RPL.

Alex

>
>
> Jerry
>
>
>
>
> From: 	JP Vasseur <[email-masked]> To: 	Alexandru Petrescu
> <[email-masked]> Cc: 	Emmanuel Monnerie
> <[email-masked]>, ROLL WG <[email-masked]> Date:
> 06/23/2010 10:51 AM Subject: 	Re: [Roll] P2P term again
>
>
>>> P2P: Point To Point. This refers to traffic exchanged between
>>> two nodes (regardless of the number of hops between the two
>>> nodes).
>>>
>> JP - I suggest to change and no longer use the term P2P to stand
>> for traffic exchange between two nodes regardless of the number of
>>  hops between the two nodes (I do agree with the need of _that_
>> protocol behaviour, but calling it P2P loses much of its sense to
>> me.)
>
> but the counter argument is that Peer to peer refers to something
> very different too. P2P as Point to Point is in line with others
> terms P2MP and MP2P, this is why I would prefer to keep it unchanged.
> P2P in the context of ROLL is defined in the terminology ID (this is
> why we have one) so there is no ambiguity.
>
>>
>> At IETF there is a Working Group called P2PSIP - they say P2P
>> stands for peertopeer.
>>
>>>> I agree that the term P2P was not always used the right way.
>>>> P2P should refer to Peer-to-Peer, not Point-to-Point.
>>>>
>>>> communication (...) A network device MUST be able to
>>>> communicate in an end-to-end manner with any other device on
>>>> the network."
>>>>
>>>> Best Regards
>>>>
>>>>
>>>>
>>>> [mailto:[email-masked]] On Behalf Of Anders Brandt
>>>> Sent: Monday, June 21, 2010 6:47 AM To: Alexandru Petrescu;
>>>> So do you have some good acronyms on the table? PPP is
>>>> something different; most of all it is a specific protocol,
>>>> while our term mainly deals with the special type of traffic
>>>> that is between two points inside the LLN.
>>>>
>>>>> [mailto:[email-masked]] On Behalf Of Alexandru
>>>>> Petrescu Sent: Monday, June 21, 2010 12:14 To: [email-masked]
>>>>> To my reading, "point-to-point" stands for a specific kind
>>>>> of link, different than broadcast, or multicast capable
>>>>> links (Ethernet) - point-to-point links, sometimes
>>>>> abbreviated ptp, are using the PPP prrotocol ("PPP" stands
>>>>> for point-to-point protocol). This is again different than
>>>>> what you seem to use as P2P term - your P2P is not using
>>>>> PPP.
>>>>>
>>>>> each other.
>>>>>> Now, the other question is how does a packet, that wants
>>>>>> to travel along a particular P2P hop-by-hop route, specify
>>>>>> its preference for such a route? I guess we need some sort
>>>>>> of labeling mechanism here. Any suggestions regarding how
>>>>>> will it work?
>>>>>>
>>>>>> Thanks Mukul
>>>>>> _______________________________________________ Roll
>>>>>  list [email-masked]
>>>> Management Solutions Office: +1 678 258 1695 Fax: +1 678 258
>>>> 1316 [email-masked] www.landisgyr.com manage
>>>> energy better _______________________________________________