Subject: [Roll] Closing on issue 54

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 18 Jun 2010 14:23:37 +0200

Dear WG:

We’d like to close on issue 54 by draft 10. There are in fact 3 questions on the table. Can you please spend a few minutes to gives us your vote on each:

1)      It has been noted that In some small networks, the non-storing mode approach of flooding or many unicast would be acceptable as a multicast approach.  Please vote whether the support of DAO based multicast on storing nodes should be a:

a.       MAY 

b.      SHOULD 

c.       MUST

2)      LL multicast address used for RPL control.  At the moment, all mcast control goes to FF02::1, which might bother more nodes than need be. Please vote to use:

a.       - all nodes                           [RFC4291]

b.      - all routers                         [RFC4291]

c.       - LL MANET nodes           [RFC5498]

d.      - LL RPL nodes                   [that we need to request to IANA] 

3)      Non storing nodes. They cannot do the DAO based stateful multicast so we plan to allow the root to either do many unicast or flood. Unicast is straightforward but flooding might require some text WRT pruning and use of trickle. To avoid duplication, the art usually adds a sequence to each packet being flooded. If we have such a sequence we can use it alone or in conjunction with trickle to prune excess multicast. Please vote:

a.       Do not prune anything, just propagate downwards all the multicast packets from parents (simplest but greedy)

b.      a + Describe the sequence nb in the hop-by-hop spec to prune flooded duplicates

c.       b + Describe the trickled version of it

Votes appreciated J

Pascal

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 18 Jun 2010 14:30:48 +0200

Le 18/06/2010 14:23, Pascal Thubert (pthubert) a écrit :
> Dear WG:
>
> We’d like to close on issue 54 by draft 10. There are in fact 3
> questions on the table. Can you please spend a few minutes to gives us
> your vote on each:
>
> 1) It has been noted that In some small networks, the non-storing mode
> approach of flooding or many unicast would be acceptable as a multicast
> approach.  Please vote whether the support of DAO based multicast on*
> storing* nodes should be a:
>
> a. MAY
>
> b. SHOULD
>
> c. MUST
>
> 2) LL multicast address used for RPL control.  At the moment, all mcast
> control goes to FF02::1, which might bother more nodes than need be.

Small correction: current draft mentions control going also to FF02::2 
(not only FF02::1).

Alex

> Please vote to use:
> 3) Non storing nodes. They cannot do the DAO based stateful multicast so
> we plan to allow the root to either do many unicast or flood. Unicast is
> straightforward but flooding might require some text WRT pruning and use
> of trickle. To avoid duplication, the art usually adds a sequence to
> each packet being flooded. If we have such a sequence we can use it
> alone or in conjunction with trickle to prune excess multicast. Please vote:
>
> a. Do not prune anything, just propagate downwards all the multicast
> packets from parents (simplest but greedy)
>
> * *
> *Pascal*
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: "Don Sturek" <[email-masked]>
Date: Fri, 18 Jun 2010 06:06:24 -0700

Hi Pascal,

My votes noted below……..

Don

From: [email-masked] [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Friday, June 18, 2010 5:24 AM
To: [email-masked]
Subject: [Roll] Closing on issue 54

Dear WG:

a.       MAY 

b.      SHOULD 

c.       MUST

DON:  MAY for storing nodes (item a)

a.       - all nodes                           [RFC4291]

DON:  LL RPL nodes (item d)

DON:  b + Describe the trickled version of it (item c)

Votes appreciated J

Pascal

---

From: JP Vasseur <[email-masked]>
Date: Fri, 18 Jun 2010 16:23:36 +0200

Hi Pascal,

On Jun 18, 2010, at 2:23 PM, Pascal Thubert (pthubert) wrote:

> questions on the table. Can you please spend a few minutes to gives  
> us your vote on each:
>
> 1)      It has been noted that In some small networks, the non- 
> storing mode approach of flooding or many unicast would be  
> acceptable as a multicast approach.  Please vote whether the support  
> of DAO based multicast on storing nodes should be a:
> a.       MAY
> b.      SHOULD
> c.       MUST

b.

>
> 2)      LL multicast address used for RPL control.  At the moment,  
> all mcast control goes to FF02::1, which might bother more nodes  
> than need be. Please vote to use:
> a.       - all nodes                           [RFC4291]

d.

>
> 3)      Non storing nodes. They cannot do the DAO based stateful  
> multicast so we plan to allow the root to either do many unicast or  
> flood. Unicast is straightforward but flooding might require some  
> text WRT pruning and use of trickle. To avoid duplication, the art  
> usually adds a sequence to each packet being flooded. If we have  
> such a sequence we can use it alone or in conjunction with trickle  
> to prune excess multicast. Please vote:
> a.       Do not prune anything, just propagate downwards all the  
> multicast packets from parents (simplest but greedy)

b.

---

From: Jonathan Hui <[email-masked]>
Date: Fri, 18 Jun 2010 07:39:44 -0700

> of DAO based multicast on storing nodes should be a:

A or B, but strongly against C.

> d.      - LL RPL nodes                   [that we need to request to  

D.

> c.       b + Describe the trickled version of it

C.  Though I don't think the description belongs in the RPL spec - it  
is, after all, a set of forwarding rules.  We will have a draft coming  
on this soon :)

--
Jonathan Hui

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 18 Jun 2010 17:42:48 +0200

Pascal - thanks for the poll, just a quick side note - please keep the 
group updated about what you're going to do with results, especially the 
part concerning IANA and group addresses.  I will wait and see.

Alex

---

From: Richard Kelsey <[email-masked]>
Date: Fri, 18 Jun 2010 12:15:45 -0400

> Date: Fri, 18 Jun 2010 14:23:37 +0200
> From: "Pascal Thubert (pthubert)" <[email-masked]>
> 
> approach of flooding or many unicast would be acceptable as a
> multicast approach.  Please vote whether the support of DAO based
> multicast on storing nodes should be a:
> 
> a.  MAY
> 
> b.  SHOULD
> 
> c.  MUST

A or B.  Not C.

> 2) LL multicast address used for RPL control.  At the moment, all
> mcast control goes to FF02::1, which might bother more nodes than need
> be. Please vote to use:
> 
> a.  - all nodes [RFC4291]
> 

D.

> 3) Non storing nodes. They cannot do the DAO based stateful multicast
> so we plan to allow the root to either do many unicast or
> flood. Unicast is straightforward but flooding might require some text
> WRT pruning and use of trickle. To avoid duplication, the art usually
> adds a sequence to each packet being flooded. If we have such a
> sequence we can use it alone or in conjunction with trickle to prune
> excess multicast. Please vote:
> 

C, but in a separate draft, not in the core RPL spec.

                             -Richard Kelsey

---

From: "Samita Chakrabarti" <[email-masked]>
Date: Fri, 18 Jun 2010 14:52:46 -0700

Hi Pascal,

Please see below.

Dear WG:

a.      MAY 

b.      SHOULD 

c.      MUST

[SC>]  b.

a.      - all nodes                           [RFC4291]

[SC>]  d.

[SC>] For non-storing nodes, I am curious to know why are we allowing both options (unicast or flooding)?  Would not just multiple-unicasts be good enough ?

Non-storing nodes generally would be starving devices – more options mean more code and more configuration and more issues with interoperability.

Thanks,

-Samita

---

From: Philip Levis <[email-masked]>
Date: Fri, 18 Jun 2010 16:43:52 -0700

On Jun 18, 2010, at 7:39 AM, Jonathan Hui wrote:

> C.  Though I don't think the description belongs in the RPL spec - it is, after all, a set of forwarding rules.  We will have a draft coming on this soon :)

+1

Phil

---

From: Roger Alexander <[email-masked]>
Date: Sun, 20 Jun 2010 17:07:49 -0700 (PDT)

Hi Pascal,

See votes below. Thanks.

Roger

________________________________
From: Pascal Thubert (pthubert) <[email-masked]>
To: [email-masked]
Sent: Fri, June 18, 2010 8:23:37 AM
Subject: [Roll] Closing on issue 54

Dear WG:

1)      It has been noted that In some small networks, the non-storing mode approach of flooding or many unicast would be acceptable as a multicast approach.  Please vote whether the support of DAO based multicast onstoring nodes should be a:
a.       MAY 
b.      SHOULD 
c.       MUST
 
[RA] a.

[RA] d.

[RA] b. 

Votes appreciated J
 
Pascal

---

From: Daniel Gavelle <[email-masked]>
Date: Mon, 21 Jun 2010 09:21:43 +0100

Pascal Thubert (pthubert) wrote:
> 1)      It has been noted that In some small networks, the non-storing 
> mode approach of flooding or many unicast would be acceptable as a 
> multicast on* storing* nodes should be a:
> 
> a.       MAY
> 
> b.      SHOULD
> 
> c.       MUST

A or B

> d.      - LL RPL nodes                   [that we need to request to IANA]

B, 6LowPAN multicast is a broadcast at layer 2 so the hardware filtering 
argument doesn't apply.  If using 6LowPAN-ND, the node is already 
listening on all routers.  I wouldn't have any objections to any of the 
options if they are useful for other MACs.

> adds a sequence to each packet being flooded. If we have such a sequence 
> we can use it alone or in conjunction with trickle to prune excess 
> multicast. Please vote:
> 

B.

> 
>  
> 
> Votes appreciated J
> 
> * *
> 
> *Pascal*
> 
>  
> 
> 
> ------------------------------------------------------------------------
> 

-- 
__________________________________________________
Daniel Gavelle, Software Engineer
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK
Comp Reg No: 3191371  Registered In England
http://www.jennic.com
__________________________________________________

---

From: Richard Kelsey <[email-masked]>
Date: Mon, 21 Jun 2010 05:56:48 -0400

> From: "Samita Chakrabarti" <[email-masked]>
> Date: Fri, 18 Jun 2010 14:52:46 -0700
> 
>> From: Pascal Thubert (pthubert)
>> multicast.
> [SC>>] For non-storing nodes, I am curious to know why are we allowing
> both options (unicast or flooding)?  Would not just multiple-unicasts be
> good enough?

The multiple-unicasts mechanism is both resource intensive
and unreliable.  An all-nodes multicast in a 100-node
network requires 99 succesful one-hop unicasts.  That isn't
going to work well unless the links are very reliable.

Besides, flooding of one form or another is what is being
used today in these networks.  Does anyone have experience
with a deployed multiple-unicast mechanism?  The systems
that I am familiar with use flooding for forwarding
multicasts.

> Non-storing nodes generally would be starving devices -  more
> options mean more code and more configuration and more issues with
> interoperability.

More options means more code only for devices that implement
them.  Devices that lack the memory for storing unicast DAOs
are likely to lack the memory for storing multicast DAOs and
thus would only implement the flooding option.

                                    -Richard Kelsey