Subject: [Roll] Soliciting a DAO

From: Mukul Goyal <[email-masked]>
Date: Thu, 17 Jun 2010 11:28:13 -0500 (CDT)

Hi Pascal,

Will the next version of RPL have a description of how to use DIO+target_option to solicit a DAO? At present, RPL spec does mention the possibility of including a target option in a DIO but has no description of how it will be used.

Looks like such a provision will add a "reactive" flavor to RPL.

Thanks
Mukul

---

From: Philip Levis <[email-masked]>
Date: Thu, 17 Jun 2010 10:19:19 -0700

> Looks like such a provision will add a "reactive" flavor to RPL.

Can you be more specific? Currently this is done with the T flag and DTSN. But you want to solicit one deep in a sub-DODAG?

Phil