Subject: [Roll] LC RPL-10

From: David Culler <[email-masked]>
Date: Tue, 29 Jun 2010 21:16:14 -0700

Dear ROLL WG,
   I would like to propose that we Last Call rpl with http://www.ietf.org/id/draft-ietf-roll-rpl-10.txt.  We have completed a significant body of clean up and simplification items since IETF 77, and we have wrapped up the critical open items, including routing security.  We have few open tickets.  We have areas of future work, but we have been able to separate them from the core spec, so they can be developed more fully while experience is gained with the core.  We have numerous implementations that are operational and many many more that are waiting to be sure things have settled down.  By going to LC now, we have three weeks to focus all of our attention on last minute clarifications and clean up of the document before Maastricht.  Those refinements will be captured in 11 once submissions reopen at IETF 78.  

So, please all in favor of LC on RPL-10...

---

From: Michael Richardson <[email-masked]>
Date: Wed, 30 Jun 2010 09:28:43 -0400

>>>>> "David" == David Culler <[email-masked]> writes:
    David> Dear ROLL WG, I would like to propose that we Last Call rpl
    David> with http://www.ietf.org/id/draft-ietf-roll-rpl-10.txt.  We
    David> have completed a significant body of clean up and
    David> simplification items since IETF 77, and we have wrapped up

I agree with WG LC on -10.txt, but not until after IETF78.
I'm not sure you understand what a last call is. It's not an opportunity
for:

    David> settled down.  By going to LC now, we have three weeks to
    David> focus all of our attention on last minute clarifications and
    David> clean up of the document before Maastricht.  Those
    David> refinements will be captured in 11 once submissions reopen at
    David> IETF 78.

A LC is what you do after those clarifications are done.

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 30 Jun 2010 16:24:43 +0200

I mainly agree with the point made by Michael, because I have a rough
feeling that we are very early in the process of debugging conceptually
the RPL spec.

I have technical comments about multicast, for example.

I also have technical comments about using IPsec AH.

RPL has strong dependency on 6MAN documents which are not yet WG items
there.

(just 2 cents worth)

Alex

Le 30/06/2010 15:28, Michael Richardson a écrit :
>
>>>>>> "David" == David Culler<[email-masked]>  writes:
> David>  have completed a significant body of clean up and David>
> simplification items since IETF 77, and we have wrapped up
>
> I agree with WG LC on -10.txt, but not until after IETF78. I'm not
> sure you understand what a last call is. It's not an opportunity
> for:
>
> David>  clean up of the document before Maastricht.  Those David>
> refinements will be captured in 11 once submissions reopen at David>
>  IETF 78.
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 30 Jun 2010 17:03:32 +0200

Hi Michael:

Chicken and an egg... The Last call is an opportunity to give us an
hopefully last round of comments before we expose the spec to a larger
audience.

What it tells us is that the chairs trust that we are getting somewhere,
and probably very close to where we want to be.
What is also tells us is that now is a good time to reread the spec and
see what's missing. 

We already know we need to add text on path sequence based on the FSM
that was present till 08.
There's also discussion on DAO Ack for non-storing that might impact the
behavior described in 10, 
and non-RPL hosts support that might be incompletely described.

Anything else we need to add / update / delete ?

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Michael Richardson
> Sent: Wednesday, June 30, 2010 3:29 PM
> To: David Culler
> Cc: [email-masked]
> Subject: Re: [Roll] LC RPL-10
> 
> 
>    Kyoto Plus: watch the video
> <http://www.youtube.com/watch?v=kzx1ycLXQSE>
> 	               then sign the petition.
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 30 Jun 2010 17:54:51 +0200

> Anything else we need to add / update / delete ?

Yes add IPsec AH I can write text if you need.

Alex

---

From: Philip Levis <[email-masked]>
Date: Wed, 30 Jun 2010 10:23:05 -0700

On Jun 30, 2010, at 8:54 AM, Alexandru Petrescu wrote:

>> cribed.

Alex,

Are you suggesting that AH should replace the current security mechanisms, or that it's an additional option?

Phil