Subject: Re: [Roll] leaf node and DTSN

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 8 Jun 2010 18:58:04 +0200

Hi Mathilde

(Tim correct me if I'm incomplete here J )

1)      There's at least the case when a router becomes leaf. It needs a DIO to poison. And if it keeps getting unicast DAOs, it needs to repeat poisoning. But I do not see a case where it would advertise itself as a router.

2)      That would be when an inconsistency is detected and the node wants to refresh its cache. For instance, it has a doubt that a DAO might have been missing since a target is not revalidated.

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mathilde Durvy (mdurvy)
Sent: Tuesday, June 08, 2010 4:30 PM
To: [email-masked]
Subject: [Roll] leaf node and DTSN

Hi All,

Small questions 

- Section 6.5

What is the rationale behind a leaf node sending DIOs if nobody can attach to it?

I would rather expect the node to use a DAO to advertize its presence and allow packets to be routed to it.

- Section 7.1.7

When is the DTSN incremented without having the 'T' flag set?

Best,

Mathilde

Durvy Mathilde
Software Engineer
Technology center

[email-masked] <mailto:[email-masked]> 
Phone: +41 21 822 1725
Mobile: +41 76 396 8116

Cisco Systems International Sàrl
Av. des Uttins, 5
CH-1180 Rolle

Cisco home page <http://www.cisco.com> 

 Think before you print.

This e-mail may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply e-mail and delete all copies of this message.

---

From: "Mathilde Durvy (mdurvy)" <[email-masked]>
Date: Wed, 9 Jun 2010 09:12:36 +0200

Hi Pascal,

Thanks for your answer. I think it would be worth clarifying these points in
the next RPL release.

Best,

Mathilde

From: Pascal Thubert (pthubert) 
Sent: mardi, 8. juin 2010 18:58
To: Mathilde Durvy (mdurvy); [email-masked]
Subject: RE: [Roll] leaf node and DTSN

Hi Mathilde

(Tim correct me if I’m incomplete here J )

1)      There’s at least the case when a router becomes leaf. It needs a DIO
to poison. And if it keeps getting unicast DAOs, it needs to repeat
poisoning. But I do not see a case where it would advertise itself as a
router.

2)      That would be when an inconsistency is detected and the node wants
to refresh its cache. For instance, it has a doubt that a DAO might have
been missing since a target is not revalidated.

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Mathilde Durvy (mdurvy)
Sent: Tuesday, June 08, 2010 4:30 PM
To: [email-masked]
Subject: [Roll] leaf node and DTSN

Hi All,

Small questions 

- Section 6.5

What is the rationale behind a leaf node sending DIOs if nobody can attach
to it?

I would rather expect the node to use a DAO to advertize its presence and
allow packets to be routed to it.

- Section 7.1.7

When is the DTSN incremented without having the ‘T’ flag set?

Best,

Mathilde

http://www.cisco.com/swa/i/logo.gif

Durvy Mathilde
Software Engineer
Technology center

 <mailto:[email-masked]> [email-masked]
Phone: +41 21 822 1725
Mobile: +41 76 396 8116

 <http://www.cisco.com> Cisco home page

Think before you print.Think before you print.

This e-mail may contain confidential and privileged material for the sole
use of the intended recipient. Any review, use, distribution or disclosure
by others is strictly prohibited. If you are not the intended recipient (or
authorized to receive for the recipient), please contact the sender by reply
e-mail and delete all copies of this message.

---

From: JP Vasseur <[email-masked]>
Date: Wed, 9 Jun 2010 16:09:38 +0200

Logging a case, not to forget, should be easy to incorporate.

On Jun 9, 2010, at 9:12 AM, Mathilde Durvy (mdurvy) wrote:

> Hi Pascal,
>
> Thanks for your answer. I think it would be worth clarifying these  
> points in the next RPL release.
> Best,
> Mathilde
>
> 1)      There’s at least the case when a router becomes leaf. It  
> needs a DIO to poison. And if it keeps getting unicast DAOs, it  
> needs to repeat poisoning. But I do not see a case where it would  
> advertise itself as a router.
> 2)      That would be when an inconsistency is detected and the node  
> wants to refresh its cache. For instance, it has a doubt that a DAO  
> might have been missing since a target is not revalidated.
>
> Pascal
>
> I would rather expect the node to use a DAO to advertize its  
> presence and allow packets to be routed to it.
> - Section 7.1.7
> [email-masked]
> Cisco home page
> This e-mail may contain confidential and privileged material for the  
> sole use of the intended recipient. Any review, use, distribution or  
> disclosure by others is strictly prohibited. If you are not the  
> intended recipient (or authorized to receive for the recipient),  
> please contact the sender by reply e-mail and delete all copies of  
> this message.
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll