Subject: [Roll] leaf node and DTSN

From: "Mathilde Durvy (mdurvy)" <[email-masked]>
Date: Tue, 8 Jun 2010 16:29:34 +0200

Hi All,

Small questions 

- Section 6.5

What is the rationale behind a leaf node sending DIOs if nobody can attach
to it?

I would rather expect the node to use a DAO to advertize its presence and
allow packets to be routed to it.

- Section 7.1.7

When is the DTSN incremented without having the ‘T’ flag set?

Best,

Mathilde

http://www.cisco.com/swa/i/logo.gif

Durvy Mathilde
Software Engineer
Technology center

 <mailto:[email-masked]> [email-masked]
Phone: +41 21 822 1725
Mobile: +41 76 396 8116

Cisco Systems International Sàrl
Av. des Uttins, 5
CH-1180 Rolle

 <http://www.cisco.com> Cisco home page

Think before you print.Think before you print.

This e-mail may contain confidential and privileged material for the sole
use of the intended recipient. Any review, use, distribution or disclosure
by others is strictly prohibited. If you are not the intended recipient (or
authorized to receive for the recipient), please contact the sender by reply
e-mail and delete all copies of this message.

---

From: JP Vasseur <[email-masked]>
Date: Wed, 9 Jun 2010 16:08:39 +0200

Funny, while making another pass, I was wondering too ... ;-)

On Jun 8, 2010, at 4:29 PM, Mathilde Durvy (mdurvy) wrote:

> Hi All,
>
> Small questions
> - Section 6.5
> What is the rationale behind a leaf node sending DIOs if nobody can  
> attach to it?
> I would rather expect the node to use a DAO to advertize its  
> presence and allow packets to be routed to it.
> - Section 7.1.7
> [email-masked]
> Cisco home page
> Think before you print.
> This e-mail may contain confidential and privileged material for the  
> sole use of the intended recipient. Any review, use, distribution or  
> disclosure by others is strictly prohibited. If you are not the  
> intended recipient (or authorized to receive for the recipient),  
> please contact the sender by reply e-mail and delete all copies of  
> this message.
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Philip Levis <[email-masked]>
Date: Wed, 9 Jun 2010 09:16:48 -0700

On Jun 9, 2010, at 7:08 AM, JP Vasseur wrote:

>> What is the rationale behind a leaf node sending DIOs if nobody can attach to it?
>> I would rather expect the node to use a DAO to advertize its presence and allow packets to be routed to it.

If a node becomes a leaf, it needs to tell other nodes that it is now a leaf. I.e., send DIOs with a Rank of infinity. In the case where a node joins a network for the first time as a leaf, I agree, it should not have to transmit DIOs. The current text is a little unclear. Would this edit make it better?

Change

"A leaf node does not extend DODAG connectivity but still needs to advertise its presence using DIOs."

to

"A leaf node does not extend DODAG connectivity but might still need to advertise its presence using DIOs. One example of such a case is if it used to be a non-leaf node and needs to poison routes."

Do you think it is worthwhile to add a bit of text to the DIO transmission rules saying that leaves MAY ignore DIS messages?

>> When is the DTSN incremented without having the ‘T’ flag set?

Good question -- is the T flag necessary, or is a DTSN increment sufficient? Another way to ask this question is: when does a node clear the T bit?

Pascal -- can you provide some insight into this?

Phil

---

From: Philip Levis <[email-masked]>
Date: Wed, 9 Jun 2010 11:08:28 -0700

> Good question -- is the T flag necessary, or is a DTSN increment sufficient? Another way to ask this question is: when does a node clear the T bit?

The answer to Mathilde's question is that a node increments DTSN but does not set the 'T' flag when it wants to trigger DAOs from its children, but not its entire sub-DODAG. It is not clear to me when this operation is needed. Is this a storing versus non-storing distinction? 

Phil

---

From: JP Vasseur <[email-masked]>
Date: Thu, 10 Jun 2010 10:44:52 +0200

On Jun 9, 2010, at 8:08 PM, Philip Levis wrote:

>> Good question -- is the T flag necessary, or is a DTSN increment  
>> sufficient? Another way to ask this question is: when does a node  
>> clear the T bit?
>
> The answer to Mathilde's question is that a node increments DTSN but  
> does not set the 'T' flag when it wants to trigger DAOs from its  
> children, but not its entire sub-DODAG.

That was also my understanding.

Pascal ?

> It is not clear to me when this operation is needed. Is this a  
> storing versus non-storing distinction?
>
> Phil

---

From: Richard Kelsey <[email-masked]>
Date: Thu, 10 Jun 2010 08:45:23 -0400

> From: Philip Levis <[email-masked]>
> Date: Wed, 9 Jun 2010 11:08:28 -0700
>
> children, but not its entire sub-DODAG. It is not clear to me when
> this operation is needed. Is this a storing versus non-storing
> distinction?

In a storing network a node that needed to refresh its DAO
storage would do exactly this.  It needs DAOs from its
children, but need not bother their chilren.  I can't think
of a situation where a storing node would need to cause its
entire subDAG to send DAOs.

The opposite holds in a non-storing network, where a root
that wanted to refresh its DAO storage would need to request
DAOs from the entire DODAG.  I can't think of a situation
where a non-storing node would need to solicit DAOs from
just its children.
                                     -Richard Kelsey

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 10 Jun 2010 16:26:29 +0200

Exactly.

I has old slides illustrating this. It is used in stateful in case of
inconsistency, and in stateless in case of a movement. 
For stateful, it mostly covered a lost DAO, but now we have the DAO Ack,
so maybe it's actually not needed anymore...

Pascal

> -----Original Message-----
> From: JP Vasseur [mailto:[email-masked]]
> Sent: Thursday, June 10, 2010 10:45 AM
> To: Philip Levis; Pascal Thubert (pthubert)
> Cc: [email-masked]
> Subject: Re: [Roll] leaf node and DTSN
> 
> 
> >>>> When is the DTSN incremented without having the 'T' flag set?
> >>>>
> >>
> >>
storing
> > versus non-storing distinction?
> >
> > Phil

---

From: "Mathilde Durvy (mdurvy)" <[email-masked]>
Date: Thu, 10 Jun 2010 17:10:43 +0200

Hi,

I think Richard asked the key question:
Is there a situation where a storing node would need to cause its entire
subDAG to send DAOs?
We could imagine that the root would like to once in a while do a global
refresh all the DAO state (similar to an increase of the version number for
the DIO). But this is not clear to me.

So if we summarize we have: 
T flag set / no DTSN increment     	DAO from root subdag?   (should this
case happen)
T flag set / DTSN increment		DAO from root subdag
T flag not set / no DTSN increment 	Nothing
T flag not set / DTSN increment    	Storing: DAO from child,
Non-Storing: DAO from subdag

Is that correct?
Using only one flag does not change anything in the storing case but would
limit the refresh to child in the non-storing case... Also I'm still not
completely clear on the type of inconsistencies that would trigger a node to
increment its DTSN in the first place. Maybe the spec could be a bit more
specific there.

Best,
Mathilde

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Richard Kelsey
Sent: jeudi, 10. juin 2010 14:45
To: Philip Levis
Cc: [email-masked]
Subject: Re: [Roll] leaf node and DTSN

---

From: "Mathilde Durvy (mdurvy)" <[email-masked]>
Date: Thu, 10 Jun 2010 17:18:35 +0200

Hi Phil,

Yes I think it would indeed make sense to be more specific.
We could say that a leaf node does not send DIOs. But a node switching to
leaf node should send a no-DIO (possibly several) before doing so. Would
that make sense?
Alternatively we could say that a leaf node is only allowed to send DIO with
rank infinity (i.e. no-DIOs).

Mathilde

-----Original Message-----
From: Philip Levis [mailto:[email-masked]] 
Sent: mercredi, 9. juin 2010 18:17
To: JP Vasseur
Cc: Mathilde Durvy (mdurvy); [email-masked]
Subject: Re: [Roll] leaf node and DTSN

attach to it?

If a node becomes a leaf, it needs to tell other nodes that it is now a
leaf. I.e., send DIOs with a Rank of infinity. In the case where a node
joins a network for the first time as a leaf, I agree, it should not have to
transmit DIOs. The current text is a little unclear. Would this edit make it
better?

Change

"A leaf node does not extend DODAG connectivity but still needs to advertise
its presence using DIOs."

to

"A leaf node does not extend DODAG connectivity but might still need to
advertise its presence using DIOs. One example of such a case is if it used
to be a non-leaf node and needs to poison routes."

Do you think it is worthwhile to add a bit of text to the DIO transmission
rules saying that leaves MAY ignore DIS messages?

>> When is the DTSN incremented without having the 'T' flag set?

Good question -- is the T flag necessary, or is a DTSN increment sufficient?
Another way to ask this question is: when does a node clear the T bit?

Phil

---

From: JP Vasseur <[email-masked]>
Date: Thu, 10 Jun 2010 17:20:37 +0200

Thanks Mathilde, we had a discussion, and that will be clarified in 09.
Thanks.

JP.

On Jun 10, 2010, at 5:18 PM, Mathilde Durvy (mdurvy) wrote:

> sufficient?