Subject: [Roll] Fwd: New Version Notification for draft-tripathi-roll-rpl-simulation-04

From: Joydeep Tripathi <[email-masked]>
Date: Mon, 14 Jun 2010 16:53:55 -0400

Hi,

We have published the fourth revision of the simulation document. This
time, we have simulated a large scale network (2442 nodes), whose data
have been gathered from a chunk of a huge smart meter network. To show
the scalability of RPL, it includes the relevant metrics such as path
stretch, delay and control overhead. Please let us know your feedback.

Thanks,
Joydeep

---------- Forwarded message ----------
From: Joydeep Tripathi <[email-masked]>
Date: Fri, Jun 11, 2010 at 11:37 PM
Subject: Fwd: New Version Notification for draft-tripathi-roll-rpl-simulation-04
To: [email-masked]

---------- Forwarded message ----------
From: IETF I-D Submission Tool <[email-masked]>
To: [email-masked]
Date: Fri, 11 Jun 2010 20:35:20 -0700 (PDT)
Subject: New Version Notification for draft-tripathi-roll-rpl-simulation-04

A new version of I-D, draft-tripathi-roll-rpl-simulation-04.txt has
been successfully submitted by Joydeep Tripathi and posted to the IETF
repository.

Filename:        draft-tripathi-roll-rpl-simulation
Revision:        04
Title:           Performance Evaluation of Routing Protocol for Low
Power and Lossy Networks (RPL)
Creation_date:   2010-06-11
WG ID:           Independent Submission
Number_of_pages: 16

Abstract:
This document presents a performance evaluation of the Routing
Protocol for Low power and Lossy Networks (RPL) for small outdoor and
for a large scale smart meter network.  Detailed simulations are
carried out to produce several routing performance metrics using a
set of real-life scenarios.

The IETF Secretariat.

---

From: Philip Levis <[email-masked]>
Date: Mon, 14 Jun 2010 14:04:01 -0700

> stretch, delay and control overhead. Please let us know your feedback.

Joydeep,

1) My concerns with the methodology remain; assuming independent packet losses over 10-minute intervals can have significant effects on how a protocol reacts (e.g., NUD). It makes me unable to make strong conclusions from any of the rest of the results.

2) "To simulate a more realistic scenario, 20% of the generated packets by each node are destined to the root, and the remaining 80% of the packets are uniformly assigned as destined to nodes other than the root." Can you provide some insight into why this is more "realistic?" Networks rarely follow uniform distributions, and using one can make you reach the wrong conclusion (e.g., algorithm X scales when it doesn't in real patterns).

Note that these are basic concerns with the methodology to obtain the results.

Phil