Subject: [Roll] determining downward routes at the root

From: Mukul Goyal <[email-masked]>
Date: Tue, 20 Jul 2010 04:25:25 -0500 (CDT)

I was wondering if it makes sense to add some text to the RPL draft regarding how does a root, in non-storing LLN, determine the _shortest_ downward routes to different destinations using the "path control" values as the (inverse) link costs.

Thanks
Mukul

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 20 Jul 2010 13:26:00 +0200

Hi Mukul:

This is a pretty classical recursive route lookup. Only the highest
preference 1hop route should show up so recursively the root will quite
naturally build the source route header. Routing protocols usually do
not describe such operation. 

Do you think there is a risk of misinterpretation? 
Would someone else please shime in?

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Mukul Goyal
> Sent: Tuesday, July 20, 2010 11:25 AM
> To: roll
> Subject: [Roll] determining downward routes at the root
> 
> I was wondering if it makes sense to add some text to the RPL draft
regarding
> how does a root, in non-storing LLN, determine the _shortest_ downward
> routes to different destinations using the "path control" values as
the (inverse)
> link costs.
> 
> Thanks
> Mukul
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 20 Jul 2010 06:26:00 -0500

WARNING: contains banned part

Subject: Re: [Roll] determining downward routes at the root
From: "Pascal Thubert (pthubert)" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>, "roll" <[email-masked]>
Date: Tue, 20 Jul 2010 06:26:00 -0500

Hi Mukul:

Pascal

Of
regarding
the (inverse)

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 20 Jul 2010 06:26:00 -0500

Hi Mukul:

Pascal

Of
regarding
the (inverse)