Subject: [Roll] small comment on DIS format

From: Yoav Ben-Yehezkel <[email-masked]>
Date: Mon, 26 Jul 2010 11:19:05 +0300

Hi,

I found a small editorial fix in the description of “Option Length” field in
the SIO description.

Right now the description says Option Length 19 bytes, which I think little
misleading. If I understand correctly, it should be saying that the length
of the field is 1 byte and its value shall be set to 19, right?

Regards,

Yoav

5.7.9.  Solicited Information

...

        0                   1                   2                   3

        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

       |   Type = 7    | Option Length | RPLInstanceID |V|I|D|  Rsvd   |

       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

       |                                                               |

       +                                                               +

       |                                                               |

       +                            DODAGID                            +

       |                                                               |

       +                                                               +

       |                                                               |

       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

       |    Version    |

       +-+-+-+-+-+-+-+-+

           Figure 22: Format of the Solicited Information Option

...

   Option Length:  19 bytes

---

From: JP Vasseur <[email-masked]>
Date: Mon, 26 Jul 2010 10:37:54 +0200

Hi Yoav,

On Jul 26, 2010, at 10:19 AM, Yoav Ben-Yehezkel wrote:

> Hi,
>
> I found a small editorial fix in the description of “Option Length”  
> field in the SIO description.
>
> Right now the description says Option Length 19 bytes, which I think  
> little misleading. If I understand correctly, it should be saying  
> that the length of the field is 1 byte and its value shall be set to  
> 19, right?
>

Well, in Section 5.7.1, this is actually clarified:

5.7.1.  RPL Control Message Option Generic Format

    RPL Control Message Options all follow this format:

         0                   1                   2
         0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3
        +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- - - - - - - -
        |  Option Type  | Option Length | Option Data
        +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- - - - - - - -

                    Figure 14: RPL Option Generic Format

    Option Type:  8-bit identifier of the type of option.  The Option
          Type values are to be confirmed by the IANA Section 18.4.

    Option Length:  8-bit unsigned integer, representing the length in
          octets of the option, not including the Option Type and Length
          fields.

    Option Data:  A variable length field that contains data specific to
          the option.

But I see your point, what we should be doing is to put the number 19  
in the figure.

In other words, for each figure:
Option Lenght (1 byte): 19
+
shows the number (when we have a fixed number) on the figure.

Would that clarify ?

Thanks.

JP.

>        +                             
> DODAGID                            +
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Yoav Ben-Yehezkel <[email-masked]>
Date: Mon, 26 Jul 2010 11:47:35 +0300

See below the places where fixes value is assigned to this field.

5.7.6.  DODAG Configuration

...

Option Length:  8 bytes

...

Option Length:  19 bytes

5.7.10.  Prefix Information

...

Option Length:  30.  Note that this length is expressed in units of

         single-octets, unlike in IPv6 ND.

I thought there was inconsistency because of 5.7.10. Maybe the correct thing
to do is fix it to be consistent with the rest of the sections.

My personal preference is to remove the word bytes in the field description,
or specify the number inside the field,  but the main point was really about
consistency. Any way you choose to fix this that makes this field
description consistent is OK by me.

Hope this clears things up.

Thanks,

Yoav

*From:* JP Vasseur [mailto:[email-masked]]
*Sent:* Monday, July 26, 2010 11:38 AM
*To:* Yoav Ben-Yehezkel
*Cc:* [email-masked]
*Subject:* Re: [Roll] small comment on DIS format

Hi Yoav,

  Hi,

        0                   1                   2

         Type values are to be confirmed by the IANA Section 18.4
<http://tools.ietf.org/html/draft-ietf-roll-rpl-10#section-18.4>.

         fields.

         the option.

But I see your point, what we should be doing is to put the number 19 in the
figure.

+

Would that clarify ?

Thanks.

JP.

  Regards,

Yoav

...

        0                   1                   2                   3

       |                                                               |

       +                                                               +

       |                                                               |

       +                            DODAGID                            +

       |                                                               |

       +                                                               +

       |                                                               |

       |    Version    |

       +-+-+-+-+-+-+-+-+

...

   Option Length:  19 bytes

---

From: JP Vasseur <[email-masked]>
Date: Mon, 26 Jul 2010 10:49:46 +0200

On Jul 26, 2010, at 10:47 AM, Yoav Ben-Yehezkel wrote:

> I thought there was inconsistency because of 5.7.10. Maybe the  
> correct thing to do is fix it to be consistent with the rest of the  
> sections.
>
> My personal preference is to remove the word bytes in the field  
> description, or specify the number inside the field,  but the main  
> point was really about consistency. Any way you choose to fix this  
> that makes this field description consistent is OK by me.
>

It does, thanks for the feed-back. Will clarify in the next revision.

JP.

>
> Thanks,
> Yoav
>
>
>
> From: JP Vasseur [mailto:[email-masked]]
> Sent: Monday, July 26, 2010 11:38 AM
> To: Yoav Ben-Yehezkel
> Cc: [email-masked]
> Subject: Re: [Roll] small comment on DIS format
>
> Hi Yoav,
>
> But I see your point, what we should be doing is to put the number  
> 19 in the figure.
>