Subject: [Roll] Nit: what is a 'datapath', 'data packet' - must all apps be modified to include Rank in HbH

From: Alexandru Petrescu <[email-masked]>
Date: Sun, 25 Jul 2010 00:43:25 +0200

Nit:  what is a datapath?  The term appears in the title of a section

> 3.3.7. Datapath Validation and Loop Detection

and it is not explained further.

I understand path and data but the combination is not clear to me.

Because of this, this text reads strange:
> RPL uses a hop-by-hop IPv6 header to detect possible loops within a
> DODAG.  Each data packet includes the Rank of the transmitter.

What is a 'data packet'?  Do you mean I have to modify every application
to include that IPv6 header to insert new options?

E.g. if I run http and TCP - do I have to modify the TCP stack to
include this Rank on each data packet?

(Is it "Each" or "Some"?)

Alex

---

From: JP Vasseur <[email-masked]>
Date: Sun, 25 Jul 2010 10:44:17 +0200

On Jul 25, 2010, at 12:43 AM, Alexandru Petrescu wrote:

> What is a 'data packet'?

An IPv6 packet carrying user data as opposed to a routing control  
message
such as a DIS.

> Do you mean I have to modify every application

Your application builds the IP packet and allows setting IPv6 header  
field (DS, ...),
but also extended headers, ...

In RPL, datapath validation and loop detection is performed by adding  
the RPL option
defined in (draft-hui-6man-rpl-option-01) carried in the hop by
hop header. This part will be more detailed in the next revision (see  
for example ticket
64)

JP.

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Alexandru Petrescu <[email-masked]>
Date: Sun, 25 Jul 2010 11:23:18 +0200

Le 25/07/2010 10:44, JP Vasseur a écrit :
>>> RPL uses a hop-by-hop IPv6 header to detect possible loops within
>>> a DODAG. Each data packet includes the Rank of the transmitter.
>>
>> What is a 'data packet'?
>
> message such as a DIS.
>> Do you mean I have to modify every application to include that IPv6
>> header to insert new options?
>>
>
>  field (DS, ...), but also extended headers, ...
>
>  the RPL option defined in (draft-hui-6man-rpl-option-01) carried in
> the hop by hop header. This part will be more detailed in the next
> revision (see for example ticket 64)

Who adds that option field? ("Each data packet includes the Rank of the 
transmitter.") - the application or RPL?

Alex

>> _______________________________________________ Roll mailing list
>> [email-masked] <mailto:[email-masked]>

---

From: JP Vasseur <[email-masked]>
Date: Sun, 25 Jul 2010 11:28:47 +0200

On Jul 25, 2010, at 11:23 AM, Alexandru Petrescu wrote:

> Who adds that option field? ("Each data packet includes the Rank of  
> the transmitter.") - the application or RPL?

RPL ! The application does not know about the rank of course.

JP.

---

From: Alexandru Petrescu <[email-masked]>
Date: Sun, 25 Jul 2010 11:37:35 +0200

Le 25/07/2010 11:28, JP Vasseur a écrit :
>>>>> RPL uses a hop-by-hop IPv6 header to detect possible loops
>>>>> within a DODAG. Each data packet includes the Rank of the
>>>>> transmitter.
>>>>
>>>> What is a 'data packet'?
>>>
>>> An IPv6 packet carrying user data as opposed to a routing
>>> control message such as a DIS.
>>>
>>>> Do you mean I have to modify every application to include that
>>>> IPv6 header to insert new options?
>>>>
>>>
>>> Your application builds the IP packet and allows setting IPv6
>>> header field (DS, ...), but also extended headers, ...
>>>
>>> In RPL, datapath validation and loop detection is performed by
>>> adding the RPL option defined in (draft-hui-6man-rpl-option-01)
>>> carried in the hop by hop header. This part will be more detailed
>>> in the next revision (see for example ticket 64)
>>

RPL touches every data packet?  I would oppose that.  In some
exceptional cases - maybe, but not always.  Let the app be end-to-end,
in most cases at least.

You're mentioning a draft-hui about hbh - would RPL advance without that 
document adopted as WG item, progressed, etc.

Would the MEssage Authentication Code cover that HbH header?  How? 
Which fields are initialized and which are computed first?  Or would AH 
cover it?

Alex

>
> JP.
>
>>
>> Alex
>>
>>>
>>> JP.
>>>
>>>> E.g. if I run http and TCP - do I have to modify the TCP stack
>>>> to include this Rank on each data packet?
>>>>
>>>> _______________________________________________ Roll mailing
>>>> list [email-masked] <mailto:[email-masked]>

---

From: JP Vasseur <[email-masked]>
Date: Sun, 25 Jul 2010 11:41:48 +0200

On Jul 25, 2010, at 11:37 AM, Alexandru Petrescu wrote:

> You're mentioning a draft-hui about hbh - would RPL advance without  
> that document adopted as WG item, progressed, etc.
>

The document has been approved as WG document in 6man. As you know the  
publishing window will reopen
very soon now. So you will see it as a WG ID soon.

> Which fields are initialized and which are computed first?  Or would  
> AH cover it?
>

Leave it for all your questions about security.

JP.