Subject: [Roll] Closing issue#56: Transit and Target address mismatch

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 9 Jul 2010 16:57:47 +0200

Hi Mathilde:

Based on the thread we have had I think that the text must clarify that:

- The R bit in PIO is used  as in RFC3775 to indicate a (global/ULA) address as opposed to a prefix. 
- The prefix is still valid for the purpose of autoconf when the R bit is set.
- The address in the PIO can be used as transit parent by the children but is not necessarily on link for the children.
- The router that it advertises an address as parent in PIO must also advertise that address as target in a DAO for the route recursion to complete.
- An address that is advertised as target in a DAO must be collocated or reachable onlink by the parent that is indicated in the associated transit information.
- A new flag in the transit information qualifies a target address that is behind a router, either as an attached host or installed on another interface. The router is the tunnel endpoint for such address.

Will that be enough to close 56?

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of roll
> issue tracker
> Sent: Tuesday, July 06, 2010 1:41 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: [Roll] [roll] #56: Transit and Target address mismatch
> 
> #56: [Roll] Transit and Target address mismatch
> -----------------------------+------------------------------------------
> -----------------------------+----
>  Reporter:  jpv@…            |       Owner:  wintert@…
>      Type:  enhancement      |      Status:  new
>  Priority:  minor            |   Milestone:
> Component:  rpl              |     Version:
>  Severity:  In WG Last Call  |    Keywords:
> -----------------------------+------------------------------------------
> -----------------------------+----
>  Hi All,
> 
>  Let’s consider the storing mode in a simple topology AàBàR (à mark the
> parent relationship). Let’s also assume that A has a prefix ‘Ap’ and a  global
> address ‘Ag’ to advertise.
>  In this example we have:
>  - A sends DAO with “target Ag, Ap, transit B”
>  - B sends DAO with “target Bg, transit R” together with the information  from
> A, i.e. “target Ag, Ap, transit B”
> 
>  Then R recombines the information to get the route to for example Ap  (Target
> Ap, transit B, target Bg, transit R)  For this to work, transit B and target Bg need
> to be matched. How can this  be done? Does it mean that the transit parent
> address has to be a global  address? This would imply that we use global
> addresses in the routing  header. However 6man-rpl-routing-header says:
>  “When processing the Type 4 Routing header, a router MUST drop the packet
> if the next entry is not on-link”
>  As global addresses have to be off-link in NBMA network like 802.15.4, I  see a
> problem…
> 
>  Can you please clarify how addresses are supposed to be used in this  source-
> routing scenario.
> 
>  Thanks,
>  Mathilde
> 
> --
> Ticket URL: <https://svn.tools.ietf.org/wg/roll/trac/ticket/56>
> roll <http://tools.ietf.org/wg/roll/>
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: "Mathilde Durvy (mdurvy)" <[email-masked]>
Date: Mon, 12 Jul 2010 10:08:30 +0200

Hi Pascal,

This sounds good!

Few minor comments:
- The R bit in PIO is used as in RFC3775 to indicate a (global/ULA) address as opposed to a prefix. 
[M] OK
- The prefix is still valid for the purpose of autoconf when the R bit is set.
[M] OK
- The address in the PIO can be used as transit parent by the children but is not necessarily on link for the children.
[M] Is it really a "can be used" or a "MUST"?
- The router that advertises an address as parent in PIO must also advertise that address as target in a DAO for the route recursion to complete.
[M] OK
- An address that is advertised as target in a DAO must be collocated or reachable onlink by the parent that is indicated in the associated transit information.
[M] Maybe we want to mention that when a node receives a DAO with a transit address equal to its address it must remember the target as on-link?
- A new flag in the transit information qualifies a target address that is behind a router, either as an attached host or installed on another interface. The router is the tunnel endpoint for such address.
[M] Yes, I guess this would make sense

Will that be enough to close 56?
[M] Yes, thanks a lot for your help in clarifying these points!

Best,
Mathilde

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 12 Jul 2010 11:07:05 +0200

Hi Mathilde

> [M] Is it really a "can be used" or a "MUST"?

[Pascal] The parent in the transit MUST be picked from a parent PIO.  But a node can ignore the PIO if that parents has multiple PIOs or if the node does not want to ise that parent as DAO parent. So we can place a MUST but we need to reverse the sentence.

> - The router that advertises an address as parent in PIO must also advertise
> that address as target in a DAO for the route recursion to complete.
> [M] OK
> - An address that is advertised as target in a DAO must be collocated or
> reachable onlink by the parent that is indicated in the associated transit
> information.
> [M] Maybe we want to mention that when a node receives a DAO with a transit
> address equal to its address it must remember the target as on-link?
[Pascal] 
[Pascal] Sure. This is really when placing a SLLAO in the DAO would have made a lot of sense. Now the parent has to support NS/NA.

> - A new flag in the transit information qualifies a target address that is behind a
> router, either as an attached host or installed on another interface. The router
> is the tunnel endpoint for such address.
[Pascal]  : )