Subject: [Roll] Local instance id

From: "Reddy, Joseph" <[email-masked]>
Date: Tue, 13 Jul 2010 18:44:05 -0500

Hi,

A question on the local instance ID

It used to be that a node can only join one DoDAG within an RPL instance 
Now, with the concept of local instances, my understanding is that different DoDAG's can have the same local instance identifier ( since they are allocated without any coordination )

In this situation, can a node join two DoDAG's with the same local instance identifier but different DoDAG ID's ? I assume yes, since they two actually different instances that happen to have same identifier

If so, how does a router know which on which of the two DoDAG's it should forward a data packet that has this particular instance id in the flow label ?

-Thanks, Joseph

---

From: Jonathan Hui <[email-masked]>
Date: Tue, 13 Jul 2010 17:14:18 -0700

Joseph,

Local instances are also parameterized on the DODAGID.  Section 4.1 of rpl-10 describes how the RPLInstanceID carried in data packets indicates which of the IPv6 header addresses (source or destination) to use for the DODAGID.

--
Jonathan Hui

On Jul 13, 2010, at 4:44 PM, Reddy, Joseph wrote:

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll