Subject: [Roll] Option Len Field mismatch in metric doc.

From: "Ajay Kumar (ajakuma2)" <[email-masked]>
Date: Mon, 26 Jul 2010 19:48:20 +0530

Hi WG,

I see following text in roll-metric draft.

0 1 2 3

0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
...

| Type=2 | Option Len | Routing Metric/Constraint objects

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
...

Figure 1: DAG Metric Container format

This is from core RPL spec.

The Routing Metric/Contraints objects have a common format consisting

of one or more 8-bit words with a common header:

0 1 2 3

0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

|Routing-MC-Type|Res|R|G| A |O|C| Object Length (bytes) |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

| |

// (object body) //

| |

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

How can the Length field in Metric Container Format accommodate Length
specified in Common header that follows?

I believe the value in second field cannot be greater than 253 leaving
out(Routin-MC-Type & Flags). 

Please ignore of it has already been pointed out.

Regards,

Ajay

---

From: JP Vasseur <[email-masked]>
Date: Mon, 26 Jul 2010 17:56:47 +0200

Hi Ajay,

On Jul 26, 2010, at 4:18 PM, Ajay Kumar (ajakuma2) wrote:

> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
> + ...
> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- 
> + ...
> How can the Length field in Metric Container Format accommodate  
> Length specified in Common header that follows?
>
> I believe the value in second field cannot be greater than 253  
> leaving out(Routin-MC-Type & Flags).
>

Good catch, thanks. The change in the RPL ID has not been reflected in  
the metric-ID. We changed it in the RPL
spec (this is why we can have more than one container) but not yet in  
the metric-ID. It will be fixed in metric-ID
version 9. Thanks for the comments.

>
> Regards,
> Ajay
>
>
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: <[email-masked]>
Date: Mon, 26 Jul 2010 18:29:02 +0200

Hello Ajay,
 
Good catch!
The RPL option length was recently adjusted to express length in bytes (as opposed to in 8 bytes chunks) so, definitely, the DAG Metric Container length field (expressing length in bytes) does not need to be more than 8 bits long.
We'll take this into account for -09.
Thanks
 
Dominique

________________________________

De : [email-masked] [mailto:[email-masked]] De la part de Ajay Kumar (ajakuma2)
Envoyé : lundi 26 juillet 2010 16:18
À : [email-masked]
Objet : [Roll] Option Len Field mismatch in metric doc.

Hi WG,

0 1 2 3

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ ...

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ ...

0 1 2 3

| |

// (object body) //

| |

How can the Length field in Metric Container Format accommodate Length specified in Common header that follows?

I believe the value in second field cannot be greater than 253 leaving out(Routin-MC-Type & Flags). 

Regards,

Ajay