Subject: Re: [Roll] Section 3.4 in RPL-10

From: Mukul Goyal <[email-masked]>
Date: Tue, 20 Jul 2010 02:57:18 -0500 (CDT)

Hi Phil

"...In the case of a storing
network, P2P packets travel upwards towards a DODAG Root until they
reach a common ancestor with the destination, at which point they
travel down to the destination."

Not quite. Since the DAO parent set is just a subset of DODAG parent set, the first common ancestor (of source and destination) may not know about the destination. Some common ancestor would know but we dont know which one.

Also, the packet may travel upwards in a manner that it does not reach the first common ancestor that does know about the destination.

Thanks
Mukul 

----- Original Message -----
From: "Philip Levis" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>
Cc: "roll" <[email-masked]>
Sent: Monday, July 19, 2010 7:45:15 PM
Subject: Re: [Roll] Section 3.4 in RPL-10

On Jul 19, 2010, at 11:55 AM, Mukul Goyal wrote:

> Here is a quote from Section 3.4 of RPL-10
>
> "Any given RPL Instance is either
>
>
>
> Winter, et al. Expires December 30, 2010
> [Page 15]
>
> Internet-Draft draft-ietf-roll-rpl-10 Jun
> 2010
>
>
>    storing or non-storing. In both cases, P2P packets travel up to a
>    DODAG Root then down to the final destination (unless the
> destination
>    is on the upward route).
> "
>
> I dont think that a P2P packet necessarily always travels to the
> DODAG root in storing mode. It is possible that it turns around at
> a common non-root ancestor of the source and the destination.

Mukul,

You're right. I'd suggest removing the last sentence and replacing it
with:

"In the case of a non-storing network, P2P packets travel up to a
DODAG Root then down to the final destination (unless the destination
is on the upward path to the DODAG Root). In the case of a storing
network, P2P packets travel upwards towards a DODAG Root until they
reach a common ancestor with the destination, at which point they
travel down to the destination."

What do you think?

Phil

---

From: JP Vasseur <[email-masked]>
Date: Tue, 20 Jul 2010 11:44:27 +0200

Hi Phil and Mukul,

On Jul 20, 2010, at 9:57 AM, Mukul Goyal wrote:

> Not quite. Since the DAO parent set is just a subset of DODAG parent  
> set, the first common ancestor (of source and destination) may not  
> know about the destination. Some common ancestor would know but we  
> dont know which one.

We'll make it clearer. Note that there are many other clarifications  
to be done in Ticket #70.

>
> Also, the packet may travel upwards in a manner that it does not  
> reach the first common ancestor that does know about the destination.
>

JP.

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: "JP Vasseur" <[email-masked]>
Date: Tue, 20 Jul 2010 04:44:27 -0500

WARNING: contains banned part

Subject: Re: [Roll] Section 3.4 in RPL-10
From: "JP Vasseur" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>, "Philip Levis" <[email-masked]>
Cc: "roll WG" <[email-masked]>
Date: Tue, 20 Jul 2010 04:44:27 -0500

Hi Phil and Mukul,

JP.