Subject: [Roll] Nit: message diagrams, addresses missing

From: Alexandru Petrescu <[email-masked]>
Date: Sun, 25 Jul 2010 02:04:13 +0200

> The aim of this section is to describe RPL in the spirit of
> [RFC4101].

I do like that RFC4101 "Writing Protocol Models" and I like it is 
mentioned here.  However, I feel that its spirit is a bit different.  It 
gives 4 example protocol descriptions: each contains a message exchange 
diagram like this:

>  Client                                      Server
>    ------                                      ------
>    DCCP-Request            ->
>    [Ports, Service,
>    Features]
>                            <-           DCCP-Response
>                                            [Features,
>                                               Cookie]
>    DCCP-Ack                ->
>    [Features,
>    Cookie]

It's but an example but the arrows show the messages being exchanged in 
certain direction, they have names (DCCP-Request).  This is very useful 
for understanding the protocol; it's also useful for the designer!

I miss such diagram from RPL, I would like to see.

I could even try to sketch some if you accepted.

Also, most examples have addresses painted on them - I miss this too in 
RPL - real addresses (be them the 2001:db8 documentation prefix).

Alex

---

From: JP Vasseur <[email-masked]>
Date: Sun, 25 Jul 2010 10:28:34 +0200

Hi,

On Jul 25, 2010, at 2:04 AM, Alexandru Petrescu wrote:

> mentioned here.  However, I feel that its spirit is a bit  
> different.  It gives 4 example protocol descriptions: each contains  
> a message exchange diagram like this:
>
>> Client                                      Server
>>   ------                                      ------
>>   DCCP-Request            ->
>>   [Ports, Service,
>>   Features]
>>                           <-           DCCP-Response
>>                                           [Features,
>>                                              Cookie]
>>   DCCP-Ack                ->
>>   [Features,
>>   Cookie]
>
> It's but an example but the arrows show the messages being exchanged  
> in certain direction, they have names (DCCP-Request).  This is very  
> useful for understanding the protocol; it's also useful for the  
> designer!
>
> Also, most examples have addresses painted on them - I miss this too  
> in RPL - real addresses (be them the 2001:db8 documentation prefix).
>

There are many ways to provide an overview of the protocol. You could  
either use arrows where there are lots of messages exchanges (3 way  
hand-check, ...).
Here is another example from RFC5440:
                +-+-+                 +-+-+
                |PCC|                 |PCE|
                +-+-+                 +-+-+
                  |                     |
                  | Open msg            |
                  |--------             |
                  |        \   Open msg |
                  |         \  ---------|
                  |          \/         |
                  |          /\         |
                  |         /  -------->|
                  |        /            |
                  |<------     Keepalive|
                  |             --------|
                  |Keepalive   /        |
                  |--------   /         |
                  |        \/           |
                  |        /\           |
                  |<------   ---------->|
                  |                     |

But in the RPL case, these are pretty straightforward and we preferred  
to describe it with words and can you can see there is a lot of text  
there already.

Thanks.

JP.

> Alex
>
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Alexandru Petrescu <[email-masked]>
Date: Sun, 25 Jul 2010 10:37:14 +0200

Le 25/07/2010 10:28, JP Vasseur a écrit :
>> gives 4 example protocol descriptions: each contains a message
>> exchange diagram like this:
>>
>>> Client Server
>>> ------ ------
>>> DCCP-Request ->
>>> [Ports, Service,
>>> Features]
>>> <- DCCP-Response
>>> [Features,
>>> Cookie]
>>> DCCP-Ack ->
>>> [Features,
>>> Cookie]
>>
>> useful for understanding the protocol; it's also useful for the designer!
>>

That is good!  IT shows a notion of time.

> to describe it with words and can you can see there is a lot of text

I prefer to think a picture is worth thousand words...

I think this is missing from many otherwise good drafts and RFCs which 
could have made them better.

It's up to you.

Alex

>> [email-masked] <mailto:[email-masked]>