Subject: [Roll] Comment Section 7.4

From: JP Vasseur <[email-masked]>
Date: Thu, 15 Jul 2010 13:14:40 +0200

Section 7.4

7.4.  DODAG Selection

    The DODAG selection is implementation and OF dependent.  Nodes  
SHOULD
    prefer to join DODAGs for RPLInstanceIDs advertising OCPs and
    destinations compatible with their implementation specific
    objectives.

I would advocate for a MUST there.

Thought?

JP.

---

From: Yoav Ben-Yehezkel <[email-masked]>
Date: Thu, 15 Jul 2010 14:30:26 +0300

I understand why joining based on RPLInstanceIDs should be must – this is an
application requirement.

However, being able to support a certain OCP in an RPLInstance that is not
required by my application, seems a little confusing to me.

Also, I’m not sure - where are “destinations compatible with their …”
advertised?

Thanks,

Yoav

*From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *JP
Vasseur
*Sent:* Thursday, July 15, 2010 2:15 PM
*To:* ROLL WG
*Subject:* [Roll] Comment Section 7.4

Section 7.4

7.4.  DODAG Selection

   The DODAG selection is implementation and OF dependent.  Nodes SHOULD

   objectives.

Thought?

JP.

---

From: "Mathilde Durvy (mdurvy)" <[email-masked]>
Date: Thu, 15 Jul 2010 14:46:37 +0200

+1

But would remove the "and destinations" as they are not part of the policy.

Best,

Mathilde

From: [email-masked] [mailto:[email-masked]] On Behalf Of JP
Vasseur
Sent: jeudi, 15. juillet 2010 13:15
To: ROLL WG
Subject: [Roll] Comment Section 7.4

Section 7.4

7.4.  DODAG Selection

Thought?

JP.

---

From: JP Vasseur <[email-masked]>
Date: Thu, 15 Jul 2010 14:50:26 +0200

On Jul 15, 2010, at 2:46 PM, Mathilde Durvy (mdurvy) wrote:

> +1
> But would remove the “and destinations” as they are not part of the  
> policy.
>

Yes

> Best,
> Mathilde
>
> From: [email-masked] [mailto:[email-masked]] On Behalf  
> Of JP Vasseur

---

From: Richard Kelsey <[email-masked]>
Date: Thu, 15 Jul 2010 10:32:41 -0400

> From: JP Vasseur <[email-masked]>
> Date: Thu, 15 Jul 2010 13:14:40 +0200
> Section 7.4
> 
> 7.4.  DODAG Selection
> 

I don't think there is any point in this sentence, whether
it is a SHOULD or a MUST.  Given that the "implementation
specific objectives" are entirely implementation specific,
what would it mean to require that the node act compatibly
with them?  This sentence is equivalent to:
  Implementations SHOULD/MUST act in a fashion
  compatible with their objectives.
While I would hope this to be true, we cannot meaningfully
require it.
                          -Richard Kelsey

---

From: JP Vasseur <[email-masked]>
Date: Fri, 16 Jul 2010 09:25:29 +0200

Hi Richard,

> While I would hope this to be true, we cannot meaningfully

That was my point. We are stating the obvious so we should either:
1) Remove the sentence completely.
2) Make it a MUST

Agree ?

I guess that you choose 1).

Others ?

---

From: JP Vasseur <[email-masked]>
Date: Fri, 16 Jul 2010 09:26:31 +0200

Hi,

On Jul 15, 2010, at 1:30 PM, Yoav Ben-Yehezkel wrote:

> I understand why joining based on RPLInstanceIDs should be must –  
> this is an application requirement.
>
> However, being able to support a certain OCP in an RPLInstance that  
> is not required by my application, seems a little confusing to me.
>
> Also, I’m not sure - where are “destinations compatible with their  
> …” advertised?
>

Yes, please see the previous reply on the list. Tell us what you prefer.

Thanks.

JP.

> Sent: Thursday, July 15, 2010 2:15 PM
> To: ROLL WG

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 16 Jul 2010 11:45:25 +0200

I'd remove the uppercase and say that the application is expected to
have some out of scope policy to decide which OCP/OF it should join, in
terms such as white list, black list, preference and maximum number.

Pascal

> -----Original Message-----
Of JP
> Vasseur
> Sent: Friday, July 16, 2010 9:25 AM
> To: ROLL WG; Richard Kelsey
> Subject: Re: [Roll] Comment Section 7.4
> 
> Hi Richard,
> 
> >> Date: Thu, 15 Jul 2010 13:14:40 +0200 Section 7.4
> >>
> >> 7.4.  DODAG Selection
> >>
> > I don't think there is any point in this sentence, whether it is a
> > SHOULD or a MUST.  Given that the "implementation specific
objectives"
> > are entirely implementation specific, what would it mean to require
> > that the node act compatibly with them?  This sentence is equivalent
> > to:
> >  Implementations SHOULD/MUST act in a fashion  compatible with their
> > objectives.
> > While I would hope this to be true, we cannot meaningfully require
it.
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Yoav Ben-Yehezkel <[email-masked]>
Date: Fri, 16 Jul 2010 17:24:43 +0300

Thanks JP –

I’m in favor of leaving something about DODAG selection. Even if it’s almost
straight-forward, as an implementer I would expect to have something about
it.

Are there restrictions on how not to select the DODAG that should be added?

Thanks,

Yoav

*From:* JP Vasseur [mailto:[email-masked]]
*Sent:* Friday, July 16, 2010 10:27 AM
*To:* Yoav Ben-Yehezkel
*Cc:* ROLL WG
*Subject:* Re: [Roll] Comment Section 7.4

Hi,

  I understand why joining based on RPLInstanceIDs should be must – this is
an application requirement.

Thanks.

JP.

  Thanks,

Yoav

Section 7.4

7.4.  DODAG Selection

   objectives.

Thought?

JP.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 16 Jul 2010 16:28:29 +0200

Hi Yoav:

A node that does not know the OCP might misbehave and generate
misleading routing information. So it can only join as a leaf. I think
we have text on that.

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Yoav Ben-Yehezkel
Sent: Friday, July 16, 2010 4:25 PM
To: JP Vasseur
Cc: ROLL WG
Subject: Re: [Roll] Comment Section 7.4

Thanks JP - 

I'm in favor of leaving something about DODAG selection. Even if it's
almost straight-forward, as an implementer I would expect to have
something about it. 

Are there restrictions on how not to select the DODAG that should be
added? 

Thanks,

Yoav

From: JP Vasseur [mailto:[email-masked]] 
Sent: Friday, July 16, 2010 10:27 AM
To: Yoav Ben-Yehezkel
Cc: ROLL WG
Subject: Re: [Roll] Comment Section 7.4

Hi,

I understand why joining based on RPLInstanceIDs should be must - this
is an application requirement.

However, being able to support a certain OCP in an RPLInstance that is
not required by my application, seems a little confusing to me.

Also, I'm not sure - where are "destinations compatible with their ..."
advertised?

Thanks.

JP.

Thanks,

Yoav

From: [email-masked] [mailto:[email-masked]] On Behalf Of
JP Vasseur
Sent: Thursday, July 15, 2010 2:15 PM
To: ROLL WG
Subject: [Roll] Comment Section 7.4

Section 7.4

7.4.  DODAG Selection

Thought?

JP.

---

From: JP Vasseur <[email-masked]>
Date: Fri, 16 Jul 2010 16:31:02 +0200

Hi,

On Jul 16, 2010, at 4:28 PM, Pascal Thubert (pthubert) wrote:

> misleading routing information. So it can only join as a leaf. I  
> think we have text on that.

Right.

> Of Yoav Ben-Yehezkel
> I’m in favor of leaving something about DODAG selection. Even if  
> it’s almost straight-forward, as an implementer I would expect to  
> have something about it.

---

From: JP Vasseur <[email-masked]>
Date: Fri, 16 Jul 2010 16:31:26 +0200

> terms such as white list, black list, preference and maximum number.

Great: this is already covered in Section 16 :)

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 16 Jul 2010 16:59:12 +0200

Pretty much:

The text is actually present for the metrics and instance ID. Maybe we
could add similar wording for the OCP though it seems quite obvious...

  o  RPLInstanceID [DIO message, in DIO base message].  Although the
      RPLInstanceID must be configured on the DODAG root, it must also
      be configured as a policy on every node in order to determine
      whether or not the node should join a particular DODAG.  Note that
      a second RPLInstance can be configured on the node, should it
      become root of a floating DODAG.

   o  Objective Code Point (OCP)

   o  List of supported metrics: [I-D.ietf-roll-routing-metrics]
      specifies a number of metrics and constraints used for the DODAG
      formation.  Thus a RPL implementation should allow configuring the
      list of metrics that a node can accept and understand.  If a DIO
      is received with a metric and/or constraint that is not understood
      or supported, as specified in Section 7.5, the node would join as
      a leaf node.

Pascal

> Sent: Friday, July 16, 2010 4:31 PM
> To: Pascal Thubert (pthubert)
> Cc: ROLL WG; Richard Kelsey
> > have some out of scope policy to decide which OCP/OF it should join,
> > in terms such as white list, black list, preference and maximum
> > number.
>