Subject: [Roll] Section 3.4 in RPL-10

From: Mukul Goyal <[email-masked]>
Date: Mon, 19 Jul 2010 13:55:38 -0500 (CDT)

Here is a quote from Section 3.4 of RPL-10
 
"Any given RPL Instance is either

Winter, et al.          Expires December 30, 2010              [Page 15]
 
Internet-Draft           draft-ietf-roll-rpl-10                 Jun 2010

   storing or non-storing.  In both cases, P2P packets travel up to a
   DODAG Root then down to the final destination (unless the destination
   is on the upward route).
"

I dont think that a P2P packet necessarily always travels to the DODAG root in storing mode. It is possible that it turns around at a common non-root ancestor of the source and the destination.

Thanks
Mukul

---

From: JP Vasseur <[email-masked]>
Date: Mon, 19 Jul 2010 22:24:58 +0200

Thanks Mukul, I had caught this one in the detailed review that I sent  
out last week (ticket #70):

3.4.  Downward Routes and Destination Advertisement

    RPL uses Destination Advertisement Object (DAO) messages to  
establish
    downward routes from DODAG roots.
JP> Not just from DODAG roots ...
DAO messages are an optional
    feature for applications that require P2MP or P2P traffic.  RPL
    supports two modes of downward traffic: storing (fully stateful) or
    non-storing (fully source routed).  Any given RPL Instance is either



    storing or non-storing.  In both cases, P2P packets travel up to a
    DODAG Root
JP> Or a common ancestor in the case of storing nodes
then down to the final destination (unless the destination
    is on the upward route).
JP> with regards to the last sentence, indicate that this is with the  
default
mode of RPL specified in this specification.
Cheers.

JP.

On Jul 19, 2010, at 8:55 PM, Mukul Goyal wrote:

> I dont think that a P2P packet necessarily always travels to the  
> DODAG root in storing mode. It is possible that it turns around at a  
> common non-root ancestor of the source and the destination.
>
> Thanks
> Mukul
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Philip Levis <[email-masked]>
Date: Mon, 19 Jul 2010 17:45:15 -0700

On Jul 19, 2010, at 11:55 AM, Mukul Goyal wrote:

> DODAG root in storing mode. It is possible that it turns around at  
> a common non-root ancestor of the source and the destination.

Mukul,

You're right. I'd suggest removing the last sentence and replacing it  
with:

"In the case of a non-storing network, P2P packets travel up to a  
DODAG Root then down to the final destination (unless the destination  
is on the upward path to the DODAG Root). In the case of a storing  
network, P2P packets travel upwards towards a DODAG Root until they  
reach a common ancestor with the destination, at which point they  
travel down to the destination."

What do you think?

Phil

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 20 Jul 2010 08:59:41 +0200

This text troubles me a bit. 

There is a confusion between P2P in the sense of node to node (as
opposed to P2MP and MP2P) and P2P in the sense of the optimization that
Mukul, Jerry, Anders and others are working on. I'd like to separate the
2. We can indicate that additional P2P optimizations are on the works
but with the main spec, the P2P goes up to the common parent and then
down in storing, and up to the root and then down in non storing.
Extending Phil's text:

"In the case of a non-storing network, P2P packets travel up to a DODAG
Root then down to the final destination (unless the destination is on
the upward path to the DODAG Root). In the case of a storing network,
P2P packets travel upwards towards a DODAG Root until they reach a
common ancestor with the destination, at which point they travel down to
the destination. Additional route optimization like [non normative ref
to Mukul's draft] that may enable shortcuts are out of scope for this
specification."

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of Philip
> Levis
> Sent: Tuesday, July 20, 2010 2:45 AM
> To: Mukul Goyal
> Cc: roll
> Subject: Re: [Roll] Section 3.4 in RPL-10
> 
> 
DODAG
> > root in storing mode. It is possible that it turns around at a
common
> > non-root ancestor of the source and the destination.
> 
> Mukul,
> 
DODAG Root
> then down to the final destination (unless the destination is on the
upward path
> to the DODAG Root). In the case of a storing network, P2P packets
travel
> upwards towards a DODAG Root until they reach a common ancestor with
the
> destination, at which point they travel down to the destination."
> 
> What do you think?
> 
> Phil
>

---

From: Yoav Ben-Yehezkel <[email-masked]>
Date: Tue, 20 Jul 2010 10:07:30 +0300

Hi Pascal,

I agree to this text, but there may be some ambiguity in the following
para.:
"... Additional route optimization like [non normative ref to Mukul's
draft] that may enable shortcuts are out of scope for this specification."

One may understand that these optimizations cannot be used with RPL.

May I suggest a slight modification to this - something in the lines of:
"... Additional RPL route optimization such as [non normative ref to
Mukul's draft] that may enable P2P packet travel shortcuts can be used in
complementary to the P2P method described above."

Best regards,
Yoav

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Pascal Thubert (pthubert)
Sent: Tuesday, July 20, 2010 10:00 AM
To: Philip Levis; Mukul Goyal
Cc: roll
Subject: Re: [Roll] Section 3.4 in RPL-10

Pascal

Of Philip
DODAG
common
DODAG Root
upward path
travel
the

---

From: Yoav Ben-Yehezkel <[email-masked]>
Date: Tue, 20 Jul 2010 10:22:47 +0300

Maybe even further clarification of (I'm not sure "shortcuts" is indeed
true - it's more about good enough criteria and "reactive-ness" of routing
formation):
"... Additional on-demand reactive RPL route formation such as [non
normative ref to Mukul's draft] can be used in complementary to the P2P
method described above."

-----Original Message-----
From: Yoav Ben-Yehezkel [mailto:[email-masked]]
Sent: Tuesday, July 20, 2010 10:08 AM
To: 'Pascal Thubert (pthubert)'; 'Philip Levis'; 'Mukul Goyal'
Cc: 'roll'
Subject: RE: [Roll] Section 3.4 in RPL-10

Hi Pascal,

Best regards,
Yoav

-----Original Message-----

Pascal

Of Philip
DODAG
common
DODAG Root
upward path
travel
the

---

From: JP Vasseur <[email-masked]>
Date: Tue, 20 Jul 2010 11:43:25 +0200

> normative ref to Mukul's draft] can be used in complementary to the  

We do not need to reference other in progress work. Just specify what  
the core specification does.

> Of