Subject: [Roll] IPR Disclosure: Rene Struik's Statement of IPR relating to draft-ietf-roll-rpl-10 and belonging to Certicom Corporation

From: IETF Secretariat <[email-masked]>
Date: Thu, 15 Jul 2010 15:13:38 -0700 (PDT)

Dear Pascal Thubert, Tim Winter, ROLL Team:

An IPR disclosure that pertains to your Internet-Draft entitled "RPL: IPv6
Routing Protocol for Low power and Lossy Networks" (draft-ietf-roll-rpl) was
submitted to the IETF Secretariat on 2010-07-12 and has been posted on the "IETF
Page of Intellectual Property Rights Disclosures"
(https://datatracker.ietf.org/ipr/1356/). The title of the IPR disclosure is
"Rene Struik's Statement of IPR relating to draft-ietf-roll-rpl-10 and belonging
to Certicom Corporation."

The IETF Secretariat

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 19 Jul 2010 17:14:38 +0200

Hmmm... interesting to hear there is an IPR disclosure relating to the
security aspects in draft-ietf-roll-rpl-10.

Earlier this year (January) we discussed about potential IPR on the
Security DT draft.  At that time the view was absence of known IPR in
that Security DT draft:
http://tools.ietf.org/html/draft-tsao-roll-security-framework-02

What does the Security DT think about the IPR disclosure relating to
security in the RPL draft?

Is the security part of RPL coming from the Security DT text?  When did
this happen and in what manner?  (I suppose the output of the Security
DT is subject to WG accepting it... yet I don't hear anything about this
acceptance.)

Who are the members of the Security DT?  Last time I heard was about the
names in the attached message... is that list still final or has it
evolved since?

Alex

Le 16/07/2010 00:13, IETF Secretariat a écrit :
> An IPR disclosure that pertains to your Internet-Draft entitled "RPL:
> IPv6 Routing Protocol for Low power and Lossy Networks"
> (draft-ietf-roll-rpl) was submitted to the IETF Secretariat on
> 2010-07-12 and has been posted on the "IETF Page of Intellectual
> Property Rights Disclosures"
> (https://datatracker.ietf.org/ipr/1356/). The title of the IPR
> disclosure is "Rene Struik's Statement of IPR relating to
> draft-ietf-roll-rpl-10 and belonging to Certicom Corporation."
>
> The IETF Secretariat
>
>
> _______________________________________________ Roll mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/roll
>

Subject: Re: [Roll] New Design Team to work on RPL Security
From: JP Vasseur <[email-masked]>
To: ROLL WG <[email-masked]>
Cc: Adrian Farrel <[email-masked]>
Date: Tue, 2 Feb 2010 09:04:56 +0100
List-Id: Routing Over Low power and Lossy networks <roll.ietf.org>

Dear all,

On Jan 26, 2010, at 12:22 AM, JP Vasseur wrote:

> Dear all,
>
> This is to announce the formation of a new RPL Security Design Team,  
> made of the following members:
> * Tzeta Tsao
> * Roger Alexander
> * Dave Ward
> * Phil Levis
>

Kris Pister kindly accepted to help there. Thanks Kris.
The final DT is thus:
* Tzeta Tsao,
* roger Alexander
* Dave Ward
* Phil Levis
* Kris Pister

Thanks.

JP.

> Thanks to the four of you for volunteering.
>
> Rene Struik will help the team as our security advisor.
>
> As a reminder:
>
> * The work produced by a Design Team has no special status in the WG  
> and is subject to WG consensus as any other individual submission
> * We ask the Design Team to request for input from the WG and to  
> provide regular updates on the progress: please send input requests  
> to the mailing list, post regular updates of the document to get a  
> chance to everybody to comment, ...
> * All: please provide input to the Design Team and copy the mailing  
> list.
>
> Charter
> ######
>
> The charter of the security design team is to produce a Security  
> Framework document and the potential routing security extensions to  
> RPL in the context of that framework (or document how existing  
> routing mechanisms should be used). With regards to the framework,  
> the Security DT may choose to use http://www.ietf.org/id/draft-tsao-roll-security-framework-01.txt 
>  as a starting point (the document has been presented and discussed  
> at the last two Working Group meetings).
>
> Please make sure to be aligned with the ROLL terminology document  
> and provide input to their authors should new terms be introduced.
>
> Milestones
> #########
>
> Milestones are pretty aggressive.
>
> Feb 10: produce a first draft of Security Framework to be submitted  
> to the WG for WG adoption
> Feb 29: produce a first draft on the potential security extensions  
> for RPL as a separate document (that may be incorporated in the core  
> specification of RPL in a second step).
>
> The Design Team may not be dissolved after the completion of the  
> security work for RPL as security in routing within LLN may apply to  
> future specifications produced by the Working Group.
>
> It is strongly encouraged to produce new version as the document  
> progress (each time a substantial change is made to the document).
>
> Thanks.
>
> JP and David.
>
> On Jan 21, 2010, at 9:09 AM, JP Vasseur wrote:
>
>> Dear WG,
>>
>> I think that we can all be very happy with our progress so far with  
>> the core specification of RPL. There are still a few open issues  
>> that we need to solve before IETF-77:
>>
>> * Detailed DAO mechanisms
>> * Detailed mode of operation with multicast
>> * Use of Flow Label versus new IPv6 header
>> * Potential needed optimization such as DAO packing
>> * Editorial work
>> * ...
>>
>> We are on track for all of these.
>>
>> The one item we absolutely need to speed on is security. As you  
>> know there is a security framework document that is still not a WG  
>> document and we now need to start the work on the RPL security  
>> aspects. To that end, we will form a small Design Team with  
>> aggressive milestones, the objective being to have the RPL security  
>> item almost completed by end of Feb, ready for the IETF-77.
>>
>> If you have a good understanding of RPL and routing security  
>> expertise, please go back to me (unicast).
>>
>> Thanks.
>>
>> JP.
>> _______________________________________________
>> Roll mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/roll
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll