Subject: [Roll] Routing DAOs in non-storing DODAGs

From: Richard Kelsey <[email-masked]>
Date: Mon, 12 Jul 2010 22:09:31 -0400

ROLLers,

After some discussion with Pascal and others, I would like
to propose that in non-storing DODAGs that DAOs be sent
directly to the root rather than being processed as RPL
messages at each hop.  The main reason to do this is that
the DAO acks can then also be sent end-to-end rather than
one hop, which avoids some hard-to-handle error cases.
Using end-to-end acks is both simpler and more robust.

In general it makes sense to send the DAOs end-to-end, as in
non-storing DODAGs the intermediate nodes do not make use of
the information in the DAOs.  Sending them directly reduces
the amount of processing on intermediate nodes.

One other change is needed for this to work: in order to
send a DAO to the root, the root's address must be known.
Part two of the proposal is that the DODAGID be required to
be a routable address of the root.  The draft currently
gives this as a possibility; the change is to make it a
requirement.  While this would only be needed for
non-storing DODAGs, it would be cleaner to require it
always.

Thoughts?
                             -Richard Kelsey

---

From: Philip Levis <[email-masked]>
Date: Mon, 12 Jul 2010 19:11:58 -0700

> non-storing DODAGs, it would be cleaner to require it

Seems like a good idea to me. Making the DAO end-to-end to the DODAG Root makes its processing closer to its intent. It also allows DAO-Acks to simply apply to this case.

Phil

---

From: Jonathan Hui <[email-masked]>
Date: Mon, 12 Jul 2010 19:30:57 -0700

I support this change.  It makes the DAO information end-points explicit and processing at intermediate non-storing modes simpler.  It also makes the DAO mechanism for non-storing mode conceptually simpler and easier to describe.

--
Jonathan Hui

On Jul 12, 2010, at 7:09 PM, Richard Kelsey wrote:

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: JP Vasseur <[email-masked]>
Date: Tue, 13 Jul 2010 11:10:23 +0200

On Jul 13, 2010, at 4:30 AM, Jonathan Hui wrote:

>
> I support this change.  It makes the DAO information end-points  
> explicit and processing at intermediate non-storing modes simpler.   
> It also makes the DAO mechanism for non-storing mode conceptually  
> simpler and easier to describe.
>

Fully agree, process of DAO on non-storing had little value anyway.

JP.