Subject: [Roll] What is "meta-data"?

From: Alexandru Petrescu <[email-masked]>
Date: Sun, 25 Jul 2010 00:15:18 +0200

I have difficulty understanding the term "meta-data":

> Each RPL packet has meta-data that associates it with a particular
> RPLInstanceID and therefore RPL Instance.(Section 4).
[...]
> For example, a node may continue to send data packets whose meta-data
> include a Rank that is not INFINITE_RANK yet still advertise
> INFINITE_RANK in its DIOs.

These are the only two occurences of the term "meta" and it is new to
me.  What is the structure of the meta data?  Is it a conceptual data
structure?

(I agree, it may be only me, I had a same issue with "out-of-band" data
and it turned out everybody understood it except me).

Alex

---

From: <[email-masked]>
Date: Sun, 25 Jul 2010 07:51:41 +0100

> I have difficulty understanding the term "meta-data":

http://en.wikipedia.org/wiki/Metadata

---

From: <[email-masked]>
Date: Sun, 25 Jul 2010 08:09:35 +0100

http://en.wikipedia.org/wiki/Out-of-band

> and it turned out everybody understood it except me).

Lloyd Wood
[email-masked]
http://sat-net.com/L.Wood

---

From: Alexandru Petrescu <[email-masked]>
Date: Sun, 25 Jul 2010 09:57:25 +0200

> http://en.wikipedia.org/wiki/Out-of-band

Please don't point me to wikipedia.

I don't understand meta-data in the RPL document, not in wikipedia, 
(wikipedia is a good thing btw.)

Alex

---

From: JP Vasseur <[email-masked]>
Date: Sun, 25 Jul 2010 10:16:16 +0200

> and it turned out everybody understood it except me).

This is to refer to information (here in this case the RPLInstanceID)  
used to route
the packet on the appropriate topology. Here is a pretty good  
discussion about this
term: http://en.wikipedia.org/wiki/Metadata

JP.

>
> Alex
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Alexandru Petrescu <[email-masked]>
Date: Sun, 25 Jul 2010 10:23:56 +0200

Le 25/07/2010 10:16, JP Vasseur a écrit :
>>> Each RPL packet has meta-data that associates it with a
>>> particular RPLInstanceID and therefore RPL Instance.(Section 4).
>> [...]
>>> For example, a node may continue to send data packets whose
>>> meta-data include a Rank that is not INFINITE_RANK yet still
>>> advertise INFINITE_RANK in its DIOs.
>>
>> These are the only two occurences of the term "meta" and it is new
>> to me. What is the structure of the meta data? Is it a conceptual
>> data structure?
>>
>> (I agree, it may be only me, I had a same issue with "out-of-band"
>> data and it turned out everybody understood it except me).
>

Calling it RPLInstanceID would read better (Rather than meta-data).

> used to route the packet on the appropriate topology. Here is a
> pretty good discussion about this term:

No.

For example you have "conceptual structures" which is ok - has fields, 
entries, leads to implementation.  MEta-data is just that: meta talk.

Thanks,

Alex

>
> JP.
>
>>
>> Alex
>>
>> _______________________________________________ Roll mailing list
>> [email-masked] https://www.ietf.org/mailman/listinfo/roll
>
>

---

From: <[email-masked]>
Date: Sun, 25 Jul 2010 09:47:53 +0100

> entries, leads to implementation.  MEta-data is just that: meta talk.

Metadata is generally structured and machine readable.

The wikipedia page gives examples.

Lloyd Wood
[email-masked]

---

From: Alexandru Petrescu <[email-masked]>
Date: Sun, 25 Jul 2010 11:24:52 +0200

> Metadata is generally structured and machine readable.

Metadata or meta-data?

Yes structured - and the spec would say how is it structured - it  doesn't.

(it does for the conceptual data structures which are not the same thing 
as 'meta-data')

Alex

---

From: <[email-masked]>
Date: Sun, 25 Jul 2010 10:50:41 +0100

> Metadata or meta-data?

pe-dant or pedant?

---

From: Alexandru Petrescu <[email-masked]>
Date: Sun, 25 Jul 2010 11:51:52 +0200

> On 25 Jul 2010, at 10:24, Alexandru Petrescu wrote:

Pedant.

Alex