Subject: [Roll] [roll] #67: DODAG Default Path Lifetime

From: "roll issue tracker" <[email-masked]>
Date: Thu, 15 Jul 2010 16:35:41 -0000

#67: DODAG Default Path Lifetime
-----------------------------+----------------------------------------------
 Reporter:  jpv@…            |       Owner:  wintert@…      
     Type:  enhancement      |      Status:  new            
 Priority:  major            |   Milestone:                 
Component:  rpl              |     Version:                 
 Severity:  In WG Last Call  |    Keywords:                 
-----------------------------+----------------------------------------------
 Email sent from Roger July 14

 Subject: [Roll] DODAG Default Path Lifetime
 Date: Wed, 14 Jul 2010 16:02:20 -0400
 From: Alexander, Roger <[email-masked]>
 To: roll <[email-masked]>

 Hi WG,

 I would like to recommend use of a DODAG-defined Default Path Lifetime
 as opposed to the current model in which Path Lifetime is specified per
 prefix using the Transit Information Option.

 As in other routing protocols, such as RIP for example, the validity
 period of an advertised prefix is defined not per destination address
 but is specified through a protocol configuration element such as the
 route-timeout timer. In the same vein, a default validity period can be
 defined for all advertised destinations through a Default Path Lifetime
 specified within the DODAG Configuration option. This default value will
 apply to all advertised prefixes unless otherwise specified using an
 optional Path Lifetime information element within the Transit
 Information option. The benefit of a Default Path Lifetime is that it
 will allow 4-bytes to be saved per advertised DAO destination unless a
 specific, dedicated Path Lifetime is needed for a given prefix. The
 Lifetime for a destination address will continue to apply from the time
 of receipt at a node.

 No additional control bits will be required within the Transit
 Information Option as the presence or absence of the Path Lifetime
 information element can be directly deduced from the value of the Option
 Length.

 Thanks.

 Roger

-- 
Ticket URL: <https://svn.tools.ietf.org/wg/roll/trac/ticket/67>
roll <http://tools.ietf.org/wg/roll/>

---

From: "roll issue tracker" <[email-masked]>
Date: Tue, 20 Jul 2010 13:08:32 -0000

#67: DODAG Default Path Lifetime
-----------------------------+----------------------------------------------
 Reporter:  jpv@…            |        Owner:  wintert@…      
     Type:  enhancement      |       Status:  closed         
 Priority:  major            |    Milestone:                 
Component:  rpl              |      Version:                 
 Severity:  In WG Last Call  |   Resolution:  fixed          
 Keywords:                   |  
-----------------------------+----------------------------------------------
Changes (by jpv@…):

  * status:  new => closed
  * resolution:  => fixed

Comment:

 Email From Pascal Thubert - July 20

 Dear WG:

 There seem to be a consensus on following Roger's proposal. I do favor
 that as well.
 We'll not that the lifetime is used to:
 - advertise no path
 - remove a stale route before the path sequence has incremented by 16.

 We'll also note that:
 - Since  the increment might accelerate at some specific occasions, it is
 still sometimes useful to advertise a lifetime in the transit.
 - Inferring on the pure size of the option is a bit dangerous since we can
 hardly play such a game twice.
 - Adaptive mapping creates complexities and bugs
 - we discussed for #56 that 3 octets is large enough for a lifetime in
 seconds.

 Suggestion:

 In the config option, we place the lifetime unit (2 octets) and the
 default value (1 octet expressed in that unit). This gives us a large
 band.
 Then in the transit option, we place only one octet, expressed in the unit
 above, and that should usually echo the default.

 Can you please shime in if that resolution suits you?

 Pascal

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/67#comment:1>
roll <http://tools.ietf.org/wg/roll/>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 20 Jul 2010 17:38:17 +0200

While we are at refining the transit option format:

It appears that in many cases, there will be a single subnet in an instance. In that case, all the parents will have the same prefix.
In a source route DAO, we can this sometimes elide the prefix of the parent. Either by placing it only on the first parent, or making it fully implicit.
For the time being, I propose a flag in the transit saying that the prefix of the parent is elided, for use in all the next parents.
If you disagree please chime in. 
If you want to elide it in all parents, please propose a simple mechanism that allows unambiguously to find what the prefix is.

Thanks again!

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of roll
> issue tracker
> Sent: Thursday, July 15, 2010 6:36 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: [Roll] [roll] #67: DODAG Default Path Lifetime
> 
> -----------------------------+------------------------------------------
> -----------------------------+----
> -----------------------------+------------------------------------------
> -----------------------------+----
>  I would like to recommend use of a DODAG-defined Default Path Lifetime  as
> opposed to the current model in which Path Lifetime is specified per  prefix
> using the Transit Information Option.
> 
>  As in other routing protocols, such as RIP for example, the validity  period of an
> advertised prefix is defined not per destination address  but is specified through
> a protocol configuration element such as the  route-timeout timer. In the same
> vein, a default validity period can be  defined for all advertised destinations
> through a Default Path Lifetime  specified within the DODAG Configuration
> option. This default value will  apply to all advertised prefixes unless otherwise
> specified using an  optional Path Lifetime information element within the
> Transit  Information option. The benefit of a Default Path Lifetime is that it  will
> allow 4-bytes to be saved per advertised DAO destination unless a  specific,
> dedicated Path Lifetime is needed for a given prefix. The  Lifetime for a
> destination address will continue to apply from the time  of receipt at a node.
> 
>  No additional control bits will be required within the Transit  Information
> Option as the presence or absence of the Path Lifetime  information element
> can be directly deduced from the value of the Option  Length.
> 
>  Thanks.
> 
>  Roger
> 
> --
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: JP Vasseur <[email-masked]>
Date: Tue, 20 Jul 2010 17:46:36 +0200

On Jul 20, 2010, at 5:38 PM, Pascal Thubert (pthubert) wrote:

> It appears that in many cases, there will be a single subnet in an  
> instance. In that case, all the parents will have the same prefix.
> In a source route DAO, we can this sometimes elide the prefix of the  
> parent. Either by placing it only on the first parent, or making it  
> fully implicit.
> For the time being, I propose a flag in the transit saying that the  
> prefix of the parent is elided, for use in all the next parents.
> If you want to elide it in all parents, please propose a simple  
> mechanism that allows unambiguously to find what the prefix is.
>

I would not add anything to the spec at this point. Could be a  
separate ID to optimize bw.

Thanks.

JP.

>> ----------------------------- 
>> +------------------------------------------
>> ----------------------------- 
>> +------------------------------------------
>> Information