Subject: [Roll] question about DODAGID field

From: Yoav Ben-Yehezkel <[email-masked]>
Date: Thu, 15 Jul 2010 14:36:35 +0300

Hi,

From:

“

5.3.1.  Format of the DIO Base Object

…

   DODAGID:  128-bit unsigned integer set by a DODAG root which uniquely

         identifies a DODAG.  Possibly derived from the IPv6 address of

         the DODAG root.

“

Seems like quite a lot of information to specify the ID of the DODAG (I
don’t expect so many DODAGs will be used per RPLInstanceID). Is it too late
to request a way to shrink this field?

BTW – is it worth mentioning that in case the DODAG root is replaced, it
might be that the DODAGID will need to change, so the IP address to derive
from should be from the IP address of the node that originally formed the
DODAG. I realize it says “possibly derived”, but this use-case could be
something that is a little annoying to discover after deployments are out.

Thanks,

Yoav

---

From: Richard Kelsey <[email-masked]>
Date: Thu, 15 Jul 2010 10:19:08 -0400

> From: Yoav Ben-Yehezkel <[email-masked]>
> Date: Thu, 15 Jul 2010 14:36:35 +0300
>
> Hi,
> 
> From:
> 
> Seems like quite a lot of information to specify the ID of
> the DODAG (I don't expect so many DODAGs will be used
> per RPLInstanceID). Is it too late to request a way to
> shrink this field?

Yes, it is a lot of bits.  The problem is that the value
needs to be unique to the root.  Using something smaller
than an IPv6 address would require adding an allocation
mechanism.  I suppose we could switch to IPv4 :).

> BTW is it worth mentioning that in case the DODAG root is replaced, it
> DODAG. I realize it says "possibly derived", but this use-case could be

What is the difficulty with having the DODAGID change when
the root device is replaced?  Using the same DODAGID would
seem to be operationally more complicated and more likely to
run into difficulties.

                                -Richard Kelsey