Subject: [Roll] Question on path to grand children in non-storing mode

From: Dario Tedeschi <[email-masked]>
Date: Thu, 19 Aug 2010 11:45:49 -0700

Given the following simple linear DODAG operating in non-storing mode:

ER
[A]<---[B]<---[C]<---[D]<---[E]

Where [A] is the DODAG root.

If [C] wants to send a packet to [E], is it true that the path would be 
[C] to [B] to [A] to [B] to [C] to [D] to [E] ?

Since, (in non-storing mode) the root node is the only node that stores 
routes, I can't see any other way of [C] reaching [E]. Or, am I missing 
something?

Dario

---

From: Mukul Goyal <[email-masked]>
Date: Thu, 19 Aug 2010 13:53:59 -0500 (CDT)

This is true as far as I understand non-storing mode operation. The proposed P2P solution can help discover more direct route in this case.

Thanks
Mukul

>Dario
_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Daniel Gavelle <[email-masked]>
Date: Fri, 20 Aug 2010 08:55:50 +0100

Dario,

Yes, that is how non-storing mode has to work.

Daniel.

> routes, I can't see any other way of [C] reaching [E]. Or, am I missing 

Regards,

Daniel.

-- 

__________________________________________________

Daniel Gavelle, Software Team Leader
Low Power RF Solutions (formerly Jennic Ltd.)
NXP Semiconductors
Furnival Street, Sheffield, S1 4QT, UK
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Comp Reg No: 3191371 - Registered In England
http://www.nxp.com http://www.jennic.com
__________________________________________________

---

From: Dario Tedeschi <[email-masked]>
Date: Fri, 20 Aug 2010 10:22:19 -0700

Thanks for the confirmation.

Dario Tedeschi wrote:
> If [C] wants to send a packet to [E], is it true that the path would 
> be [C] to [B] to [A] to [B] to [C] to [D] to [E] ?
>
> Since, (in non-storing mode) the root node is the only node that 
> stores routes, I can't see any other way of [C] reaching [E]. Or, am I 
> missing something?
>
> Dario