Subject: [Roll] Clarification on ETX computation

From: "Ajay Kumar (ajakuma2)" <[email-masked]>
Date: Sat, 21 Aug 2010 09:17:00 +0530

HI WG,

I need some clarification on the way Path ETX is calculated from  Link
ETXs. 

How is it additive metric? I believe it should be multiplicative unless
Logarithmic values are sent. Or am I missing something??

Regards,

Ajay

---

From: Omprakash Gnawali <[email-masked]>
Date: Fri, 20 Aug 2010 21:29:35 -0700

On Fri, Aug 20, 2010 at 8:47 PM, Ajay Kumar (ajakuma2)
<[email-masked]> wrote:
> HI WG,
>
>
>
> I need some clarification on the way Path ETX is calculated from  Link ETXs.
>

ETX is the number of expected transmissions on a link. You add them up
over the links to estimate the number of transmissions on a path. Here
is a draft that talks about how to compute the path metric using ETX:
http://tools.ietf.org/html/draft-gnawali-roll-minrank-hysteresis-of-01

- om_p

---

From: "Ajay Kumar (ajakuma2)" <[email-masked]>
Date: Sat, 21 Aug 2010 13:25:07 +0530

Hi Omprakash,

Consider this topo below:
                2                2                  2
  |  Root  |----------| N1  | -----------| N2 |------------|   N3 |

Labels indicate ETX value. Now, at node 3 Path ETX must be 8 if ETX = 1/Probability of Successful Transmissions (1/((0.5)*(0.5)*(0.5)).
How could it be 6??? Or this logic is left to implementation????

Regards,
Ajay

-----Original Message-----
From: Omprakash Gnawali [mailto:[email-masked]] 
Sent: Saturday, August 21, 2010 10:00 AM
To: Ajay Kumar (ajakuma2)
Cc: [email-masked]
Subject: Re: [Roll] Clarification on ETX computation

- om_p

---

From: Henning Rogge <[email-masked]>
Date: Sat, 21 Aug 2010 10:02:07 +0200

Am Samstag 21 August 2010, 09:55:07 schrieb Ajay Kumar (ajakuma2):
> Labels indicate ETX value. Now, at node 3 Path ETX must be 8 if ETX =
> 1/Probability of Successful Transmissions (1/((0.5)*(0.5)*(0.5)). How
> could it be 6??? Or this logic is left to implementation????
ETX woudl be 6 if you consider linklayer retransmissions. You need two 
transmissions for the first hop, two for the second and two for the last one.

Henning Rogge

-- 
1) You can't win.
2) You can't break even.
3) You can't leave the game.
— The Laws of Thermodynamics, summarized

---

From: "Ajay Kumar (ajakuma2)" <[email-masked]>
Date: Sat, 21 Aug 2010 13:56:42 +0530

Yes.... This clarifies. Thanks.

Regards,
Ajay

-----Original Message-----
From: Henning Rogge [mailto:[email-masked]] 
Sent: Saturday, August 21, 2010 1:32 PM
To: [email-masked]
Cc: Ajay Kumar (ajakuma2); Omprakash Gnawali
Subject: Re: [Roll] Clarification on ETX computation

> could it be 6??? Or this logic is left to implementation????
ETX woudl be 6 if you consider linklayer retransmissions. You need two transmissions for the first hop, two for the second and two for the last one.

Henning Rogge