Subject: [Roll] does an RH4 header or an RPLoption in HbH header imply a data packet?

From: Mukul Goyal <[email-masked]>
Date: Fri, 6 Aug 2010 10:39:44 -0500 (CDT)

Hi all,

I need a bit of help.

My impression is that the presence of an RH4 source route header or an RPL option in IPv6 hop-by-hop header imply that the packet is a data packet and not an RPL control packet. So, if I want the RPL process in a router to process a packet, I should not use an RH4 header or an IPv6 hop-by-hop header in that packet.

Please let me know if this is not correct.

Thanks
Mukul

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 9 Aug 2010 15:48:58 +0200

Hi Mukul:

This is not a matter of control or data plane. The HbH/RH help an arbitrary packet get to destination over multiple hops in the RPL network.
With RPL-11, only the multihop DAO/DAO_Ack used in non-storing needs those headers, since all other RPL control messages are 1 hop link local.

Cheers,

Pascal

> -----Original Message-----
> From: Mukul Goyal [mailto:[email-masked]]
> Sent: Friday, August 06, 2010 5:40 PM
> To: Jonathan Hui
> Cc: Pascal Thubert (pthubert); roll
> Subject: does an RH4 header or an RPLoption in HbH header imply a data
> packet?
> 
> Hi all,
> 
> I need a bit of help.
> 
> My impression is that the presence of an RH4 source route header or an RPL
> option in IPv6 hop-by-hop header imply that the packet is a data packet and not
> an RPL control packet. So, if I want the RPL process in a router to process a
> packet, I should not use an RH4 header or an IPv6 hop-by-hop header in that
> packet.
>

---

From: Mukul Goyal <[email-masked]>
Date: Mon, 9 Aug 2010 08:55:45 -0500 (CDT)

Thanks Pascal. I understand it now. The P2P-01 was wrongly using RH4 header to steer packets that needed hop-by-hop processing. I have corrected this error in P2P-02.

Thanks
Mukul

----- Original Message -----
From: "Pascal Thubert (pthubert)" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>, "Jonathan Hui" <[email-masked]>
Cc: "roll" <[email-masked]>
Sent: Monday, August 9, 2010 8:48:58 AM
Subject: RE: does an RH4 header or an RPLoption in HbH header imply a data packet?

Hi Mukul:

Cheers,

Pascal