Subject: Re: [Roll] AES-CCM not AES-CCM*

From: Tim Winter <[email-masked]>
Date: Fri, 01 Oct 2010 14:11:53 -0400

Hi Robert, WG,

On 09/02/2010 11:56 AM, Robert Cragie wrote:
>   I think we should be specifying AES-CCM not AES-CCM* in the RPL
> specification. There is some IPR surrounding AES-CCM* (US 2005/0154882),
> plus only AES-CCM itself is referenced in FIPS 140-2.
>
> The only real difference between AES-CCM* and AES-CCM is the encrypt
> only mode, which is illegal in AES-CCM. However, encrypt only is not
> used in RPL. Authentication only can be achieved in AES-CCM by setting
> the A data to the header concatenated with the payload and the payload
> to be encrypted to the null string and Plen to 0 (see
> http://csrc.nist.gov/publications/nistpubs/800-38C/SP800-38C_updated-July20_2007.pdf).
> In practice, this makes no difference to the RPL specification.

RPL-12 includes the following change:
	- update references from AES-CCM* to AES-CCM (RFC3610)
	- remove unnecessary reference to 802.15.4-2006

Since the two are functionally identical as used by RPL this change
is not expected to have any functional impact on RPL.  This change was
made so that we may avoid any issues with the alleged IPR on AES-CCM*
as mentioned above.  Based on my understanding of the issue the technical
impact of this change on RPL should be zero.

If you have a concern about this change please be sure to raise it to
Adrian by 7 October so that your concern may be caught in IESG evaluation.

Thanks,

-Tim

>
> Robert
> --
>
> Robert Cragie (Pacific Gas & Electric)
>
> Gridmerge Ltd.
> 89 Greenfield Crescent,
> Wakefield, WF4 4WA, UK
> +44 1924 910888
> +1 415 513 0064
> http://www.gridmerge.com <http://www.gridmerge.com/>
>
>
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 01 Oct 2010 21:03:56 +0200

Did you get a chance to update it with respect to mutable but 
predictable fields (routing header), not just mutable, as discussed on 
the RPL WG list.

Alex