Subject: Re: [Roll] [roll] routing-metrics #83 (new): Comment received WG Last Call on draft-ietf-roll-routing-metrics-09.txt --- Editorial Comments

From: <[email-masked]>
Date: Thu, 14 Oct 2010 07:59:04 +0200

Hello Phoebus, 

Thanks for your thorough review. Please find inlined the account of my processing of each of your comments.
Best regards,

Dominique

-----Message d'origine-----
De : roll issue tracker [mailto:[email-masked]] Envoyé : mardi 5 octobre 2010 16:57 À : BARTHEL Dominique RD-TECH-GRE; [email-masked] Cc : [email-masked] Objet : [roll] routing-metrics #83 (new): Comment received WG Last Call on draft-ietf-roll-routing-metrics-09.txt --- Editorial Comments

#83: Comment received WG Last Call on draft-ietf-roll-routing-metrics-09.txt --- Editorial Comments
-----------------------------+------------------------------------------
-----------------------------+----
 Reporter:  jpv@...            |       Owner:  dominique.barthel@...                 
     Type:  defect           |      Status:  new                                 
 Priority:  major            |   Milestone:                                      
Component:  routing-metrics  |     Version:                                      
 Severity:  In WG Last Call  |    Keywords:                                      
-----------------------------+------------------------------------------
-----------------------------+----
 Original Email below (refer to the archives for the full discussion)

 Email sent on September 23, by Phoebus Chen:

 General Editorial Comments for the authors:

 1) I suggest moving Section 6 on "Use of multiple DAG Metric Container"
 into Section 2 "Object formats."  It's near the end of the document, yet  it says  "In the rest of this document, this use of multiple DAG Metric  Containers will be considered as if they were actually just one long  DAG Metric Container."
[DB: done as suggested]

 2) I suggest moving Section 7 "Metric consistency" into Section 1  "Introduction".  (Also, maybe the point being made in this section is
 obvious?)
[DB: done as suggested]

 3) I suggest moving Section 8 "Metric Usage" into a subsection of Section  2, or somewhere earlier in the document.  It will shed more light when the  precedence field is first discussed.  Of course, the text will need to  mention that the metrics mentioned in the examples will be defined in more  detail in Sections 3 and 4.
[DB: done as suggested]

 4) Section 8 gives an example of how to break ties in metrics.  What  happens when there is a tie in the precedence field between two metrics?
 Is this not allowed?  Is it broken in the order of the objects in the  metric container (as it was before in version 8 of the document)?  Or is  the behavior in this case "beyond the scope of this document," and must be  resolved by the Objective Function?
[DB: specified that this is implementation dependant]

 5) Section 9 is still incomplete... is this OK for last call?  Only the  NSA and Hop-count objects are described in 9.3 and 9.4 respectively.
[DB: Only incomplete flag fields and numerical field should be managed by IANA. NSA and Hop-count are the only two of that type.]

 6) Section 1 "Introduction" has a long discussion on Dynamic vs. Static  Metrics, after classifying the links according to characteristics  (paragraphs 1, 3-5 after the list on pg. 5).  I suggest a shorter  description and deferring / moving the bulk of the discussion to Section 5  "Computation of dynamic metrics and attributes."  Or at least, present  this discussion after the discussion on the other classifications (which  turns out to just be one sentence on link and node metrics not being  exclusive), following the order of the list.
[DB: reshuffled the text somewhat to align with list. However, kept the dynamic metrics discussion up-front because of its sensitive nature.]

 7) In many of the object formats, several of the descriptions of the  flags/fields do not follow the order of the flags/fields in the object.
 See Figure 2 and the following description, Figure 3 and the following  description, and Figure 5 and the following description.  It would be a  little easier to read if the orders matched.
[DB: done as suggested in all cases, but the P flag of DMC which would be harder to understand if introduced first]

 8) In several figures, the last Byte indices above the objects are  partially missing.  Not a big deal, but it looks a little sloppy leaving  them off.
[DB: done as suggested]

 9) There are misspelled words throughout the document... please run it  through a spell checker after making the final edits.
[DB: done]

 Nits below.  Search for comments preceded by PC>."
[DB: thanks for this thorough work! Examined them one by one, and fixed most, unless disagreement in interpretation, such as the explanation of ETX update]
--
Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/83>
roll <http://tools.ietf.org/wg/roll/>

---

From: Phoebus Chen <[email-masked]>
Date: Thu, 14 Oct 2010 09:40:23 +0200

Dominique,

Thanks for taking my comments into consideration.  Please see inline 
below for responses.

-- 
Phoebus Chen
Postdoctoral Researcher
Automatic Control Lab, KTH (Royal Institute of Technology)
http://www.ee.kth.se/~phoebus

> #83: Comment received WG Last Call on draft-ietf-roll-routing-metrics-09.txt --- Editorial Comments

OK.

> [DB: Only incomplete flag fields and numerical field should be managed by IANA. NSA and Hop-count are the only two of that type.]

OK, thanks for the clarification.  Just to be sure, the flags in 
sub-objects do not need to be managed? (NE sub-object in Figure 5 and LC 
Type 2 sub-object in Figure 19)

> [DB: reshuffled the text somewhat to align with list. However, kept the dynamic metrics discussion up-front because of its sensitive nature.]

OK.

> [DB: done as suggested in all cases, but the P flag of DMC which would be harder to understand if introduced first]

OK.

> [DB: thanks for this thorough work! Examined them one by one, and fixed most, unless disagreement in interpretation, such as the explanation of ETX update]

Great!  I believe you're referring to the ETX example in section 2 on 
pg. 9.  Looking back, I didn't give a good suggestion on how to change 
the sentence.

> --
> Ticket URL:<http://trac.tools.ietf.org/wg/roll/trac/ticket/83>
> roll<http://tools.ietf.org/wg/roll/>
>