Subject: Re: [Roll] WG Last Call on draft-ietf-roll-routing-metrics-09.txt

From: JP Vasseur <[email-masked]>
Date: Fri, 1 Oct 2010 13:39:13 +0200

WG LC on draft-ietf-roll-routing-metrics-09.txt has now ended. Authors will open tickets for each issue that was raised, work on resolution and publish the new revision.

Thanks. 

JP.

On Sep 16, 2010, at 3:56 PM, David Culler wrote:

> The routing metrics draft has now gone through 9 revisions over the past 16 months, the diffs have narrowed to essentially wording and editorial changes, and the comments are few and non-controversial.  Thus, it appears that consensus has emerged and we can LC this I-D.
> 
> This email is to announce Working Group Last Call on draft-ietf-roll-routing-metrics-09.txt to complete at 12 noon PST, Sept. 30 2010.  Please read it thoroughly and forward all final comments to the authors and the WG mailing list.  
> 
> Thanks all for your good work.  We're on a ROLL.
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: David Culler <[email-masked]>
Date: Sun, 3 Oct 2010 19:46:42 -0700

Correct.

>> Thanks all for your good work.  We're on a ROLL.

David Culler
[email-masked]
Chair Computer Science
Associate Chair EECS

---

From: Nicolas DEJEAN <[email-masked]>
Date: Tue, 12 Oct 2010 09:18:22 +0200

Hello Phoebus,

2010/9/23 Phoebus Chen <[email-masked]>:
> I'm a little confused about the Node Fanout Ratio (NFR) Object in Section
> 3.4 .  Does fanout refer to outgoing links (upward, to a parents), or
> incoming links (downward, from children) of a node?
>

The idea is that this metric refers to the incoming links.

> The text says:
> "The Node Fanout Ratio (NFR) object is used to provide information on
> the nodes current forwarding load."
>
> From this, I would read fanout to mean the number of incoming links, if you
> are concerned with upward routing.  The amount of traffic you have to
> forward depends on the amount of traffic coming in, which might be roughly
> related to the number of children.

You are right.

>  But as far as I know, RPL nodes only
> keep track of parents, not of children, so it cannot keep track of the
> number of incoming links.
>

Unfortunately, you are right again. Good point.

> Or is the NFR object is used for optimizing the topology for downward
> routing (related to DAO fanout), to get path diversity / reliability? If
> this is the case, perhaps this should be explained in the metrics document.
>

This is absolutely not the idea.
As a conclusion, maybe we could find some specific cases (based on
storing/non storing mode and DAO usage for instance) that could allow
using this metric but in all cases, this is much more complicated than
expected at start.

My proposal is to remove this metric from the draft. It might be
reintroduced later in a separate ID.

Nicolas.

> --
> Phoebus Chen
> Postdoctoral Researcher
> Automatic Control Lab, KTH (Royal Institute of Technology)
> http://www.ee.kth.se/~phoebus
>
>
> On 9/16/10 3:56 PM, David Culler wrote:
>>
>> The routing metrics draft has now gone through 9 revisions over the
>> past 16 months, the diffs have narrowed to essentially wording and
>> editorial changes, and the comments are few and non-controversial.
>> Thus, it appears that consensus has emerged and we can LC this I-D.
>>
>> This email is to announce Working Group Last Call on
>> draft-ietf-roll-routing-metrics-09.txt to complete at 12 noon PST,
>> Sept. 30 2010.  Please read it thoroughly and forward all final
>> comments to the authors and the WG mailing list.
>>
>> _______________________________________________ Roll mailing list
>> [email-masked] https://www.ietf.org/mailman/listinfo/roll
>

---

From: Phoebus Chen <[email-masked]>
Date: Tue, 12 Oct 2010 14:33:43 +0200

Response below.

On 10/12/10 9:18 AM, Nicolas DEJEAN wrote:
> Hello Phoebus,
>
> 2010/9/23 Phoebus Chen<[email-masked]>:

That's fine by me.