Subject: Re: [Roll] Adopting draft-gnawali-roll-minrank-hysteresis-of-02 as anew ROLL WG document ?

From: "Cedric Chauvenet" <[email-masked]>
Date: Fri, 1 Oct 2010 15:03:47 +0200

Hi all, 

This document provides a suitable mechanism to improve the network stability.

I don't see good reason to be opposed to its WG adoption.

Cédric Chauvenet.
  ----- Original Message ----- 
  From: JP Vasseur 
  To: ROLL WG ; Omprakash Gnawali 
  Cc: David Culler 
  Sent: Thursday, September 30, 2010 8:56 PM
  Subject: [Roll] Adopting draft-gnawali-roll-minrank-hysteresis-of-02 as anew ROLL WG document ?

  Hi Omprakash,

  Thanks for the new revision addressing my comments.

  All, 

  Could you please let us know if you are in favor/opposed of adopting draft-gnawali-roll-minrank-hysteresis-of as a ROLL Working Group document ?

  Thanks.

  JP.

  On Sep 21, 2010, at 9:18 PM, Omprakash Gnawali wrote:

    Dear WG,

    I just updated the draft to address JP's comment on allowing for leaf nodes.

    - om_p

    ---------- Forwarded message ----------
    From: IETF I-D Submission Tool <[email-masked]>
    Date: Tue, Sep 21, 2010 at 2:17 PM
    Subject: New Version Notification for
    draft-gnawali-roll-minrank-hysteresis-of-02
    To: [email-masked]
    Cc: [email-masked]

    A new version of I-D, draft-gnawali-roll-minrank-hysteresis-of-02.txt
    has been successfully submitted by Omprakash Gnawali and posted to the
    IETF repository.

    Filename:        draft-gnawali-roll-minrank-hysteresis-of
    Revision:        02
    Title:           The Minimum Rank Objective Function with Hysteresis
    Creation_date:   2010-09-21
    WG ID:           Independent Submission
    Number_of_pages: 8

    Abstract:
    Hysteresis delays the effect of changes in link metric on parent
    selection.  Such delay makes the topology stable despite jitters in
    link metrics.  The Routing Protocol for Low Power and Lossy Networks
    (RPL) allows the use of objective functions to construct routes that
    optimize or constrain a routing metric on the paths.  This
    specification describes the Minimum Rank Objective Function with
    Hysteresis (MRHOF), an objective function that minimizes the node
    rank in terms of a given metric, while using hysteresis to prevent
    excessive rank churn.  The use of MRHOF with RPL results in nodes
    selecting stable paths that minimize the given routing metric to the
    roots of a Directed Acyclic Graph (DAG).

    The IETF Secretariat.
    _______________________________________________
    Roll mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/roll

------------------------------------------------------------------------------

  _______________________________________________
  Roll mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/roll

---

From: Stephen Dawson-Haggerty <[email-masked]>
Date: Mon, 4 Oct 2010 15:55:30 -0400

I am also in favor.  We certainly need a great link metric that will
work out of the box and this seems to provide a vehicle for making
one.

Steve

On Fri, Oct 1, 2010 at 9:03 AM, Cedric Chauvenet
<[email-masked]> wrote:
> Could you please let us know if you are in favor/opposed of adopting
> draft-gnawali-roll-minrank-hysteresis-of as a ROLL Working Group document ?
> Thanks.
> JP.
>
> ________________________________
>

-- 
stephen dawson-haggerty
http://cs.berkeley.edu/~stevedh
uc berkeley wireless and embedded systems lab
berkeley, ca 94720

---

From: "JeongGil Ko (John)" <[email-masked]>
Date: Mon, 4 Oct 2010 16:08:01 -0400

One more in favor. It'll be great to further discuss about a working mechanism to achieve route stability.

-John

>> roots of a Directed Acyclic Graph (DAG).

------
JeongGil Ko (John)
Ph.D. Student
Department of Computer Science
Johns Hopkins University
http://www.cs.jhu.edu/~jgko

---

From: JP Vasseur <[email-masked]>
Date: Thu, 7 Oct 2010 08:47:45 +0200

Polling again since we got very few replies ....

---

From: Thomas Heide Clausen <[email-masked]>
Date: Thu, 7 Oct 2010 15:54:14 +0200

Alright, having read the document, carefully this time around....it seems to be a good thing for the WG to take on, so I support adopting it.

Thomas

---

From: Phoebus Chen <[email-masked]>
Date: Fri, 08 Oct 2010 16:09:46 +0200

+1.

The draft seems like a good starting point.  Given the long discussion 
on "dynamic metrics" in the routing metrics document, it seems like 
having a hysteresis mechanism will be very good for routing topology 
stability.

-- 
Phoebus Chen
Postdoctoral Researcher
Automatic Control Lab, KTH (Royal Institute of Technology)
http://www.ee.kth.se/~phoebus

On 10/7/10 8:47 AM, JP Vasseur wrote:
>> /Hi Omprakash,/
>> /
>> /
>> /Thanks for the new revision addressing my comments./
>>
>> All,
>>
>>> From: IETF I-D Submission Tool <[email-masked]
>>> <mailto:[email-masked]>>
>>> To: [email-masked] <mailto:[email-masked]>
>>> Cc: [email-masked] <mailto:[email-masked]>
>>>
>>>
>>>
>>> [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>

---

From: JP Vasseur <[email-masked]>
Date: Mon, 11 Oct 2010 06:11:36 +0200

Dear all,

We did not have that many replies to the poll, but all positive. Authors, please resubmit the document (without changes
other than titles, names, dates) as draft-ietf-roll-minrank-hysteresis-00.txt. 

Thanks.

JP.

Begin forwarded message:

> From: JP Vasseur <[email-masked]>
> Date: September 30, 2010 8:56:51 PM GMT+02:00
> To: ROLL WG <[email-masked]>, Omprakash Gnawali <[email-masked]>
> Cc: David Culler <[email-masked]>
> Subject: [Roll] Adopting draft-gnawali-roll-minrank-hysteresis-of-02 as a new ROLL WG document ?
> 
> Hi Omprakash,
>