Subject: [Roll] Replace the term "good enough" with "usable" in P2P draft?

From: Mukul Goyal <[email-masked]>
Date: Wed, 17 Nov 2010 13:52:45 -0600 (CST)

Hi all

There is a proposal to replace the term "good enough route" with "usable route" in the P2P draft. I was wondering if there are any objections to this change.

Thanks
Mukul

---

From: "Anders Brandt" <[email-masked]>
Date: Thu, 18 Nov 2010 09:01:01 +0100

hi Mukul

(se inline)

Cheers,
  Anders

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Mukul Goyal
> Sent: Wednesday, November 17, 2010 20:53
> To: roll
> Subject: [Roll] Replace the term "good enough" with "usable" 
> in P2P draft?
> 
> Hi all
> 
> There is a proposal to replace the term "good enough route" 
> with "usable route" in the P2P draft. I was wondering if 
> there are any objections to this change.

(among others) I am to blaim for the "good enough" term.

I have to agree that this is not a term that one meets very often
in RFCs - and thus we should try to align it with the IETF vocabulary.
The meaning we are trying to convey is that both ends consider the
constraints fulfilled, i.e. the path is good enough.
This is slightly different from convergence-based network discovery,
where routers have time to register many candidates and pick the best.

In both cases we end up with "usable" routes. Thus, "usable" does really
not tell me a lot.

My suggestion would be that we explain in the introduction, that while
reactive discovery in a non-storing environment cannot locate the best
routes, the constraints allow us to identify routes that are good enough
for the actual purpose.
The rest of the document may then just refer to "routes".

> Thanks
> Mukul
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: Yoav Ben-Yehezkel <[email-masked]>
Date: Thu, 18 Nov 2010 10:17:43 +0200

I agree with Anders that any route is "usable". I also agree that it is
important to differentiate these routes from RPL routes and that one way
of doing so is explain that in the introduction as Anders has suggested.

An addition to what Andres proposes would be to also find a good name for
these routes. What about "sub-optimal routes"? The name coveys the message
of being usable routes, but not the necessarily the best ones. It's an
addition and not an alternative, because I still think the properties of
"sub-optimality" needs some clarification, and the introduction seems like
a good place to clarify that.

I'm not an expert on IETF vocabulary though :)

Regards,
Yoav

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Anders Brandt
Sent: Thursday, November 18, 2010 10:01 AM
To: Mukul Goyal; roll
Subject: Re: [Roll] Replace the term "good enough" with "usable" in P2P
draft?

hi Mukul

(se inline)

Cheers,
  Anders

---

From: [email-masked]
Date: Thu, 18 Nov 2010 08:01:32 -0600

I like the change.

From:

Mukul Goyal <[email-masked]>

To:

roll <[email-masked]>

Date:

11/17/2010 01:55 PM

Subject:

[Roll] Replace the term "good enough"
with "usable" in P2P draft?

Hi all

There is a proposal to replace the term "good enough route" with
"usable route" in the P2P draft. I was wondering if there are
any objections to this change.

Thanks

Mukul

Roll mailing list

[email-masked]

---

From: Mukul Goyal <[email-masked]>
Date: Fri, 19 Nov 2010 08:06:07 -0600 (CST)

Hi Yoav

I know that P2P extension may not be discovering the "optimal" routes. But, you dont have to rub it in by making us call them "suboptimal". :)

Thanks
Mukul

----- Original Message -----
From: "Yoav Ben-Yehezkel" <[email-masked]>
To: "Anders Brandt" <[email-masked]>, "Mukul Goyal" <[email-masked]>, "roll" <[email-masked]>
Sent: Thursday, November 18, 2010 2:17:43 AM
Subject: RE: [Roll] Replace the term "good enough" with "usable" in P2P draft?

Regards,
Yoav

-----Original Message-----

hi Mukul

(se inline)

Cheers,
  Anders

---

From: Mukul Goyal <[email-masked]>
Date: Fri, 19 Nov 2010 08:07:34 -0600 (CST)

Hi Anders

I like your suggestion. Just want to make sure that this is OK with every body.

Thanks
Mukul

----- Original Message -----
From: "Anders Brandt" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>, "roll" <[email-masked]>
Sent: Thursday, November 18, 2010 2:01:01 AM
Subject: RE: [Roll] Replace the term "good enough" with "usable" in P2P draft?

hi Mukul

(se inline)

Cheers,
  Anders

---

From: Yoav Ben-Yehezkel <[email-masked]>
Date: Fri, 19 Nov 2010 18:52:06 +0200

Right... Sorry about that.
Still I think it is valuable to differentiate these routes from the ones RPL
obtains by name. Maybe call them "P2P routes"?

Thanks,
Yoav

-----Original Message-----
From: Mukul Goyal [mailto:[email-masked]]
Sent: Friday, November 19, 2010 4:06 PM
To: Yoav Ben-Yehezkel
Cc: Anders Brandt; roll
Subject: Re: [Roll] Replace the term "good enough" with "usable" in P2P
draft?

Hi Yoav

I know that P2P extension may not be discovering the "optimal" routes. But,
you dont have to rub it in by making us call them "suboptimal". :)

Thanks
Mukul

----- Original Message -----
From: "Yoav Ben-Yehezkel" <[email-masked]>
To: "Anders Brandt" <[email-masked]>, "Mukul Goyal" <[email-masked]>, "roll"
<[email-masked]>
Sent: Thursday, November 18, 2010 2:17:43 AM
Subject: RE: [Roll] Replace the term "good enough" with "usable" in P2P
draft?

Regards,
Yoav

-----Original Message-----

hi Mukul

(se inline)

Cheers,
  Anders

---

From: Mukul Goyal <[email-masked]>
Date: Fri, 19 Nov 2010 13:03:36 -0600 (CST)

Yoav

I am not sure what useful purpose would be served by giving these routes a special name.

I agree with Anders's suggestion to clarify the good-enough nature of these routes in the introduction and simply refer to them as routes in the subsequent discussion.

Thanks
Mukul

----- Original Message -----
From: "Yoav Ben-Yehezkel" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>
Cc: "Anders Brandt" <[email-masked]>, "roll" <[email-masked]>
Sent: Friday, November 19, 2010 10:52:06 AM
Subject: RE: [Roll] Replace the term "good enough" with "usable" in P2P draft?

Thanks,
Yoav

-----Original Message-----
From: Mukul Goyal [mailto:[email-masked]]
Sent: Friday, November 19, 2010 4:06 PM
To: Yoav Ben-Yehezkel
Cc: Anders Brandt; roll
Subject: Re: [Roll] Replace the term "good enough" with "usable" in P2P
draft?

Hi Yoav

Thanks
Mukul

----- Original Message -----
From: "Yoav Ben-Yehezkel" <[email-masked]>
To: "Anders Brandt" <[email-masked]>, "Mukul Goyal" <[email-masked]>, "roll"
<[email-masked]>

Regards,
Yoav

-----Original Message-----

hi Mukul

(se inline)

Cheers,
  Anders

---

From: Mukul Goyal <[email-masked]>
Date: Tue, 23 Nov 2010 20:56:18 -0600 (CST)

Here is a bit of context behind this comment from Charlie. 

While commenting on the applicability section of the P2P draft, Charlie suggested that, in general, the application layer would/should decide the exact RPL constraints comprising the good enough criteria for P2P route discovery. In contrast, I was of the opinion that, in general, the application layer would not want to deal with the nitty-gritty details of RPL routing metrics and hence would just want to complain to the routing layer if the current route is not good enough (or usable). Then the routing layer should figure out the exact constraints to be used for P2P route discovery.

I guess I could modify the text so that a particular implementation may decide for itself whether the application layer would specify the good enough constraints or the routing layer.

Thanks
Mukul

----- Original Message -----
From: "Charles E. Perkins" <[email-masked]>
To: "Anders Brandt" <[email-masked]>
Cc: "Mukul Goyal" <[email-masked]>, "roll" <[email-masked]>
Sent: Tuesday, November 23, 2010 11:54:18 AM
Subject: Re: [Roll] Replace the term "good enough" with "usable" in P2P draft?

>And I still believe that the application is best suited to
provide the information determining whether or not a route
could be used.  For instance, it could setsockopt(QOS) some
specific class of service <please forgive my sin of writing
that ridiculous verb>.

Regards,
Charlie P.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 23 Nov 2010 09:54:18 -0800

Hello folks,

Comments below <original text rearranged>:

----- Original Message -----

> From: "Anders Brandt"<[email-masked]>
> To: "Mukul Goyal"<[email-masked]>, "roll"<[email-masked]>

I am O.K. with this.

> in RFCs - and thus we should try to align it with the IETF vocabulary.

I'm not aware of a particular "IETF vocabulary" on this,
but there might be a conventional term in use somewhere.
If so, we should consider adopting it.

> constraints fulfilled, i.e. the path is good enough.

Check.

> where routers have time to register many candidates and pick the best.

Here, I am not sure.  Do you have an example?  What about when a router
picks a route worth advertising, but is allowed to make local updates
based on newer information and not advertise it?  And besides, is there
any example of network discovery that is not "convergence-based"?

> In both cases we end up with "usable" routes. Thus, "usable" does really

I don't understand this.  Either a route is usable or it isn't
usable.  The criteria for acceptance should be unambiguous.
What more should be disclosed in order to improve the process
of route discovery?

Anyway, I am still O.K. with the Anders' suggestion above.
I don't think that such terms as "usable" are ambiguous as
was claimed.  In some publications, the word "feasible" has
been used successfully for this concept.

Regards,
Charlie P.