Subject: [Roll] DODAG Version Number

From: "amit dvir" <[email-masked]>
Date: Wed, 10 Nov 2010 12:39:30 +0100

Dear All,

We are a research group implementing the RPL.

Regarding the DODAG Version Number, 

In section 7.2 the example is 

" For example, if A is 240, and B is 5, then (256 + 5 - 240) is 21. 21 is
greater than SEQUENCE_WINDOW (16), thus 240 is  greater than 16."
 
1)      thus 240 is greater than 16? Shouldn't it be thus 240 is  greater
than 5
2)      240 is greater than 5, 
a.       can it really happen in RPL that the version number is restarted? 
b.      Can 240 appear after 5 as a version number?

Regards,

Dr. Amit  Dvir

 <http://www.crysys.hu/> Laboratory of Cryptography and Systems Security
(CrySyS)
 <http://www.hit.bme.hu/> Department of Telecommunications
 <http://www.bme.hu/en/index.html> Budapest University of Technology and
Economics

---

From: "Rajesh Marchappanavar (rmarchap)" <[email-masked]>
Date: Wed, 10 Nov 2010 17:50:33 -0800

From: [email-masked] [mailto:[email-masked]] On Behalf Of
amit dvir
Sent: Wednesday, November 10, 2010 5:10 PM
To: [email-masked]
Subject: [Roll] DODAG Version Number

Dear All,

" For example, if A is 240, and B is 5, then (256 + 5 - 240) is 21. 21
is greater than SEQUENCE_WINDOW (16), thus 240 is  greater than 16."
 
1)      thus 240 is greater than 16? Shouldn't it be thus 240 is
greater than 5
 
[RM:] Yes correct.
 
2)      240 is greater than 5, 
a.       can it really happen in RPL that the version number is
restarted? 

[RM:] Yes, when the LBR (root) reboots.

[RM:] After a few days of global repairs version number of a DAG might
have wrapped around 255 and reached 5 and now the LBR reboots.
 
Cheers,
Rajesh

Regards,

Dr. Amit  Dvir

Laboratory of Cryptography and Systems Security (CrySyS)
<http://www.crysys.hu/> 
Department of Telecommunications <http://www.hit.bme.hu/> 
Budapest University of Technology and Economics
<http://www.bme.hu/en/index.html>