Subject: Re: [Roll] [6lo] [6tisch] Fwd: Comparison of 6lo-rpl drafts

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 17 Sep 2014 07:48:40 +0000

Hello Carsten:

The split and domain-dependent use of the Flow Label field was still on the table in the RFC 6437 discussions. This was rejected as a general rule but we still need an exception to RFC 6437 for LLNs so let us see what we get there.

I can still agree with you to progress on a 6lo NHC proposal and produce the best personal submission we can for WG evaluation. This in turn does not mean that 6lo will adopt the work or that ROLL will favor that option. 

I suggest we focus discussions on the relevant MLs:
- 6MAN on whether we can avoid having to set and/or carry a field of randomized 20 bits in the LLN  then eventually rewrite it for LLN purpose
- ROLL to decide whether to use a ROLL solution (based on FL is the only one on the table) or wait for 6lo to deliver
- 6Lo to decide whether and how to compress the RPL option (3 proposals on the table)

In any case copying 6TiSCH, which depends on the overall result to deliver the minimal draft, is a good idea.

Cheers,

Pascal

> -----Original Message-----
> From: Carsten Bormann [mailto:[email-masked]]
> Sent: mercredi 17 septembre 2014 08:42
> To: Pascal Thubert (pthubert)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [6lo] [6tisch] Fwd: Comparison of 6lo-rpl drafts
> 
> On 17 Sep 2014, at 07:46, Pascal Thubert (pthubert) <[email-masked]>
> wrote:
> 
> > we have one free bit there
> 
> It's not free, all 20 bits of the flow label are the flow label.
> 
> (Again, we can argue dedicating the field that way in 1994, and keeping it
> that way even while nibbling off bits for other uses, was bad protocol design,
> but that's water under the bridge.)
> 
> I would prefer to stop wasting time on trying to hijack the flow label and
> instead finish the work on an NHC representation.
> 
> Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 17 Sep 2014 10:02:00 +0200

On 17 Sep 2014, at 09:48, Pascal Thubert (pthubert) <[email-masked]> wrote:

> - 6MAN on whether we can avoid having to set and/or carry a field of randomized 20 bits in the LLN  

Laudable, and completely unrelated to the hijacking.
(Not on critical path, anyway.)

> then eventually rewrite it for LLN purpose

Don’t do that.

> - ROLL to decide whether to use a ROLL solution (based on FL is the only one on the table) or

The flow label is not ROLL’s, so there is nothing to do here.

> wait for 6lo to deliver

ROLL has waited long enough for consensus to build in 6man around the flow label hijacking.
Not happening.

> - 6Lo to decide whether and how to compress the RPL option (3 proposals on the table)

I think we are converging quickly here.

Summary:

I’m calling for all involved to stop muddying the water with the dead flow label hijacking proposal.
It is a distraction from the consensus that is being built around a 6lo solution, and it will never fly.

Grüße, Carsten

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 17 Sep 2014 12:11:28 +0200

On Wednesday, September 17, 2014, Carsten Bormann wrote:

> On 17 Sep 2014, at 09:48, Pascal Thubert (pthubert) <[email-masked]
> <javascript:;>> wrote:
>

Why not?

> The flow label is not ROLL’s, so there is nothing to do here.

If this WG decides that we want ROLL's solution decision then we may do
cross WGs discussions or cross areas (this in not done much in IETF because
still IETF is not flexible or ADs are not promoting that enough).

> I think we are converging quickly here.

I think we need to clarify that 3 proposals. So why you think we are doing
it quickly.

> solution, and it will never fly.

Why you think that it is dead? I don't think it expired yet. What do you
mean by consensus built around 6Lo solution, do you mean the 6Lo charter?
Why you think that it never fly?

I understood Martins proposal but did not understand your reply reasons.

 AB

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 17 Sep 2014 13:04:59 +0200

> Why not?

RFC 6437 explains what flow labels are and how you can use them.

> If this WG decides that we want ROLL's solution decision then we may do cross WGs discussions or cross areas (this in not done much in IETF because still IETF is not flexible or ADs are not promoting that enough). 

There already was a common WGLC between ROLL and 6man.
Initially, there was some flexibility on the 6man side along the lines of “if you really have to do this”.
Once it was demonstrated that there is no actual need to hijack the flow label, the sentiment shifted.
I see little point in repeating this experiment.

> I think we need to clarify that 3 proposals. So why you think we are doing it quickly. 

Because the 6lo WG has a track record of getting things done quickly.
(Also, I’m only aware of a single active proposal, but maybe I haven’t been paying enough attention.)

> Why you think that it is dead? 

See above.

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Tue, 23 Sep 2014 14:27:31 -0400

> I see little point in repeating this experiment.

The 6man WG chairs have not confirmed the conclusion of Ines and I, and we
did not observe wuch a "shift".    One 6man co-chair is on paternity leave,
so perhaps we will still hear from them.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-