Subject: [Roll] draft-rahul-roll-rpl-observations-00 Section 2.1: Wear leveling

From: Carsten Bormann <[email-masked]>
Date: Thu, 22 Mar 2018 10:28:41 +0000

Today, at the mike, I asked about wear leveling.

The numbers in 2.1 seem to assume you do a full erase/write cycle per store operation.
That is not a good way to use Flash storage.  Obviously, for true wear leveling you need a bit more flash space (and a bit more code, which also needs flash space), but then there already are other items that you want to commit to stable storage on a somewhat regular basis.

Grüße, Carsten

---

From: Rahul Jadhav <[email-masked]>
Date: Thu, 22 Mar 2018 17:08:02 +0000

Thanks Carsten for the feedback. Yes a full erase / write cycle per store is not optimal... We are doing that and there was reason to do that i could not recollect now.. I will reply back again with the details soon.

Thanks,
Rahul 

> On 22-Mar-2018, at 10:28 AM, Carsten Bormann <[email-masked]> wrote:
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll