Subject: [Roll] Discussion -- DIS modifications draft

From: Cenk Gündoğan <[email-masked]>
Date: Thu, 22 Mar 2018 16:14:43 +0100

Hello all,

a couple of months ago the draft on DIS modifications [1] expired and we
are highly motivated to continue the work on these enhancements during
the next months.

To summarize, the DIS modification draft tweaks the behaviour of RPL
nodes that receive DIS messages. These extensions are backward
compatible, so that existing RPL implementations do not break.
The tweaks include:
1. control over solicited DIOs (unicast vs multiucast)
2. control over the trickle timer (reset due to inconsistency or not)
3. control over options to include in the solicited DIO

This fine-grained control over solicited DIOs inarguably can be
leveraged to limit the number of packets on the control plane and
deflate solicited DIOs by eliding the mandatory DODAG Conf. option (16
octets) in cases where the DODAG Conf. option is already distributed and
trickled down.

Our question to everyone in this group is whether there is still enough
support and interest in the WG to continue with the work?

Cheers,
Cenk

[1] https://tools.ietf.org/html/draft-ietf-roll-dis-modifications-00

-- 
Cenk Gündoğan

Hamburg University of Applied Sciences
Dept. of Computer Science / Internet Technologies Group
Berliner Tor 7, 20099 Hamburg, Germany
Fon: +49 40 42875 - 8426
Mail: [email-masked]
Web: https://www.inet.haw-hamburg.de/

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 22 Mar 2018 15:48:46 +0000

There is support on my side!

But then you need to express better when the optimization’s are efficient and when they are detrimental; eg is that related to density?

Regards,

Pascal

> Le 22 mars 2018 à 15:15, Cenk Gündoğan <[email-masked]> a écrit :
> 
> Hello all,
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Michael Richardson <[email-masked]>
Date: Thu, 22 Mar 2018 16:02:27 +0000

Cenk Gündoğan <[email-masked]> wrote:
    Cenk> a couple of months ago the draft on DIS modifications [1] expired
    Cenk> and we are highly motivated to continue the work on these
    Cenk> enhancements during the next months.

I wondered what had happened to this work...

    Cenk> Our question to everyone in this group is whether there is still
    Cenk> enough support and interest in the WG to continue with the work?

I'm still interested.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Ines Robles <[email-masked]>
Date: Thu, 22 Mar 2018 16:25:32 +0000

On Thu, Mar 22, 2018, 16:02 Michael Richardson

>     Cenk> enough support and interest in the WG to continue with the work?

+1

---

From: Rahul Jadhav <[email-masked]>
Date: Thu, 22 Mar 2018 17:02:20 +0000

+1 
This is definitely useful. 

> On 22-Mar-2018, at 4:25 PM, Ines Robles <[email-masked]> wrote:
> 
> 
>