Subject: Re: [Roll] [6tisch] I-D Action: draft-ietf-6tisch-enrollment-enhanced-beacon-00.txt

From: Michael Richardson <[email-masked]>
Date: Sun, 23 Sep 2018 16:38:32 -0400

Georgios Z. Papadopoulos <[email-masked]> wrote:
    > Many thanks for this work.  Going through the draft, I have a
    > comment/question :

    > Considering that “The containing Enhanced Beacon is not encrypted.”
    > (Section 3), is it necessary to include “rank priority” at L2 and,
    > thus, revealing this information?

I consider it a concern as well.

When returning from a deep sleep,  where there may be multiple
LLNs on different PANIDs (and in 6tisch, with different schedules, even using
different sets of channels),  there is a desire to know which network will
"closer".

I think that we need to understand the tradeoffs, so let's discuss
(also in the ROLL WG!).  Perhaps a compromise is that the rank priority can
be forced to maximum value on networks that want to keep the information
private.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Sun, 23 Sep 2018 17:49:53 -0300

Michael,
             I agree on putting the rank to the maximum value
to code that the network is not interested in accepting more members,
thus, keeping their internal data private.
Regards,

                             Diego

Le dim. 23 sept. 2018 à 17:38, Michael Richardson <[email-masked]> a
écrit :

> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: "Georgios Z. Papadopoulos" <[email-masked]>
Date: Thu, 27 Sep 2018 14:10:40 +0200

Hello Michael,

> On Sep 23, 2018, at 22:38, Michael Richardson <[email-masked]> wrote:
> 
> 

+1

Georgios