Subject: [Roll] Fwd: New Version Notification for draft-audeoudh-rpl-asymmetric-links-00.txt

From: Henry-Joseph Audéoud <[email-masked]>
Date: Wed, 13 Mar 2019 11:52:13 +0100

Dear all,

We have just submitted a new draft
(draft-draft-audeoudh-rpl-asymmetric-links) summarizing some
observations we have made on RPL, using the Contiki's implementation.
It will be discussed at the ROLL meeting in Prague.  Here are the
abstract and the links.

Best,

> Name:		draft-audeoudh-rpl-asymmetric-links
> Revision:	00
> Title:		Experimental observation of RPL: routing protocol overhead and asymmetric links
> Document date:	2019-03-11
> Group:		Individual Submission
> Pages:		10
> URL:            https://www.ietf.org/internet-drafts/draft-audeoudh-rpl-asymmetric-links-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-audeoudh-rpl-asymmetric-links/
> Htmlized:       https://tools.ietf.org/html/draft-audeoudh-rpl-asymmetric-links-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-audeoudh-rpl-asymmetric-links
> 
> 
> Abstract:
>    This document summarizes our observations of the behavior of RPL on a
>    testbed composed of tens of IEEE 802.15.4 nodes.  Our first
>    observation is that the continuous task of estimating the link metric
>    to all candidate neighbors causes a significant background load.
>    This traffic is persistent, even in a stable network where DIO
>    transmissions are eventually widely spaced.  Next, this document
>    focuses on the case of the presence of an asymmetric link, due to
>    either a muted or a deaf node.  In these circumstances, the standard
>    RPL mechanisms may well generate hundreds of routing messages per
>    node and per hour.

-- 
Henry-Joseph Audéoud
Univ. Grenoble Alpes - Grenoble INP - LIG

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 13 Mar 2019 12:32:10 +0000

Many thanks to the authors, this is a great read.

This tells me that we should complete the work on https://tools.ietf.org/html/draft-ietf-roll-dis-modifications which was mostly missing an applicability statement (e.g., network bootstrap vs. new counter in an existing network use cases, and maybe also revive https://tools.ietf.org/html/draft-thubert-roll-asymlink-02... 

All the best,

Pascal

>   -----Original Message-----
>   From: Roll <[email-masked]> On Behalf Of Henry-Joseph Audéoud
>   Sent: mercredi 13 mars 2019 11:52
>   To: ROLL <[email-masked]>
>   Subject: [Roll] Fwd: New Version Notification for draft-audeoudh-rpl-
>   asymmetric-links-00.txt
>   
>   Dear all,
>   
>   (draft-draft-audeoudh-rpl-asymmetric-links) summarizing some observations
>   we have made on RPL, using the Contiki's implementation.
>   It will be discussed at the ROLL meeting in Prague.  Here are the abstract and
>   the links.
>   
>   Best,
>   
>