Subject: Re: [Roll] FW: New Version Notification for draft-thubert-roll-eliding-dio-information-02.txt

From: <[email-masked]>
Date: Mon, 4 Nov 2019 14:39:49 +0000

Hello all,

The draft doesn't talk about unicast/multicast DIS and the resulting
effects on the Trickle timer at the responding router.
In https://tools.ietf.org/html/draft-ietf-roll-dis-modifications-00 , we
addressed this question with a pair of flags:
- N for "no-inconsistency" to signal that the Trickle timer should not be
reset, even with a multicast DIS
- T to signal if a unicast or multicast DIO was solicited. This flag was
meant to be set if a node thinks it is the only one needing the
information (e.g. after a reboot)
Another aspect of the above draft was to request an immediate, one-off
response, in addition to let the general Trickle mechanism trigger a
response at a pseudo-random time according to its parameters.
The behavior is illustrated in a table in Section 5.
The "DIO Option Request" option that we had described in the above draft
is replaced by the R, D, P, M, O flags of
draft-thubert-roll-eliding-dio-information.

Opinions on adding the N and T flags and the immediate response into
draft-thubert-roll-eliding-dio-information?
Best regards

Dominique  

Le 25/10/19 16:52, « Roll on behalf of Pascal Thubert (pthubert) »
<[email-masked] on behalf of [email-masked]> a écrit :

>Dear all:
>
>This commit adds text from Li and other additions on eliding DAO content
>as well.
>
>Cheers,
>
>Pascal
>
>-----Original Message-----
>From: [email-masked] <[email-masked]>
>Sent: vendredi 25 octobre 2019 16:48
>To: Pascal Thubert (pthubert) <[email-masked]>; Li Zhao (liz3)
><[email-masked]>; Rahul Jadhav <[email-masked]>; Rahul Arvind
>Jadhav <[email-masked]>; Dominique Barthel
><[email-masked]>
>Subject: New Version Notification for
>draft-thubert-roll-eliding-dio-information-02.txt
>
>
>A new version of I-D, draft-thubert-roll-eliding-dio-information-02.txt
>has been successfully submitted by Pascal Thubert and posted to the IETF
>repository.
>
>Name:		draft-thubert-roll-eliding-dio-information
>Revision:	02
>Title:		Eliding and Querying RPL Information
>Document date:	2019-10-25
>Group:		Individual Submission
>Pages:		16
>URL:            
>https://www.ietf.org/internet-drafts/draft-thubert-roll-eliding-dio-inform
>ation-02.txt
>Status:         
>https://datatracker.ietf.org/doc/draft-thubert-roll-eliding-dio-informatio
>n/
>Htmlized:       
>https://tools.ietf.org/html/draft-thubert-roll-eliding-dio-information-02
>Htmlized:       
>https://datatracker.ietf.org/doc/html/draft-thubert-roll-eliding-dio-infor
>mation
>Diff:           
>https://www.ietf.org/rfcdiff?url2=draft-thubert-roll-eliding-dio-informati
>on-02
>
>Abstract:
>   This document presents a method to safely elide a group of RPL
>   options in a DIO message by synchonizing the state associated with
>   each of these options between parent and child using a new sequence
>   counter in DIO or DAO messages.  A child that missed a DIO message
>   with an update of any of those protected options detects it by the
>   change of sequence counter and queries the update with a DIS Message.
>   The draft also provides a method to fully elide the options in a DAO
>   message.
>
>                  
>        
>
>
>Please note that it may take a couple of minutes from the time of
>submission until the htmlized version and diff are available at
>tools.ietf.org.
>
>The IETF Secretariat
>
>_______________________________________________
>Roll mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/roll

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Li Zhao (liz3)" <[email-masked]>
Date: Mon, 4 Nov 2019 23:33:43 +0000

Hello Dominique,

I like the idea very much. These two flags are really useful.
Only one question, can we extend T flag to unicast DIS?
There is one case that multiple children may reboot at the same time, it's very common in smart grid deployment because of power outage.
In this case, it's better to use unicast DIS to request multicast DIS.

So can we add some mechanism in T flag to indicate unicast DIS to request multicast response?

Best regards,
Li

On 2019/11/4, 22:40, "[email-masked]" <[email-masked]> wrote:

    Hello all,

    
    Dominique