Subject: Re: [Roll] WG Adoption for turnon-8138 at IETF 106

From: <[email-masked]>
Date: Wed, 11 Dec 2019 17:34:04 +0000

Dear all,

The call for WG adoption of draft-thubert-roll-turnon-rfc8138 has been open since Nov 19th.
Based on the reaction at the WG meeting in Singapore (IETF106) and on the mailing list after that, the WG chairs declare consensus on the matter.
Therefore, Pascal, can you please republish the draft as a WG document?

For the record:

  *   There were positive opinions, including from people who actively contribute to the writing of drafts at ROLL and related WGs, and who contribute to developing or evaluating their implementations.
  *   There was one opposition, arguing that RFC8138 turn on should be done another way.
  *   There is no substantiated technical proposal on the table other than draft-thubert-roll-turnon-rfc8138.

Best regards,
Inès and Dominique

De : Roll <[email-masked]<mailto:[email-masked]>> on behalf of Ines Robles <mariainesrobles=[email-masked]<mailto:mariainesrobles=[email-masked]>>
Répondre à : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date : Tuesday 19 November 2019 02:24
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Objet : [Roll] WG Adoption for turnon-8138 at IETF 106

Dear all,

Today at ROLL Meeting we will discuss the adoption of turnon-8138. It would be nice if you could state your opinion on-site or remotely. The adoption call will be confirmed by ML also,

Thanks,

Ines, Dominique and Peter.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 17 Dec 2019 12:34:58 +0200

On Wed, Dec 11, 2019 at 7:34 PM <[email-masked]> wrote:

> Based on the reaction at the WG meeting in Singapore (IETF106) and on the
> mailing list after that, the WG chairs declare consensus on the matter.
>    - There were positive opinions, including from people who actively
>    contribute to the writing of drafts at ROLL and related WGs, and who
>    contribute to developing or evaluating their implementations.
>    - There was one opposition, arguing that RFC8138 turn on should be
>    done another way.
>
>
>    - There is no substantiated technical proposal on the table other than
>    draft-thubert-roll-turnon-rfc8138.
>
> Adding to the WG record, that that draft is using a reserved bits for
configuring the RPL DAG, and it is using it for configuring the data
compression. The argument on the WG list with authors was WHY that use of
reserved (important question), IMO they did not answer that but asked for
another proposal. Usually IMHO if we get a proposal we discuss that one
proposal and find ways to modify and answer question of why it was designed
that way, because we are working as an ietf group not as individuals.

AB

>
>
> De : Roll <[email-masked]> on behalf of Ines Robles <
> mariainesrobles=[email-masked]>
> Répondre à : "[email-masked]" <[email-masked]>
> À : "[email-masked]" <[email-masked]>
> Today at ROLL Meeting we will discuss the adoption of turnon-8138. It
> would be nice if you could state your opinion on-site or remotely. The
> adoption call will be confirmed by ML also,
>
> Thanks,
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 17 Dec 2019 13:13:26 +0000

This was debated at length during the IETF meeting, which is available on youtube.
I also posted a discussion on this ML.
We ended up with a time bomb on the bits, they’ll be defines only for RPL v1 (MOP<7).

Cheers,

Pascal

From: Roll <[email-masked]> On Behalf Of Abdussalam Baryun
Sent: mardi 17 décembre 2019 11:35
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] WG Adoption for turnon-8138 at IETF 106

On Wed, Dec 11, 2019 at 7:34 PM <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

For the record:

  *   There is no substantiated technical proposal on the table other than draft-thubert-roll-turnon-rfc8138.
Adding to the WG record, that that draft is using a reserved bits for configuring the RPL DAG, and it is using it for configuring the data compression. The argument on the WG list with authors was WHY that use of reserved (important question), IMO they did not answer that but asked for another proposal. Usually IMHO if we get a proposal we discuss that one proposal and find ways to modify and answer question of why it was designed that way, because we are working as an ietf group not as individuals.

AB

De : Roll <[email-masked]<mailto:[email-masked]>> on behalf of Ines Robles <mariainesrobles=[email-masked]<mailto:mariainesrobles=[email-masked]>>

Dear all,

Thanks,

Thank you.
_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 17 Dec 2019 15:55:49 +0200

> This was debated at length during the IETF meeting, which is available on
I did not attend but the WG mailing list is important to discuss these
issues

> * I also posted a discussion on this ML. *
>

We need to work together to make progress, I don't mind discussing but I
hope authors help in progress. once I asked an author in another
organisation and I asked him why you used this type of technology and his
answer was why no. So it is difficult to discuss while requests are replied
by requests, furthermore, no need for two/three proposals only if we work
as individuals.

> * We ended up with a time bomb on the bits, they’ll be defines only for
> RPL v1 (MOP<7).*
>

This should be discussed on the WG list more, and not quickly (why the
hurry we still have time to be perfect, doing it quickly mostly means
mistakes) I did not see this, but will follow up.

AB

>
>
>
>
>
>
>
>
>
>
>
>
>
> *Pascal   From: Roll <[email-masked] <[email-masked]>> On
Behalf Of Abdussalam Baryun Sent: mardi 17 décembre 2019 11:35 To: Routing
Over Low power and Lossy networks <[email-masked] <[email-masked]>> Subject:
Re: [Roll] WG Adoption for turnon-8138 at IETF 106       On Wed, Dec 11,
2019 at 7:34 PM <[email-masked]
<[email-masked]>> wrote: Dear all,   The call for WG adoption
of draft-thubert-roll-turnon-rfc8138 has been open since Nov 19th. Based on
the reaction at the WG meeting in Singapore (IETF106) and on the mailing
list after that, the WG chairs declare consensus on the matter. Therefore,
Pascal, can you please republish the draft as a WG document?   For the
record: - There were positive opinions, including from people who actively
contribute to the writing of drafts at ROLL and related WGs, and who
contribute to developing or evaluating their implementations.- There was
one opposition, arguing that RFC8138 turn on should be done another way.  -
There is no substantiated technical proposal on the table other than
draft-thubert-roll-turnon-rfc8138. Adding to the WG record, that that draft
is using a reserved bits for configuring the RPL DAG, and it is using it
for configuring the data compression. The argument on the WG list with
authors was WHY that use of reserved (important question), IMO they did not
answer that but asked for another proposal. Usually IMHO if we get a
proposal we discuss that one proposal and find ways to modify and answer
question of why it was designed that way, because we are working as an
ietf group not as individuals.    AB       De : Roll <[email-masked]
<[email-masked]>> on behalf of Ines Robles
<mariainesrobles=[email-masked]
<mariainesrobles=[email-masked]>> Répondre à :
"[email-masked] <[email-masked]>" <[email-masked] <[email-masked]>> Date :
Tuesday 19 November 2019 02:24 À : "[email-masked] <[email-masked]>"
<[email-masked] <[email-masked]>> Objet : [Roll] WG Adoption for turnon-8138
at IETF 106   Dear all,   Today at ROLL Meeting we will discuss the
adoption of turnon-8138. It would be nice if you could state your opinion
on-site or remotely. The adoption call will be confirmed by ML also,
Thanks,   Ines, Dominique and Peter.
_________________________________________________________________________________________________________________________
  Ce message et ses pieces jointes peuvent contenir des informations
confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
exploites ou copies sans autorisation. Si vous avez recu ce message par
erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les
pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou
falsifie. Merci.   This message and its attachments may contain
confidential or privileged information that may be protected by law; they
should not be distributed, used or copied without authorisation. If you
have received this email in error, please notify the sender and delete this
message and its attachments. As emails may be altered, Orange is not liable
for messages that have been modified, changed or falsified. Thank you.
_______________________________________________ Roll mailing list
[email-masked] <[email-masked]> https://www.ietf.org/mailman/listinfo/roll
<https://www.ietf.org/mailman/listinfo/roll> *
>
>
>
>
>
> * _______________________________________________ Roll mailing list
> [email-masked] <[email-masked]> https://www.ietf.org/mailman/listinfo/roll
> <https://www.ietf.org/mailman/listinfo/roll> *

---

From: Rahul Jadhav <[email-masked]>
Date: Wed, 18 Dec 2019 08:56:48 +0800

>
> Adding to the WG record, that that draft is using a reserved bits for configuring the RPL DAG, and it is using it for configuring the data compression. The argument on the WG list with authors was WHY that use of reserved (important question), IMO they did not answer that but asked for another proposal.

I was skeptical too about using a reserved bit in DIO Config option
for handshaking a compression flag. But the proposition of using the
reserved bit for MOP<7 made sense to me. We certainly can't set this
flag in DIO base object or any other place in DIO. The reserved bit is
part of DIO Configuration option, and the indication of compression
flag also is a form of DAG-wide configuration. Thus it fits ok
principally too!

Anyways, it would be interesting to learn of other ways from the WG.
8138 is useful and for it to be put to use in existing networks, such
a flag/compression handshake is necessary.