Subject: [Roll] RFC6553 ?

From: Toerless Eckert <[email-masked]>
Date: Thu, 12 Mar 2020 01:20:17 +0100

Quick question: I can not see RFC6553 to be deprecated or superceeded in
RFC Index. Nevertheless:

https://www.iana.org/assignments/ipv6-parameters/ipv6-parameters.xhtml#ipv6-parameters-2

RPL Option (DEPRECATED)	[RFC6553]

Couldn't find quickly an explanation for this.

Can anyone fill me in, pls. ?

Specifically: In my ANIMA ACP draft i tried to unwind all those RPL TLAs
like RPI and that had me include a sentence about RFC6553 being one RPI
option, only to the extend that we do not want to use it though (informational),
so i hope thats fine whether or not RFC6553 is not recommended anymore
in general.

Thanks
    Toerless

---

From: Rahul Jadhav <[email-masked]>
Date: Thu, 12 Mar 2020 01:15:40 +0000

[RJ] https://tools.ietf.org/html/draft-ietf-roll-useofrplinfo-36#section-4.2 updates RFC6553 RPL Option type value from 0x63 to 0x23. The section provides good reasoning for the update. Hope it helps.

Thanks
    Toerless

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 12 Mar 2020 03:59:29 +0100

Argh... ok. And 0x23 was even a line earlier in IANA.

Somewhat of a strance process to deprecate in IANA before useofrplinfo
is RFC. Or could at least have said ("DEPRECATED, see 0x23)

Oh well.

Thanks for helping the blind.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 12 Mar 2020 07:22:25 +0100

On 2020-03-12, at 03:59, Toerless Eckert <[email-masked]> wrote:
> 
> deprecate in IANA before useofrplinfo
> is RFC.

“Is RFC” is not a statement with any meaning outside the bureaucratic satisfaction of it finally being published.  Public service announcement: Do not use this phrase in the sense of progression of a document.

“Is approved” is more interesting.  For useofrplinfo, that was 2019-07-11.
This type of event is also when the IANA actions are implemented (which here took until 2019-07-15).

Grüße, Carsten