Subject: [Roll] FW: New Version Notification for draft-ietf-roll-unaware-leaves-10.txt

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 12 Mar 2020 14:08:55 +0000

Dear all

As discussed with the IOT DIR, this draft is not the gating factor for all cluster C310.
In order to progress I made a full pass on it and fixed a few bugs and misalignments with useofrplinfo.

I believe the doc is ripe for WGLC.

Many thanks

Pascal

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: jeudi 12 mars 2020 15:04
To: Michael Richardson <[email-masked]>; Michael C. Richardson <[email-masked]>; Pascal Thubert (pthubert) <[email-masked]>
Subject: New Version Notification for draft-ietf-roll-unaware-leaves-10.txt

A new version of I-D, draft-ietf-roll-unaware-leaves-10.txt
has been successfully submitted by Pascal Thubert and posted to the IETF repository.

Name:		draft-ietf-roll-unaware-leaves
Revision:	10
Title:		Routing for RPL Leaves
Document date:	2020-03-12
Group:		roll
Pages:		32
URL:            https://www.ietf.org/internet-drafts/draft-ietf-roll-unaware-leaves-10.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-roll-unaware-leaves/
Htmlized:       https://tools.ietf.org/html/draft-ietf-roll-unaware-leaves-10
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-roll-unaware-leaves
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-roll-unaware-leaves-10

Abstract:
   This specification extends RFC6550 and RFC8505 to provide unicast and
   multicast routing services in a RPL domain to 6LNs that are plain
   Hosts and do not participate to RPL, and enables the RPL Root to
   proxy the EDAR/EDAC flow on behalf of the RULs and RANs in its DODAG.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Rahul Jadhav <[email-masked]>
Date: Thu, 12 Mar 2020 14:40:50 +0000

Hello Pascal,

Regarding this statement,
"Non-Storing Mode DAO messages are used to signal external routes to
   the Root, even if the DODAG is operated in Storing Mode."

I couldn't find any text which provides reasoning to do so. Why non-storing mode DAO is needed and why storing mode DAO won't work? There is this text which says, "The Non-Storing Mode DAO messaging enables to advertise the 6LR that serves the RUL and injects the route to the Root." This can be achieved even with storing mode DAO with the target as RUL address and transit information containing parent address as anchor 6LR address.

Trying to understand the reason because this mode of signaling has implications (already covered in the draft), particularly that, when the DAG is operating in storing mode, the communication to RUL from other RANs would mandatorily have to be routed through root only. If we use storing mode DAO then this could be optimized. Not sure if I am missing anything?

Thanks,
Rahul

________________________________
From: Roll <[email-masked]> on behalf of Pascal Thubert (pthubert) <pthubert=[email-masked]>
Sent: 12 March 2020 07:38 PM
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: [Roll] FW: New Version Notification for draft-ietf-roll-unaware-leaves-10.txt

Dear all

Many thanks

Pascal

-----Original Message-----
From: [email-masked] <[email-masked]>
Sent: jeudi 12 mars 2020 15:04
To: Michael Richardson <[email-masked]>; Michael C. Richardson <[email-masked]>; Pascal Thubert (pthubert) <[email-masked]>
Subject: New Version Notification for draft-ietf-roll-unaware-leaves-10.txt

Abstract:

The IETF Secretariat

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 12 Mar 2020 14:56:53 +0000

Hello Rahul 😊

Please find below inline answers. Also, I did not get any objection from 6lo so I added a IANA section that reduces the EARO status range to 0-63, which solves the issue you raised.

I couldn't find any text which provides reasoning to do so. Why non-storing mode DAO is needed and why storing mode DAO won't work?

Pascal> We need the address of the 6LR to terminate the tunnel and remove the artifacts, and the NS signaling will give us that. This is how we removed the hassle of hop by hop link local tunnels that was in the old useofrplinfo.

There is this text which says, "The Non-Storing Mode DAO messaging enables to advertise the 6LR that serves the RUL and injects the route to the Root." This can be achieved even with storing mode DAO with the target as RUL address and transit information containing parent address as anchor 6LR address.

Pascal > Which is not the normal storing mode signaling. It would be an hybrid. The cool thing with NS is that the external prefixes are not visible inside the RPL domain. Legacy nodes do not have to know they exist. Only the 6LR at the border that inject the external routes and the Root are aware and need to know about the new signaling. Using an hybrid impacts every node.

Pascal > Well, yes, we could have done that as well. The path could be optimized but
*  it would mean that the common parent has to encapsulate to the 6LR, which is an additional function there
* It would also mean that the network has ot be aware of external routes, which may be too many for the SM tables.

Pros and cons I guess. We went for the simple and backward compatible way.

Take care,

Pascal
________________________________
From: Roll <[email-masked]<mailto:[email-masked]>> on behalf of Pascal Thubert (pthubert) <pthubert=[email-masked]<mailto:pthubert=[email-masked]>>
Sent: 12 March 2020 07:38 PM
To: Routing Over Low power and Lossy networks <[email-masked]<mailto:[email-masked]>>
Subject: [Roll] FW: New Version Notification for draft-ietf-roll-unaware-leaves-10.txt

Dear all

Many thanks

Pascal

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: jeudi 12 mars 2020 15:04
To: Michael Richardson <[email-masked]<mailto:[email-masked]>>; Michael C. Richardson <[email-masked]<mailto:[email-masked]>>; Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-ietf-roll-unaware-leaves-10.txt

Htmlized:       https://tools.ietf.org/html/draft-ietf-roll-unaware-leaves-10<https://tools.ietf..org/html/draft-ietf-roll-unaware-leaves-10>

Abstract:

The IETF Secretariat

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: Rahul Jadhav <[email-masked]>
Date: Thu, 12 Mar 2020 15:32:22 +0000

[RJ] Yep, that indeed takes care of a major point 😊. Please find my [RJ] responses inline.

Pascal > Which is not the normal storing mode signaling.

[RJ] Yes, but 6550 does not stop us from doing it. Interestingly, I have a use-case in my deployment wherein I need to send this parent address info even in storing MOP. It helps the root get the complete network graph even in storing mode for visualization purposes (if the admin wants to check how the network is formed, how many hops etc on the root in storing mode).

It would be an hybrid. The cool thing with NS is that the external prefixes are not visible inside the RPL domain. Legacy nodes do not have to know they exist. Only the 6LR at the border that inject the external routes and the Root are aware and need to know about the new signaling. Using an hybrid impacts every node.

[RJ] The hybrid may not necessarily impact every node. An intermediate 6LR may decide to ignore that external target in the DAO and that would still be ok. In this case, the signaling will work through next common ancestor which has to capability to hold/process that kind of info.

[RJ] I am just keen on doing this because it makes things flexible. Anchor 6LR has both options of sending NS-DAO or storing DAO. Intermediate 6LRs also have both options, honor the external target info or ignore it and just pass it on.

[RJ] Yes, Backward compatibility may be an issue because intermediate 6LRs operating in pure storing mode will try to cache the external target and may not be able to do IP-in-IP at their point. However, handling this compatibility may not be a big challenge. The flexibility this provides is very compelling to me. With DAO projection, we have already entered that zone where the nodes could be hybrid in nature.

Take care,

Pascal

Dear all

Many thanks

Pascal

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: jeudi 12 mars 2020 15:04
To: Michael Richardson <[email-masked]<mailto:[email-masked]>>; Michael C. Richardson <[email-masked]<mailto:[email-masked]>>; Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-ietf-roll-unaware-leaves-10.txt

Abstract:

The IETF Secretariat

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 12 Mar 2020 16:49:30 +0000

Hello Rahul

RFC 6550 says:

“

9.8<https://tools.ietf.org/html/rfc6550#section-9.8>.  Storing Mode

   In Storing mode, RPL routes messages Downward by the IPv6 destination
   address.  The following rules apply to nodes that are in Storing
   mode:

   1.  The DODAG Parent Address subfield of a Transmit Information
       option MUST be empty.

“

So even if it is a good idea it requires new specs to override RFC 6550.

More below (using P2>)

From: Rahul Jadhav <[email-masked]>
Sent: jeudi 12 mars 2020 16:32
To: Pascal Thubert (pthubert) <[email-masked]>; Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: New Version Notification for draft-ietf-roll-unaware-leaves-10.txt

P2> It does actually, see above

P2> which is still an impact; new code to recognize the ‘E’ flag and decide to ignore the address. A legacy node would not do the right thing.

P2> I’m happy to discuss it and see if and how we open RPL in that direction. But for short term we’re shipping useofrplinfo and RUL with the low hanging fruit.

PT2> with the capability work we’ll be able to introduce this and more : )

Take care,

Pascal

Dear all

Many thanks

Pascal

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: jeudi 12 mars 2020 15:04
To: Michael Richardson <[email-masked]<mailto:[email-masked]>>; Michael C. Richardson <[email-masked]<mailto:[email-masked]>>; Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-ietf-roll-unaware-leaves-10.txt

Abstract:

The IETF Secretariat

---

From: Rahul Jadhav <[email-masked]>
Date: Thu, 12 Mar 2020 17:05:59 +0000

???? Yes, looks like i have been violating the rfc in our internal implementation to fulfill the use case.
Regarding the use of non storing dao in storing mode for RUL nodes, I am now clear about the whole picture and appreciate the discussion.

Thanks,
Rahul
________________________________
From: Pascal Thubert (pthubert) <[email-masked]>
Sent: Friday, March 13, 2020 12:49:30 AM
To: Rahul Jadhav <[email-masked]>; Routing Over Low power and Lossy networks <[email-masked]>
Subject: RE: New Version Notification for draft-ietf-roll-unaware-leaves-10.txt

Hello Rahul

RFC 6550 says:

“

   mode:

       option MUST be empty.

“

More below (using P2>)

[RJ] Yep, that indeed takes care of a major point ??. Please find my [RJ] responses inline.

Take care,

Pascal

Dear all

Many thanks

Pascal

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: jeudi 12 mars 2020 15:04
To: Michael Richardson <[email-masked]<mailto:[email-masked]>>; Michael C. Richardson <[email-masked]<mailto:[email-masked]>>; Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-ietf-roll-unaware-leaves-10.txt

Abstract:

The IETF Secretariat