Subject: Re: [Roll] DIS-modifications use cases; Re: FW: New Version Notification for draft-ietf-roll-dis-modifications-01.txt

From: "Georgios Z. Papadopoulos" <[email-masked]>
Date: Tue, 3 Mar 2020 11:18:09 +0100

Dear all,

I just updated the repository with Rahul’s use-case “Adjacencies probing with RPL” : https://github.com/roll-wg/roll-dis-modifications-use-cases <https://github.com/roll-wg/roll-dis-modifications-use-cases>
Many thanks Rahul! 

Please let me know if you have more use-cases in mind.

Thx,
Georgios

> On Feb 25, 2020, at 08:43, [email-masked] wrote:
> 
> Hello Rahul, all,
> 
> Thanks, Rahul,  for your contribution, this is helpful!
> WG, others ideas, comments?
> Best regards
> 
> Dominique
> 
> De : Roll <[email-masked] <mailto:[email-masked]>> on behalf of Rahul Jadhav <[email-masked] <mailto:[email-masked]>>
> Répondre à : "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> Date : Tuesday 25 February 2020 06:38
> À : "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> Objet : Re: [Roll] DIS-modifications use cases; Re: FW: New Version Notification for draft-ietf-roll-dis-modifications-01.txt
> 
> 
> 
> On Mon, 24 Feb 2020 at 22:22, <[email-masked] <mailto:[email-masked]>> wrote:
>> Dear Rollers,
>> 
>> In preparation for the modification of the DIS (DODAG Information
>> Solicitation), we are collecting the use cases.
>> We want to make sure we understand all the requirements before crafting a
>> solution.
>> Georgios has kindly prepared a document on the ROLL GitHub repo.
>> See a text rendition at
>> https://github.com/roll-wg/roll-dis-modifications-use-cases/blob/master/dra
>> ft-papadopoulos-roll-dis-modifications-use-cases.txt <https://github.com/roll-wg/roll-dis-modifications-use-cases/blob/master/draft-papadopoulos-roll-dis-modifications-use-cases.txt>
> [RJ] Thanks Georgios. This surely helps. I am assuming that the use-cases text will get merged in the dis-modifications draft.
> One point mentioned in the use-cases draft is that unicast DIS can request __specific__ metric information from the parent. Currently, the parent sends the complete metric set to the child using unicast DIO. Wondering whether we need this mechanism for sending specific metric info back to the child node. The draft does not give a use-case for this. Anyways, this would be discussed when the drafts get merged and sent to the group.
> 
>> Currently, the document has two use cases:
>> - a new node joins an established RPL network. The use case calls for a
>> fairly quick confirmation that the node has joined with a good quality
>> path. However, we don't want to reset the Trickle timers of all nearby
>> routers and trigger broadcast, since the use case is that just one new
>> node was added/replaced/rebooted.
>> - another use case is that several nodes join at about the same time (e.g.
>> electricity meters all reboot following power outage). We want the DIOs to
>> be sent with broadcast so that all joining nodes benefit from them.
>> The draft draft-thubert-roll-eliding-dio-information-03 has another
>> request for modifying the DIS. We'll soon incorporate it into the use
>> cases document.
> 
> [RJ] Another use-case is of "adjacency probing". While (I believe) no new primitives need to be added, still the use-case is well-worth mentioning. The RPL-observations draft points to this use-case and you can pick some text from there.
>  
>  _________________________________________________________________________________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
> Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged information that may be protected by law;
> they should not be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
> Thank you.
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: <[email-masked]>
Date: Fri, 6 Mar 2020 09:47:19 +0000

Dear all,

The cut-off date for draft publication before IETF107 is Monday, approaching fast.
If you have requirements for new/different DIS behaviour, please let us know what they are, preferably before Monday noon CET.
You can write a description by email, or submit a Pull Request to the github repo indicated below.
We'll publish a draft on Monday so that we can discuss it at IETF107.
Best regards,

Dominique

De : "Georgios Z. Papadopoulos" <[email-masked]<mailto:[email-masked]>>
Date : Tuesday 3 March 2020 11:18
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc : Rahul Jadhav <[email-masked]<mailto:[email-masked]>>, Dominique Barthel <[email-masked]<mailto:[email-masked]>>
Objet : Re: [Roll] DIS-modifications use cases; Re: FW: New Version Notification for draft-ietf-roll-dis-modifications-01.txt

Dear all,

I just updated the repository with Rahul’s use-case “Adjacencies probing with RPL” : https://github.com/roll-wg/roll-dis-modifications-use-cases
Many thanks Rahul!

Thx,
Georgios

On Feb 25, 2020, at 08:43, [email-masked]<mailto:[email-masked]> wrote:

Hello Rahul, all,

Dominique

De : Roll <[email-masked]<mailto:[email-masked]>> on behalf of Rahul Jadhav <[email-masked]<mailto:[email-masked]>>
Répondre à : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date : Tuesday 25 February 2020 06:38
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Objet : Re: [Roll] DIS-modifications use cases; Re: FW: New Version Notification for draft-ietf-roll-dis-modifications-01.txt

On Mon, 24 Feb 2020 at 22:22, <[email-masked]<mailto:[email-masked]>> wrote:
Dear Rollers,

ft-papadopoulos-roll-dis-modifications-use-cases.txt<https://github.com/roll-wg/roll-dis-modifications-use-cases/blob/master/draft-papadopoulos-roll-dis-modifications-use-cases.txt>

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll