Subject: [Roll] New Version for draft-ietf-roll-useofrplinfo-38.txt

From: Ines Robles <[email-masked]>
Date: Mon, 23 Mar 2020 18:52:24 +0200

Dear all,

We have updated the document:

-  We add in Section 7.1.3. SM: Example of Flow from Root to RUL, a case
with no encapsulation (Figure 11)
- We add more clarification to the tables, e.g. in the Modified headers
row, we changed IP-IP(RPI) to RPI - this indicates that only the RPI is
modified and not the IP-IP.
- Adding text to explain the modifications.
- We eliminate the Hop-by-Hop re-encapuslation definition and
following mention in the text, because it is not used.

Diff:
https://tools.ietf.org/rfcdiff?url2=draft-ietf-roll-useofrplinfo-38.txt

Comments welcome,

Thank you,

The authors.

---------- Forwarded message ---------
From: <[email-masked]>
Date: Mon, Mar 23, 2020 at 6:41 PM
Subject: New Version Notification for draft-ietf-roll-useofrplinfo-38.txt
To: Michael C. Richardson <[email-masked]>, Pascal Thubert <
[email-masked]>, Maria Ines Robles <[email-masked]>

A new version of I-D, draft-ietf-roll-useofrplinfo-38.txt
has been successfully submitted by Maria Ines Robles and posted to the
IETF repository.

Name:           draft-ietf-roll-useofrplinfo
Revision:       38
Title:          Using RPI Option Type, Routing Header for Source Routes and
IPv6-in-IPv6 encapsulation in the RPL Data Plane
Document date:  2020-03-23
Group:          roll
Pages:          63
URL:
https://www.ietf.org/internet-drafts/draft-ietf-roll-useofrplinfo-38.txt
Status:
https://datatracker.ietf.org/doc/draft-ietf-roll-useofrplinfo/
Htmlized:       https://tools.ietf.org/html/draft-ietf-roll-useofrplinfo-38
Htmlized:
https://datatracker.ietf.org/doc/html/draft-ietf-roll-useofrplinfo
Diff:
https://www.ietf.org/rfcdiff?url2=draft-ietf-roll-useofrplinfo-38

Abstract:
   This document looks at different data flows through LLN (Low-Power
   and Lossy Networks) where RPL (IPv6 Routing Protocol for Low-Power
   and Lossy Networks) is used to establish routing.  The document
   enumerates the cases where RFC6553 (RPI Option Type), RFC6554
   (Routing Header for Source Routes) and IPv6-in-IPv6 encapsulation is
   required in data plane.  This analysis provides the basis on which to
   design efficient compression of these headers.  This document updates
   RFC6553 adding a change to the RPI Option Type.  Additionally, this
   document updates RFC6550 defining a flag in the DIO Configuration
   option to indicate about this change and updates [RFC8138] as well to
   consider the new Option Type when the RPL Option is decompressed.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 23 Mar 2020 16:57:14 +0000

Dear Ines:

I checked and found it ready for publication.

Many thanks for your patience!

Be safe;

Pascal

From: Roll <[email-masked]> On Behalf Of Ines Robles
Sent: lundi 23 mars 2020 17:52
To: roll <[email-masked]>
Subject: [Roll] New Version for draft-ietf-roll-useofrplinfo-38.txt

Dear all,

-  We add in Section 7.1.3. SM: Example of Flow from Root to RUL, a case with no encapsulation (Figure 11)
- We add more clarification to the tables, e.g. in the Modified headers row, we changed IP-IP(RPI) to RPI - this indicates that only the RPI is modified and not the IP-IP.
- Adding text to explain the modifications.
- We eliminate the Hop-by-Hop re-encapuslation definition and following mention in the text, because it is not used.

Diff: https://tools.ietf.org/rfcdiff?url2=draft-ietf-roll-useofrplinfo-38.txt

Comments welcome,

Thank you,

The authors.
---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Mon, Mar 23, 2020 at 6:41 PM
Subject: New Version Notification for draft-ietf-roll-useofrplinfo-38.txt
To: Michael C. Richardson <[email-masked]<mailto:[email-masked]>>, Pascal Thubert <[email-masked]<mailto:[email-masked]>>, Maria Ines Robles <[email-masked]<mailto:[email-masked]>>

Name:           draft-ietf-roll-useofrplinfo
Revision:       38
Title:          Using RPI Option Type, Routing Header for Source Routes and IPv6-in-IPv6 encapsulation in the RPL Data Plane
Document date:  2020-03-23
Group:          roll
Pages:          63
URL:            https://www.ietf.org/internet-drafts/draft-ietf-roll-useofrplinfo-38.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-roll-useofrplinfo/
Htmlized:       https://tools.ietf.org/html/draft-ietf-roll-useofrplinfo-38
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-roll-useofrplinfo
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-roll-useofrplinfo-38

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat