Subject: [Roll] Routing Over Low power and Lossy networks (roll) WG Virtual Meeting: 2020-05-25

From: IESG Secretary <[email-masked]>
Date: Thu, 07 May 2020 09:37:17 -0700

The Routing Over Low power and Lossy networks (roll) Working Group will hold
a virtual interim meeting on 2020-05-25 from 11:00 to 13:00 UTC.

Agenda:
Draft Agenda:

New Option and Backward compatibility
Compression for control messages? Applicable for nsa-extension
RPL Observation topics 
RPL Ping
Additional Items to be determined

Information about remote participation:
Roll interim May meeting Hosted by ROLL WG  Monday, May 25, 2020 6:45 am | 2 hours 45 minutes | (UTC-04:00) Eastern Time (US & Canada) 
Meeting number: 611 684 862 
Password: vbR9EnBMs98 

https://ietf.webex.com/ietf/j.php?MTID=m59fad4e3500688e160f0d772b9f942ac  

Join by video system 
Dial [email-masked] 
You can also dial 173.243.2.68 and enter your meeting number.  
Join by phone 1-650-479-3208 
Call-in toll number (US/Canada) 
Access code: 611 684 862

Meeting Information like link to video recording , etc would be located in https://github.com/roll-wg/ROLL-Interim-Meeting

---

From: Ines Robles <[email-masked]>
Date: Thu, 14 May 2020 10:20:00 +0300

Dear all,

Please let us know the topics that you would like to discuss during the
meeting by 19th May.

So far we have a draft Agenda (topics resulting from the previous (04-29)
interim meeting):

   - New Option and Backward compatibility
   - Compression for control messages? Applicable for nsa-extension
   - RPL Observation topics
   - RPL Ping

You can upload the slides here:
https://datatracker.ietf.org/meeting/interim-2020-roll-02/session/roll
The link to the video recording will be available here:
https://github.com/roll-wg/ROLL-Interim-Meeting/tree/master/20200525
Webex details can be found below.

Thank you and have a nice day,

Ines and Dominique

---------- Forwarded message ---------
From: IESG Secretary <[email-masked]>
Date: Thu, May 7, 2020 at 7:39 PM
Subject: [Roll] Routing Over Low power and Lossy networks (roll) WG Virtual
Meeting: 2020-05-25
To: IETF-Announce <[email-masked]>
Cc: <[email-masked]>

Agenda:
Draft Agenda:

Information about remote participation:
Roll interim May meeting Hosted by ROLL WG  Monday, May 25, 2020 6:45 am |
2 hours 45 minutes | (UTC-04:00) Eastern Time (US & Canada)
Meeting number: 611 684 862
Password: vbR9EnBMs98

Join by video system

Meeting Information like link to video recording , etc would be located in
https://github.com/roll-wg/ROLL-Interim-Meeting

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 14 May 2020 07:52:11 +0000

Hello Ines

If time permits, I’d like to present the proposed operation of https://datatracker.ietf.org/doc/draft-thubert-roll-eliding-dio-information/ and get confirmation of the interest on the work by the WG. To go deeply in the proposed operation we probably need at least 20 minutes. Then we need to challenge it and improve the design, this could be started here and continued on the ML.

For memory, this draft is the result of a past discussion at a ROLL interim. We found that the DIO could not be made larger and larger forever, and that eliding options would cause nodes to miss critical changes, which could have operational consequences. So we decided that RPLv2 must ensure that all nodes are synchronized on configuration changes and capability exchanges.

As for other drafts, this is infrastructure work that we need before the new features come in. If we reach an agreement to continue with the work I’ll be happy to progress the draft and make the changes we decide in the personal submission.

Take care,

Pascal

From: Roll <[email-masked]> On Behalf Of Ines Robles
Sent: jeudi 14 mai 2020 09:20
To: roll <[email-masked]>
Subject: [Roll] WG Virtual Meeting: 2020-05-25

Dear all,

Please let us know the topics that you would like to discuss during the meeting by 19th May.

So far we have a draft Agenda (topics resulting from the previous (04-29) interim meeting):

  *   New Option and Backward compatibility
  *   Compression for control messages? Applicable for nsa-extension
  *   RPL Observation topics
  *   RPL Ping

You can upload the slides here: https://datatracker.ietf.org/meeting/interim-2020-roll-02/session/roll
The link to the video recording will be available here: https://github.com/roll-wg/ROLL-Interim-Meeting/tree/master/20200525
Webex details can be found below.

Ines and Dominique

---------- Forwarded message ---------
From: IESG Secretary <[email-masked]<mailto:[email-masked]>>
Date: Thu, May 7, 2020 at 7:39 PM
Subject: [Roll] Routing Over Low power and Lossy networks (roll) WG Virtual Meeting: 2020-05-25
To: IETF-Announce <[email-masked]<mailto:[email-masked]>>
Cc: <[email-masked]<mailto:[email-masked]>>

Agenda:
Draft Agenda:

Join by video system
Dial [email-masked]<mailto:[email-masked]>
You can also dial 173.243.2.68 and enter your meeting number.
Join by phone 1-650-479-3208
Call-in toll number (US/Canada)
Access code: 611 684 862

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: Ines Robles <[email-masked]>
Date: Wed, 20 May 2020 12:00:11 +0300

Dear all,

Please find below the agenda to the Monday 25th Interim meeting.

https://datatracker.ietf.org/meeting/interim-2020-roll-02/materials/agenda-interim-2020-roll-02-roll-01.txt

11:00 - 11:10 [10 min] WG Status --IETF 108: Meeting Format (when we meet?
how much time, slots?) -- Ines/Dominique
11:10 - 11:30 [20 min] draft-thubert-roll-eliding-dio-information -- Pascal
11:30 - 11:50  [20 min] New Option and Backward compatibility  -- Everyone
11:50 - 12:10  [20 min] Compression for control messages? Applicable for
nsa-extension --- Everyone
12:10 - 12:30  [20 min] RPL Observation topics -- Everyone
12:30 - 12:50  [20 min] RPL Ping -- Everyone
12:50 -13:00  [10 min] Open Floor  -- Everyone

Please use
https://datatracker.ietf.org/meeting/interim-2020-roll-02/session/roll if
you want to upload some slides for topic presentation

Comments welcome,

Thank you and best regards,

Ines and Dominique

On Thu, May 14, 2020 at 10:52 AM Pascal Thubert (pthubert) <pthubert=
[email-masked]> wrote:

> Hello Ines
>
>
>
> If time permits, I’d like to present the proposed operation of
> https://datatracker.ietf.org/doc/draft-thubert-roll-eliding-dio-information/
> and get confirmation of the interest on the work by the WG. To go deeply in
> the proposed operation we probably need at least 20 minutes. Then we need
> to challenge it and improve the design, this could be started here and
> continued on the ML.
>
>
>
> For memory, this draft is the result of a past discussion at a ROLL
> interim. We found that the DIO could not be made larger and larger forever,
> and that eliding options would cause nodes to miss critical changes, which
> could have operational consequences. So we decided that RPLv2 must ensure
> that all nodes are synchronized on configuration changes and capability
> exchanges.
>
>
>
> As for other drafts, this is infrastructure work that we need before the
> new features come in. If we reach an agreement to continue with the work
> I’ll be happy to progress the draft and make the changes we decide in the
> personal submission.
>
>
>
> Take care,
>
>
>
> Pascal
>
>
>
>
>
> *From:* Roll <[email-masked]> *On Behalf Of *Ines Robles
> *Sent:* jeudi 14 mai 2020 09:20
> *To:* roll <[email-masked]>
> *Subject:* [Roll] WG Virtual Meeting: 2020-05-25
>
>
>
> Dear all,
>
>
>
> From: *IESG Secretary* <[email-masked]>

---

From: Ines Robles <[email-masked]>
Date: Mon, 25 May 2020 11:18:37 +0300

Dear all,

Please find below information about the Today ROLL Interim Meeting:

1. Materials:

Where you can find:

1.1 Proposed Agenda:

1.2 Complete Set of Slides:
https://datatracker.ietf.org/meeting/interim-2020-roll-02/materials/slides-interim-2020-roll-02-sessa-completeset-roll-interim-20200525

2. Etherpad:
https://etherpad.ietf.org:9009/p/notes-ietf-roll-interim-20200525

 - Bluesheets: The Etherpad is working as blueesheet, so please remember to
add your name  and affiliation. Please consider volunteer as minute-taker.

3- Jabber room: [email-masked]. Information for setting
https://www.ietf.org/how/meetings/jabber/

4. Please note that we aim to record the meeting. The link to the video
recording is going to be available here
https://github.com/roll-wg/ROLL-Interim-Meeting/tree/master/20200525

5. Webex details:

Note that the webex will open 15 minutes before, in case that the
presenters want to test screen-sharing, audio, video  features. We aim to
have the meeting in two hours, however the webex is going to be open still
30 minutes more in case that some discussion requires more time or if
someone wants to discuss with the chairs after the meeting, etc.

Roll interim May meeting
Hosted by ROLL WG

Monday, May 25, 2020 6:45 am | 2 hours 45 minutes | (UTC-04:00) Eastern
Time (US & Canada)
Meeting number: 611 684 862
Password: vbR9EnBMs98
https://ietf.webex.com/ietf/j.php?MTID=m59fad4e3500688e160f0d772b9f942ac

Join by video system

Join by phone
1-650-479-3208 Call-in toll number (US/Canada)
Access code: 611 684 862

Comments welcome! :)

Thank you,

Ines and Dominique

On Wed, May 20, 2020 at 12:00 PM Ines Robles <[email-masked]>
wrote:

>> Roll interim May meeting Hosted by ROLL WG  Monday, May 25, 2020 6:45 am
>> | 2 hours 45 minutes | (UTC-04:00) Eastern Time (US & Canada)
>> Meeting Information like link to video recording , etc would be located
>> in https://github.com/roll-wg/ROLL-Interim-Meeting
>>

---

From: Ines Robles <[email-masked]>
Date: Sun, 31 May 2020 23:11:39 +0300

Dear all,

Please find the link to the video of the meeting on 20200525:

https://github.com/roll-wg/ROLL-Interim-Meeting/blob/master/20200525/LinkToVideoRecording
- Note that all IETF Interim meetings are posted in Youtube.

Conclusions/Action Points of the meeting:

-- IETF 108: Form with questions related to -- meeting during IETF
108/meeting after IETF108-- to be sent shortly.

-- Backward compatibility and New Options:
Proposition 2
"Use second higher order bit of Option Type to indicate 'X' extended Option
Flag": More flexible than Proposition 1, need more examples to discuss, to
be included into MOPEX draft, Use Core-Flags as base: Critical, Elective
and Safte-to-Forward.  [minute 0:20 to minute 0:27]

-- Compression of Control Messages: The mechanism to be developed  do not
need to include information into nsa-extension, thus nsa-extension can move
forward. No objections [minute 0:37 to minute 0:43]

-- RPL-Observations: Important document to track the development of RPLv2

-- Draft-thubert-roll-eliding-dio-information: Please read and send your
review to the ML.

 -- RootAck:
Are there dependencies with unaware-leaves draft? [minute 1:39 to minutes
1:41]
Handling Capability Query: Keep separte messages RootCapQuery and
CapResponse [minute 1:47 to minute 1:50]

--Open Floor: Good to have an interim meeting in June.

Minutes:
https://datatracker.ietf.org/meeting/interim-2020-roll-02/materials/minutes-interim-2020-roll-02-202005251100.txt

Comments welcome,

Thank you,

Ines and Dominique

On Mon, May 25, 2020 at 11:18 AM Ines Robles <[email-masked]>
wrote:

>  - Bluesheets: The Etherpad is working as blueesheet, so please remember
> to add your name  and affiliation. Please consider volunteer as
> minute-taker.
>
> On Wed, May 20, 2020 at 12:00 PM Ines Robles <
> [email-masked]> wrote:
>
>> Dear all,
>>
>> 11:00 - 11:10 [10 min] WG Status --IETF 108: Meeting Format (when we
>> meet? how much time, slots?) -- Ines/Dominique
>> if you want to upload some slides for topic presentation
>>
>> Comments welcome,
>>