Subject: Re: [Roll] Eliding-Info: Abbreviated Option and RCSS of an Option

From: "Li Zhao (liz3)" <[email-masked]>
Date: Thu, 4 Jun 2020 08:28:23 +0000

Hello Rahul,

RCSS can identify whole options in DIO, but it may be not flexible.
Imagine the case that some reduced function device which don’t support MOPex/GCO, when root only update MOPex/GCO, even though RCSS increment, DIO can carry AOO and advertise the updated options, these RFDs could ignore the RCSS increment.

Is it possible to add mode for RCSS? Simple mode means RCSS can only be a common counter for all the options. Complex mode means AOO can identify individual protected options?

Best regards,
Li

From: Roll <[email-masked]> on behalf of Rahul Jadhav <[email-masked]>
Reply-To: Routing Over Low power and Lossy networks <[email-masked]>
Date: Thursday, June 4, 2020 at 15:45
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: [Roll] Eliding-Info: Abbreviated Option and RCSS of an Option

Hello All, Pascal,

Based on my understanding currently, the draft serves three purposes:
1. Helps elide common DIO options which rarely change
2. Helps elide common DAO options during route refresh cycles
3. Allow sync for individual protected options by assigning RCSS to an option (this implies the use of new AOO)

Points 1 and 2 are quite clear and easy to follow.

The whole complexity of the proposal lies in point 3 and from what I understand I believe the utility is not convincing enough for the amount of complexity it introduces.

My understanding is that with AOO, it is possible that a Root assigns a different RCSS to individual protected options such that the downstream nodes can individually query and synchronize with any of that option on change.

My rationale is that PIO/RIO/DODAG Configuration/MOPex/GCO options rarely change. IMO, if either of it changes then it is no big deal to advertise all the options. Rather than managing versions for each of these options, the RCSS can only be a common counter for all the options.

I understand that RCSS of an option is "an extension" and it is possible to only use common RCSS. But I believe the whole RCSS of an option as an extension is adding to the complexity of the draft (introducing more scenarios to handle), and also making it difficult for the reader.

Best,
Rahul

---

From: Rahul Jadhav <[email-masked]>
Date: Thu, 4 Jun 2020 08:44:04 +0000

Please find my response inline [RJ].

[RJ] I would argue on the contrary that for an RFD the complexity of AOO is even less useful. Assuming that the protected options change rarely, how big is the utility for an RFD to know that only one of the protected options is changed and syncing it individually.

[RJ] I understand that the draft supports simple mode and complex mode (using AOO) is only an extension. But what I intend to say is that the complex mode may be a deterrent to anyone reading the draft. More importantly, I could not figure out much utility. The purpose of this draft is to reduce runtime network overhead. I would argue that complex mode will reduce the control overhead by a fraction of a percentage but requires more flash/ram.

Hello All, Pascal,

Best,

Rahul

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 4 Jun 2020 09:23:58 +0000

Hello Rahul

If the root always sends all options when it increments the RCSS then we get the behavior you're proposing.
So maybe the possibility to advertise options separately is a capability?

Pascal

From: Roll <[email-masked]> On Behalf Of Rahul Jadhav
Sent: jeudi 4 juin 2020 10:44
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] Eliding-Info: Abbreviated Option and RCSS of an Option

Imagine the case that some reduced function device which don't support MOPex/GCO, when root only update MOPex/GCO, even though RCSS increment, DIO can carry AOO and advertise the updated options, these RFDs could ignore the RCSS increment.

From: Roll <[email-masked]<mailto:[email-masked]>> on behalf of Rahul Jadhav <[email-masked]<mailto:[email-masked]>>
Reply-To: Routing Over Low power and Lossy networks <[email-masked]<mailto:[email-masked]>>
Date: Thursday, June 4, 2020 at 15:45
To: Routing Over Low power and Lossy networks <[email-masked]<mailto:[email-masked]>>
Subject: [Roll] Eliding-Info: Abbreviated Option and RCSS of an Option

Hello All, Pascal,

Best,

Rahul

---

From: Rahul Jadhav <[email-masked]>
Date: Thu, 4 Jun 2020 20:06:13 +0800

To simply state:
I believe that using per option RCSS will have negligible/no improvement in
the control overhead.

We can keep per option RCSS just for flexibility and as Li mentioned, we
can keep simple/complex modes separated out in the draft. That is one way
to handle it if we still go for it.
But I still am in favor of not using per option RCSS at all.

On Thu, 4 Jun 2020 at 17:24, Pascal Thubert (pthubert) <pthubert=
[email-masked]> wrote:

> Hello Rahul
>
>
>
> If the root always sends all options when it increments the RCSS then we
> get the behavior you’re proposing.
>

[RJ] Yes, this is what I would like to have (and is already clearly there).

> So maybe the possibility to advertise options separately is a capability?

[RJ] Yeah, if we still decide to go for per option RCSS, then yes,
capability can help.

>
> Pascal
>
>
>
> *From:* Roll <[email-masked]> *On Behalf Of *Rahul Jadhav
> *Sent:* jeudi 4 juin 2020 10:44
> *To:* Routing Over Low power and Lossy networks <[email-masked]>
> *Subject:* Re: [Roll] Eliding-Info: Abbreviated Option and RCSS of an
> Option
>
>
>
> Imagine the case that some reduced function device which don’t support MOPex/GCO,
> when root only update MOPex/GCO, even though RCSS increment, DIO can carry
> AOO and advertise the updated options, these RFDs could ignore the RCSS
> increment.
>
>
>
> [RJ] I would argue on the contrary that for an RFD the complexity of AOO
> is even less useful. Assuming that the protected options change rarely, how
> big is the utility for an RFD to know that only one of the protected
> options is changed and syncing it individually.
>
>
>
> Is it possible to add mode for RCSS? Simple mode means RCSS can only be a
> common counter for all the options. Complex mode means AOO can identify
> individual protected options?
>
>
>
> [RJ] I understand that the draft supports simple mode and complex mode
> (using AOO) is only an extension. But what I intend to say is that the
> complex mode may be a deterrent to anyone reading the draft. More
> importantly, I could not figure out much utility. The purpose of this draft
> is to reduce runtime network overhead. I would argue that complex mode will
> reduce the control overhead by a fraction of a percentage but requires more
> flash/ram.
>
>
>
>
>
>
>
>
>
> *From: *Roll <[email-masked]> on behalf of Rahul Jadhav <
> [email-masked]>
> *Reply-To: *Routing Over Low power and Lossy networks <[email-masked]>
> *Date: *Thursday, June 4, 2020 at 15:45
> *To: *Routing Over Low power and Lossy networks <[email-masked]>
> *Subject: *[Roll] Eliding-Info: Abbreviated Option and RCSS of an Option
>
>
>
> Hello All, Pascal,
>
>
>
> The whole complexity of the proposal lies in point 3 and from what I
> understand I believe the utility is not convincing enough for the amount of
> complexity it introduces.
>
>
>
> My understanding is that with AOO, it is possible that a Root assigns a
> different RCSS to individual protected options such that the downstream
> nodes can individually query and synchronize with any of that option on
> change.
>
>
>
> My rationale is that PIO/RIO/DODAG Configuration/MOPex/GCO options rarely
> change. IMO, if either of it changes then it is no big deal to advertise
> all the options. Rather than managing versions for each of these options,
> the RCSS can only be a common counter for all the options.
>
>
>
> I understand that RCSS of an option is "an extension" and it is possible
> to only use common RCSS. But I believe the whole RCSS of an option as an
> extension is adding to the complexity of the draft (introducing more
> scenarios to handle), and also making it difficult for the reader.
>
>
>
> Best,
>
> Rahul
>
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>