Subject: [Roll] Default setting for config flags after MOP 7.

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 21 Jul 2020 10:03:41 +0000

Dear all:

During Alvaro's review, another point was raised for which we need a group consensus.

We said repeatedly that the turnon flag is defined only for MOPs < 7. This is also true for the "RPI 0x23 enable" flag defined in useofrplinfo.

So we are asking implementation to check that the MOP is less than 7 before they use the flag and only use it in that case.

But then, when it finds a MOP that is >= 7, what should the code that we write today do? For one thing RFC 6550 makes it a leaf. 
But what about the RFC 8138 compression and the RPI 0x23?

For both bits, the assumption would be that the probation phase has ended and that implementations have migrated.
This means that after MOP 7 the default is that RFC 8138 is turned on, and that Option Type in the RPL option is 0x23.

Do we agree?

Pascal

---

From: Michael Richardson <[email-masked]>
Date: Tue, 21 Jul 2020 09:18:12 -0400

Pascal Thubert \(pthubert\) <pthubert=[email-masked]> wrote:
    > But then, when it finds a MOP that is >= 7, what should the code that
    > we write today do? For one thing RFC 6550 makes it a leaf.

So, it would find that MOP=7, and there was a MOPEX which it did not
understand?
Yes, as a RPL aware leaf maybe? It should be able to send DAOs, right?
Well, but it might not know where to send them, not knowing if it is in
storing or non-storing.

    > For both bits, the assumption would be that the probation phase has
    > ended and that implementations have migrated.

{yes, and some old hardware has been turned back on. Maybe it will upgrade
over the air...}

    > This means that after MOP 7 the default is that RFC 8138 is turned on,
    > and that Option Type in the RPL option is 0x23.

Yes, I agree.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 21 Jul 2020 13:47:22 +0000

> -----Original Message-----
> From: Roll <[email-masked]> On Behalf Of Michael Richardson
> Sent: mardi 21 juillet 2020 15:18
> To: Routing Over Low power and Lossy networks <[email-masked]>
> Subject: Re: [Roll] Default setting for config flags after MOP 7.
> 
> 
> Well, but it might not know where to send them, not knowing if it is in storing
> or non-storing.

True, the MOP may be even yet another thingy. RUL is the safest bet, but at the time of RFC 6550 RULs did not exist so we said leaf.
The current text has language to MUST RUL operation when not supporting RFC 8138 and the flag is set.
"
   It is RECOMMENDED to only deploy nodes that support [RFC8138] in a
   network where the compression is turned on.  A node that does not
   support [RFC8138] MUST only be used as a RUL.
"

The same should be recommended for a non-understood MOP, as opposed to leaf only. 
But that's for a RFC-6550-update not this spec I guess...

>     > and that Option Type in the RPL option is 0x23.

Many thanks, Michael

Pascal

> Michael Richardson <[email-masked]>, Sandelman Software Works  -
> = IPv6 IoT consulting =-
> 
>

---

From: Rahul Jadhav <[email-masked]>
Date: Wed, 29 Jul 2020 13:28:43 +0530

Sorry for the late reply. But for the record, I agree that 6lorh be turned
on by default for RFC6550-update and also 0x23 be the only option type used
for RPI (obsoleting 0x63).
Should we also start a thread listing all the mandates that RFC6550-update
might do?

Regards,
Rahul

On Tue, 21 Jul 2020 at 15:34, Pascal Thubert (pthubert) <pthubert=
[email-masked]> wrote:

> We said repeatedly that the turnon flag is defined only for MOPs < 7. This
> is also true for the "RPI 0x23 enable" flag defined in useofrplinfo.
>
> So we are asking implementation to check that the MOP is less than 7
> before they use the flag and only use it in that case.
>
> But then, when it finds a MOP that is >= 7, what should the code that we
> write today do? For one thing RFC 6550 makes it a leaf.
> This means that after MOP 7 the default is that RFC 8138 is turned on, and
> that Option Type in the RPL option is 0x23.
>
> Do we agree?
>
> Pascal
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>