Subject: [Roll] draft-ietf-roll-dao-projection: message type for P-DAO

From: "Huimin She (hushe)" <[email-masked]>
Date: Fri, 18 Dec 2020 02:15:33 +0000

Hi Pascal,

The P-DAO format is the same as DAO. And the TrackID in the DAO has the same meaning as Local RplInstanceID. How does a node tell whether the received message is a P-DAO message or Local RPL instance DAO? To implement it more easily, we need to identity the message type. So I suggest to add a bit in the P-DAO message, such as “| K | D | P|     Flags      |”.

Best regards,
Huimin

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 18 Dec 2020 06:07:08 +0000

Yes Huimin

I ended up doing something similar in the RUL draft to avoid some confusion that was isolated during IESG review. Better do it now!

You’ll find the flag in the next publication, unless the group opposes.

Enjoy the break !

Pascal

Le 18 déc. 2020 à 03:15, Huimin She (hushe) <hushe=[email-masked]> a écrit :

Hi Pascal,

Best regards,
Huimin
_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll