Subject: [Roll] RPL-Unaware-Leaf or RPL-Unaware Leaf ?

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 14 Dec 2020 15:08:08 +0000

Dear all:

We just got this remark in Elwyn's review of the RUL draft:

> s1, s2.2, s2.3: The term defined in [USEofRPLinfo] is RPL-Unaware-Leaf rather

> than RPL-Unaware Leaf: s/RPL-Unaware Leaf/RPL-Unaware Leaf/ (3 places).

> Similarly s/RPL-Aware Leaf/RPL-Aware-Leaf/ (1 place) and s/RPL-Aware

> Node/RPL-Aware-node/ (2 places).

I wondered, in terms of English which makes more sense?

We can fix either draft. I can't understand why useofrplinfo has a '-' between aware and leaf?

Keep safe;

Pascal

---

From: "Timothy J. Salo" <[email-masked]>
Date: Mon, 14 Dec 2020 13:46:49 -0600

On 12/14/2020 9:08 AM, Pascal Thubert (pthubert) wrote:
> Dear all:
> 
> We just got this remark in Elwyn’s review of the RUL draft:
> 
> We can fix either draft. I can’t understand why useofrplinfo has a ‘–‘ 
> between aware and leaf?

The rules for hyphens in English include:

o Use a hyphen to join two or more words serving as a single adjective
   before a noun.

So, "RPL-Unaware Leaf" would be better than "RPL-Unaware-Leaf".
Hyphenating "RPL Unaware Leaf Node" might be, in my opinion, a bit more
ambiguous: Do you mean "RPL-Unaware-Leaf Node" or
"RPL-Unaware Leaf-Node".

Another of the hyphenation rules is:

o Use a hyphen to avoid confusion.

This might rule might provide some insight into "RPL-Unaware-Leaf Node"
or "RPL-Unaware Leaf-Node".  In this document, I think that
"RPL-Unaware Leaf Node" would be preferred, because that we all
understand that "Leaf Node" is a essentially single term.

In general, I don't think there should be a hyphen between aware and
leaf.

-tjs

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 14 Dec 2020 20:03:44 +0000

Many thanks Timothy!

Ines, do we agree to change both drafts to say RPL-(un)aware Leaf|node ?

Pascal

> Le 14 déc. 2020 à 20:47, Timothy J. Salo <[email-masked]> a écrit :
> 
>> We can fix either draft. I can’t understand why useofrplinfo has a ‘–‘ between aware and leaf?
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Michael Richardson <[email-masked]>
Date: Mon, 14 Dec 2020 20:08:34 -0500

>> o Use a hyphen to avoid confusion.

I prefer this rule, and to leave it as "RPL-unware-leaf"

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 15 Dec 2020 06:06:12 +0000

Which confusion is that, Michael ?

This is a leaf that is not aware of RPL.

So it is RPL-Unaware. If it was blue would you call it a blue-leaf?

This is beyond my level in English !

Take care,

Pascal

> Le 15 déc. 2020 à 02:09, Michael Richardson <[email-masked]> a écrit :
> 
>

---

From: "Timothy J. Salo" <[email-masked]>
Date: Tue, 15 Dec 2020 16:47:32 -0600

> I prefer this rule, and to leave it as "RPL-unware-leaf"

I assume an editor will catch this and change it to RPL-unaware leaf.

In my view, "RPL-unaware leaf" is grammatically correct and unambiguous.

-tjs

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 16 Dec 2020 08:17:08 +0000

Dear all

I committed draft-ietf-roll-unaware-leaves-25 with RPL-Unaware Leaf convention.
Note that I also lowercased leaf, host and router throughout based on review comments. 
This needs to aligned in useofrplinfo, which seems to use pseudo-randomly  the uppercased version.
Note: I left Leaf uppercased only in the full " RPL-(Un)aware Leaf ". Still time to change but we want alignment.

What do you all think?

Pascal

> -----Original Message-----
> From: Roll <[email-masked]> On Behalf Of Timothy J. Salo
> Sent: mardi 15 décembre 2020 23:48
> To: [email-masked]
> Subject: Re: [Roll] RPL-Unaware-Leaf or RPL-Unaware Leaf ?
>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 16 Dec 2020 08:06:29 -0500

Pascal Thubert \(pthubert\) <pthubert=[email-masked]> wrote:
    > I committed draft-ietf-roll-unaware-leaves-25 with RPL-Unaware Leaf
    > convention.  Note that I also lowercased leaf, host and router
    > throughout based on review comments.  This needs to aligned in
    > useofrplinfo, which seems to use pseudo-randomly the uppercased
    > version.  Note: I left Leaf uppercased only in the full " RPL-(Un)aware
    > Leaf ". Still time to change but we want alignment.

    > What do you all think?

Works for me.

Ines and I will fix useofrplinfo.