Subject: [Roll] New column in ND status?

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 15 Dec 2020 06:57:08 +0000

Hello Alvaro

Elwyn has a suggestion that I wanted to run by you:

>> s6.3, next to last para. s8 and s 12.2:  In view of the statement in s6.3:
>> The RPL Root MUST set the 'E' flag to 1 for all rejection and unknown status
>> codes. The status codes in the 1-10 range [RFC8505] are all considered
>> rejections. I think that IANA should be requested to add a column to the EARO
>> status codes registry being modified by s12.2 to add a column that identifies a
>> status code as a rejection or otherwise.   Some words in s8 may be appropriate.

> Well that would require normative text on the 6LoWPAN part.
> I guess we can do that at the next iteration of a 6LoWPAN ND specification.
> For now what we specify is that from the RPL perspective the listed codes denote
> a failure such that the RPL operation that wraps it cannot happen and that's enough for us.

ED>  While I understand that it would be polite to involve 6LoWPAN, WGs don't 'own' RFCs and their associated IANA registries.  Since this draft 'needs' the extra information I personally wouldn't see a problem in asking for the extra column. It doesn't break anythng 6LoWPAN are doing AFAICS. Anyway that's not my call...  ask your AD.

What do you think?

Pascal

---

From: Alvaro Retana <[email-masked]>
Date: Tue, 15 Dec 2020 07:17:59 -0800

Pascal:

Hi!

I see Elwyn’s point, and agree that it might be nice to see that in the
registry.

However, your point about the description being from the RPL perspective
keeps me from thinking that it is a necessary addition.  If I remember
correctly, not all the status codes may be considered the same way in RPL
when compared to ND.  Also, there’s no E flag used in ND.

I don’t think we should make the extra change to the registry in this
document.

Thanks!

Alvaro.

On December 15, 2020 at 1:58:50 AM, Pascal Thubert (pthubert) (
[email-masked]) wrote:

Hello Alvaro

> a failure such that the RPL operation that wraps it cannot happen and
that's enough for us.

ED>  While I understand that it would be polite to involve 6LoWPAN, WGs
don't 'own' RFCs and their associated IANA registries.  Since this draft
'needs' the extra information I personally wouldn't see a problem in asking
for the extra column. It doesn't break anythng 6LoWPAN are doing AFAICS.
Anyway that's not my call...  ask your AD.

What do you think?

Pascal