Subject: [Roll] P-DAO request

From: "Turner, Randy" <[email-masked]>
Date: Tue, 8 Jun 2021 17:53:35 +0000

Hi Guys,

In the -17 draft for P-DAO, section 3.3, a portion of this section says:

A positive PDR-ACK indicates that the Track was built and that the Roots commits to maintain the Track for the negotiated lifetime. In the case of a complex Track, each Segment is maintained independently and asynchronously by the Root, with its own lifetime that may be shorter, the same, or longer than that of the Track. The Root may use an asynchronous PDR-ACK with an negative status to indicate that the Track was terminated before its time.

I think it will be very difficult for the root to maintain tracks, given the spurious nature of topology changes in an RF mesh --- Rather than a PDR-ACK that says the track could not be maintained, could we have something like an async notification that says, “Your previous track is stale, here’s the new version”  as long as the egress point still exists.  Assuming it’s possible that the egress joined another DODAG.

I haven’t read the entire draft yet so I may have missed something that would preclude this capability.

Thanks,
Randy

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 9 Jun 2021 12:19:33 +0000

Hello Randy

Not sure what you mean by "Your previous track is stale, here's the new version". As it goes, the Root can redraw the Track, add segments here,  remove others there, it's still the same track as long as it is functional, and there's no provision in the draft to tell the ingress about those changes.

If that does not help, could you please rephrase?

Pascal

From: Roll <[email-masked]> On Behalf Of Turner, Randy
Sent: mardi 8 juin 2021 19:54
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: [Roll] P-DAO request

Hi Guys,

I think it will be very difficult for the root to maintain tracks, given the spurious nature of topology changes in an RF mesh --- Rather than a PDR-ACK that says the track could not be maintained, could we have something like an async notification that says, "Your previous track is stale, here's the new version"  as long as the egress point still exists.  Assuming it's possible that the egress joined another DODAG.

I haven't read the entire draft yet so I may have missed something that would preclude this capability.

Thanks,
Randy

---

From: "Turner, Randy" <[email-masked]>
Date: Wed, 9 Jun 2021 23:47:46 +0000

So,  from the draft, it looks like the basic idea is for nodes in DODAG to request routes between itself and another node, for P2P use-cases.  This idea is what I believe the original discussions centered around, and I admit I haven’t been following recent discussions on this draft, but the introduction sounds familiar.

Forgive me if I’m simplifying, but here is  how I was thinking this would work (from my previous email):

node(A) would like to setup P2P communications with node (B), so it issues a P-DAO request to the root/PCE for  a path from (A) to (B).  If this request is successful, the PDR-ACK returns a set of VIAs from (A) to (B).

So (A) can source-route a packet from itself to (B) based on the VIA information.

The root will monitor any change to the projected route, and if the route cannot be maintained, it will asynchronously notify (A).

If this interpretation is correct, then I was thinking that, if the state of the projected route changes (through future DAO/SIO reception by the root), then a new projected route could be calculated and node(A) could be asynchronously notified of new VIAs for its’ originally requested route to (B), without receiving an async notification that the route is no longer valid, and having to possibly perform a new P-DAO request.

Is this possible? Or did I miss something in the latest thinking?

Thanks!
Randy

From: Roll <[email-masked]> on behalf of Pascal Thubert (pthubert) <pthubert=[email-masked]>
Date: Wednesday, June 9, 2021 at 8:20 AM
To: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] P-DAO request
Hello Randy

Not sure what you mean by “Your previous track is stale, here’s the new version”. As it goes, the Root can redraw the Track, add segments here,  remove others there, it’s still the same track as long as it is functional, and there’s no provision in the draft to tell the ingress about those changes.

Pascal

Hi Guys,

Thanks,
Randy

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 10 Jun 2021 04:51:34 +0000

This is all exactly correct Randy.
If the change is limited to one segment, node A may not even know it happened.
But if it affects the source routed skeleton of the track, then A will know.
Note also that the request to build a Track may come from a management entity (a controller) as opposed to the PDR from node A.

Keep safe,

Pascal

Le 10 juin 2021 à 01:48, Turner, Randy <[email-masked]> a écrit :

Thanks!
Randy

Pascal

Hi Guys,

Thanks,
Randy

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll