Subject: [Roll] DAO projection

From: Iliar Rabet <[email-masked]>
Date: Thu, 24 Jun 2021 14:40:54 +0000

Hi all,

I would like to ask about two possibilities regarding the dao-projection draft that most probably have been discussed before.
1- According to the draft, the projected routes are only installed with highest probability. What if the controller aims at installing backup routes/any other priority?
2- Can the root node use projected DAO to install multiple parents/multipath routing?

Best regards,
Iliar Rabet
 Ph.D student
Personal Webpage<https://eur01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.es.mdh.se%2Fstaff%2F4137-Iliar_Rabet&data=04%7C01%7Ciliar.rabet%40mdh.se%7Cd1a2649889d24dadd37608d8dcb7c84e%7Ca1795b64dabd4758b988b309292316cf%7C0%7C0%7C637502029221809365%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=zy9ddLIoFtRnIV1mnBJqbPyYFcXa4oTWBsSN3jxhw0w%3D&reserved=0>
mobile: (+46) 73-6621725
Malardalen University , Västerås Sweden

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 24 Jun 2021 14:54:54 +0000

Hello Iliard;

I hope you're doing good.

  1.  The problem when you have multiple topologies (like the main DODAG and the Track) is that switching the packet from one topology to another may yield loops. This can be addressed by forcing an order relationship, like a DODAG of topologies, or a distance. One can jump on another topology if that topology is "lower" but never higher. The current design is that the Track is lower than the main DODAG so once you jump in a Track, you can never return to the main dodag, the track must take you to destination, or you switch to a lower Track. If the track was higher the packet swould immediately leave the Track to follow the main DODAG and never return.

We have not really formalized that "rank" of Tracks. Maybe we should

  1.  Yes it can; these are as many segments of a complex Track.

Keep safe

Pascal

From: Roll <[email-masked]> On Behalf Of Iliar Rabet
Sent: jeudi 24 juin 2021 16:41
To: [email-masked]
Subject: [Roll] DAO projection

Hi all,

Best regards,
Iliar Rabet
 Ph.D student