Subject: meaning of'list of'

From: Engin Gunduz <[email-masked]>
Date: Thu, 25 May 2000 18:41:09 +0200 (CEST)

Hi,

I have to questions regarding to the RPSL syntax:

=-=-=-=-=-
1.
In RFC2622 page 6, it is said that " A
   list is represented by separating the list members by commas ",".
   For example, "AS1, AS2, AS3, AS4" is a list of AS numbers."

But in page 40: 
   "A value of a list type
   is represented as a sequence of elements separated by the character
   "," and enclosed by the characters "{" and "}".

So, if mnt-by in mntner is defined as

mnt-by     list of <mntner-name>   mandatory, multi-valued

then which one of the below has the corrct syntax:

mnt-by: { A-MNT, B-MNT}
 or
mnt-by: A-MNT, B-MNT

=-=-=-=-=-
2.

If the tech-c   is defined as 

tech-c     <nic-handle>            mandatory, multi-valued

in mntner, than has 

mntner: A-MNT

---

From: <[email-masked]>
Date: Thu, 25 May 2000 10:38:34 -0700 (PDT)

>    "," and enclosed by the characters "{" and "}".

That paragraph starts with:

   A value of an attribute may also be a list of one of these types.  A
   list is represented by separating the list members by commas ",".
   For example, "AS1, AS2, AS3, AS4" is a list of AS numbers.  Note that
   being list valued and being multiple valued are orthogonal.  A
   multiple valued attribute has more than one value, each of which may
   or may not be a list.  On the other hand a single valued attribute
   may have a list value.

Hence, this definition applies to object attributes.

Where as the paragraph on page 40 describes the types for
rp-attributes that are defined in the dictionary.  rp-attributes are
used in specifying filters and actions and are different than object
attributes.

mnt-by: A-MNT, B-MNT

is correct.

On the other hand

   import: from AS1 accept community == { 1:1, 2:2 } 

is correct where community is an rp-attribute. In this case, we need
the {} to separate the argument what comes next.

I did not get the second question.

Cengiz

-- 
Cengiz Alaettinoglu           Information Sciences Institute
http://www.isi.edu/~cengiz    University of Southern California

---

From: Engin Gunduz <[email-masked]>
Date: Thu, 25 May 2000 19:49:18 +0200 (CEST)

> Engin Gunduz ([email-masked]) on May 25:

[...]
> > mntner: A-MNT

Thank you for quick answer.

> I did not get the second question.

The second part of my mail is below, I don't know what went wrong but
last 10 or so lines was cut in the message that came back from 
the list processor.

-=-=-=-=-=-=-=-
2.

in mntner, than has 

mntner: A-MNT

---

From: <[email-masked]>
Date: Thu, 25 May 2000 10:54:50 -0700 (PDT)

Engin Gunduz ([email-masked]) on May 25:
> .
> .
> tech-c: EE5-ARIN
>         EF56-ARIN
> .
> .
> correct syntax, regarding its tech-c attributes?

tech-c: EE5-ARIN
        EF56-ARIN

is not correct. But,
tech-c: EE5-ARIN
tech-c: EF56-ARIN

is correct. 

In the former case there is only one tech-c attribute whose value is
"EE5-ARIN EF56-ARIN" which is not a correct <nic-handle>. In the
latter, you have two tech-c attributes, and they are both of type
<nic-handle>.

if tech-c was "list of <nic-handle>"

than
tech-c: EE5-ARIN,
        EF56-ARIN

(with a comma) would have been valid.

Cengiz

---

From: <[email-masked]>
Date: Thu, 25 May 2000 11:48:35 -0700 (PDT)

Gerald Andrew Winters ([email-masked]) on May 25:
> Cengiz,
> 
> Just curious, semantically what is the difference between
> a 'list valued' attribute and a 'multivalued' attribute?
> Is it necessary to have both these?

For example, import attribute is multi-valued. I.e. it can appear in
an object several times.  It is not list valued. i.e. its value is not 
a list of items.
      import: from AS1 accept AS1
      import: from AS2 accept AS2

members attribute of an as-set is list valued, i.e. its value is a
list of items.
	as-set: as-foo
	members: AS1, AS2, AS3

Hence, they are quite different indeed. But you knew this.
The members attribute is also multi-valued:
	as-set: as-foo
	members: AS1, AS2, AS3
	members: AS4, AS5

Is this what is confusing everyone?

Long time ago, attributes which are list valued were not multi-valued
at the same time. But this was different than the current ripe
behavior with respect to many attributes. The consensus was we allow
these since it makes the user experience better. (I think the
suggestion come from Mark Prior and Daniel Karrenberg.)

> --jerry

Cengiz

---

From: [email-masked] (Gerald Andrew Winters)
Date: Thu, 25 May 2000 14:12:26 -0400 (EDT)

Cengiz,

--jerry

---

From: [email-masked] (Gerald Andrew Winters)
Date: Thu, 25 May 2000 15:22:36 -0400 (EDT)

Cengiz,

> Is this what is confusing everyone?

I asked my question just to hear your response.  The spec
Is clear (IMHO).  However, for me, I could not see a semantic
difference between 

tech-c: EE5-ARIN
tech-c: EF56-ARIN

and 

tech-c: EE5-ARIN, EF56-ARIN

For this particular case it seems to be extra typing to use
the multivalued form.  But as you point out the 'import:'
attribute is clearly a case that is better as multivalued
(ie, better for humans to read).

--jerry