Subject: firsttime/lasttime

From: Carlos del Castillo <[email-masked]>
Date: 19 Apr 2002 21:32:37 -0500

Hello everybody, I'm new to netramet, I have been doing some tests and
everything is working fine, but I really don't understand the fileds
firsttime and lasttime.

In the documentation I read that this files are the time in seconds/100
since that flow was first seen and last seen.

But the problem is that if i started the NetFlowMet and NeMaC process a
few minutes ago, I get values really big. About  2154190161.

What does this mean? Do I have a problem or is it a bug?

Thank you very much.

Carlos del Castillo
capc75 at mac dot com

---

From: Nevil Brownlee <[email-masked]>
Date: Sun, 21 Apr 2002 15:08:36 -0700 (PDT)

Hello Carlos:

FIrstTime and LastTime are in SNMP TimeTicks, i.e. units
of 0.01 s.  But the values are relative to the time the
meter started, hence the large values you're seeing.

NeMaC gives the time of day (or UTC time) when a meter
reading began, together with the corresponding SysUpTime
value (same untis); you can use that to convert the times
to time of day.  Or, if you only want the duration of
a flow, just subract LastTime-FirstTime.

Cheers, Nevil

-------------------------------------------------------------
   Nevil Brownlee                     Internet Researcher
   Phone: (858) 534 8338                 CAIDA, San Diego

---

From: Carlos del Castillo <[email-masked]>
Date: 21 Apr 2002 23:18:22 -0500

Thank you very much, I got it. OI could read the sysUpTime with th
snmbulkget command.  Thank you very much. 

On Sun, 2002-04-21 at 17:08, Nevil Brownlee wrote: 
    Hello Carlos:

    
    Cheers, Nevil