Subject: RE: Proposed BFD WG

From: "Phelan, Tom" <[email-masked]>
Date: Thu, 25 Mar 2004 09:51:31 -0500

Hi Pekka,

You wrote:
> On Wed, 24 Mar 2004, Rahul Aggarwal wrote:
> > > The point is, do we want to state in charter which protocols (at
> > > least) should have usage profiles?  Do we leave it empty? 
>  Do we rule
> > > out some protocols from usage profiles?
> > 
> > Imho this is a detail that can be worked out when the WG 
> discusses the BFD
> > over IPv4 document. Bootstrapping details can be added 
> where they seem
> > necessary. Don't think the charter needs to spell it out..
> 
> You said "over IPv4" but you meant "over IP", I hope.  Any work that 
> would start with only IPv4 would be completely inappropriate.
> 
> IMHO, this is probably an important point.  If we don't know any
> protocols we'd like to rule out right now, they should be listed
> there.

I'm having trouble parsing this.  Did you mean "If we know any protocols ..."?

> On the other hand, listing the protocols which we should AT
> LEAST work on would be equally useful; for example, the list could be
> at least: IS-IS (both IPv4 and IPv6), OSPFv2, OSPFv3, eBGP, {static
> routes}.

If we're going to have a list of protocols we're going to give guidelines to, I'd like to see "static routes" taken out of parenthesis.  We seem to have a very router-to-router focus on the uses of BFD here, but it's also very useful for high-availability host systems to monitor interface and first hop router status.  In these cases the routers usually have static routes to the hosts, since the hosts tend to not run routing protocols.

Tom Phelan

---

From: David Meyer <[email-masked]>
Date: Thu, 25 Mar 2004 07:50:52 -0800

>> > If we're going to have a list of protocols we're going to give
>> > guidelines to, I'd like to see "static routes" taken out of
>> > parenthesis.  We seem to have a very router-to-router focus on the
>> > uses of BFD here, but it's also very useful for high-availability
>> > host systems to monitor interface and first hop router status.  In
>> > these cases the routers usually have static routes to the hosts,
>> > since the hosts tend to not run routing protocols.
>> 
>> Yes, static routes has a lot of nice areas of applicability.  The
>> reason why I put it in parentheses was because it is not an
>> "adjancency" being formed as such.  So if it is to be included, some
>> wiggling around in the charter could be useful.
>>
>> FWIW, another good for static routes is that you would not need to run
>> a routing protocol between the ISP and customer if you did this for
>> redundancy.  Just set up two static routes, with two physical links
>> (one set of routes with lower preference), and if BFD notices the
>> primary link goes down, it's taken down and you start to use the less
>> preferred one automatically.  (Today this doesn't work on media which
>> don't provide end-to-end link state notifications to the routers, like
>> Ethernets.)

	Exactly. I would say that it should be included if at all
	possible. In a few of the carriers/ISPs I've worked at in
	the past I would have loved to have the functionality for
	statics (which were in common use for singly homed
	customers). 

>> Very simple in very simple multi-connection scenarios.  No need for
>> OSPF or BGP mess in a scenario where you don't need it.

	Yep, and even in those scenarios BFD can make sense.

	Dave

---

From: Pekka Savola <[email-masked]>
Date: Thu, 25 Mar 2004 17:26:32 +0200 (EET)

> I'm having trouble parsing this.  Did you mean "If we know any protocols ..."?

That's what I meant -- sorry.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings