Subject: RE: Re: draft-suping-bfd-mpls-fecmismatch-00 questions

From: "David Allan" <[email-masked]>
Date: Mon, 28 Feb 2005 15:57:18 -0500

<snipped>
> 
> > forwarding at intermediate nodes... IMO not needed if we are 
> > discussing a p2p PHY link, as misdirection to a different BFD 
> > termination and collisions in the dsicriminator space are highly 
> > unlikely. Question is how often can you be sure when all is 
> said and 
> > done, it truly was just a PHY...
> 
> BFD won't be able to tell you what is actually broken. OAM 
> thingies do this.

Agreed, goal is to simply know so you can follow up...

> 
> -DWard
> 
> > 
> > rgds
> > Dave
> >   
> > > 
> > > If this problem is as we seem to agree a control plane
> > > programming issue, an OAM protocol seems more applicable at 
> > > config time.
> > > 
> > > -DWard
> > > 
> > > On Sun, Feb 27, 2005 at 04:21:39PM -0500, David Allan wrote:
> > > > It is not detecting a control plane failure, it is detecting
> > > > inconsistencies in forwarding such that synch between 
> > > control and data
> > > > plane has been lost.. connectivity to somewhere exists 
> but is not
> > > > necessarily correct...IMO that is still a data plane problem...
> > > > 
> > > > Dave
> > > > 
> > > > > -----Original Message-----
> > > > > From: [email-masked] 
> [mailto:[email-masked]] 
> > > > > On Behalf Of David Ward
> > > > > Sent: Sunday, February 27, 2005 10:48 AM
> > > > > To: zhaisuping
> > > > > Cc: [email-masked]
> > > > > Subject: Re: Re: draft-suping-bfd-mpls-fecmismatch-00 
> questions
> > > > > 
> > > > > 
> > > > > Unfort., what you write is 180 degrees opposite from 
> the charter 
> > > > > of the BFD WG and the philosophy of how the protocol is to 
> > > > > function. BFD is not to check the consistency of the 
> forwarding 
> > > > > and control plane. We do not want to take this 
> protocol into the 
> > > > > realm of control plane failure detection system (as there are 
> > > > > many better protocols or protocol machinery for that) but,  
> > > > > focus on forwarding failure detection that can send alarms, 
> > > > > event notification, diags, etc up the stack.
> > > > > 
> > > > > 
> > > > > -DWard
> > > > > 
> > > > > 
> > > > > 
> > > > > On Sat, Feb 26, 2005 at 09:41:49AM +0800, zhaisuping wrote:
> > > > > > Hi, all
> > > > > > The purpose of FEC filter in BFD is to detect the
> > > consistence of
> > > > > > the control plane and data plane. So that in the 
> MPLS network,
> > > > > > just running the BFD session(LSP-Ping is not needed) is 
> > > enough for
> > > > > > the defect detection. Or else such tools as 
> LSP-Ping is needed
> > > > > > because the BFD session can't detect the 
> inconsistence of the 
> > > > > > control plane and data plane. In the section 2 of the 
> > > draft, there
> > > > > > is description of the problem the draft want to solve.
> > > > > > >> Wouldn't LSP-Ping (or VCCV) be a more appropriate place
> > > > > to do this
> > > > > > >> filter verification?
> > > > > > 
> > > > > > 
> > > > > > >
> > > > > > >LSP-Ping does a verification on the FEC itself, so a
> > > > > filter would add
> > > > > > >nothing.
> > > > > > >
> > > > > > >VCCV is not a protocol.  Just a little sideband 
> for sending 
> > > > > > >IP packets down a pseudowire so that you can run
> > > LSP-Ping, BFD, etc.
> > > > > > >between the two ends.
> > > > > > >
> > > > > > >....George
> > > > > > >
> > > > > > 
> > > > > >=============================================================
> > > > > ===========
> > > > > > >George Swallow             Cisco Systems                  
> > > > > (978) 936-1398
> > > > > > >                           1414 Massachusetts Avenue
> > > > > > >                           Boxborough, MA 01719
> > > > > 
> > > > > 
> > > > > 
> > > 
> > > 
> 
>

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 28 Feb 2005 16:00:59 -0500

> Agreed, goal is to simply know so you can follow up...

Then wouldn't it be best to BFD for what it is good at, namely checking
that forwarding is working, and then use another mechanism to clean
house when something fails?

By analogy, one doesn't extend ICMP to check your interface configuration
because you want to add this to your ping.

(Then again, seeing such a thing proposed in the IPv6 working groups
wouldn't shock me at all. :-)

-- 
Jeff Haas 
NextHop Technologies

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 28 Feb 2005 16:51:10 -0500

> house when something fails?

	I explained in my first posting on this draft that there
already exist mechanisms that can be used to confirm the
consistency of the sessions. There is no need for another
mechanism, IMO.

	--Tom