Subject: Fw: Re: Transition from failing state

From: zhaisuping <[email-masked]>
Date: Thu, 03 Feb 2005 09:40:03 +0800

So nobody response the following question?

I think that Fail state is redundant,the state machine can be simplified as following:

       H(1)
 |-------------->|
 |   H(0)   H(1) |
init--->down--->up
         |  H(0) |
         |<------|

Should this can be simple?

Regards
suping zhai
>Section 6.6.6 of draft-ietf-bfd-base-00.txt states: 
>
>Else if bfd.SessionState is Failing 
>  If I Hear You is zero, set bfd.SessionState to Down
>
>However, unless I'm missing something, the draft does not appear to describe what happens if bfd.SessionState is Failing and:
>
>- The sink/destination receives a BFD packet
>- The source receives a BFD packet with a nonzero I Hear You
>
>Should the node transition to the init state?
>
>Thanks,
>Richard

---

From: Dave Katz <[email-masked]>
Date: Wed, 2 Feb 2005 22:33:33 -0800

The problem with this approach is that it is possible to flap one side 
of the session without the other side knowing.  That is why there is a 
three-way handshake for both session establishment and session failure 
(and thus four states.)

--Dave

On Feb 2, 2005, at 5:40 PM, zhaisuping wrote:

>> However, unless I'm missing something, the draft does not appear to 
>> describe what happens if bfd.SessionState is Failing and:
>>