Subject: Re: Transition from failing state

From: zhaisuping <[email-masked]>
Date: Tue, 01 Feb 2005 18:19:39 +0800

I think that Fail state is redundant,the state machine can be simplified as following:

       H(1)
 |-------------->|
 |   H(0)   H(1) |
init--->down--->up
         |  H(0) |
         |<------|

Should this can be simple?

Regards
suping zhai
>Section 6.6.6 of draft-ietf-bfd-base-00.txt states: 
>
>Else if bfd.SessionState is Failing 
>  If I Hear You is zero, set bfd.SessionState to Down
>
>However, unless I'm missing something, the draft does not appear to describe what happens if bfd.SessionState is Failing and:
>
>- The sink/destination receives a BFD packet
>- The source receives a BFD packet with a nonzero I Hear You
>
>Should the node transition to the init state?
>
>Thanks,
>Richard

---

From: zhaisuping <[email-masked]>
Date: Thu, 03 Feb 2005 15:43:06 +0800

comments on the BFD mechanism for MPLS application:

1.may the detection type add the FEC_Mismatch in MPLS application?

we can do so by adding some fiels,for example FEC Filter as in Y.1713 to BFD control packet.

2.can the BFD development the mechanism to notify the defect to the far end of the LSP, I mean when the nested
LSP has a defect, how the upper LSP know the defect?

I think a way to solve this problem is that, when LSP is setup, record some information for this use is ok. So when nested LSP is wrong, it can be notified to the upper LSP layer through the BFD packet, in which I Hear You is 0, and Diag is 7(administratively down).

welcome the further discuss.
best regards,
suping
>On Feb 1, 2005, at 12:11 AM, <[email-masked]> wrote:
>
>> However, unless I'm missing something, the draft does not appear to 
>> describe what happens if bfd.SessionState is Failing and:
>>
>Nope, the whole point of Failing state is to wait there until IHU=0, 
>thus ensuring that the other end has killed the session as well.  In 
>the pseudocode in the spec, you simply fall through on that test and go 
>on with the rest of the process.
>
>--Dave
>\