Subject: some comment to draft-ietf-bfd-base-02.txt

From: zhaisuping <[email-masked]>
Date: Sat, 26 Mar 2005 11:41:24 +0800

Dave2,
In the draft-ietf-bfd-base-02.txt, 6.3. (Demultiplexing and the Discriminator Fields), it reads as following,　　

   The method of demultiplexing the initial packets (in which Your
   Discriminator is zero) is application-dependent, and is thus outside
   the scope of this specification.　　

One problem is that when the two nodes running BFD session are belong to different providers, So there should be some specification on the interworking problem. I propose to add some general description about this some like the following,

   When use OSPF as the BFD bootstrap mechanism, the method fo demutipexing the initail packets is......
   When use IS-IS as the BFD bootstrap mechanism, the method fo demutipexing the initail packets is......
   When use MPLS-Ping as the BFD bootstrap mechanism, the method fo demutipexing the initail packets is......

   Or the common TLV can be defined to these mechanism to bootstrap BFD session.

So I don't know if this is appropriate to the BFD base draft?

Best Regards,
[email-masked]
Huawei Technologies Co., Ltd.
Tel: +86-10-82882867
Fax: +86-10-82882537
2005-03-26

---

From: Dave Katz <[email-masked]>
Date: Fri, 25 Mar 2005 23:54:01 -0700

On Mar 25, 2005, at 8:41 PM, zhaisuping wrote:

> Dave2,
> In the draft-ietf-bfd-base-02.txt, 6.3. (Demultiplexing and the 
> Discriminator Fields), it reads as following,　　
>
> One problem is that when the two nodes running BFD session are belong 
> to different providers, So there should be some specification on the 
> interworking problem. I propose to add some general description about 
> this some like the following,
>
>    When use OSPF as the BFD bootstrap mechanism, the method fo 
> demutipexing the initail packets is......
>    When use IS-IS as the BFD bootstrap mechanism, the method fo 
> demutipexing the initail packets is......
>    When use MPLS-Ping as the BFD bootstrap mechanism, the method fo 
> demutipexing the initail packets is......
>

This is all specified in the application drafts.

--Dave