Subject: Session state notifications

From: "Sankaranarayanan - CTD, Chennai." <[email-masked]>
Date: Fri, 5 Aug 2005 09:22:00 +0530

Hello,

Description of bfdSessDiag says "A diagnostic code
specifying the local system's reason for the last
transition of the session from up(1) to some other
state."  But the description of bfdSessUp
notification says that value up (1) is set to
bfdSessDiag and description of bfdSessDown
notification says that value down (4) or adminDown
(5)is set to bfdSessDiag.  I am not sure whether
bfdSessDiag object in the notification is used to
communicate the diagnostic code or session state.

As per the new standard bfdSessState uses value 4
for up state.  But description of bfdSessDiag uses
value 1 and description of bfdSessUp notification
uses value 1 and 2 for up state.  Similarly
bfdSessState uses value 1 for adminDown and value
2 for down state.  But description of bfdSessDown
notification uses value 5 for adminDown state and
value 4 for down state.  

Regards,
Sankar
DISCLAIMER 
This message and any attachment(s) contained here are information that is confidential, proprietary to HCL Technologies 
and its customers. Contents may be privileged or otherwise protected by law. The information is solely intended for the 
individual or the entity it is addressed to. If you are not the intended recipient of this message, you are not authorized to 
read, forward, print, retain, copy or disseminate this message or any part of it. If you have received this e-mail in error, 
please notify the sender immediately by return e-mail and delete it from your computer

---

From: Dave Katz <[email-masked]>
Date: Thu, 4 Aug 2005 22:36:33 -0700

On Aug 4, 2005, at 8:52 PM, Sankaranarayanan - CTD, Chennai. wrote:

> state.

Which document are you referring to?  The base spec says:

    A diagnostic code specifying the local system's reason for the  
last session state change.

In any case, the diagnostic is just that, a diagnostic, generally  
intended to make life easier for network operators to figure out what  
went wrong.

This is entirely separate from the session state, which is an  
integral part of the state machine.