Subject: Regarding Min. value of Desired Min. Tx Interval and Required Min. Rx. Interval

From: Tonuka SinhaRay <[email-masked]>
Date: Fri, 25 Nov 2005 04:41:06 -0800 (PST)

Sir/Madam,

  In the draft "draft-ietf-bfd-base-03.txt" Page 26
and 27 , it says that bfd.DesiredMinTxInterval must be
initialised to a value of at least one second
(1,000,000 microseconds). Does this mean that
bfd.DesiredMinTxInterval should be always greater or
equal to 1 sec?

But, in the same draft , Section 6.7.3 (paragraph 6),
it is specified that if bfd.SessionState is not Up,
the system MUST set bfd.DesiredMInTxInterval to a
value not less than one second.

Can someone please clarify  what is min. value of
Desired Min Tx Interval 
and Required Min. Rx Interval?
Is the Min. values for Desired Min. Tx Interval and
required Min. Rx. Interval
different when session is Down/AdminDown/Init from
when the session is up?

Thank you in Advance,
With Regards,
Tonuka

__________________________________ 
Start your day with Yahoo! - Make it your home page! 
http://www.yahoo.com/r/hs

---

From: Dave Katz <[email-masked]>
Date: Fri, 25 Nov 2005 07:06:32 -0800

> bfd.DesiredMinTxInterval should be always greater or

No, just that the value must be at least one second when the session  
is first created.

> and Required Min. Rx Interval?

There is no minimum (well, one microsecond.)  MinTx reflects the  
sender's desire to transmit rapidly;  MinRx reflects the receiver's  
desire to receive slowly.  Thus the receiver always places a lower  
bound on the interval.

> different when session is Down/AdminDown/Init from

As you quote above, MinTx must be at least one second when the  
session isn't up.

The point of this whole exercise is to give each system unilateral  
control over the maximum transmission rate in both directions.  When  
a session is first starting up, however, each system sends slowly  
because it does not know the requirements of the other system (which  
can't be guaranteed until the session is up.)  For that matter,  
perhaps only one system is configured to use BFD, and the session may  
never come up, so the bandwidth consumption needs to be limited.

--Dave

---

From: Tonuka SinhaRay <[email-masked]>
Date: Fri, 25 Nov 2005 21:07:16 -0800 (PST)

Thank you Dave,
One more clarification  please?
By up, Does it mean that When the session is down or
init or admin down , the min. Tx interval should be
min. 1 sec?
But when the session state is up, Is the max. value
the Desired min. Tx. interval  1 sec?

With Regards,
Tonuka

		
__________________________________ 
Yahoo! Music Unlimited 
Access over 1 million songs. Try it free. 
http://music.yahoo.com/unlimited/

---

From: Dave Katz <[email-masked]>
Date: Fri, 25 Nov 2005 21:11:59 -0800

> the Desired min. Tx. interval  1 sec?

No, it could be any value, including greater, though one might expect  
that if you wanted to run at, say, 10 seconds when up, that you would  
start with a value that large or larger before the session came up.

--Dave