Subject: Re: Re: Regarding Min. value of Desired Min. Tx Interval and Required Min.Rx. Interval

From: Suping Zhai <[email-masked]>
Date: Wed, 14 Dec 2005 21:15:16 +0800

Hi Tonuka,
>From my understanding, BFD echo packets frame format is the same as the request packet frame format except that in some scenario the "P" and "F" bit value is different.

Best Regards,
Suping
>Sir/Madam,
>
>I am not able to find the Packet format of BFD Echo
>packets.
>Can someone please let me know about Packet Format of
>BFD Echo Packets?
>
>With Regards,
>Tonuka
>--- Dave Katz <[email-masked]> wrote:
>
>> 
>> On Nov 25, 2005, at 4:41 AM, Tonuka SinhaRay wrote:
>> 
>> >
>> >  Sir/Madam,
>> >
>> >   In the draft "draft-ietf-bfd-base-03.txt" Page
>> 26
>> > and 27 , it says that bfd.DesiredMinTxInterval
>> must be
>> > initialised to a value of at least one second
>> > (1,000,000 microseconds). Does this mean that
>> > bfd.DesiredMinTxInterval should be always greater
>> or
>> > equal to 1 sec?
>> 
>> No, just that the value must be at least one second
>> when the session  
>> is first created.
>> 
>> >
>> > But, in the same draft , Section 6.7.3 (paragraph
>> 6),
>> > it is specified that if bfd.SessionState is not
>> Up,
>> > the system MUST set bfd.DesiredMInTxInterval to a
>> > value not less than one second.
>> >
>> > Can someone please clarify  what is min. value of
>> > Desired Min Tx Interval
>> > and Required Min. Rx Interval?
>> 
>> There is no minimum (well, one microsecond.)  MinTx
>> reflects the  
>> sender's desire to transmit rapidly;  MinRx reflects
>> the receiver's  
>> desire to receive slowly.  Thus the receiver always
>> places a lower  
>> bound on the interval.
>> 
>> > Is the Min. values for Desired Min. Tx Interval
>> and
>> > required Min. Rx. Interval
>> > different when session is Down/AdminDown/Init from
>> > when the session is up?
>> 
>> As you quote above, MinTx must be at least one
>> second when the  
>> session isn't up.
>> 
>> The point of this whole exercise is to give each
>> system unilateral  
>> control over the maximum transmission rate in both
>> directions.  When  
>> a session is first starting up, however, each system
>> sends slowly  
>> because it does not know the requirements of the
>> other system (which  
>> can't be guaranteed until the session is up.)  For
>> that matter,  
>> perhaps only one system is configured to use BFD,
>> and the session may  
>> never come up, so the bandwidth consumption needs to
>> be limited.
>> 
>> --Dave
>> 
>> >
>> > Thank you in Advance,
>> > With Regards,
>> > Tonuka
>> >
>> >
>> > 		
>> > __________________________________
>> > Start your day with Yahoo! - Make it your home
>> page!
>> > http://www.yahoo.com/r/hs
>> >
>> 
>> 
>
>
>__________________________________________________
>Do You Yahoo!?
>Tired of spam?  Yahoo! Mail has the best spam protection around 
>http://mail.yahoo.com

---

From: David Ward <[email-masked]>
Date: Wed, 14 Dec 2005 11:42:47 -0600

The P and F bit have no bearing in the Echo packet contents (you are sending
packets to yourself from yourself). Remember there is a control and data
stream for Echo and P and F would only be used in the control stream.

You can fill Echo packets w/ whatever you like ... 0s, 1s, Shakespeare, etc
:-)

-DWard

On 12/14/05 7:15 AM, "Suping Zhai" <[email-masked]> wrote:

> Hi Tonuka,
>> From my understanding, BFD echo packets frame format is the same as the
>> request packet frame format except that in some scenario the "P" and "F" bit
>> value is different.
> 
> Best Regards,
> Suping
>> Sir/Madam,
>>