Subject: BFD Sessions: Graceful Shutdown

From: "Satyam Sinha" <[email-masked]>
Date: Tue, 21 Mar 2006 16:20:26 -0800

Hi,

Presently, we do not have any way to gracefully shutdown a BFD session. By looking at the drafts, I
could not find a way by which we could de-couple a BFD session from a registered protocol.

If a user decides to decouple the BFD session from a protocol registered to use the BFD session,
tearing down the BFD session will always causes the protocol to take the adjacency down. For some
administrative reason, if we do decide to decouple the session, we should have a way to do it.

One solution would be that the requestor could probably send a BFD message with a "Diag Code -
Graceful Shutdown" or somesuch alongwith the 'P' bit set. The requestor on receiving the same diag
code and the 'F' bit set could tear down the session gracefully.

Regards,

-Satyam.
----------------
IP Division
Alcatel USA

---

From: Reshad Rahman <[email-masked]>
Date: Tue, 21 Mar 2006 21:00:56 -0500

I think the admindown state is also for gracefully shutting down a BFD 
session (see 6.7.17. Administrative Control). So the procedure should be 
something like this
1- Requestor sets state to admindown, local diag to the appropriate 
value and sets P bit
2- From 6.7.6 BFD at the other end goes down:
      If received state is AdminDown
          If bfd.SessionState is not Down
              Set bfd.LocalDiag to 3 (Neighbor signaled session down)
              Set bfd.SessionState to Down
3- On receiving F bit the requestor can remove the session if needed.

I think the part which isn't mentioned in the draft is that when a 
session goes down because the remote is admindown, then the protocol 
adjacency should not go down.

Regards,
Reshad.

---

From: David Ward <[email-masked]>
Date: Wed, 22 Mar 2006 11:54:30 -0600

This is discussed in the state machine and subsequent textual description.

-DWard