Subject: BFD for PW Fault Detection (VCCV)

From: "Oren Geron" <[email-masked]>
Date: Wed, 10 May 2006 11:12:51 +0200

One of the PWE3 VCCV options is to use the BFD as a fault detection tool.
If I understand correctly, when using PWE3 VCCV, the BFD packets should be UDP/IP packets.
What is the use of the UDP/IP encapsulation? 
Why can't it be a Control Word (PW Associated Channel Header  with 0001 as first nibble) followed by the BFD Packet ? 

With regards, 
	Oren Geron.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 11 May 2006 14:46:21 -0400

> should be UDP/IP packets.
	Its  basically a UDP/IP behind the PW header.
> Why can't it be a Control Word (PW Associated Channel Header  with  
> 0001 as first nibble) followed by the BFD Packet ?
	I have an update of the draft coming out with some clarifications, but
in essence, you use the same packet format as the other VCCV payloads.

	--tom

---

From: Rahul Aggarwal <[email-masked]>
Date: Thu, 11 May 2006 12:54:50 -0700 (PDT)

Hi Oren,

> What is the use of the UDP/IP encapsulation?

Here are the advantages:

- It keeps BFD over PWs encaps to be as close to the generic BFD over
MPLS encaps as possible. Look at draft-ietf-bfd-mpls-02.txt [Soon to
be refreshed].
- It allows retaining information of the PW source. The IP source
address adds robustness and enables checking a BFD over MPLS packet to be
from the expected source.
- Of course, to send BFD directly in a PWACH packet
we would need to define a new "channel type"
(presently RFC 4385 only defines 0x21 of IPv4 and 0x57 for IPv6).

Further LSP-Ping for PWs uses an IP/UDP header as well. So why deviate for
BFD ?

rahul