Subject: Poll sequence for Echo

From: "Vishwas Manral" <[email-masked]>
Date: Mon, 8 Dec 2008 14:56:29 -0800

Hi,

The BFD base specification states that:

   If either bfd.DesiredMinTxInterval is changed or
   bfd.RequiredMinRxInterval is changed, a Poll Sequence MUST be
   initiated.

Is there a reason it does not state the same for
bfd.RequiredMinEchoRxInterval? I think the Poll sequence needs to be
required for this too.

Thanks,
Vishwas

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Mon, 8 Dec 2008 22:23:44 -0800

Hello Vishwas.

Good question. I must reply that whether Poll/Final
sequence is needed for bfd.RequiredMinEchoRxInterval
is arguable.

Change in bfd.RequiredMinEchoRxInterval parameter of a
session may trigger neighboring system to:
1) Change the echo packet transmission interval.
2) Failure detection interval, based on 1).

Unlike bfd.DesiredMinTxInterval parameter, triggered
changes, in terms of session behavior, are isolated to
one system. Thus, Poll/Final sequence is not necessary.

On the other hand, without Poll/Final sequence, a local system
cannot know whether neighboring system has acknowledged
the bfd.RequiredMinEchoRxInterval change or not.

With that said, IMHO, it's probably better not to use Poll/Final
sequence when bfd.RequiredMinEchoRxInterval changes.
Main reason is that, we can avoid/ignore the corner case of:

"What if a local system attempt to change the
bfd.RequiredMinEchoRxInterval value, but neighboring system
does not ack (no final sent back)?".

Thanx,
Nobo

> -----Original Message-----
> From: Vishwas Manral [mailto:[email-masked]] 
> Sent: Tuesday, December 09, 2008 7:56 AM
> To: [email-masked]; David Ward
> Cc: Nobo Akiya (nobo)
> Subject: Poll sequence for Echo
> 
> Hi,
> 
> bfd.RequiredMinEchoRxInterval? I think the Poll sequence 
> needs to be required for this too.
> 
> Thanks,
> Vishwas
>