Subject: Parameter change

From: "Shahram Davari" <[email-masked]>
Date: Tue, 18 Aug 2009 19:30:22 -0700

Hi,

There is a discrepancy in the base draft regarding when any of the BFD parameter changes. Section 6.8.10, 11 and 12 say that poll sequence is not required when bfd.DesiredMinTxInterval  or bfd.RequiredMinRxInterval  are changed, while section 6.8.3 says:

" If either bfd.DesiredMinTxInterval is changed or bfd.RequiredMinRxInterval is changed, a Poll Sequence MUST be initiated (see section 6.5)"

Which one is correct? If not in demand mode is there any need to initiate Poll if any of the local parameters change?

Thanks,
Shahram

---

From: David Ward <[email-masked]>
Date: Wed, 19 Aug 2009 00:21:47 -0500

Shahram -

6.8 and 10 clearly state that the rules of 6.8.3 apply. I don't  
believe there is a need for more verbiage than exists.

6.8.12 is discussing a different attribute, the detect multiplier. It  
clearly states that a poll sequence is not necessary. This should be  
obvious as the detectmult is a local matter and doesn't affect  
anything on the remote end.

You do need to use the poll sequence in all cases. Demand mode setting  
is orthogonal.

-DWard

On Aug 18, 2009, at 9:30 PM, Shahram Davari wrote:

> Hi,
>
> There is a discrepancy in the base draft regarding when any of the  
> BFD parameter changes. Section 6.8.10, 11 and 12 say that poll  
> sequence is not required when bfd.DesiredMinTxInterval  or  
> bfd.RequiredMinRxInterval  are changed, while section 6.8.3 says:
>
> " If either bfd.DesiredMinTxInterval is changed or  
> bfd.RequiredMinRxInterval is changed, a Poll Sequence MUST be  
> initiated (see section 6.5)"
>
> Which one is correct? If not in demand mode is there any need to  
> initiate Poll if any of the local parameters change?
>
> Thanks,
> Shahram

---

From: "Shahram Davari" <[email-masked]>
Date: Wed, 19 Aug 2009 10:28:19 -0700

Hi David,

I thought Detection Multiplier is a parameter sent by a local system to a remote system, so that the remote system can compute the Detection Interval Timer. What do you mean by "Detection Multiplier is a Local matter"? If it is a local matter then why is it communicated to the remote system?

I think I am not clear on the definition of Detection Multiplier. The base draft defines it as:

Detect Mult

"Detection time multiplier. The negotiated transmit interval, multiplied by this value, provides the Detection Time for the transmitting system in Asynchronous mode."

May be you could explain it in the following example:

A ------------------------------->B
A<--------------------------------B

BFD packets send from A --> B:

Detect Mult=A1, Desired Min Tx Interval = A2, Require Min RX Interval =A3

BFD packets send from B --> A:

Detect Mult=B1, Desired Min Tx Interval = B2, Require Min RX Interval =B3

The Detection Window at B = A1 * Max (A2, B3)

The Detection Window at A = B1 * Max (B2, A3)

Is this computation correct?

Thanks,
Shahram

________________________________
From: David Ward [mailto:[email-masked]]
Sent: Tuesday, August 18, 2009 10:22 PM
To: Shahram Davari
Cc: David Ward; [email-masked]
Subject: Re: Parameter change

Shahram -

6.8 and 10 clearly state that the rules of 6.8.3 apply. I don't believe there is a need for more verbiage than exists.

6.8.12 is discussing a different attribute, the detect multiplier. It clearly states that a poll sequence is not necessary. This should be obvious as the detectmult is a local matter and doesn't affect anything on the remote end.

You do need to use the poll sequence in all cases. Demand mode setting is orthogonal.

-DWard

Hi,

Thanks,
Shahram

---

From: Dave Katz <[email-masked]>
Date: Wed, 19 Aug 2009 12:14:24 -0600

DaveW misspoke slightly.

Your computation is correct.

There is no need for a poll sequence when the multiplier is changed  
because the timing of the packet transmission doesn't change.

The poll sequence is needed to coordinate timing changes if the packet  
transmission interval might change, as the detection time change needs  
to be coordinated with the transmission rate change so that the  
session doesn't fail by mistake.

--Dave

On Aug 19, 2009, at 11:28 AM, Shahram Davari wrote:

> Hi David,
>
> I thought Detection Multiplier is a parameter sent by a local system  
> to a remote system, so that the remote system can compute the  
> Detection Interval Timer. What do you mean by "Detection Multiplier  
> is a Local matter"? If it is a local matter then why is it  
> communicated to the remote system?
>
> "Detection time multiplier. The negotiated transmit interval,  
> multiplied by this value, provides the Detection Time for the  
> transmitting system in Asynchronous mode."
>
>
> 6.8.12 is discussing a different attribute, the detect multiplier.  
> It clearly states that a poll sequence is not necessary. This should  
> be obvious as the detectmult is a local matter and doesn't affect

---

From: "Shahram Davari" <[email-masked]>
Date: Wed, 19 Aug 2009 11:51:47 -0700

Hi Dave K,

But the draft says" provides the Detection Time for the transmitting system". Shouldn't this be changed to "provides the Detection Time for the receiving system"

Yours,
Shahram

________________________________
From: Dave Katz [mailto:[email-masked]]
Sent: Wednesday, August 19, 2009 11:14 AM
To: Shahram Davari
Cc: David Ward; [email-masked]
Subject: Re: Parameter change

DaveW misspoke slightly.

There is no need for a poll sequence when the multiplier is changed because the timing of the packet transmission doesn't change.

The poll sequence is needed to coordinate timing changes if the packet transmission interval might change, as the detection time change needs to be coordinated with the transmission rate change so that the session doesn't fail by mistake.

--Dave

Hi David,

Detect Mult

Thanks,
Shahram

Cc: David Ward; [email-masked]<mailto:[email-masked]>

Shahram -

-DWard

Hi,

Thanks,
Shahram

---

From: Dave Katz <[email-masked]>
Date: Wed, 19 Aug 2009 14:20:15 -0600

Right you are, fixed in the next version.

--Dave

On Aug 19, 2009, at 12:51 PM, Shahram Davari wrote:

> Hi Dave K,
>
> But the draft says" provides the Detection Time for the transmitting  
> system". Shouldn't this be changed to "provides the Detection Time  
> for the receiving system"
>
> Yours,
> Shahram
>
> The poll sequence is needed to coordinate timing changes if the  
> packet transmission interval might change, as the detection time  
> change needs to be coordinated with the transmission rate change so  
> that the session doesn't fail by mistake.
>
> --Dave
>
>> I thought Detection Multiplier is a parameter sent by a local  
>> system to a remote system, so that the remote system can compute  
>> the Detection Interval Timer. What do you mean by "Detection  
>> Multiplier is a Local matter"? If it is a local matter then why is  
>> it communicated to the remote system?
>>
>> It clearly states that a poll sequence is not necessary. This  
>> should be obvious as the detectmult is a local matter and doesn't  
>> affect anything on the remote end.
>>