Subject: Induced Jitter

From: "Shahram Davari" <[email-masked]>
Date: Fri, 14 Aug 2009 14:23:42 -0700

Hi,

When a local system applies Jitter to transmitted BFD control packets, is the remote system aware of the amount of this Jitter? or the remote bases its Detection time without taking to account this Jitter? If so then doesn't this cause a problem, since the Jitter could be as much as 25% and this value is added on top of the network jitter.

Thanks,
Shahram

---

From: Nitin Bahadur <[email-masked]>
Date: Fri, 14 Aug 2009 14:37:53 -0700

Remote system is not aware of jitter.

Application of jitter SHOULD NOT result in increase in send interval.

So, if you the send interval is 1000ms and jitter is 25%, then you need to send a packet
every 750-1000 ms.

Remote end does not take jitter into account when deducing it's detection time.

Thanks
Nitin

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Shahram Davari
Sent: Friday, August 14, 2009 2:24 PM
To: [email-masked]
Subject: Induced Jitter

Hi,

Thanks,
Shahram

---

From: Vishwas Manral <[email-masked]>
Date: Fri, 14 Aug 2009 16:28:54 -0700

Hi Shahram,

This was the exact issue I raised in BFD a few months back. Tat
resulted in the spec being changed significantly.

Look at the discussion here

http://www.ietf.org/mail-archive/web/rtg-bfd/current/msg00570.html

also look at the changes between the versions of the recent drafts.

Thanks,
Vishwas

On Fri, Aug 14, 2009 at 2:23 PM, Shahram Davari<[email-masked]> wrote:
> Hi,
>
> When a local system applies Jitter to transmitted BFD control packets, is
> the remote system aware of the amount of this Jitter? or the remote bases
> its Detection time without taking to account this Jitter? If so then doesn't
> this cause a problem, since the Jitter could be as much as 25% and this
> value is added on top of the network jitter.
>
> Thanks,
> Shahram

---

From: Dave Katz <[email-masked]>
Date: Sat, 15 Aug 2009 16:29:50 -0600

On Aug 14, 2009, at 3:23 PM, Shahram Davari wrote:

> Hi,
>
> When a local system applies Jitter to transmitted BFD control  
> packets, is the remote system aware of the amount of this Jitter? or  
> the remote bases its Detection time without taking to account this  
> Jitter? If so then doesn't this cause a problem, since the Jitter  
> could be as much as 25% and this value is added on top of the  
> network jitter.

Jitter is always *subtracted.*  I believe the text is clear on this.

The receiving end neither knows nor cares;  it calculates the  
Detection Time based on the parameters and times out.  All that the  
jitter does is raise the frequency of received packets by an average  
of 12.5%, which provides more robustness rather than less.

--Dave