Subject: Few Queries regarding BFD

From: GAURAV HALWASIA <[email-masked]>
Date: Fri, 13 Nov 2009 13:00:16 +0530 (IST)

Hello Experts,

I will be working on implemmenting BFD in out protocol stack and due to that trying to understand the in/out of this protocol. I have couple of doubts regarding this protocol and need the help of you guys to help me out.

1. Should we (as BFD application) be getting the session parameters like Neighbour address (either Ipv4 and Ipv6), Timers (Desired Min TX Interval, Required Min RX Interval and Required Min Echo RX Interval in case Echo mode is supported), Ipv4/IPv6 encapsulation information, Active/Passive information etc from the BFD client/application like OSPF/BGP etc. Any clarity would be helpful.

2. I am not very much clear that how BFD application will decide whether this going to be session will be single hop or multi hop. Will the BFD application/client provide this information to BFD or will the BFD application should be able to find out the same consulting the routing module.

3. In BFD base draft I read the following 
  " Since multiple BFD sessions may be running between two systems, there
   needs to be a mechanism for demultiplexing received BFD packets to the proper session. "
   
   I am really not clear how the multiple BFD session can exist in between the two boxes.? I am really getting  for this point. Please help me to understand this clearly. 
    
Your inputs and help will be highly appreciated. A big thanks in advance.

Regards,
Gaurav Halwasia

      The INTERNET now has a personality. YOURS! See your Yahoo! Homepage. http://in.yahoo.com/

---

From: Vishwas Manral <[email-masked]>
Date: Fri, 13 Nov 2009 09:36:14 -0800

Hi Gaurav,

> I will be working on implemmenting BFD in out protocol stack and due to that
> trying to understand the in/out of this protocol. I have couple of doubts
> regarding this protocol and need the help of you guys to help me out.
>
> 1. Should we (as BFD application) be getting the session parameters like
> Neighbour address (either Ipv4 and Ipv6), Timers (Desired Min TX Interval,
> Required Min RX Interval and Required Min Echo RX Interval in case Echo mode
> is supported), Ipv4/IPv6 encapsulation information, Active/Passive
> information etc from the BFD client/application like OSPF/BGP etc. Any
> clarity would be helpful.
It is dependent on the implementation.

> 2. I am not very much clear that how BFD application will decide whether
> this going to be session will be single hop or multi hop. Will the BFD
> application/client provide this information to BFD or will the BFD
> application should be able to find out the same consulting the routing
> module.
The application should know this.

>    I am really not clear how the multiple BFD session can exist in between
> the two boxes.? I am really getting  for this point. Please help me to
> understand this clearly.
If for example you have multiple parallel links between a set of
routers you can have multiple parallel links and in turn sessions.

Thanks,
Vishwas
> ________________________________
> The INTERNET now has a personality. YOURS! See your Yahoo! Homepage.