Subject: Re: Few Queries regarding BFD

From: GAURAV HALWASIA <[email-masked]>
Date: Sat, 14 Nov 2009 11:05:41 +0530 (IST)

Hi Vishwas,

Thanks a lot for your inputs in this. Please see inline @ GAURAV

Regards,
Gaurav

________________________________

From: Vishwas Manral <[email-masked]>
To: GAURAV HALWASIA <[email-masked]>
Cc: [email-masked]
Sent: Fri, 13 November, 2009 9:36:14 AM
Subject: Re: Few Queries regarding BFD

[GAURAV] Ok. Makes sense.

> 2. I am not very much clear that how BFD application will decide whether
> this going to be session will be single hop or multi hop. Will the BFD
> application/client provide this information to BFD or will the BFD
> application should be able to find out the same consulting the routing
> module.
The application should know this.

[GAURAV] So the application (for ex OSPF) will be in position to know before hand itself that it's neighbour is directly connected (single hop) or multi hop.?? Because I think for BFD it will not be trivial to find the same(i.e single/multi hop) other than interfacing with the routing module. Further considering the short detection time which is required in this application, I also personally think that if the BFD client/application can give this ready to use information to us, it will be good. Any thoughts ..??

> 3. In BFD base draft I read the following
>   " Since multiple BFD sessions may be running between two systems, there
>    needs to be a mechanism for demultiplexing received BFD packets to the
> proper session. "
>
>    I am really not clear how the multiple BFD session can exist in between
> the two boxes.? I am really getting  for this point. Please help me to
> understand this clearly.
If for example you have multiple parallel links between a set of
routers you can have multiple parallel links and in turn sessions.

[GAURAV] Ok. But Are you referring to this scenario for single hop or multi hop..? is it something like we also need to take into account the interface on the box which is getting used for the session. Do you know any document/link which clearly explains in detail this scenario..? This will be very helpful.

Once again. Thanks a lot for your inputs and help.

Thanks,
Vishwas
> Your inputs and help will be highly appreciated. A big thanks in advance.
>
> Regards,
> Gaurav Halwasia
> ________________________________
> The INTERNET now has a personality. YOURS! See your Yahoo! Homepage.

Hi Gaurav,

> I will be working on implemmenting BFD in out protocol stack and due to that
> trying to understand the in/out of this protocol. I have couple of doubts
> regarding this protocol and need the help of you guys to help me out.
>
> 1. Should we (as BFD application) be getting the session parameters like
> Neighbour address (either Ipv4 and Ipv6), Timers (Desired Min TX Interval,
> Required Min RX Interval and Required Min Echo RX Interval in case Echo mode
> is supported), Ipv4/IPv6 encapsulation information, Active/Passive
> information etc from the BFD client/application like OSPF/BGP etc. Any
> clarity would be helpful.
It is dependent on the implementation.

      The INTERNET now has a personality. YOURS! See your Yahoo! Homepage. http://in.yahoo.com/

---

From: Vishwas Manral <[email-masked]>
Date: Sat, 14 Nov 2009 07:33:51 -0800

Hi Gaurav,

> [GAURAV] So the application (for ex OSPF) will be in position to know before
> hand itself that it's neighbour is directly connected (single hop) or multi
> hop.?? Because I think for BFD it will not be trivial to find the same(i.e
> single/multi hop) other than interfacing with the routing module. Further
> considering the short detection time which is required in this application,
> I also personally think that if the BFD client/application can give this
> ready to use information to us, it will be good. Any thoughts ..??
So if you are having a BFD session for directly connected OSPF
neighbors it will be single hop. The virtual links can always be
modelled as multihop.

If the application does not know it could as well ask the user input
the information.

> [GAURAV] Ok. But Are you referring to this scenario for single hop or multi
> hop..? is it something like we also need to take into account the interface
> on the box which is getting used for the session. Do you know any
> document/link which clearly explains in detail this scenario..? This will be
> very helpful.

Though I am referring to a single hop case the same can occur in the
multi-hop case too.

Thanks,
Vishwas