Subject: BFD VCCV!!

From: <[email-masked]>
Date: Tue, 17 Nov 2009 21:05:01 +0530

Hi All,
 
Once the PW is operational and VCCV-BFD session is established between
the PW peers (after they exchanged the BFD VCCV capabilty), can this BFD
session be brought down administratively without bringing
down/re-signaling the PW?
 
If i'm correct, I think the same can be done using "Administratively
Down" Diag code in case of other BFD applications like OSPF. 
 
But in case of BFD VCCV, as per the below text in
draft-ietf-pwe3-oam-msg-map-11 which discusses the BFD Diag codes, I
understand that "Administrative down" Diag code is used to signal to the
PW peer that the PW is brought down administratively, not for signaling
that the BFD session between PW peers is brought down.
 
"A PE shall  use "Administrative down" to bring down the BFD session
when the PW  is brought down administratively"
 
Thanks in Advance for any inputs,
 
Regards,
Mahesh.

---

From: Vishwas Manral <[email-masked]>
Date: Tue, 17 Nov 2009 08:19:25 -0800

Hi Mahesh,

> session be brought down administratively without bringing down/re-signaling
> the PW?
>
> If i'm correct, I think the same can be done using "Administratively Down"
> Diag code in case of other BFD applications like OSPF.
That is correct Mahesh.

> understand that "Administrative down" Diag code is used to signal to the PW
> peer that the PW is brought down administratively, not for signaling that
> the BFD session between PW peers is brought down.
>
> "A PE shall  use "Administrative down" to bring down the BFD session when
> the PW  is brought down administratively"
I do not see a conflict here. The BFD session can be brought down
administratively. When a PW is brought down administratively, in that
case too we will use the "Admin down" diag.

What is it I am missing in the question?

Thanks,
Vishwas

---

From: <[email-masked]>
Date: Tue, 17 Nov 2009 22:19:23 +0530

Hi Vishwas,

Thanks for your quick reply.

If we use "Admin Down" diag code to signal both the "PW Down" and "VCCV BFD Session Down" to the PW peer, what should be the action at the peer?

Should the peer just delete the BFD session and stop expecting/sending BFD control packets on that VC or should it assume that the VC Fib has been uninstalled on the other and take necessary action like un-installing the VC fib entry at its end too?

Thanks,
Mahesh

-----Original Message-----
From: Vishwas Manral [mailto:[email-masked]] 
Sent: Tuesday, November 17, 2009 9:49 PM
To: Mahesh Akula (WT01 - Telecom Equipment)
Cc: [email-masked]
Subject: Re: BFD VCCV!!

Hi Mahesh,

> the PW peers (after they exchanged the BFD VCCV capabilty), can this 
> BFD session be brought down administratively without bringing 
That is correct Mahesh.

> understand that "Administrative down" Diag code is used to signal to 
> the PW peer that the PW is brought down administratively, not for 
> signaling that the BFD session between PW peers is brought down.
>
I do not see a conflict here. The BFD session can be brought down administratively. When a PW is brought down administratively, in that case too we will use the "Admin down" diag.

Thanks,
Vishwas

---

From: Vishwas Manral <[email-masked]>
Date: Tue, 17 Nov 2009 09:57:57 -0800

Hi Mahesh,

> Should the peer just delete the BFD session and stop expecting/sending BFD control packets on that VC or should it assume that the VC Fib has been uninstalled on the other and take necessary action…
For Admin-down you will not delete the BFD session. It will still
expect BFD packets and send packets just like in the normal BFD case.

Thanks,
Vishwas

> Please do not print this email unless it is absolutely necessary.
>
> The information contained in this electronic message and any attachments to this message are intended for the exclusive use of the addressee(s) and may contain proprietary, confidential or privileged information. If you are not the intended recipient, you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately and destroy all copies of this message and any attachments.
>
> WARNING: Computer viruses can be transmitted via email. The recipient should check this email and any attachments for the presence of viruses. The company accepts no liability for any damage caused by any virus transmitted by this email.
>
> www.wipro.com
>

---

From: <[email-masked]>
Date: Wed, 18 Nov 2009 13:51:36 +0530

Hi Vishwas,

Thanks for correcting me. 

I'll rephrase my question then,

On receiving "Admin Down" Diag code from the peer, should the node just stop expecting the BFD control packets from the peer on that VC (or) should it assume that the PW is down at the other end and take necessary action, may be bring down the PW at its end too.

I think if PW is down at the peer end, there is no point in sending BFD control packets on that VC any more right?

Thanks for your inputs and time.

Regards,
Mahesh

-----Original Message-----
From: Vishwas Manral [mailto:[email-masked]] 
Sent: Tuesday, November 17, 2009 11:28 PM
To: Mahesh Akula (WT01 - Telecom Equipment)
Cc: [email-masked]
Subject: Re: BFD VCCV!!

Hi Mahesh,

> Should the peer just delete the BFD session and stop expecting/sending BFD control packets on that VC or should it assume that the VC Fib has been uninstalled on the other and take necessary action…
For Admin-down you will not delete the BFD session. It will still expect BFD packets and send packets just like in the normal BFD case.

Thanks,
Vishwas

>> Once the PW is operational and VCCV-BFD session is established 
>> between the PW peers (after they exchanged the BFD VCCV capabilty), 
>> can this BFD session be brought down administratively without 
>> bringing down/re-signaling the PW?
>>

---

From: Vishwas Manral <[email-masked]>
Date: Wed, 18 Nov 2009 08:11:19 -0800

HI Mahesh,

> I think if PW is down at the peer end, there is no point in sending BFD control packets on that VC any more right?
As the diganostics code is used for different scenarios we will send
the BFD packets till the VC is removed from the local end. This will
take care of the case where its just that BFD is brought down
Administratively.

Thanks,
Vishwas