Subject: BFD on LAN

From: Glen Kent <[email-masked]>
Date: Wed, 2 Jun 2010 05:50:04 +0530

Hi,

Since BFD does not use a mcast address does it mean that it will form
a full mesh of unicast BFD sessions on a LAN?

Glen

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Tue, 1 Jun 2010 19:23:03 -0500

Yes.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Glen Kent
Sent: Tuesday, June 01, 2010 8:20 PM
To: [email-masked]
Subject: BFD on LAN

Hi,

Glen

---

From: Vishwas Manral <[email-masked]>
Date: Tue, 1 Jun 2010 22:00:14 -0700

Hi Glen,

Reshad is right.

We could have a FULL mesh, or if we wanted to only check particular
reachability we could have BFD sessions between DROther and DR/ BDR.
this however would be an optimization for OSPF and IS-IS.

Thanks,
Vishwas

---

From: Dave Katz <[email-masked]>
Date: Wed, 2 Jun 2010 11:57:18 -0600

Yes, this is on purpose.  The biggest benefit is that the intervals are negotiated pairwise, so faster systems are not held hostage to slower systems.

It's also the case that the use of multicast in control protocols is usually overrated (unicast replies are typically necessary, so the reduction in traffic is often uninteresting, and the complexity required to make multicast work becomes ugly--EIGRP is one of the worst offenders along these lines.)  IS-IS is the only protocol I've seen that leverages multicast well.

There are protocols that use multicast for discovery but do the bulk of their work over unicast (e.g., LDP).  BFD effectively uses this model when supporting IGPs, by letting the IGP take care of discovery.

--Dave

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Tue, 8 Jun 2010 14:23:15 +0530

Hi Vishwas,

I would presume that we would create a BFD session with only the DR/BDR. Why should two DROther routers have a BFD session with each other in the context of OSPF? AFAIK, they are not even aware of the presence of the other.

Cheers, Manav 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Vishwas Manral
> Sent: Wednesday, June 02, 2010 10.30 AM
> To: Glen Kent
> Cc: [email-masked]
> Subject: Re: BFD on LAN
> 
> Hi Glen,
> 
> Reshad is right.
>

---

From: Minto Jeyananth <[email-masked]>
Date: Tue, 8 Jun 2010 06:54:06 -0700

Manav, 

 DRother may use other DRother routers to forward traffic. I know one implementation even provide a knob to control it :). 

-minto  

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On Behalf
|Of Bhatia, Manav (Manav)
|Sent: Tuesday, June 08, 2010 1:53 AM
|To: Vishwas Manral
|Cc: [email-masked]
|Subject: RE: BFD on LAN
|
|Hi Vishwas,
|
|I would presume that we would create a BFD session with only the DR/BDR.
|Why should two DROther routers have a BFD session with each other in the
|context of OSPF? AFAIK, they are not even aware of the presence of the
|other.
|
|Cheers, Manav
|

---

From: Vishwas Manral <[email-masked]>
Date: Tue, 8 Jun 2010 07:23:04 -0700

Hi Manav,

They have adjacencies which are parked in  2-way state.

You are right from the control plane perspective the sessions may not
be required.

Thanks,
Vishwas

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Wed, 9 Jun 2010 00:02:53 +0530

Hi Vishwas,

Yup, obviously that's correct. What I meant was that they are not in the FULL state.

Cheers, Manav

> From: Vishwas Manral [mailto:[email-masked]] 
> Sent: Tuesday, June 08, 2010 7.53 PM
> To: Bhatia, Manav (Manav)
> Cc: [email-masked]
> Subject: Re: BFD on LAN
> 
> Hi Manav,
> 
> > I would presume that we would create a BFD session with 
> only the DR/BDR. Why should two DROther routers have a BFD 
> session with each other in the context of OSPF? AFAIK, they 
> are not even aware of the presence of the other.
> >
> > Cheers, Manav
> >

---

From: Dave Katz <[email-masked]>
Date: Tue, 8 Jun 2010 11:54:11 -0700

> I would presume that we would create a BFD session with only the DR/BDR. Why should two DROther routers have a BFD session with each other in the context of OSPF? AFAIK, they are not even aware of…

Well, OSPF routers forward directly through each other (by virtue of being neighbors) regardless of DR-ship, so if you're actually trying to protect the forwarding path, running BFD makes sense.

One could argue that running sessions only with the DR/BDR is nearly as good, since a failed DROther router will show up as not being adjacent to the Network LSA and thus forwarding will be stopped, but that potentially adds additional latency to the process.

Also, a full mesh of BFD provides protection against non-transitive connectivity in broadcast domains.  Whether this is an actual concern is probably arguable, though I'll point out that my crappy powerline ethernet boxes at home do this regularly (I guess I won't build a transit POP in my house.)  As switching continues to get more complicated, this may be a bigger issue than it was in the days of orange hoses and vampire taps.

--Dave