Subject: Basic clarification on BFD session setup

From: [email-masked]
Date: Fri, 02 Jul 2010 03:19:45 -0400

All,

I have been looking into BFD drafts recently and have the following basic queries. Would appreciate if someone could clarify.

Firstly, the base draft states - "A session begins with the periodic, slow transmission of BFD Control
packets". My interpretation of this is that during session establishment, the configured DesiredMinTxInterval and the transmit interval (max of DesiredMinTx and RemoteMinRx) determined thereof will not be used. Instead some fixed default value that would result in a slow rate so as not to hog the bandwidth, should be used. That is the actual negotiated transmit interval is actually used only after session establishment (UP state) for the periodic transmission of BFD control packets. Is this right?

Further from the bfd for mpls draft, it looks like the LSP ping echo request is to be immediately replied by a BFD control packet without necessarily being sent on the next periodic transmission. This seems unlike the base draft (as quoted above - slow "periodic" transmission). Or have I got this wrong?

Cheers
Lucy

---

From: Dave Katz <[email-masked]>
Date: Fri, 2 Jul 2010 10:25:27 -0700

> packets". My interpretation of this is that during session establishment, the configured DesiredMinTxInterval and the transmit interval (max of DesiredMinTx and RemoteMinRx) determined thereof will…

Yes.  There is more formal language in the normative part of the spec that defines this process more precisely.

> Further from the bfd for mpls draft, it looks like the LSP ping echo request is to be immediately replied by a BFD control packet without necessarily being sent on the next periodic transmission. T…

The point of the bootstrapping process is that there is no way to send BFD packets before the LSP Ping arrives, so there isn't any periodic transmission happening.  The arrival of the Ping triggers the creation of the session, and the periodicity starts at that point.

Having said that, this is an implementation decision.  The fact is that there will always be latency between the time a system sends a Ping and the time it eventually sees a BFD packet from the other end.  Whether that latency is due to an implementation taking its time sending the first packet or because of interplanetary packet delays cannot be determined.  "Immediately" is a rather nebulous concept in networking.  In the cases in the BFD base spec where an "extra" packet is to be returned (ignoring the negotiated interval), the point is to speed the BFD state machine along.  For that matter, the "extra" packet could be lost in flight, so the correctness of the protocol can never rely on anything happening "immediately" or "as soon as practicable" or "post haste"--it's an optimization.

--Dave