Subject: Re: BFD alternate path?

From: ibtisam jamal <[email-masked]>
Date: Wed, 18 Aug 2010 21:52:48 +0300

Hi,

I have a ring topology that uses bfd on interfaces to detect link failure.
When bfd detects that a link is down .What happens to the already
packaged packets on mpls level are they droped or rerouted to the next
available path.

logicaly speaking i think the packets already labeled will be dropped.

on the other hand a few miliseconds later the link is reestablished
and down again.What happens to these packets are they queued while
mpls is recalculating the path or are they discarded.

Another situation is when the link is up but has errors does bfd have
anyway to detect this.when i monitor the interface i see that  there
is a mismatch in the IN packets and OUT packets but bfd is still up.

What does bfd do when it detects these errors ?

thanks ,

Ibtisam

---

From: Dave Katz <[email-masked]>
Date: Thu, 19 Aug 2010 00:14:35 -0700

Much of this are implementation details that are not subject to standardization;  the answer would depend on a particular vendor's implementation (and this list is not an appropriate place to discuss vendor details).

BFD does not detect errors, nor does it detect lost packets (nor can it).  Sessions generally fail due to session timeout, which typically requires N lost packets in a row, where N is the multiplier value called out in the spec.

--Dave