Subject: Draft MPLS-TP CC CV RDI, BFD for MPLS-TP

From: David Allan I <[email-masked]>
Date: Wed, 30 Mar 2011 01:51:47 -0400

FYI, a "comments welcome" situation...

The current MPLS-TP CC-CV-RDI draft does not support poll/final discipline for modifying an existing session or during session startup (the current draft documents a "fast start" procedure which permits an transition to UP at the desired session Tx rates by an exchange of INIT in either direction)....

In the transport application some consider modifying an existing session on the fly to be a redundant function. However a last call comment suggests putting this capabilty back to maximize commonality with existing implementations.

What the editors have proposed is effectively an update to RFC 5880 in the form of what an implementation should do if a POLL does not get a FINAL response in a finite amount of time (which COULD be specified as the RxInterval * detect mult which if the session has not timed out means the far end is ignoring the POLL). It should simply abandon the attempt on the assumption that the far end does not support P/F, and any session changes can only be performed via a transition to ADMIN DOWN and the P/F less session startup procedures document in draft-cc-cv-rdi... Alternatively using P/F COULD just bring the session down.

To be clear CC-CV-RDI does require a few other changes, including encapsulation such that this is not a compatability with existing implementations scenario. All will need some degree of change to work for MPLS-TP operation...

Thanks
Dave (on behalf of editors)

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 30 Mar 2011 08:50:48 +0200

Dave,
Lots of thanks for sending this out and, incidentally, explaining in detail what you propose to do.
(The slide with the explanation has been missing it the version of your presentation that is available on the Web, and my understanding from the session yesterday was incorrect.)

I am very eager to hear what the response of the BFD WG would be:).

Regards,
     Sasha

From: [email-masked] [mailto:[email-masked]] On Behalf Of David Allan I
Sent: Wednesday, March 30, 2011 7:52 AM
To: [email-masked]
Subject: Draft MPLS-TP CC CV RDI, BFD for MPLS-TP

Thanks