Subject: RE: Solicit comments on BFD for Interface draft

From: Mach Chen <[email-masked]>
Date: Mon, 01 Aug 2011 07:32:01 +0000

Hi Manav,

The comments that I made is from the view of process of BFD packet. 

The world is not always only one way, people are always looking for better and more simple way. Based on most of the existing implementations of BFD and ETH OAM(eg., .ah/.ag...), BFD's configuration more simple, this is why many opertors (especically those operators who are running IP/MPLS network and familar with BFD) like it. 

Best regards,
Mach
________________________________________
发件人: Manav Bhatia [[email-masked]]
发送时间: 2011年8月1日 15:00
到: Mach Chen
Cc: [email-masked]
主题: Re: 答复: 答复: Solicit comments on BFD for Interface draft

Hi Mac,

This is exactly the point that i am trying to make - one pays a price by
sending BFD on each component link - so we must only do it if there is
no way out. Thus your comment in the earlier mail "From the view of
implementation, there is no difference between runing single BFD over a
LAG and runing per-link BFD." isnt entirely correct.

Cheers, Manav

On 8/1/2011 12:16 PM, Mach Chen wrote:
> Hi Manav,
>
>> Practically, most routers are constrained by the number of BFD packets the system can send and receive per second. If we start sending BFD packets over each component link of the lag, then the
> number of IP interfaces that can support BFD goes down.
>
> In the case of certain resources, this should be so. You have to pay this if you want to do per-link detection whatever techniques are used.
>
> Best regards,
> Mach
> ________________________________________
> 发件人: [email-masked] [[email-masked]] 代表 Manav Bhatia [[email-masked]]
> 发送时间: 2011年8月1日 14:36
> 到: [email-masked]
> 主题: Re: 答复: Solicit comments on BFD for Interface draft
>
> Hi Mach,
>
>> First, Could you please explain your protocol layering model. Do we now need 2 IP layers, one before LAG termination and one after LAG termination, where the one before LAG termination only understands the well known Multicast IPDA.
>>
>> Or implementing this draft assumes  bypassing LAG termination when IP-DA is the known multicast proposed in the draft. In other words now LAG termination is conditional on IP address.
>>
>> [Mach] From the view of implementation, there is no difference between runing single BFD over a LAG and runing per-link BFD. The key point is how to identify a BFD packet, current as defined in RFC 5880, it uses the UDP port, now for per-link BFD, it uses both multicast IP DA and UDP port. You can do it before or after the LAG termination, it's implementation specific.
>
> [Manav] I disagree. Practically, most routers are constrained by the
> number of BFD packets the system can send and receive per second. If we
> start sending BFD packets over each component link of the lag, then the
> number of IP interfaces that can support BFD goes down.
>
> Cheers, Manav

---

From: Manav Bhatia <[email-masked]>
Date: Mon, 1 Aug 2011 13:29:43 +0530

Hi Mach,

Then can this point about configuration complexity be added to the draft
so that the reader is aware of why this solution is being proposed?
Secondly, can you split this into two drafts - one that discusses doing
BFD over unnumbered IP interfaces and a new one that discusses BFD over
lags. While your original draft did not explicitly deal with the latter,
i think it makes sense to have a separate draft that deals with how BFD
could/should be done over lags.

Cheers, Manav

---

From: Mach Chen <[email-masked]>
Date: Mon, 01 Aug 2011 08:11:52 +0000

Hi Manav,

Many thanks for your suggestions! We will add text for the configuation complexity part. And basically, from my side, I am fine to split the draft if that help. I need to discuss with the co-authors and solicit the opinions of the WG and then decide how to progress it.

Best regards,
Mach
________________________________________
发件人: Manav Bhatia [[email-masked]]
发送时间: 2011年8月1日 15:59
到: Mach Chen
Cc: [email-masked]
主题: Re: Solicit comments on BFD for Interface draft

Hi Mach,

Cheers, Manav