Subject: Proposed update to WG milestones

From: Jeffrey Haas <[email-masked]>
Date: Tue, 14 May 2013 17:30:06 -0400

As everyone is doubtless aware, we're well past our proposed milestones for
the WG.  Our AD has prodded us to update them.  Here is my proposal:

November 2013	Submit the BFD MIB to the IESG to be considered as a Proposed Standard
November 2013	Submit the BFD over LAG document to the IESG to be considered as a Proposed Standard
June 2014	Submit the the document on BFD point-to-multipoint support to the IESG to be considered as a Proposed Standard
January 2015	Submit the generic keying based cryptographic authentication mechanism to the IESG to be considered as a Proposed Standard
January 2015	Submit the cryptographic authentication procedures for BFD to the IESG to be considered as a Proposed Standard
January 2015	Submit a BFD MIB extension in support of the generic keying document to the IESG to be considered as a Proposed Standard

Motivation for the above dates:
November 2013 - these documents are likely to be ready by that upcoming
IETF.  The MIB is mature and waiting for nits to be addressed (and I'll
re-send those nits to the authors soon).  The BFD over LAG work has already
done some interop work and the document needs a little bit of final smithing
(please review!) to get it done.

June 2014 - P2MP is already partially implemented by ALU.  Other vendors
have suggested they have implementations in progress.  I'd prefer to see at
least one more implementation before we LC the document.  Based on feedback
from implementors, the tail reporting mechanism is not getting implemented.
This may suggest the feature should be pruned from the final spec.

The crypto documents have been heavily reviewed at this point.  However,
I've yet to hear from anyone willing to implement them to advance them in
standards.  The January date is basically saying "not sure when".  The MIB
extension will be authored in the background to support this work should it
ever get implemented.

-- Jeff

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Wed, 15 May 2013 15:54:30 +0000

Hello Jeff,

> November 2013	Submit the BFD MIB to the IESG to be considered as a

I agree for BFD base MIB. For BFD MPLS MIB, it will be more beneficial to allow more time. Something along the line of November 2014.

Regards,
Nobo

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Jeffrey Haas
> Sent: Tuesday, May 14, 2013 5:30 PM
> To: [email-masked]
> Subject: Proposed update to WG milestones
> 
> As everyone is doubtless aware, we're well past our proposed milestones
> for the WG.  Our AD has prodded us to update them.  Here is my proposal:
> 
> June 2014	Submit the the document on BFD point-to-multipoint
> support to the IESG to be considered as a Proposed Standard
> January 2015	Submit the generic keying based cryptographic
> authentication mechanism to the IESG to be considered as a Proposed
> Standard
> January 2015	Submit the cryptographic authentication procedures for BFD
> to the IESG to be considered as a Proposed Standard
> January 2015	Submit a BFD MIB extension in support of the generic keying
> document to the IESG to be considered as a Proposed Standard
> 
> IETF.  The MIB is mature and waiting for nits to be addressed (and I'll re-send
> those nits to the authors soon).  The BFD over LAG work has already done
> some interop work and the document needs a little bit of final smithing
> least one more implementation before we LC the document.  Based on
> feedback from implementors, the tail reporting mechanism is not getting
> implemented.

---

From: Sam Aldrin <[email-masked]>
Date: Wed, 15 May 2013 09:13:20 -0700

We the authors of BFD MPLS MIB are slacking a little one getting new version published.
It is definitely on our plate to publish a new version very soon.
As far as date is concerned, I think we could shoot for Nov 13 itself, but given how the MIB's takes time, extending a little is more reasonable approach.

Cheers
Sam

Sent from my iPad

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 15 May 2013 13:02:35 -0400

> We the authors of BFD MPLS MIB are slacking a little one getting new version published.

As IETF history will readily note, I have zero room to complain about MIBs
taking a while for publication.

> As far as date is concerned, I think we could shoot for Nov 13 itself, but given how the MIB's takes time, extending a little is more reasonable approach.

My recommendation would be to wait until there's an implementation before we
move to WGLC.  If you think you have an implementation that will cover the
updated MIB, that may be reasonable.

-- Jeff