Subject: Discovering IP address to use for uBFD sessions

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Thu, 20 Jun 2013 05:09:35 +0000

Hi,

draft-ietf-bfd-on-lags is silent on how the IP address used for micro BFD sessions is derived/learnt/discovered.

It wisely assumes that an out-of-band mechanism exists which arms the routers with the knowledge about the remote IP address that it must use to establish the micro BFD session.

Some time back few of us wrote a short draft - draft-mmsn-bfd-on-lags-address-00, that describes how routers can obtain/discover remote IP addresses required for establishing uBFD sessions.

I would like the WG members to go through the above draft and discuss whether we need a draft that describes alternate ways to discover remote IP addresses or can we all assume that the remote IP addresses MUST be statically configured. 

The problem with implicitly assuming that the remote IP addresses MUST be configured is that as more folks start implementing this, they would stumble upon this issue and would be left clueless on how the IP addresses have to be derived. In case the WG decides that its premature to work on an autodiscovery mechanism, I would still like us to publish a draft that says that addresses MUST be statically configured and an Appendix where alternate mechanisms are listed along with their pros and cons (mostly for the sake of posterity).

Cheers, Manav

---

From: Glen Kent <[email-masked]>
Date: Thu, 20 Jun 2013 23:01:08 +0530

Hi Manav,

We did have a discussion around this more than a year back here:
http://www.ietf.org/mail-archive/web/rtg-bfd/current/msg01294.html

There clearly was interest in pursuing something like this.

I agree that we should have some mechanism to discover the remote IP
addresses.

Glen

On Thu, Jun 20, 2013 at 10:39 AM, Bhatia, Manav (Manav) <
[email-masked]> wrote:

> It wisely assumes that an out-of-band mechanism exists which arms the
> routers with the knowledge about the remote IP address that it must use to
> establish the micro BFD session.
>
> Some time back few of us wrote a short draft -
> draft-mmsn-bfd-on-lags-address-00, that describes how routers can
> obtain/discover remote IP addresses required for establishing uBFD sessions.
>
> I would like the WG members to go through the above draft and discuss
> whether we need a draft that describes alternate ways to discover remote IP
> addresses or can we all assume that the remote IP addresses MUST be
> statically configured.
>
> The problem with implicitly assuming that the remote IP addresses MUST be
> configured is that as more folks start implementing this, they would
> stumble upon this issue and would be left clueless on how the IP addresses
> have to be derived. In case the WG decides that its premature to work on an
> autodiscovery mechanism, I would still like us to publish a draft that says
> that addresses MUST be statically configured and an Appendix where
> alternate mechanisms are listed along with their pros and cons (mostly for
> the sake of posterity).
>
> Cheers, Manav
>
>
>
>
>

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Fri, 21 Jun 2013 23:02:49 +0000

Hello Manav, Glen, et al,

[hat on]

Primary discussion on the thread seemed to have revolved around which discovery mechanism is preferred (multicast vs. 127/8). There was also a preference of static configuration approach, to allow for faster implementation.

Based on number of responses on the thread, one can argue there was interest in auto discovery approach back then.

Now that several vendors have implement BFD on LAG, and using static configuration approach, it would be beneficial to see if there is still significant interest for auto discovery approach or if interest have shifted.

Can people (vendors, operators, others) kindly chime in?

[hat off]

Products that I know has proprietary but very similar to BFD on LAG solution, has static configuration approach, and have been used for years. I have not seen any auto discovery requests. Thus I personally think static configuration is an acceptable approach, and my preference is to go with last paragraph/sentence of Manav's email.

Regards,
Nobo

From: [email-masked] [mailto:[email-masked]] On Behalf Of Glen Kent
Sent: Thursday, June 20, 2013 1:31 PM
To: Bhatia, Manav (Manav)
Cc: [email-masked]
Subject: Re: Discovering IP address to use for uBFD sessions

Hi Manav,

I agree that we should have some mechanism to discover the remote IP addresses.

Glen

On Thu, Jun 20, 2013 at 10:39 AM, Bhatia, Manav (Manav) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Cheers, Manav