Subject: network interface BFD configuration issues.

From: Lokesh B <[email-masked]>
Date: Thu, 6 Jun 2013 15:52:46 +0530

Hi All,

I know that BFD can be enabled/disabled per network interface. Major
vendors allow configuration of BFD parameters like Min/Max Tx and Rx values
per interface. Also routing applications can specify their own BFD
parameters while creating bfd session. which values to select for BFD
operation in this case? should we go for the minimum of each specified
parameter?.
Also as interface can be configured with its own BFD parameters, should we
treat them as default parameters in case application creating a BFD session
on that interface does not specify them?
Highly appreciate the answers.

Regards and Thanks
-Lokesh.

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Thu, 6 Jun 2013 13:46:16 +0000

Hello Lokesh,

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Lokesh B
> Sent: Thursday, June 06, 2013 6:23 AM
> To: [email-masked]
> Subject: network interface BFD configuration issues.
> 
> Hi All,
> vendors allow configuration of BFD parameters like Min/Max Tx and Rx
> values per interface. Also routing applications can specify their own BFD

This falls in the area of implementation specifics, thus there are design choices but no right answer. Generically speaking, if multiple applications request BFD on same target, my personal preference would be to take the values that results in more aggressive detection time.

> Also as interface can be configured with its own BFD parameters, should
> we treat them as default parameters in case application creating a BFD
> session on that interface does not specify them?

Either applications have deviating default detection time values, user has configured deviating detection time values on applications or combination of both. Do you want to treat "interface" as a special application that takes precedence over other applications? Perhaps, perhaps not. It would seem most flexible if one approach was implemented and well documented, but allowed a knob to behave in different approaches as well.

Probably not the exact answers you were looking for, but I hope this helps.

Regards,
Nobo