Subject: Re: few queries regarding BFD

From: Lokesh B <[email-masked]>
Date: Wed, 21 Aug 2013 12:10:19 +0530

Thanks Marc,
I'm just picking this old thread because my question is in this context,
could you please let me know names of vendors and products of these "8k-16k
BFD sessions per linecard" systems? I'm interested in software/hardware
specifications of such high end systems.
Is it cisco? I googled but could not find any.

Regards
-Lokesh

On Fri, May 17, 2013 at 1:11 PM, Marc Binderberger <[email-masked]> wrote:

> Hello Lokesh,
>
> I know about systems that support 8k - 16k BFD sessions per linecard and
> "no limit" per system. For software-based I/O we talk about intervals of
> several hundreds of milliseconds then, hardware-based I/O can deliver much
> faster though.
>
> I use quotation marks as it mainly means no hard limits in the code; in
> reality one may find certain code/data structures like SNMP work fine for a
> few thousands but not for hundreds of thousands of sessions - and need
> optimization.
>
>
> Regards, Marc
>
>
>
>
> On 2013-05-17, at 6:30 , Lokesh NB wrote:
>
> Thanks Marc for the answers,
>
> >> 2. what is the currently supported maximum number of BFD sessions in
> high end routers? is it in the orders of hundreds of thousands?
>
> >Thousands. Details may depend on the timer values when the implementation
> is software based, still >system-wide I stick to "thousands".
>
> do you have any information about what is the highest number of BFD
> sessions supported by high end routers? I mean how many thousands of
> sessions do they support? I searched online but could not find the info.
>
> Regards
> -Lokesh
>
>
>
>
> On Fri, May 3, 2013 at 3:30 PM, Marc Binderberger <[email-masked]> wrote:
>
>> Hello Lokesh,
>>
>> some questions are quite generic but nevertheless ...
>>
>>
>> > 1. How to arrive at maximum number of BFD sessions to be supported in a
>> high end router.?
>>
>> distributed architecture and/or using ASIC/FPGA/NP to offload the packet
>> Tx/Rx
>>
>>
>> > 2. what is the currently supported maximum number of BFD sessions in
>> high end routers? is it in the orders of hundreds of thousands?
>>
>> Thousands. Details may depend on the timer values when the implementation
>> is software based, still system-wide I stick to "thousands".
>>
>>
>> > 3. What is the minimum Tx time to be supported for layer 3 UDP encap
>> peers? I know cisco supports minimum 50 msec but can we expect requirement
>> for IP peers to be monitored below that 50 msecs? like 10,20 msec?
>>
>> Actually this particular vendor you mention supports 15msec for high-end
>> equipment today. With a multiplier of 2 that makes a detection time of
>> 30msec maximum, so depending on the fiber length in a network that could
>> make the 50-60msec time for detection & restoration.
>>
>> Obviously: the faster the timer the better :-) , for MPLS-TP OAM the
>> usual number you hear is 3.3msec (so 10msec detection time with a
>> multiplier of 3).
>>
>>
>> > 4. What is average Tx time usually IP peers settle for in general? is
>> it like 100-300 msec? In other words what is usually configured Tx time for
>> IP peers?
>>
>> there is no single number, too many network designs out there in real
>> life. In the core customers typically go fast, to the endpoints some
>> customers go slower, just to stay below 1sec detection time so VoIP
>> controller don't freak out.
>>
>>
>> Regards, Marc
>>
>>
>>
>> > 5. What is the expected percentage of BFD traffic of the total
>> bandwidth of the device? I know it depends on how many sessions are active
>> in parallel and Tx/Rx timers but in general is it correct to estimate that
>> BFD traffic generally should not exceed 2 to 5 % of the total bandwidth
>> available for user data?
>> >
>> > 6. How frequently Auth is used in general deployments? is it only used
>> for multi hop peers usually?
>> >
>> > Regards
>> > -Lokesh
>> >
>> >
>> >
>> >
>> >
>> >
>>
>>
>>
>
>
>

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 21 Aug 2013 14:26:39 +0000

Lokesh,

Any modern high end NP, depending on timers used could do 2-4K BFD sessions.

Cheers,
Jeff

From: Lokesh B <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, August 20, 2013 11:40 PM
To: Marc Binderberger <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: few queries regarding BFD

Thanks Marc,
I'm just picking this old thread because my question is in this context,
could you please let me know names of vendors and products of these "8k-16k BFD sessions per linecard" systems? I'm interested in software/hardware specifications of such high end systems.
Is it cisco? I googled but could not find any.

Regards
-Lokesh

On Fri, May 17, 2013 at 1:11 PM, Marc Binderberger <[email-masked]<mailto:[email-masked]>> wrote:
Hello Lokesh,

I know about systems that support 8k - 16k BFD sessions per linecard and "no limit" per system. For software-based I/O we talk about intervals of several hundreds of milliseconds then, hardware-based I/O can deliver much faster though.

I use quotation marks as it mainly means no hard limits in the code; in reality one may find certain code/data structures like SNMP work fine for a few thousands but not for hundreds of thousands of sessions - and need optimization.

Regards, Marc

>> 2. what is the currently supported maximum number of BFD sessions in high end routers? is it in the orders of hundreds of thousands?

>Thousands. Details may depend on the timer values when the implementation is software based, still >system-wide I stick to "thousands".

do you have any information about what is the highest number of BFD sessions supported by high end routers? I mean how many thousands of sessions do they support? I searched online but could not find the info.

Regards
-Lokesh

On Fri, May 3, 2013 at 3:30 PM, Marc Binderberger <[email-masked]<mailto:[email-masked]>> wrote:
Hello Lokesh,

> 1. How to arrive at maximum number of BFD sessions to be supported in a high end router.?

distributed architecture and/or using ASIC/FPGA/NP to offload the packet Tx/Rx

> 2. what is the currently supported maximum number of BFD sessions in high end routers? is it in the orders of hundreds of thousands?

Thousands. Details may depend on the timer values when the implementation is software based, still system-wide I stick to "thousands".

> 3. What is the minimum Tx time to be supported for layer 3 UDP encap peers? I know cisco supports minimum 50 msec but can we expect requirement for IP peers to be monitored below that 50 msecs? like 10,20 msec?

Actually this particular vendor you mention supports 15msec for high-end equipment today. With a multiplier of 2 that makes a detection time of 30msec maximum, so depending on the fiber length in a network that could make the 50-60msec time for detection & restoration.

Obviously: the faster the timer the better :-) , for MPLS-TP OAM the usual number you hear is 3.3msec (so 10msec detection time with a multiplier of 3).

> 4. What is average Tx time usually IP peers settle for in general? is it like 100-300 msec? In other words what is usually configured Tx time for IP peers?

there is no single number, too many network designs out there in real life. In the core customers typically go fast, to the endpoints some customers go slower, just to stay below 1sec detection time so VoIP controller don't freak out.

Regards, Marc

> 5. What is the expected percentage of BFD traffic of the total bandwidth of the device? I know it depends on how many sessions are active in parallel and Tx/Rx timers but in general is it correct to estimate that BFD traffic generally should not exceed 2 to 5 % of the total bandwidth available for user data?
>
> 6. How frequently Auth is used in general deployments? is it only used for multi hop peers usually?
>
> Regards
> -Lokesh
>
>
>
>
>
>